Subject: RE: [dhcwg] Re: One more question

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Sat, 29 Oct 2005 17:03:52 -0400

The question is if the RECONFIGURE specifies a RENEW (in msg-type of the
Reconfigure option), what server identifier option does the client
include (as a RENEW requires that option)? The one from which it
acquired the address(es) or the one which sent it the RECONFIGURE (if
they are different). If we were to issue an errata, I'd recommend we say
that the client use the server identifier option from the RECONFIGURE
message.

For INFORMATION-REQUEST, the client likely won't include a server
identifier option (as it is optional).

- Bernie

> -----Original Message-----
> From: Ted Lemon [mailto:[email-masked]] 
> Sent: Friday, October 28, 2005 3:02 PM
> To: [email-masked]
> Cc: Bernie Volz (volz); Ralph Droms (rdroms); D. R. Evans; 
> Shengyou Zeng (szeng)
> Subject: Re: [dhcwg] Re: One more question
> 
> On Saturday 29 October 2005 06:32, Bernie Volz (volz) wrote:
> > I vote for the server that sent the Reconfigure message! 
> That's also how
> > I read the text, but don't disagree it is open for interpretation.
> 
> I would just go back to the normal address re-acquisition 
> process.   Indeed, 
> I'm not sure how you'd avoid it, since DHCPv6 messages are generally 
> multicast.
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Fri, 28 Oct 2005 14:06:17 -0700

On Saturday 29 October 2005 14:03, Bernie Volz (volz) wrote:
> If we were to issue an errata, I'd recommend we say

Does that make any sense?   It seems to me that the server identifier of the 
server that assigned the addresses is the one to use.