Subject: Re: [dhcwg] Re: One more question

From: Ted Lemon <[email-masked]>
Date: Fri, 28 Oct 2005 14:47:05 -0700

On Sunday 30 October 2005 07:52, Bernie Volz (volz) wrote:
> I respectfully disagree with this, per my email just a few minutes ago.

Yup, I don't think it works to say that reconfigure can only come from the 
server that issued the original lease.   If it's properly authenticated, it's 
effectively coming from the same server.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Sun, 30 Oct 2005 09:52:13 -0500

> -----Original Message-----
> From: Shengyou Zeng (szeng) 
> Sent: Sunday, October 30, 2005 7:26 AM
> To: Ralph Droms (rdroms); Bernie Volz (volz); Ted Lemon; 
> [email-masked]
> Cc: D. R. Evans
> Subject: RE: [dhcwg] Re: One more question
> 
> I suggest the following: 
> 
> 1. In Reconfigure validation (15.11), add a condition to 
> "clients MUST discard" list  
> 
>    - the message doesn't come from the server which granted 
> the lease or replied to Information-Request
> 
> This means clients will only accept Reconfigure from the 
> original server.  I don't see a lot of value in providing the 
> capability to allow another server to command Reconfigre.  If 
> the server is down, Reconfigre can wait; the client will be 
> reconfigured when it next does Renew.
> 
> 2. In 19.4.1 (Receipt of Reconfigure Messages), we specify 
> that responses to Reconfigure (Renew or Info-Req) be sent to 
> the server that issued the Reconfigure (which is the server 
> that granted the lease because of 1 above).  
> 
> Shengyou Zeng
> Cisco Systems, Inc.
> [email-masked]
> 978-936-1609
> Boxborough, MA 01719
> 
> 
> > -----Original Message-----
> > From: Ted Lemon [mailto:[email-masked]] 
> > Sent: Friday, October 28, 2005 5:16 PM
> > To: [email-masked]
> > Cc: Bernie Volz (volz); Shengyou Zeng (szeng); D. R. Evans; 
> > Ralph Droms (rdroms)
> > Subject: Re: [dhcwg] Re: One more question
> > 
> > On Saturday 29 October 2005 19:00, Bernie Volz (volz) wrote:
> > > Think about a failover environment and the failover partner 
> > that gave
> > > out the addresses is down ...
> > 
> > I don't see how that's relevant.   If the protocol doesn't 
> > work with failover 
> > in the absence of reconfigure, that's a problem that needs to 
> > be solved.   
> > You can't solve it by being more specific about how the 
> > client behaves in the 
> > presence of reconfigure.
> > 
>