Subject: RE: [Softwires] Re: [dhcwg] Cost of DHCPv6

From: "Durand, Alain" <[email-masked]>
Date: Thu, 13 Oct 2005 06:49:07 -0400

Jordi,
 
This DHCPv6 question is a red herring.
It has been discussed ad nauseam in the DNS discovery case which is very similar.
The prefix delegation (same for the DNS delegation) is essentially a two packet exchange.
Hard to beat that...
 
Let's please not reinvent the wheel.
 
    - Alain.

________________________________

From: [email-masked] on behalf of JORDI PALET MARTINEZ
Sent: Thu 10/13/2005 3:23 AM
To: Mohacsi Janos
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [Softwires] Re: [dhcwg] Cost of DHCPv6

Hi Janos,

Ok. That's the point ... 100K seems to me a lot for a thin device or a
cellular phone, but I guess need to wait for some vendors to confirm as I
may be wrong.

Regards,
Jordi

> De: Mohacsi Janos <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Thu, 13 Oct 2005 09:14:07 +0200 (CEST)
> Para: JORDI PALET MARTINEZ <[email-masked]>
> CC: "[email-masked]" <[email-masked]>, "[email-masked]"
> <[email-masked]>, <[email-masked]>, "Soininen Jonne
> (Nokia-NET/Helsinki)" <[email-masked]>, "[email-masked]"
> <[email-masked]>
> Asunto: Re: [dhcwg] Cost of DHCPv6
>
> Hi Jordi,
>
>
>
> On Thu, 13 Oct 2005, JORDI PALET MARTINEZ wrote:
>
>> Hi all,
>>
>> One of the debates that we had during the interim meeting is about using
>> DHCPv6 for the prefix delegation across the tunnel, or embedding the prefix
>> request/delegation in the tunnel handshake/setup.
>>
>> The main reason why I want to raise this question is because despite a
>> couple of folks said DHCPv6 is a lightweight protocol, very easy to
>> implement and not consuming resources in the client, neither needing too
>> many packet exchanges, I'm not really sure if that's the view from others,
>> specially the cellular phone manufacturers (that's why I've specially copied
>> some people involved previously at the v6tc/zero-config work).
>>
>> This may be the case also for other thin devices.
>>
>> Today, even in XP/2003 we don't have DHCPv6 ... So is really a concern if
>> this will become widely available. While I agree that is better to have only
>> one protocol, I think it must be balanced with a few issues.
>
> Official support of DHCPv6 for Windows XP/2003 not exists, but as we
> tested in 6NET project, there are some working alternatives: from NEC,
> Lucent and dibbler. They are tend to be mature.
>
>>
>> So the question is, are cellular phone vendors and other small devices
>> manufacturers, going to implement DHCPv6 client capable of Prefix Delegation
>> ? Please, consider in your answer that the Prefix Delegation option may be
>> the main reason to use DHCPv6, it makes sense ?
>
> For prefix delegation DHCPv6 the compiled code size can be as low as 100K
> - tested with KAME dhcpv6 client - without any optimisation the client
> size is 98156 on i386 platform. The KAME code uses BSD license, so
> implementing in embedded device is matter of importing the code, giving
> credit to the KAME project - and of course integrating into the platform.
>
>>
>> Can somebody tell me how much it means in terms of code, how many packets,
>> other issues, etc. ?
>>
>> Same questions somehow for the server side. Do you expect to become widely
>> available in server and router platforms ?
>
>
> We are using prefix delegating server on Cisco platform and FreeBSD more
> than two years now. I know, but not using, Juniper ERX platform has
> extensive DHCPv6 support also.
>
> Regards,
> Janos Mohacsi
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg

************************************
The IPv6 Portal: http://www.ipv6tf.org

Barcelona 2005 Global IPv6 Summit
Information available at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Durand, Alain" <[email-masked]>
Date: Thu, 13 Oct 2005 09:46:26 -0400

>> The implementation isn't probably a big deal - I'll point out that
>> DHCPv6 isn't planned to be used for address allocation in 3GPP networks,
>> so that is a much bigger barrier to deploying DHCPv6 on the handset
>> than anything else.

May or may not, as you do not have to implement the full DHCPv6 machinery
at either end.
 
Someone need to write the piece of code that does this function, the fact that
this code is using the DHCPv6 format to send packet over the tunnel or using
a new packet format (tbd by the "softwire' protocol) would seemed to make little
difference... Do I miss something?
 
   - Alain.