Subject: [dhcwg] What about using a single dhcpv6 server for dual-stack hosts to get ipv6/ipv4 settings?

From: [email-masked]
Date: Tue, 15 Feb 2011 08:43:38 +0800

RFC4477 described issues identified with dual IP version DHCP interactions 
and also promotes potential 
solutions to solve these issues.one solution may be to modify DHCPv6 to be 
able to return IPv4 information.

This solution is hinted at in the DHCPv6 specification<xref 
target="RFC3315"/>: "If there is sufficient 
interest and demand,integration can be specified in a document that 
extends DHCPv6 to carry IPv4 
addresses and configuration information." This solution may allow DHCP for 
IPv4 to be completely replaced 
by DHCPv6 with additional IPv4 information options, for dual-stack nodes.

RFC4477 described the advantages and protential problems about the 
solution.

Do you think it make sense to develop this solution in details? It will 
solve the problems,the content will include:
/the client's implementation and behavior
/the server's implementation and behavior
/the isp network's behavior
/compatibility and potential protocl traslation
/location identify and AAA

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Ted Lemon <[email-masked]>
Date: Mon, 28 Feb 2011 15:04:02 -0800

On Feb 14, 2011, at 4:43 PM, <[email-masked]>  <[email-masked]> wrote:
> RFC4477 described issues identified with dual IP version DHCP interactions and also promotes potential 
> solutions to solve these issues.one solution may be to modify DHCPv6 to be able to return IPv4 information. 

We've discussed that in the past and pretty much rejected it because it would add a lot of complexity and the functionality is only useful during the transitional period when hosts are running dual-stack.   Is there some reason why DHCPv4+DHCPv6 isn't an option?