Subject: [dhcwg] IETF81 dhcwg - volunteers for minutes and jabber

From: "Brzozowski, John" <[email-masked]>
Date: Sun, 24 Jul 2011 01:28:25 +0000

The dhcwg chair would like volunteers to take meeting minutes and for
jabber scribing during our upcoming working group meeting in Quebec City.

Meeting details can be found here:

http://www.ietf.org/proceedings/81/agenda/dhc.html

Thanks,

Ted and John

---

From: "Brzozowski, John" <[email-masked]>
Date: Sun, 24 Jul 2011 13:31:09 +0000

FYI

=========================================
John Jason Brzozowski
Comcast Cable
e) mailto:[email-masked]
o) 609-377-6594
m) 484-962-0060
w) http://www.comcast6.net
=========================================

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 25 Jul 2011 03:30:25 +0200

> http://www.ietf.org/proceedings/81/agenda/dhc.html

Thanks for the updated agenda.  I notice that the

              draft-ietf-mif-dhcpv6-route-option-01

is reserved a 5 minutes slot.  Once the presentation is done, I would
like to comment on it.

My interest in it is about its otherwise unstated feature of
communicating a default route.  I think that the draft is indeed useful
to communicate a default route.  A default route is a particular form of
route in which the prefix is presumably a ::/0, that is 128 zero bits
and a prefix length octet equaling 0.

Moreover, if I am not mistaken, I think this may be the only current
DHCPv6 document approaching a specification about how to communicate a
default route with DHCPv6.

But, were it to have this specific goal of communicating default routes
- I believe it could be improved with lifetime and MAC address aspects,
and more.

There shouldn't be two different ways of configuring a default route
with DHCPv6.

There are a number of other aspects and typos I could comment on the draft.

Alex

>
> ========================================= John Jason Brzozowski
> Comcast Cable e) mailto:[email-masked] o)
> 609-377-6594 m) 484-962-0060 w) http://www.comcast6.net
>> The dhcwg chair would like volunteers to take meeting minutes and
>> for jabber scribing during our upcoming working group meeting in
>> Quebec City.
>>
> _______________________________________________ dhcwg mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 25 Jul 2011 08:03:13 +0200 (CEST)

> - I believe it could be improved with lifetime and MAC address aspects, 

I would like to include a source address field as well. In some deployment 
scenarios one wants different default gateways depending on what source 
address the packet has (think multiple ISPs, multiple on-link networks in 
combination with antispoofing). It would be short sighted to not include 
support for this when designing route handout via DHCPv6.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: MOUTON Maximilien <[email-masked]>
Date: Tue, 26 Jul 2011 12:23:49 +0000

M. Abrahamsson,    

See my comments inline.

>-----Message d'origine-----
>De : [email-masked] [mailto:[email-masked]] De la part de Mikael Abrahamsson
>Envoyé : lundi 25 juillet 2011 08:03
>À : Alexandru Petrescu
>Cc : [email-masked]
>Objet : Re: [dhcwg] comment on default route of draft-ietf-mif-dhcpv6-route-option-01 (was: UPDATED - IETF81 dhcwg >agenda)
>

Can you clarify how you intend to use the source address field?
In one scenario you mentioned multiple ISPs and multiple on-link networks meaning that the client is connected to multiple links over one or several interfaces.
My question is then how the source address can influence the choice of the default gateway? I would expect that if the client wants to send a packet, with one of its addresses, it should be sent through a default gateway of the link the source address belongs.
>From my point of view I think this field can be useful if there are several default gateways available on the same link and the client has several addresses on it.

>[email-masked]
>https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Mikael Abrahamsson <[email-masked]>
Date: Tue, 26 Jul 2011 20:53:39 +0200 (CEST)

On Tue, 26 Jul 2011, MOUTON Maximilien wrote:

> Can you clarify how you intend to use the source address field? In one 
> scenario you mentioned multiple ISPs and multiple on-link networks 
> meaning that the client is connected to multiple links over one or 
> several interfaces. My question is then how the source address can 
> influence the choice of the default gateway? I would expect that if the 
> client wants to send a packet, with one of its addresses, it should be 
> sent through a default gateway of the link the source address belongs.

On NIC1 there is /64 for ISP1 and another /64 from ISP2. I want packets 
sourced from IP addresses from ISP1 to go out thru the CPE for ISP1, and 
packet sourced from ISP2 addresses to go thru ISP2 CPE.

And what you describe today typically doesn't happen, the host will choose 
a single best default gw and send all packets out thru it (afaik), 
regardless of what IP address is used as source for the packet.

---

From: "Brzozowski, John" <[email-masked]>
Date: Wed, 27 Jul 2011 18:02:24 +0000

Any volunteers please contact the chairs.

---

From: MOUTON Maximilien <[email-masked]>
Date: Wed, 27 Jul 2011 18:06:37 +0000

>De : Mikael Abrahamsson [mailto:[email-masked]] 
>Envoyé : mardi 26 juillet 2011 20:54
>À : MOUTON Maximilien
>Cc : Alexandru Petrescu; [email-masked]
>Objet : RE: [dhcwg] comment on default route of draft-ietf-mif-dhcpv6-route-option-01 (was: UPDATED - IETF81 dhcwg >agenda)

>packet sourced from ISP2 addresses to go thru ISP2 CPE.

I agree with you. In this scenario the client needs two default routers; each one wants to receive packets with source address in its prefix. Thus a source address field is justified in this case.

But in your example the content of source address field is the client address the client already knows. Isn't it?

My question is then is an address field really necessary? 

In the present scenario you could simply use a bit equals to 0 if the default router accepts all source addresses and equals to 1 if it accepts only source addresses from its prefix.

Maximilien

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 27 Jul 2011 20:12:27 +0200 (CEST)

On Wed, 27 Jul 2011, MOUTON Maximilien wrote:

> But in your example the content of source address field is the client 
> address the client already knows. Isn't it?

Yes.

> My question is then is an address field really necessary?

I'm not sure.

> In the present scenario you could simply use a bit equals to 0 if the 
> default router accepts all source addresses and equals to 1 if it 
> accepts only source addresses from its prefix.

How does the client know what prefix sourced it should send where? What if 
the DHCPv6 server is not the same unit as the default router, or if the 
default gw for a certain prefix consists of two routers running VRRP? What 
if you have a DHCPv6-PD structure so a ISP CPE actually handles a range of 
subnets?

Deducing this information from other information might work in some 
scenarios, but I doubt it'll work in all.