Subject: [dhcwg] [dhcpwg] Comments on draft-ietf-dhc-dhcpv6-relay-supplied-options-09.txt

From: "Gaurav Halwasia (ghalwasi)" <[email-masked]>
Date: Tue, 6 Sep 2011 20:15:24 +0530

Hi Authors,

I was reading and reviewing this document and I do support this work.

I do have a small comment.

Section 5 talks about including RSOO in Relay-forward messages but it
does not talk about which client messages. Do we really need to allow
relay agents to add RSOO while forwarding all types of client messages.
For eg, does it really makes sense for relay agents to add RSOO while
forwarding RELEASE and DECLINE.? 

Thanks,

Gaurav

---

From: Ted Lemon <[email-masked]>
Date: Tue, 6 Sep 2011 16:53:15 +0000

On Sep 6, 2011, at 10:45 AM, Gaurav Halwasia (ghalwasi) wrote:
Section 5 talks about including RSOO in Relay-forward messages but it does not talk about which client messages. Do we really need to allow relay agents to add RSOO while forwarding all types of client messages. For eg, does it really makes sense for relay agents to add RSOO while forwarding RELEASE and DECLINE.?

I don't think it makes sense for relay agents to detect the DHCP message type before adding RSOO, so yes, they should add it to all messages, even though as you rightly point out, it will not actually be used in the case of a RELEASE or DECLINE.