Subject: Re: [dhcwg] Call for review: draft-ietf-savi-dhcp-10

From: Jari Arkko <[email-masked]>
Date: Tue, 10 Jan 2012 18:53:11 +0200

Was there a response on this? My search of the archives gives no reviews from DHC WG, but maybe I'm missing something. It would indeed be essential for the WG to make a review.

(In the meantime, the draft has been revised per my AD review comments but we still have some questions that must be resolved before the draft can go forward. But getting the DHCP experts to look at this draft is key -- I know that I was unable to do a good review from that perspective.

Jari

On 21.09.2011 22:17, Jean-Michel Combes wrote:
> Thanks Ted!
>
> Indeed, SAVI WG would appreciate feedback from DHC WG.
>
> Thanks in advance for your comments.
>
> Best regards.
>
> JMC, SAVI WG co-chair.
>
> 2011/9/21 Ted Lemon<[email-masked]>:
>> The SAVI (Source Address Validation Improvements) working group has a draft
>> out that describes how to do SAVI in cooperation with DHCP.   AFAIK nobody
>> in the DHC working group has reviewed this draft.   It would almost
>> certainly be helpful both to us and to them for some of us here to review
>> it.
>> The draft is here: http://tools.ietf.org/html/draft-ietf-savi-dhcp-10
>> _______________________________________________
>> dhcwg mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dhcwg
>>
>>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 10 Jan 2012 17:41:15 +0000

> (In the meantime, the draft has been revised per my AD review comments but we still have some questions that must be resolved before the draft can go forward. But getting the DHCP experts to look a…

I didn't see a response.   It's a difficult draft to evaluate from a DHCP perspective because actually the draft mostly has nothing to do with DHCP—that is, you need to be a SAVI expert to really grok it.

As a non-SAVI expert, what I was able to glean from a quick read is that the expectation is that devices on the network that want to do SAVI will snoop DHCP packets and use the results of this snooping to build validation tables.

This seems fragile to me unless the device in question is the sole device in the path between the DHCP client and the rest of the world.   This technique has been used successfully in DHCP relay agents in specific deployments where there is only a single path between the DHCP client and the rest of the world; if that is the only intended use case, then this is probably okay.

The bottom line though is that I feel like this draft requires a much more thorough read than I just gave it in order to comment constructively.   It might help to bootstrap that process if the authors could engage in some discussion here, starting with a brief (emphasis on brief!) introduction on the topic of what SAVI is, what its use cases are, and how the authors envision it interacting with DHCP, so that potential reviewers don't have to try to synthesize that understanding from the draft.

---

From: Jari Arkko <[email-masked]>
Date: Tue, 10 Jan 2012 22:31:05 +0200

Ted:

I agree that you need an understanding of SAVI. Authors, could you provide some background for this draft? Thanks.

But I would also claim that this draft needs a serious DHCP perspective review, because I for one was unable to determine if the snooping is in sync with the way DHCP expects its state machine to work.

Jari

---

From: Ted Lemon <[email-masked]>
Date: Tue, 10 Jan 2012 22:51:02 +0000

> But I would also claim that this draft needs a serious DHCP perspective review, because I for one was unable to determine if the snooping is in sync with the way DHCP expects its state machine to w…

I suspect you are right.   I have to admit that I'm concerned that a SAVI-implementing device would essentially have to replicate the DHCP state machine, given that the DHCP state machine might evolve over time, and that not all clients behave in exactly the same way.   But I don't feel like I can really evaluate that without a bit of background that I'm currently missing.

---

From: "Jun Bi" <[email-masked]>
Date: Thu, 12 Jan 2012 12:10:35 +0800

Dear Ted and Jari,

This draft handles anti-spoofing in local link at DHCP-only scenario (in the 
subnet, only DHCP server is allowed to assign source address).
The basic mechanism is that the first hop switch (maybe L2 switch) will set 
up binding entries based on snooping DHCP control packets.

The attached file is the PPT that I presented at IETF79 (Nov. 2010).
This is old but it was the last PPT of this draft, after IETF79, the draft 
passed WG last call, then in the last year, we only slightly revised drafts 
based comments received from WGLC and AD reviews. In the last year, we also 
worked on the implementation (about 7 vendors now implmented it) and 
deloyment in CNGI-CERNET2 and 100 universities' campus network.

Hope it provides some background information.

thanks,
Jun Bi

-----原始邮件----- 
From: Ted Lemon
Sent: Wednesday, January 11, 2012 6:51 AM
To: Jari Arkko
Cc: Jean-Michel Combes ; [email-masked] WG ; 
[email-masked]
Subject: Re: [dhcwg] Call for review: draft-ietf-savi-dhcp-10

On Jan 10, 2012, at 12:31 PM, "Jari Arkko" <[email-masked]> wrote:
> But I would also claim that this draft needs a serious DHCP perspective 
> review, because I for one was unable to determine if the snooping is in 
> sync with the way DHCP expects its state machine to work.

I suspect you are right.   I have to admit that I'm concerned that a 
SAVI-implementing device would essentially have to replicate the DHCP state 
machine, given that the DHCP state machine might evolve over time, and that 
not all clients behave in exactly the same way.   But I don't feel like I 
can really evaluate that without a bit of background that I'm currently 
missing.