Subject: [dhcwg] Multiple Provisioning Domains (future work mentioned in draft-ietf-dhc-dhcpv6-stateful-issues)

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 11 Dec 2012 22:39:30 +0000

On my "to-do" list that never seems to bubble to the top is a draft about multiple provisioning domains (this is related to the single provisioning domain that DHCPv6 assumes today explicitly mentioned in draft-ietf-dhc-dhcpv6-stateful-issues)  ... a while back I had written to the DHC WG:

I do know Ted wants to see an I-D regarding the multiple provisioning domains but I am not sure whether that would block draft-ietf-dhc-dhcpv6-stateful-issues-00 until available. I just haven't had much time to work on that ID -- the concept is fairly simple in that servers would have to include the provisioning domain identifier in their responses and clients would have to make decisions based on the provisioning identifier - Advertisements that have the same provisioning identifier are selected from pretty much as clients do today without this support and if multiple provisioning identifiers are present, a client can select one Advertisement from each set and fork separate transactions (when and why a client may want to do this need to be worked out - such as is it only done if one domain provides addresses and another prefixes, or should the client do it always).

Now, while I guess I should submit something basic, I also wonder whether anyone has a need for this today and thus is it worth drafting something for a hypothetical situation that doesn't exist today and thus might not meet (future) real world requirements. There may also be unexpected issues that aren't addressed - one could be how different server's options would be integrated into a single configuration (this is much like the issues a client with multiple interfaces faces).

If there is someone that believes they have a need for this or feels strongly that a draft to address this exist, please let me (or the WG) know so that perhaps we can partner on this draft and make use of those real world requirements.

Thanks for your attention.

-          Bernie

---

From: Ted Lemon <[email-masked]>
Date: Wed, 12 Dec 2012 02:35:13 +0000

> If there is someone that believes they have a need for this or feels strongly that a draft to address this exist, please let me (or the WG) know so that perhaps we can partner on this draft and mak…

Yes, _please_!   I've been feeling guilty about not writing this for at least a year now.