Subject: Re: [dhcwg] Call for adoption: draft-boucadair-dhc-address-name-encoding-03

From: Ted Lemon <[email-masked]>
Date: Wed, 19 Dec 2012 14:25:06 +0000

On Nov 30, 2012, at 10:07 AM, Ted Lemon <[email-masked]> wrote:
> Med has asked for a call for adoption to gauge working group consensus as to whether we should work on his proposal.   The consensus we are trying to get here is, is it a good idea have a DHCP option format that is a text representation of either a name or an IP address, and to recommend the use of this format to address some use cases that might arise in the development of future DHCPv6 options.
> 
> To be clear, this is not a consensus call on whether we should have an option format representation for FQDNs: we already have one.   It is not even a consensus call on whether we should be able to have options that carry both FQDNs and IP addresses—there's already an example of such an option in the ntp option document.

There was a lot of good discussion on this call for adoption, but it's clear that we do not have consensus—there were one or two more people against adopting than in favor, with about ten people getting involved in the conversation.   Several participants were neither for nor against, but thought the question should be addressed in the dhcpv6 option guidelines draft.

So the bottom line is that the DHC working group will not be adopting this draft, and those who think this is an interesting question should engage in discussion with the authors of the DHCPv6 Option Guidelines draft to see that the use cases this draft was intended to address are addressed.

While this does not mean that this option format has been formally rejected by the working group, I would expect that an option that attempted to use this format would have similar difficulty gaining consensus in the working group.

---

From: <[email-masked]>
Date: Wed, 19 Dec 2012 16:15:40 +0100

Hi Ted,

Thank you for this fair conclusion. 

The discussion has shown: (1) this is a real problem, (2) there is a need for a dhc recommendation.

I personally like the plan proposed by Tomek here: http://www.ietf.org/mail-archive/web/dhcwg/current/msg13559.html

I still think we need to discuss the ordering of the encoding choices when both IP/FQDN are needed. 

Cheers,
Med 

>-----Message d'origine-----
>De : [email-masked] [mailto:[email-masked]] De 
>la part de Ted Lemon
>Envoyé : mercredi 19 décembre 2012 15:25
>À : [email-masked] WG
>Objet : Re: [dhcwg] Call for adoption: 
>draft-boucadair-dhc-address-name-encoding-03
>
>> Med has asked for a call for adoption to gauge working group 
>consensus as to whether we should work on his proposal.   The 
>consensus we are trying to get here is, is it a good idea have 
>a DHCP option format that is a text representation of either a 
>name or an IP address, and to recommend the use of this format 
>to address some use cases that might arise in the development 
>of future DHCPv6 options.
>> 
>> To be clear, this is not a consensus call on whether we 
>should have an option format representation for FQDNs: we 
>already have one.   It is not even a consensus call on whether 
>we should be able to have options that carry both FQDNs and IP 
>addresses-there's already an example of such an option in the 
>ntp option document.
>
>There was a lot of good discussion on this call for adoption, 
>but it's clear that we do not have consensus-there were one or 
>two more people against adopting than in favor, with about ten 
>people getting involved in the conversation.   Several 
>participants were neither for nor against, but thought the 
>question should be addressed in the dhcpv6 option guidelines draft.
>
>So the bottom line is that the DHC working group will not be 
>adopting this draft, and those who think this is an 
>interesting question should engage in discussion with the 
>authors of the DHCPv6 Option Guidelines draft to see that the 
>use cases this draft was intended to address are addressed.
>
>While this does not mean that this option format has been 
>formally rejected by the working group, I would expect that an 
>option that attempted to use this format would have similar 
>difficulty gaining consensus in the working group.
>
>_______________________________________________
>dhcwg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dhcwg
>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 19 Dec 2012 15:58:52 +0000

> I personally like the plan proposed by Tomek here: http://www.ietf.org/mail-archive/web/dhcwg/current/msg13559.html
+1

> I still think we need to discuss the ordering of the encoding choices when both IP/FQDN are needed. 

What do you mean by ordering here?   The order of preference on the client, or the order the options appear on the server?

I would not expect a server to supply both IP address and FQDN, since the use cases are different.   You'd supply FQDN because you had to—for example in the case you were talking about where you have two administrative domains, one of which controls DHCP and one of which controls DNS, and the DNS is configured to return different answers depending on the location of the client.   In this case, the IP address option won't work at all, so the administrator would not configure it.

Similarly, in the case where IP address _would_ work, I would expect the administrator to configure only IP address, or else to configure only FQDN, since there's no benefit to configuring both.

Of course your draft would have to _require_ that the client use the FQDN if it gets an FQDN, or else we'd have interoperability problems.

---

From: <[email-masked]>
Date: Thu, 20 Dec 2012 07:39:24 +0100

Hi Ted, 

Please see inline.

Cheers,
Med 

>De : Ted Lemon [mailto:[email-masked]] 
>Envoyé : mercredi 19 décembre 2012 16:59
>À : BOUCADAIR Mohamed OLNC/OLN
>Cc : [email-masked] WG
>> I personally like the plan proposed by Tomek here: 
>http://www.ietf.org/mail-archive/web/dhcwg/current/msg13559.html
>+1
>
>> I still think we need to discuss the ordering of the 
>encoding choices when both IP/FQDN are needed. 
>
>What do you mean by ordering here? 

Med: I meant the ordering of the possibilities listed by B. Volz here: http://www.ietf.org/mail-archive/web/dhcwg/current/msg13547.html.

  The order of preference 
>on the client, or the order the options appear on the server?
>
>I would not expect a server to supply both IP address and 
>FQDN, since the use cases are different.   You'd supply FQDN 
>because you had to-for example in the case you were talking 
>about where you have two administrative domains, one of which 
>controls DHCP and one of which controls DNS, and the DNS is 
>configured to return different answers depending on the 
>location of the client.   In this case, the IP address option 
>won't work at all, so the administrator would not configure it.
>
>Similarly, in the case where IP address _would_ work, I would 
>expect the administrator to configure only IP address, or else 
>to configure only FQDN, since there's no benefit to configuring both.
>
>Of course your draft would have to _require_ that the client 
>use the FQDN if it gets an FQDN, or else we'd have 
>interoperability problems.
>
>

---

From: Tomek Mrugalski <[email-masked]>
Date: Fri, 21 Dec 2012 12:11:19 +0100

> http://www.ietf.org/mail-archive/web/dhcwg/current/msg13559.html
I wouldn't call it my proposal. My first choice would be to not do it at
all. My second choice is "if you really have to write anything about
this, do it this way".

option-guidelines-09 was uploaded, but without any reference to
address-name-encoding. There were 2 reasons for that. First, we were
working under time pressure to upload before expiration
(option-guidelines would have expired today). Second, several co-authors
of option-guidelines spoke against this solution and nobody wanted to do it.
The conclusion reached was that we will include something once the WG
reaches consensus on how to formulate the recommendation here.
Another aspect taken into consideration here was Ted's summary of the
adoption call of address-name-encoding. We believe it summarizes the
situation very well - there was no consensus.

> when both IP/FQDN are needed.
I think the WG should reach a consensus if this is really the approach
we want to recommend.

Personally, I fear that if we write that address-name-encoding is least
preferred, but viable option, many authors will ignore all the arguments
against it and just use it anyway. They may even turn the whole thing
around and try to legitimize that approach by saying that it was
recommended by option-guidelines.

I hope that this mail and my previous comments on this topic explain my
opinion on this topic. When gauging a consensus I'm afraid my voice
should be counted as "moderately against".

Tomek