Subject: [dhcwg] [DHC]:Comments on draft-ietf-dhc-dhcpv4-over-dhcpv6

From: [email-masked]
Date: Fri, 5 Jul 2013 09:37:12 +0800

Hi,
        Here are some comments on this draft.
        The behaviours of Client/Relay/Sever seem to be lack of specific 
messages. 
    For example, DHCPv4 messages, 
DHCPDISCOVER/DHCPOFFER/DHCPREQUEST/DHCPACK/DHCPNAK 
    message, how to interact with DHCPv6 messages 
SOLICIT/ADVERTISE/REQUEST/CONFIRM/
    RENEW/RELEASE/DECLINE message (as a option of DHCPv6). 
        By the way, interaction process of messages might be included in 
the document.
 
Cheers,
Wei

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 5 Jul 2013 03:17:22 +0000

Huh? There is no interaction - these new messages contain normal dhcpv4 messages.

- Bernie (from iPad)

On Jul 4, 2013, at 9:38 PM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

Hi,
        Here are some comments on this draft.
        The behaviours of Client/Relay/Sever seem to be lack of specific messages.
    For example, DHCPv4 messages, DHCPDISCOVER/DHCPOFFER/DHCPREQUEST/DHCPACK/DHCPNAK
    message, how to interact with DHCPv6 messages SOLICIT/ADVERTISE/REQUEST/CONFIRM/
    RENEW/RELEASE/DECLINE message (as a option of DHCPv6).
        By the way, interaction process of messages might be included in the document.

Cheers,

Wei
_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: [email-masked]
Date: Fri, 5 Jul 2013 11:34:20 +0800

For example， client generates DHCPv4 DISCOVER message and embed it as a 
option into
DHCPv6 SOLICIT message.  It is named as "DHCPv4 DISCOVER over DHCPv6 
SOLICIT"
also "DHCPv4 over RELAY-FORW"/  "DHCPv4 OFFER over DHCPv6 ADVERTISE" and 
so on.

Thanks.

"Bernie Volz (volz)" <[email-masked]> 写于 2013-07-05 11:17:22:

> On Jul 4, 2013, at 9:38 PM, "[email-masked]" <[email-masked]
> > wrote:

> [email-masked]

---

From: Cong Liu <[email-masked]>
Date: Fri, 5 Jul 2013 11:40:58 +0800

Hi Wei,

There are 2 new DHCPv6 messages (BOOTREQUESTV6 & BOOTREPLYV6) defined in
the draft. The BOOTP Message Option (which contains DHCPv4 message) can
only be carried in the new defined messages.

Best Wishes,
Cong

2013/7/5 <[email-masked]>

---

From: [email-masked]
Date: Fri, 5 Jul 2013 14:50:11 +0800

Hi Cong，

      Got it. 
      But why define 2 new "msg-type"s instead of existing msg-type? 
    If define "BOOTP Message Option" with existing DHCPv6 "msg-type"s, 
    it would get IPv4/IPv6 addresses at the same time and in one process.

Cheers,
Wei

Cong Liu <[email-masked]>  2013-07-05 11:40:58:

> Hi Wei,
> 
> There are 2 new DHCPv6 messages (BOOTREQUESTV6 & BOOTREPLYV6) 
> defined in the draft. The BOOTP Message Option (which contains 
> DHCPv4 message) can only be carried in the new defined messages. 
> 
> Best Wishes,
> Cong
> 

> For example， client generates DHCPv4 DISCOVER message and embed it 
> as a option into 
> DHCPv6 SOLICIT message.  It is named as "DHCPv4 DISCOVER over 
DHCPv6SOLICIT" 
> also "DHCPv4 over RELAY-FORW"/  "DHCPv4 OFFER over DHCPv6 ADVERTISE"
> and so on. 
> 
> Thanks. 
> 
> 
> "Bernie Volz (volz)" <[email-masked]>  2013-07-05 11:17:22:
> 
>

---

From: Cong Liu <[email-masked]>
Date: Fri, 5 Jul 2013 15:25:24 +0800

Hi Wei,

Here are some possible reasons:
1. DHCPv6 server and DHCPv4-over-DHCPv6 unified server may be different
servers, so their reply messages can not be merged.
2. IPv6/IPv4 addresses may have different lease time, their renew processes
can not be combined.

Best Wishes,
Cong