Subject: [dhcwg] Questions about PD and PD_EXCLUDE

From: Ted Lemon <[email-masked]>
Date: Sun, 14 Jul 2013 23:04:18 +0000

This question was asked during a conversation I was having with a developer a while back, and I don't know the answer, so I'm curious to know what working group participants think.

Suppose a client asks for a /48 and gets a /64.   Can the client do a second request and ask for additional prefixes, in hopes of getting enough to satisfy its needs, even if they aren't contiguous?   What do current implementations do if they get a DHCP Discover with two IA_PDs in it?   What do they do if they get a DHCP Discover with an IA_PD in it with a different IAID, when the DUID already has a prefix assigned to it, on a different IAID?

I think that what should happen is that if local policy allows it, the second IA_PD should get an allocation, in either case.   I think that it's unlikely that existing clients would follow this behavior, but I think it's meaningful behavior.

I suspect that existing relay agents that snoop on DHCP PD messages to set up routing may currently do the wrong thing if more than one IA_PD appears in the message.

Thoughts?

---

From: Ted Lemon <[email-masked]>
Date: Sun, 14 Jul 2013 23:16:23 +0000

On Jul 14, 2013, at 4:04 PM, Ted Lemon <[email-masked]> wrote:
> What do current implementations do if they get a DHCP Discover with two IA_PDs in it?

DHCP Solicit.   Sigh.

---

From: Andre Kostur <[email-masked]>
Date: Sun, 14 Jul 2013 16:53:56 -0700

> What do current implementations do if they get a DHCP Discover with two IA_PDs in it?

For our implementation, the client would get two prefixes assigned to
it, one per IA.  Assuming the service isn't otherwise configured to
prevent the second allocation.  (Of course, reading Solicit for
Discover)

A client might be asking for two different prefixes as it may have two
different networks that it wants a prefix for.  It could ask for a /63
and split it by hand, or it could ask for two separate /64s.

On Sun, Jul 14, 2013 at 4:04 PM, Ted Lemon <[email-masked]> wrote:
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

-- 
Andre Kostur
Distinguished Software Architect & Engineer
P: 604-678-2864
E: [email-masked]
Toll-Free: 1-800-877-1856

F: 604-678-2864
VoIP: sip:[email-masked]

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 15 Jul 2013 00:47:06 +0000

Yes, Cisco Prime Network Registrar would also provide the two prefixes (one per IA).

It really is up to the client.

I think CMTS (relay agents) now support multiple PDs per client. 

- Bernie (from iPad)

---

From: "Gaurav Halwasia (ghalwasi)" <[email-masked]>
Date: Mon, 15 Jul 2013 02:37:08 +0000

>I suspect that existing relay agents that snoop on DHCP PD messages to set up routing may currently do the wrong thing if more than one IA_PD appears in the message.

Implementations which I work on and aware of shall add the route for both the IA_PD's. What do you mean by "wrong thing" exactly.?

-Gaurav

---

From: Ted Lemon <[email-masked]>
Date: Mon, 15 Jul 2013 14:22:30 +0000

> Implementations which I work on and aware of shall add the route for both the IA_PD's. What do you mean by "wrong thing" exactly.?

Not routing for both IA_PDs would be the "wrong thing."   Good to know, thanks!