Subject: [dhcwg] Remidner - RE: WGLC on draft-ietf-dhc-dhcpv6-solmaxrt-update-01 - respond by July 4

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 5 Jul 2013 18:56:37 +0000

Hi:

Just a reminder about this WGLC. While it technically should have ended yesterday, Tomek and I will review on Monday to determine whether we have rough consensus for this to move forward. So, there is still time for you to get your comments in.

While we've had some responses, more would be useful to help us gauge rough consensus.

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
Sent: Thursday, June 20, 2013 12:23 PM
To: [email-masked] WG
Cc: Ralph Droms; Ted Lemon
Subject: [dhcwg] WGLC on draft-ietf-dhc-dhcpv6-solmaxrt-update-01 - respond by July 4

On 20.06.2013 17:11, Ralph Droms wrote:
> On Jun 20, 2013, at 10:30 AM 6/20/13, Ted Lemon wrote:
>> Do we need a SOL_MAX_RT presentation in Berlin?   Why not just
>> last-call it now?
> 
> OK with me.
My understanding is that under normal circumstances chairs cannot just announce WGLC on their own. They can do so if authors or editors state the the draft is ready and chairs concur with that opinion. Anyway, here it goes:

Folks, the author of draft-ietf-dhc-dhcpv6-solmaxrt-update-01
(http://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-solmaxrt-update-01)
feels it's ready for work group last call. Please review this draft and indicate whether or not you feel it is ready to be published.

This document redefines two timers (SOL_MAX_RT and INF_MAX_RT) that control SOLICIT and INFORMATION-REQUEST message retransmissions and define a mechanism for server to override client's default values. There is a document in v6ops about basic requirements for IPv6 CE routers that depends on this work.

At the time of this writing, there is no IPR reported against this draft.

Bernie and I will evaluate consensus after 2013-07-04.

Thanks,
Bernie & Tomek
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Dmitry Anipko <[email-masked]>
Date: Fri, 5 Jul 2013 23:14:10 +0000

I've read the document and support moving it forward - IMO, it will help to reduce useless load on servers as well as save energy on resource constrained clients.

One comment on the security section: do I understand correctly that if the malicious DHCP server sends an arbitrarily high value for either of the options, while the non-malicious DHCP server was temporarily down, then the client may not recover for a very long time? If such vector exists, would it be reasonable to limit the max INF_MAX_RT/SOL_MAX_RT values the server is allowed to send to the client? (e.g. to 1h, or several hours or whatever)

-Dmitry
________________________________________
From: [email-masked] <[email-masked]> on behalf of Bernie Volz (volz) <[email-masked]>
Sent: Friday, July 05, 2013 11:56 AM
To: [email-masked]
Subject: [dhcwg] Remidner - RE: WGLC on draft-ietf-dhc-dhcpv6-solmaxrt-update-01 - respond by July 4

Hi:

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
Sent: Thursday, June 20, 2013 12:23 PM
To: [email-masked] WG
Cc: Ralph Droms; Ted Lemon
Subject: [dhcwg] WGLC on draft-ietf-dhc-dhcpv6-solmaxrt-update-01 - respond by July 4

Thanks,
Bernie & Tomek

---

From: Sten Carlsen <[email-masked]>
Date: Sat, 06 Jul 2013 01:30:16 +0200

If you look at malicious servers, does it matter what the server is
allowed to do? It might be better to state what the client may accept?

-- 
Best regards

Sten Carlsen

No improvements come from shouting:
       "MALE BOVINE MANURE!!!"

---

From: Dmitry Anipko <[email-masked]>
Date: Fri, 5 Jul 2013 23:32:43 +0000

>>If you look at malicious servers, does it matter what the server is allowed to do? It might be better to state what the client may accept?

Yes, that's what I meant with "allowed" - that the client would have to validate against that limit, and either ignore the invalid message, or cap the value to the max allowed.
________________________________
From: [email-masked] <[email-masked]> on behalf of Sten Carlsen <[email-masked]>
Sent: Friday, July 05, 2013 4:30 PM
To: [email-masked]
Subject: Re: [dhcwg] Remidner - RE: WGLC on draft-ietf-dhc-dhcpv6-solmaxrt-update-01 - respond by July 4

If you look at malicious servers, does it matter what the server is allowed to do? It might be better to state what the client may accept?

-Dmitry
________________________________________
From: [email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]> on behalf of Bernie Volz (volz) <[email-masked]><mailto:[email-masked]>
Sent: Friday, July 05, 2013 11:56 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [dhcwg] Remidner - RE: WGLC on draft-ietf-dhc-dhcpv6-solmaxrt-update-01 - respond by July 4

Hi:

- Bernie

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
Sent: Thursday, June 20, 2013 12:23 PM
To: [email-masked]<mailto:[email-masked]> WG
Cc: Ralph Droms; Ted Lemon
Subject: [dhcwg] WGLC on draft-ietf-dhc-dhcpv6-solmaxrt-update-01 - respond by July 4

OK with me.

Thanks,
Bernie & Tomek
_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg
_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg

_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg

--
Best regards

Sten Carlsen

---

From: Sten Carlsen <[email-masked]>
Date: Sat, 06 Jul 2013 02:09:29 +0200

Sorry, I read your wording to suggest only binding the server. As you
explain things, I fully agree.

On 06/07/13 1:32, Dmitry Anipko wrote:
> Yes, that's what I meant with "allowed" - that the client would have
> to validate against that limit, and either ignore the invalid message,
> or cap the value to the max allowed.
> ------------------------------------------------------------------------
> *From:* [email-masked] <[email-masked]> on behalf of
> Sten Carlsen <[email-masked]>
> *Sent:* Friday, July 05, 2013 4:30 PM
> *To:* [email-masked]
> *Subject:* Re: [dhcwg] Remidner - RE: WGLC on
> draft-ietf-dhc-dhcpv6-solmaxrt-update-01 - respond by July 4
>  

-- 
Best regards

Sten Carlsen