Subject: [dhcwg] Source IP address and Server identifier

From: "gvithal ." <[email-masked]>
Date: Wed, 10 Jul 2013 16:46:37 +0530

Is it valid scenario for server identifier in the DHCP ACK to be a
different IP address then the source IP in IP header.
What is the expected client behaviour in this case.
There does not seem to be any text in RFC 2131 related to this scenario.

Thanks,
Prasad

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 10 Jul 2013 12:59:22 +0000

Yes. The packet could have been relayed which means ip header source is relay, not server.

V4 clients (and servers) don't look at ip header fields.

- Bernie (from iPad)

On Jul 10, 2013, at 7:16 AM, "gvithal ." <[email-masked]<mailto:[email-masked]>> wrote:

Is it valid scenario for server identifier in the DHCP ACK to be a different IP address then the source IP in IP header.
What is the expected client behaviour in this case.
There does not seem to be any text in RFC 2131 related to this scenario.

Thanks,
Prasad
_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Wed, 10 Jul 2013 14:46:26 +0000

> What is the expected client behaviour in this case.

The only requirement is that the server identifier be an IP address on which the DHCP server is reachable.

---

From: Sheng Jiang <[email-masked]>
Date: Thu, 11 Jul 2013 01:18:23 +0000

If there was requirements, a reasonable solution could be a new type of DUID, which carries server's IP address in the relay-reply message.

Sheng

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Ted Lemon
>Sent: Wednesday, July 10, 2013 10:46 PM
>To: gvithal .
>Cc: <[email-masked]>
>Subject: Re: [dhcwg] Source IP address and Server identifier
>
>[email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Thu, 11 Jul 2013 01:44:16 +0000

> If there was requirements, a reasonable solution could be a new type of DUID, which carries server's IP address in the relay-reply message.

Hm, I assumed he was talking about DHCPv4...