Subject: [dhcwg] Slides for Berlin DHC WG presentations! (And last chance to request time!!)

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 11 Jul 2013 16:10:40 +0000

Please do provide your slides if you're on the agenda (or requested time). Email them to the [email-masked]<mailto:[email-masked]> and one of us will post them.

I'll update the agenda tomorrow (assuming Tomek and I can find a time to review and attempt to finalize the agenda).

If you haven't submitted a request for time, please do so ASAP. We may not be able to accommodate.

-          Tomek & Bernie

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 11 Jul 2013 14:34:37 -0500

Hi Bernie,

A short slot for

http://tools.ietf.org/id/draft-sarikaya-dhc-vxlan-multicast-00.txt

please.

Regards,

Behcet

On Thu, Jul 11, 2013 at 11:10 AM, Bernie Volz (volz) <[email-masked]> wrote:

>  Please do provide your slides if you’re on the agenda (or requested
> time). Email them to the [email-masked] and one of us will
> post them.****
>
> ** **
>
> I’ll update the agenda tomorrow (assuming Tomek and I can find a time to
> review and attempt to finalize the agenda).****
>
> ** **
>
> If you haven’t submitted a request for time, please do so ASAP. We may not
> be able to accommodate.****
>
> ** **
>
> **-          **Tomek & Bernie****
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>
>

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 12 Jul 2013 16:35:00 +0000

Hi:

I will add the item to the agenda, but as this is a late request, not a DHC WG work item, and hasn't really had discussion on this list, it will be at the end and there is a [good] chance that we may not get to it. (The chairs also reserve the right to add other items before this, should we get additional requests.)

But even if there is no time, having the slides available will provide some value.

You should also see what you can do to stimulate discussion on the mailing list. And, to that end I'll provide a few additional comments (these are mostly with WG co-chair hat off).

The introduction also mentions GRE and you might want to look at http://www.ietf.org/internet-drafts/draft-xue-dhc-dynamic-gre-00.txt. Though it does not look like there is any direct overlap (at least from my very cursory look at your and that draft).

The document also appears to be a bit incomplete (for example, section 8 only mentions the DHCPv4 messages - nothing about DHCPv6).

Section 7 also concerns me as it seems to imply fairly specialized processing on the DHCPv6 server, if not outright management (and hence additional state) of the multicast addresses. But that may just expose my lack of knowledge of this particular problem space - which also brings up whether there are other IETF WGs that would be involved in this work.

-          Bernie

From: [email-masked] [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Thursday, July 11, 2013 3:35 PM
To: Bernie Volz (volz)
Cc: [email-masked]
Subject: Re: [dhcwg] Slides for Berlin DHC WG presentations! (And last chance to request time!!)

Hi Bernie,

A short slot for

please.

Regards,

Behcet
On Thu, Jul 11, 2013 at 11:10 AM, Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>> wrote:
Please do provide your slides if you're on the agenda (or requested time). Email them to the [email-masked]<mailto:[email-masked]> and one of us will post them.

-          Tomek & Bernie

_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 12 Jul 2013 14:44:39 -0500

Hi Bernie,

Please see inline.

Regards,

Behcet

On Fri, Jul 12, 2013 at 11:35 AM, Bernie Volz (volz) <[email-masked]> wrote:

>  Hi:****
>
> ** **
>
> I will add the item to the agenda, but as this is a late request, not a
> DHC WG work item, and hasn’t really had discussion on this list, it will be
> at the end and there is a [good] chance that we may not get to it. (The
> chairs also reserve the right to add other items before this, should we get
> additional requests.)****
>
> ** **
>
> But even if there is no time, having the slides available will provide
> some value.****
>
> ** **
>
> You should also see what you can do to stimulate discussion on the mailing
> list. And, to that end I’ll provide a few additional comments (these are
> mostly with WG co-chair hat off).****
>
> **
>

Yes, dhc folks, please read my draft and comment on it.

> **
>
> The introduction also mentions GRE and you might want to look at
> http://www.ietf.org/internet-drafts/draft-xue-dhc-dynamic-gre-00.txt.
> Though it does not look like there is any direct overlap (at least from my
> very cursory look at your and that draft).****
>
> **
>

You are right there is no overlap. Basically, there are two encapsulation
techniques, one is UDP based in VXLAN and the other is GRE based in nvgre,
resulting in the same type of network. Multicast operation which is the
subject of my draft is common in both nvgre and VXLAN.
While draft-xue-dhc-dynamic-gre addresses establishment of the GRE tunnel.

> **
>
> The document also appears to be a bit incomplete (for example, section 8
> only mentions the DHCPv4 messages – nothing about DHCPv6).****
>
> **
>

I think Section 8 does not contribute anything so I removed it. Sorry for
the confusion.

> **
>
> Section 7 also concerns me as it seems to imply fairly specialized
> processing on the DHCPv6 server, if not outright management (and hence
> additional state) of the multicast addresses. But that may just expose my
> lack of knowledge of this particular problem space – which also brings up
> whether there are other IETF WGs that would be involved in this work.****
>
> **
>

Thanks for your concern. In fact the server operation is completely
stateless, the information Server needs is provided by the Client in DHCP
Request or Solicit messages, I clarified it by adding VTEP as DHCP Client
to the text.
I am going to post rev 01 on Monday, just in case there are other comments.

> **
>
> **-          **Bernie****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Behcet Sarikaya
> *Sent:* Thursday, July 11, 2013 3:35 PM
> *To:* Bernie Volz (volz)
> *Cc:* [email-masked]
> *Subject:* Re: [dhcwg] Slides for Berlin DHC WG presentations! (And last
> chance to request time!!)****
>
> ** **
>
> Hi Bernie,
>
> A short slot for
>
> Behcet****
> On Thu, Jul 11, 2013 at 11:10 AM, Bernie Volz (volz) <[email-masked]>
> wrote:****
>
> Please do provide your slides if you’re on the agenda (or requested time).
> Email them to the [email-masked] and one of us will post them.*
> ***
>
>  ****
>
>  ****
>  ****
> -          Tomek & Bernie****
> https://www.ietf.org/mailman/listinfo/dhcwg****
>
> ** **
>