Subject: [dhcwg] Need some info regarding the subnet slection options and sub-option

From: Vivek Dadu <[email-masked]>
Date: Thu, 30 Jan 2014 09:04:29 +0000

Hi All
As per the subnet selection option (option id 118, RFC 3011) and subnet selection sub-option (Option 82 sub-option 5, RFC 3527) the DHCP proxy client shall send a DHCP packet filled with respective option or sub-option when they want to specify to the DHCP server that which subnet they want the ip address for, however in case of renew and rebind packets ip address assignment is a non-issue, hence I would like to understand that do  popular client\relay agent implementations take that path or they use option 118 and sub-option 5 respectively in every message they send(event renew and rebind).
Regards
Vivek

---

From: Andre Kostur <[email-masked]>
Date: Thu, 30 Jan 2014 09:03:36 -0800

> As per the subnet selection option (option id 118, RFC 3011) and subnet
> selection sub-option (Option 82 sub-option 5, RFC 3527) the DHCP proxy
> client shall send a DHCP packet filled with respective option or sub-option
> when they want to specify to the DHCP server that which subnet they want the
> ip address for, however in case of renew and rebind packets ip address
> assignment is a non-issue, hence I would like to understand that do  popular
> client\relay agent implementations take that path or they use option 118 and
> sub-option 5 respectively in every message they send(event renew and
> rebind).

My $0.02.  If we're talking about a proxy client, I would expect it to
send option 118 in every packet.  Otherwise the renews may show up at
the DHCP server and the server would see that the Request is coming
from a network that does not make sense for the CIADDR and may
potentially NAK the client to force it to switch to the appropriate
network.   Option 82.5 is really for an intervening DHCP Relay Agent
to make the subnet decision.