Subject: [dhcwg] Regarding DhcpV6 alternatives to dhcpv4 option 118 and dhcp option 82 sub-option 5

From: Vivek Dadu <[email-masked]>
Date: Thu, 16 Jan 2014 12:23:09 +0000

Hi All
I would like to know whether there are any link selection options for dhcpv6 like option 118 for dhcpv4 client and Option 82 Sub-option 5 for DHCP V4 relay agents.
Regards
Vivek

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 16 Jan 2014 14:19:35 +0000

The link-address field in the Relay-Forw is usually used for this and no link-selection option is needed.

The reason v4 needs this is that giaddr is both the relay agent's address AND the default link-selection. With DHCPv6, there is no overloading - the Relay Agent address is obtained from the IPv6 header (source address) the link-selection is the link-address field in the Relay-Forw.

-          Bernie

From: dhcwg [mailto:[email-masked]] On Behalf Of Vivek Dadu
Sent: Thursday, January 16, 2014 7:23 AM
To: [email-masked]
Subject: [dhcwg] Regarding DhcpV6 alternatives to dhcpv4 option 118 and dhcp option 82 sub-option 5

Hi All