Subject: [dhcwg] regarding the relay agents, VPN Devices and broadcast bit

From: Vivek Dadu <[email-masked]>
Date: Mon, 20 Jan 2014 13:53:07 +0000

Hi All
I have a query regarding a scenario concerning option 118. Here it goes

"Say a VPN device acting as a dhcp proxy on behalf of its VPN clients has an ip address 10.0.0.2 and belongs to subnet 10.0.0.0/24, however it wants to assign the ip address belonging to subnet 172.1.1.0/24 to one of its VPN clients, so it sends the subnet selection option 118 filled with the data 172.1.1.0 and subnet mask filled with data 255.255.255.0 as a result a relay agent receives it and forwards to dhcpserver, the dhcp server unicasts the packet to the relay agent, now will the relay agent need a special setting to tell it that packets destined to 172.1.1.0/24 subnet will be sent on 10.0.0.0/24 interface"
Also would like to know that will the broadcast bit on packet based on which the server decides to broadcast or unicast a response packet have any impact on the way relay agent processes the packet.

Regards
Vivek

---

From: Andre Kostur <[email-masked]>
Date: Mon, 20 Jan 2014 08:37:38 -0800

That's entirely up to your (VPN) device.  How the rest of your IP
traffic is routed is beyond the scope of DHCP.  DHCP has done its job
in assigning a 172.1.1.x address for the request.

As for the broadcast bit.. if the request was relayed, that bit is of
little consequence to the DHCP server beyond simply setting it in the
returned packet.  The Relay will need to pay attention to that bit
though.

On Mon, Jan 20, 2014 at 5:53 AM, Vivek Dadu <[email-masked]> wrote:
> “Say a VPN device acting as a dhcp proxy on behalf of its VPN clients has an
> ip address 10.0.0.2 and belongs to subnet 10.0.0.0/24, however it wants to
> assign the ip address belonging to subnet 172.1.1.0/24 to one of its VPN
> clients, so it sends the subnet selection option 118 filled with the data
> 172.1.1.0 and subnet mask filled with data 255.255.255.0 as a result a relay
> agent receives it and forwards to dhcpserver, the dhcp server unicasts the
> packet to the relay agent, now will the relay agent need a special setting
> to tell it that packets destined to 172.1.1.0/24 subnet will be sent on
> 10.0.0.0/24 interface”
>
> Also would like to know that will the broadcast bit on packet based on which
> the server decides to broadcast or unicast a response packet have any impact
> on the way relay agent processes the packet.
>
>
>
> Regards
>
> Vivek
>
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>

-- 
Andre Kostur