Subject: [dhcwg] RFC3315bis - Naming

From: Ole Troan <[email-masked]>
Date: Mon, 3 Mar 2014 09:28:56 +0000

just a perspective on naming and at the risk of bike shedding.

rfc3315 uses client, relay, server
rfc3633 requesting router and delegating router

rfc3633 was written with the expectation that there was no relay, this was for the purpose of route injection.
actual deployments use relays, and there isn't any special function done on the delegating router, and no need to have a special name for it.

in 3315bis with prefix delegation being integrated fully into the main DHCP RFC, I don't see a new to maintain the separate terms. just use client, relay and server.

cheers,
Ole

---

From: Sheng Jiang <[email-masked]>
Date: Mon, 3 Mar 2014 09:34:22 +0000

Agree with Ole. Additional explanation text may be used to clarify that DHCPv6 PD server may be a dedicated standalone function without other standard DHCPv6 function.

Sheng
________________________________________
From: dhcwg [[email-masked]] on behalf of Ole Troan [[email-masked]]
Sent: 03 March 2014 17:28
To: DHC WG
Cc: Ralph Droms (rdroms)
Subject: [dhcwg] RFC3315bis - Naming

cheers,
Ole

---

From: Timothy Winters <[email-masked]>
Date: Mon, 3 Mar 2014 04:37:28 -0500

Hi,
	I also agree to use the same naming since we are combining IA_NA/IA_PD.

~Tim

On Mar 3, 2014, at 4:34 AM, Sheng Jiang <[email-masked]> wrote:

> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Leaf Yeh" <[email-masked]>
Date: Mon, 3 Mar 2014 10:01:54 -0000

...rfc3633 requesting router and delegating router...

Ole - I don't see a new to maintain the separate terms. just use client,
relay and server.

I support this point. In the scenarios of DHCPv6-PD,

a.  the DHCPv6 server has not always to be a router;
b.  the CE router can be both a requesting router for requesting a prefix in
IA_PD, and a client for requesting an address in IA_NA; in fact, they use
the same message from the same function module, but are in different
options.

Best Regards,
Leaf

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Ole Troan
Sent: Monday, March 03, 2014 9:29 AM
To: DHC WG
Cc: Ralph Droms (rdroms)
Subject: [dhcwg] RFC3315bis - Naming

rfc3633 was written with the expectation that there was no relay, this was
for the purpose of route injection.
actual deployments use relays, and there isn't any special function done on
the delegating router, and no need to have a special name for it.

in 3315bis with prefix delegation being integrated fully into the main DHCP
RFC, I don't see a new to maintain the separate terms. just use client,
relay and server.

cheers,
Ole

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 03 Mar 2014 12:15:40 +0100

Le 03/03/2014 11:01, Leaf Yeh a écrit :
> Ole - I don't see a new to maintain the separate terms. just use
> client, relay and server.

In a sense yes, I also agree with this, the discussion would be easier
if we just had Client, Relay and Server.

But I have a doubt about other RFCs using Requesting Router and
Delegating Router? (e.g. RFC6276 Prefix Delegation for NEMO, the queued
draft-ietf-netext-pd-pmip-14, and others).  People reading these may no
longer understand them.

Alex

> a.  the DHCPv6 server has not always to be a router; b.  the CE
> router can be both a requesting router for requesting a prefix in
> IA_PD, and a client for requesting an address in IA_NA; in fact,
> they use the same message from the same function module, but are in
> different options.
>
>
> Best Regards, Leaf
>
>
>
> -----Original Message----- From: dhcwg
> [mailto:[email-masked]] On Behalf Of Ole Troan Sent: Monday,
> March 03, 2014 9:29 AM To: DHC WG Cc: Ralph Droms (rdroms) Subject:
> [dhcwg] RFC3315bis - Naming
>
> rfc3315 uses client, relay, server rfc3633 requesting router and
> delegating router
>
> rfc3633 was written with the expectation that there was no relay,
> this was for the purpose of route injection. actual deployments use
> relays, and there isn't any special function done on the delegating
> router, and no need to have a special name for it.
>
> in 3315bis with prefix delegation being integrated fully into the
> main DHCP RFC, I don't see a new to maintain the separate terms.
> just use client, relay and server.
>
> cheers, Ole
>
>
>
> _______________________________________________ dhcwg mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/dhcwg
>

---

From: Tomek Mrugalski <[email-masked]>
Date: Mon, 03 Mar 2014 13:59:07 +0000

On 03.03.2014, 09:28, Ole Troan wrote:
> I don't see a new to maintain the separate terms. just use client,
> relay and server.
Hear hear. Unless folks who favor delegating/requesting router
nomenclature appear in huge numbers soon, we'll go with the client,
relay and server.

Cheers,
Tomek

---

From: Ted Lemon <[email-masked]>
Date: Mon, 3 Mar 2014 14:01:01 +0000

> draft-ietf-netext-pd-pmip-14, and others).  People reading these may no

This could probably be addressed by entries in the glossary.

---

From: Marcin Siodelski <[email-masked]>
Date: Mon, 3 Mar 2014 14:07:21 +0000

> nomenclature appear in huge numbers soon, we'll go with the client,

Current terminology for DHCP client and server in RFC3315 is:

DHCP client (or client):  A node that initiates requests on a link  to
obtain configuration parameters from one or more DHCP servers.
DHCP server (or server):  A node that responds to requests from
clients, and may or may not be on the same link as the client(s).

If we just stick to this terminology, there is nothing in it that
precludes it's use for PDs, as the node is a general term. So, I agree
that we should use client, server and relay for prefix delegation,
which would make editorial work way easier.

Marcin

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 3 Mar 2014 15:36:29 +0000

I was expecting we would define this all in intro (glossary) ... Requesting router = client. We will use client / server in most of the text (as rfc 3315 does).

- Bernie (from iPad)

> On Mar 3, 2014, at 9:07 AM, "Marcin Siodelski" <[email-masked]> wrote:
>

---

From: Ted Lemon <[email-masked]>
Date: Mon, 3 Mar 2014 15:32:21 +0000

> which would make editorial work way easier.

It's also easier to say, and easier to remember which is which—I always have to think when I try to use the requesting router/delegating router terminology.   Client and server is easy.