Subject: Re: [dhcwg] WGLC for draft-ietf-dhc-dhcpv4-active-leasequery-00 - Respond by Feb. 28

From: Mathias Samuelson <[email-masked]>
Date: Mon, 3 Mar 2014 15:51:16 +0000

Unfortunately this is coming in late, but fwiw I've also read this document and support advancing it.

Mathias

On Feb 24, 2014, at 8:42 PM, Bernie Volz (volz) <[email-masked]> wrote:

> Reminder that this WGLC is outstanding.
> 
> We need feedback in order to determine whether to advance this document.
> 
> - Bernie
> 
> -----Original Message-----
> From: dhcwg [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
> Sent: Tuesday, February 11, 2014 3:38 PM
> To: dhcwg
> Subject: [dhcwg] WGLC for draft-ietf-dhc-dhcpv4-active-leasequery-00 - Respond by Feb. 28
> 
> We have adopted two active leasequery drafts after Vancouver meeting.
> There was moderate interest in that work during adoption call, but we never saw any discussions about them on the ML. Since authors confidence in those proposals are high due to existing implementations, they have requested WGLC.
> 
> After a quick discussion between chairs, we have decided to go ahead with the WGLC, hoping that it will trigger some reviews and discussion.
> Please make no mistake - those drafts need reviews and comments. A simple "I support this" followed with couple +1s will not do do the trick here.
> 
> This WGLC is for draft-ietf-dhc-dhcpv4-active-leasequery-00. Please send your comments by Feb. 28th. Note that although both documents are very similar, they are separate drafts and are going through separate WGLCs.
> If you support this work, make sure that you clearly state which draft (v4, v6 or both) you support. Each WGLC will be assessed independently.
> 
> Finally, I'd also remind you that we are looking for volunteers to do the shepherding work. Please let us know if you'd like to be a shepherd for one of those documents. It is not a difficult task, but some prior IETF experience is necessary. As a shepherd, you can get unique insight into the WGLC process and better exposure to how IESG works. Having such an experience can be useful with moving your own draft forward faster.
> 
> Bernie & Tomek
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Lewis Donzis <[email-masked]>
Date: Mon, 3 Mar 2014 09:57:51 -0600

One other thing I wanted to ask about… currently the DHCPv4 bulk leasequery sends back the entire lease state database, whereas DHCPv6 does not, presumably because it would be ridiculously large.

However, since we have to handle both cases, our implementation doesn’t need the inactive v4 leases.  At the end of the bulk transfer, we just assume that any previously-active lease that wasn’t transferred must be inactive, just the same as if the server had sent an inactive lease.

Point being, it’s inefficient and unnecessary to transfer all of the inactive leases, so it might be nice to have an option on bulk leasequery to suppress the inactive entries.

The reason I mention it here is in case it would make sense to include it in the active leasequery document, i.e., extending bulk leasequery?

Thanks,
lew

On Feb 27, 2014, at 2:01 PM, Lewis Donzis <[email-masked]> wrote:

> I also have read the draft and agree that it should be moved forward.
> 
> We have already implemented a client and have experience with this
> protocol in large production networks, and it has proven to be extremely
> useful and has significant advantages over standard leasequery.
> 
> This may be outside the scope of this discussion, but it would be nice if
> the specification included, perhaps in section 7, that the server MUST or
> at least SHOULD include lease state changes for both dynamic and reserved
> addresses.  There has been some ambiguity on this and it would be nice if
> all implementations were consistent in this regard.  At a minimum, the
> DHCP server should provide the same information via active leasequery that
> it provides via standard leasequery.
> 
> lew
> 
> 
> 
>> On 11 Feb 2014, at 21:38, Tomek Mrugalski 
>> <[email-masked]> wrote:
>> 
>>> There was moderate interest in that work during adoption call, but
>>> we never saw any discussions about them on the ML. Since authors
>>> confidence in those proposals are high due to existing 
>> implementations,
>>> they have requested WGLC.
>>> 
>>> After a quick discussion between chairs, we have decided to go ahead
>>> with the WGLC, hoping that it will trigger some reviews and 
>> discussion.
>>> Please make no mistake - those drafts need reviews and comments. A
>>> simple "I support this" followed with couple +1s will not do do the
>>> trick here.
>>> 
>>> This WGLC is for 
>> draft-ietf-dhc-dhcpv4-active-leasequery-00. Please send
>>> your comments by Feb. 28th. Note that although both 
>> documents are very
>>> similar, they are separate drafts and are going through 
>> separate WGLCs.
>>> If you support this work, make sure that you clearly state 
>> which draft
>>> (v4, v6 or both) you support. Each WGLC will be assessed 
>> independently.
>>> 
>>> Finally, I'd also remind you that we are looking for 
>> volunteers to do
>>> the shepherding work. Please let us know if you'd like to 
>> be a shepherd
>>> for one of those documents. It is not a difficult task, but 
>> some prior
>>> IETF experience is necessary. As a shepherd, you can get 
>> unique insight
>>> into the WGLC process and better exposure to how IESG 
>> works. Having such
>>> an experience can be useful with moving your own draft 
>> forward faster.
>>> 
>>> Bernie & Tomek
>>>

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 3 Mar 2014 16:07:53 +0000

Interesting point as that is what we do for v6 (partly because it could be ridicously large depending on how leasing ranges are configured and over time as you would have to keep information on any lease the server ever gave out that it hasn't reused since the server has no idea what information requester might have had).

I guess in v4 as it is generally assumed that the address space is reasonably finite, not a significant issue. But that could also leave stuff behind if server is reconfigured to remove leases. So, yes this seems like it could be useful (optional).

Is it worth extending this for v4 at this time? Making it optional (client can request to only send "useful" stuff, server can ignore if it doesn't support) would be ok.

- Bernie (from iPad)

> On Mar 3, 2014, at 10:58 AM, "Lewis Donzis" <[email-masked]> wrote:
>

---

From: Kim Kinnear <[email-masked]>
Date: Mon, 3 Mar 2014 11:26:52 -0500

I think Lewis is saying that he thinks that it is worth extending the
v4 bulk leasequery draft at this time.  I think he agrees that the
approach you are suggesting would be reasonable.

I think his question is more: Where should this extension be documented?

  1. The existing v4 bulk leasequery RFC with a new draft.

  2. Add words to v4 active leasequery to extend the v4 bulk leasequery RFC,
  and of course change the active leasequery status to "extends v4 bulk
  leasequery".

#1 is the obvious approach, but higher overhead than #2.

Regards -- Kim

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 3 Mar 2014 16:35:41 +0000

I guess a separate draft would likely be best as otherwise it might not be noticed. 

The dhcpv6 active lq draft extends the dhcpv6 bulk lq, but in ways that likely only an active LQ implementation would need.

The dhcpv4 active lq draft does NOT at present extend dhcpv4 bulk lq, because the support for those similar extensions was already in RFC 6926.

BTW: all my comments on this thread were as a wg member/co-author, not as WG co-chair.

- Bernie (from iPad)

> On Mar 3, 2014, at 11:26 AM, "Kim Kinnear (kkinnear)" <[email-masked]> wrote:
> 
>

---

From: Tomek Mrugalski <[email-masked]>
Date: Fri, 14 Mar 2014 11:17:25 +0100

On 11.02.2014, 21:38, Tomek Mrugalski wrote:
> This WGLC is for draft-ietf-dhc-dhcpv4-active-leasequery-00. Please send
> your comments by Feb. 28th. Note that although both documents are very
> similar, they are separate drafts and are going through separate WGLCs.
> If you support this work, make sure that you clearly state which draft
> (v4, v6 or both) you support. Each WGLC will be assessed independently.

It took a slightly longer than anticipated, but here it is. Bernie and I
reviewed received responses and we declare a consensus being reached on
moving forward with dhcpv4-active-leasequery. There were some comments
received, though, so updated rev is needed.

Authors, please address raised comments and upload a new version.

Bernie & Tomek