Subject: Re: [dhcwg] WGLC for draft-ietf-dhc-dhcpv6-active-leasequery-00 - Respond by Feb. 28

From: Mathias Samuelson <[email-masked]>
Date: Mon, 3 Mar 2014 15:53:07 +0000

I read this a while back and support advancing it.

Similarly to the v4 ditto, I do apologize for coming in late. Feel free not to count me in. :)

Mathias

On Feb 24, 2014, at 8:42 PM, Bernie Volz (volz) <[email-masked]> wrote:

> Reminder that this WGLC is outstanding.
> 
> We need feedback in order to determine whether to advance this document.
> 
> - Bernie
> 
> -----Original Message-----
> From: dhcwg [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
> Sent: Tuesday, February 11, 2014 3:39 PM
> To: dhcwg
> Subject: [dhcwg] WGLC for draft-ietf-dhc-dhcpv6-active-leasequery-00 - Respond by Feb. 28
> 
> We have adopted two active leasequery drafts after Vancouver meeting.
> There was moderate interest in that work during adoption call, but we never saw any discussions about them on the ML. Since authors confidence in those proposals are high due to existing implementations, they have requested WGLC.
> 
> After a quick discussion between chairs, we have decided to go ahead with the WGLC, hoping that it will trigger some reviews and discussion.
> Please make no mistake - those drafts need reviews and comments. A simple "I support this" followed with couple +1s will not do do the trick here.
> 
> This WGLC is for draft-ietf-dhc-dhcpv6-active-leasequery-00. Please send your comments by Feb. 28th. Note that although both documents are very similar, they are separate drafts and are going through separate WGLCs.
> If you support this work, make sure that you clearly state which draft (v4, v6 or both) you support. Each WGLC will be assessed independently.
> 
> Finally, I'd also remind you that we are looking for volunteers to do the shepherding work. Please let us know if you'd like to be a shepherd for one of those documents. It is not a difficult task, but some prior IETF experience is necessary. As a shepherd, you can get unique insight into the WGLC process and better exposure to how IESG works. Having such an experience can be useful with moving your own draft forward faster.
> 
> Bernie & Tomek
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Sheng Jiang <[email-masked]>
Date: Fri, 14 Mar 2014 03:53:33 +0000

This may be late. However, here is my review and comments. (I would be the document shepherd. I will do another more thorough shepherd review after update version is available.)

Overall, I have read this draft and support it moving forward, but do wish the follow-up comments get answered or addressed among with the comments from others.

Unless I missed, there is no support for a requestor to initiatively end the Active Leasequery. The current document only state, in section 8.6, "the Requestor MAY close its end of the TCP connection at any time." But, closing TCP connection does not mean the Active Leasequery operation between the requestor and the server is properly closed.

It should be clearly defined what is "binding change", which is newly introduced. Particularly, it should be clarified that binding end is also binding change though it may be already known by lifetime when a binding was created.

It may help to add some clarification text for that this document require DHCPv6 server keeps/saves historic information of binding status (maybe in section 3). I may not sure the current DHCPv6 server implementations support this, which is the precondition that they can support catch-up function in this active leasequery. There is some relevant text in paragraph 8 of section 3. But it is not explicit enough. Also, it is unclear how a server know a DHCPv6 Active Leasequery requestor connection was interrupted, and whether it is temporarily. This may be relevant to the management of historic information on the server.

In the security consideration in section 10, regarding to "prevent information leakage", intercepting for the Active Leasequery information should be discussed.

There are a few minor nits. The authors should be able to locate them by running through the IETF online nits checking tool. Please do fix them in the update version.

Best regards,

Sheng

>Sent: Wednesday, February 12, 2014 4:39 AM
>To: dhcwg
>There was moderate interest in that work during adoption call, but
>we never saw any discussions about them on the ML. Since authors
>confidence in those proposals are high due to existing implementations,
>they have requested WGLC.
>
>After a quick discussion between chairs, we have decided to go ahead
>with the WGLC, hoping that it will trigger some reviews and discussion.
>Please make no mistake - those drafts need reviews and comments. A
>simple "I support this" followed with couple +1s will not do do the
>trick here.
>
>This WGLC is for draft-ietf-dhc-dhcpv6-active-leasequery-00. Please send
>your comments by Feb. 28th. Note that although both documents are very
>similar, they are separate drafts and are going through separate WGLCs.
>If you support this work, make sure that you clearly state which draft
>(v4, v6 or both) you support. Each WGLC will be assessed independently.
>
>Finally, I'd also remind you that we are looking for volunteers to do
>the shepherding work. Please let us know if you'd like to be a shepherd
>for one of those documents. It is not a difficult task, but some prior
>IETF experience is necessary. As a shepherd, you can get unique insight
>into the WGLC process and better exposure to how IESG works. Having such
>an experience can be useful with moving your own draft forward faster.
>
>Bernie & Tomek
>

---

From: Tomek Mrugalski <[email-masked]>
Date: Wed, 19 Mar 2014 13:19:02 -0700

> (v4, v6 or both) you support. Each WGLC will be assessed independently.
It took us longer than anticipated, but we finally solved all the
obstacles and here it is. Bernie and I assessed the responses received
and we declare this workgroup last call to have passed. Having said
that, there were couple technical issues raised, so we ask the authors
to address them and publish updated rev.

Make sure that the updated revision comes idnits clean.

Sheng Jiang is the document shepherd for this one. Thank you for
volunteering.

Bernie & Tomek