Subject: [dhcwg] Question on draft-ietf-dhc-dynamic-shared-v4allocation

From: Brian Haberman <[email-masked]>
Date: Thu, 09 Apr 2015 13:52:21 -0400

All,
    I have begun my AD evaluation of
draft-ietf-dhc-dynamic-shared-v4allocation and have a need for some
clarification.  Section 8 of the draft says:

   The DHCPv4 Port Parameters Option uses the same fields as the S46
   Port Parameters Option described in Section 4.5 of
   [I-D.ietf-softwire-map-dhcp], implemented as a DHCPv4 option.  This
   is to maintain compatibility with existing port set implementations.

   The format of OPTION_V4_PORTPARAMS is shown in Figure 1.

                 0                             1
                 0  1  2  3  4  5  6  7  8  9  0  1  2  3  4  5
                +--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+
                |      option-code      |     option-len        |
                +--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+
                |         offset        |       PSID-len        |
                +--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+
                |                     PSID                      |
                +--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+

                  Figure 1: DHCPv4 Port Parameters Option

However, when I go and review the option defined in section 4.5 of
draft-ietf-softwire-map-dhcp, I see an incompatible option format:

      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |     OPTION_S46_PORTPARAMS     |         option-length         |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |   offset      |    PSID-len   |              PSID             |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

                   Figure 6: S46 Port Parameters Option

Which is correct?

Regards,
Brian

---

From: Linhui Sun <[email-masked]>
Date: Fri, 10 Apr 2015 12:54:55 +0800

Hi, Brian

I think both are correct since they are defining two different kinds of
options. The option defined in draft-ietf-dhc-dynamic-shared-v4allocation
is a DHCPv4 option, while the draft-ietf-softwire-map-dhcp specifies DHCPv6
options. Thus the "option-code" and "option-len" fields are different in
the two options.

Best Regards,
Linhui

2015-04-10 1:52 GMT+08:00 Brian Haberman <[email-masked]>:

> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>
>

---

From: Qi Sun <[email-masked]>
Date: Fri, 10 Apr 2015 14:18:58 +0800

Dear Brian,

Thanks a lot for the evaluation! 

If I understand you correctly, the incompatibility is caused because this draft is defining a DHCPv4 option while draft-ietf-softwire-map-dhcp defines a DHCPv6 option. But the meanings of the fields should be the same, which "is to maintain compatibility with existing port set implementations". Considering the readability, we drew the Figure like this.

Do we need to reword the sentence to this:
"The DHCPv4 Port Parameters Option uses the similar fields ..."

?

Thank you very much,
Qi

Sent from my iPhone

---

From: Qi Sun <[email-masked]>
Date: Fri, 10 Apr 2015 17:29:52 +0800

Dear Brian,

After a second thought, the comment seems valid. The intention of that text was that the meaning of those fields is the same, not the exact format. However, the wording there is a little confusing. 

So how about the following change:

OLD:

NEW: 
The meaning of 'offset', 'PSID-len', and 'PSID' fields of the DHCPv4 Port Parameters Option is identical to that of 'offset', 'PSID-len', and 'PSID' fields of the S46 Port Parameters Option (Section 4.5 of [I-D.ietf-softwire-map-dhcp]). The use of the same encoding in both options is meant to ensure compatibility with existing port set implementations.

Would that be clearer?

Thanks,
Qi

Sent from my iPhone

---

From: Brian Haberman <[email-masked]>
Date: Fri, 10 Apr 2015 08:29:38 -0400

Hi Qi,

On 4/10/15 5:29 AM, Qi Sun wrote:
> Dear Brian,
> 
> After a second thought, the comment seems valid. The intention of
> that text was that the meaning of those fields is the same, not the
> exact format. However, the wording there is a little confusing.
> 
> OLD: The DHCPv4 Port Parameters Option uses the same fields as the
> S46 Port Parameters Option described in Section 4.5 of 
> NEW: The meaning of 'offset', 'PSID-len', and 'PSID' fields of the
> DHCPv4 Port Parameters Option is identical to that of 'offset',
> 'PSID-len', and 'PSID' fields of the S46 Port Parameters Option
> (Section 4.5 of [I-D.ietf-softwire-map-dhcp]). The use of the same
> encoding in both options is meant to ensure compatibility with
> existing port set implementations.
> 
> Would that be clearer?

Yes, that would be clearer and explains why I was shaking my head.

Let me finish my review and then you can submit a document with any
other changes needed.

Regards,
Brian

> Thanks, Qi
>> If I understand you correctly, the incompatibility is caused
>> because this draft is defining a DHCPv4 option while
>> draft-ietf-softwire-map-dhcp defines a DHCPv6 option. But the
>> meanings of the fields should be the same, which "is to maintain
>> compatibility with existing port set implementations". Considering
>> the readability, we drew the Figure like this.
>> 
>> Do we need to reword the sentence to this: "The DHCPv4 Port
>> Parameters Option uses the similar fields ..."
>> 
>> ?
>> 
>> Thank you very much, Qi
>> 
>> Sent from my iPhone
>> 
>>> All, I have begun my AD evaluation of 
>>> draft-ietf-dhc-dynamic-shared-v4allocation and have a need for
>>> some clarification.  Section 8 of the draft says:
>>> 
>>> The DHCPv4 Port Parameters Option uses the same fields as the
>>> S46 Port Parameters Option described in Section 4.5 of 
>>> [I-D.ietf-softwire-map-dhcp], implemented as a DHCPv4 option.
>>> This is to maintain compatibility with existing port set
>>> implementations.
>>> 
>>> 0                             1 0  1  2  3  4  5  6  7  8  9  0
>>> 1  2  3  4  5 +--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+ |
>>> option-code      |     option-len        | 
>>> +--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+ |
>>> offset        |       PSID-len        | 
>>> +--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+ |
>>> PSID                      | 
>>> However, when I go and review the option defined in section 4.5
>>> of draft-ietf-softwire-map-dhcp, I see an incompatible option
>>> format:
>>> 
>>> 0                   1                   2                   3 0 1
>>> 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 
>>> 
>>> Which is correct?
>>> 
>>> Regards, Brian
>>> 
>>> _______________________________________________ dhcwg mailing
>>> list [email-masked] https://www.ietf.org/mailman/listinfo/dhcwg