Subject: [dhcwg] On RFC 7819, privacy considerations for DHCP...

From: David Singer <[email-masked]>
Date: Thu, 16 Jun 2016 15:41:36 -0700

…has there been any discussion of the possibility of the client asking for a specific allocation strategy, specifically, “please give me a DIFFERENT IP address from what you would normally give me”?

One of the easiest ways to fingerprint a system is by IP address; MAC addresses are necessary local. If I’m trying to be private, it might be nice to be able to change my address on request.

David Singer
Manager, Software Standards, Apple Inc.

---

From: Christian Huitema <[email-masked]>
Date: Thu, 23 Jun 2016 21:03:41 +0000

On Thursday, June 16, 2016 3:42 PM, David Singer wrote:
> 
> …has there been any discussion of the possibility of the client asking for a
> specific allocation strategy, specifically, “please give me a DIFFERENT IP
> address from what you would normally give me”?

We considered that in RFC 7844, but we associated it to randomization of the MAC Address, the Client Identifier Option (IPv4) or the DUID (IPv6). The idea being that if a node presents a different identity to the server, the server will mechanically provide a different address.

> One of the easiest ways to fingerprint a system is by IP address; MAC addresses
> are necessary local. If I’m trying to be private, it might be nice to be able to
> change my address on request.

Yes. The simplest way is to pick a new Client Identifier or a new DUID, as suggested in RFC 7844. But if the MAC Address remains constant, some servers could still use that to identify the client and serve the same address.

-- Christian Huitema