Subject: Re: [dhcwg] WG meeting follow-up - Forcerenew Reconfiguration Extensions for DHCPv4

From: "Fang, Luyuan" <[email-masked]>
Date: Fri, 10 Feb 2017 05:29:39 +0000

Hi Bernie,

Thank you for your review and discussion. Sorry for the late reply.
MSFT Azure is working to have an implementation in CY17, we’ll wait a bit before WGLC.

Regarding your comments for Section 2.3, good points, we removed both sentences in the updated version.
https://tools.ietf.org/html/draft-ietf-dhc-dhcpv4-forcerenew-extensions-02

Thanks,
Luyuan

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wednesday, December 7, 2016 at 9:09 AM
To: "Fang, Luyuan" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "Deepak Bansal (AZURE)" <[email-masked]>, Fabio Chiussi <[email-masked]>
Subject: RE: WG meeting follow-up - Forcerenew Reconfiguration Extensions for DHCPv4

Thanks Luyuan.

So, at this point the next step is really to up to you … seems to be:

1.       Wait until MSFT has implemented and see if that generates any additional changes to the document

2.       Initiate WGLC (either now or after 1 – perhaps waiting is best)

I do see that Section 2.3 discusses some potential work (as this alternative mechanism is not defined):

   Alternatively, a mechanism for the client to explicit inform the
   server that it is declining the server-initiated DHCPINFOFORCERENEW
   reconfiguration procedure needs to be devised.

It seems to me that this might be worth either removing? That 2.3 section also has an odd sentence (This further aligns the client behavior in DHCPv4 server-initiated reconfiguration with the corresponding behavior in DHCPv6.) as I don’t recall any such capability in DHCPv6? In DHCPv6 a client can indicate whether it supports Reconfigure, but not which of the Reconfigure messages (Renew, Rebind, or Information-Request).

And, an issue with #1 is that you’d have to pick a message number to use as IANA won’t have assigned a new one for the DHCPFORCEINFORENEW message (and that could possible conflict if there was something else assigned in the interim, though I am not aware of anything.)

-          Bernie

From: Fang, Luyuan [mailto:[email-masked]]
Sent: Friday, December 02, 2016 12:14 AM
To: Bernie Volz (volz) <[email-masked]>; [email-masked]
Cc: [email-masked]; Deepak Bansal (AZURE) <[email-masked]>; Fabio Chiussi <[email-masked]>
Subject: Re: WG meeting follow-up - Forcerenew Reconfiguration Extensions for DHCPv4

Hi Tomek and Bernie,

Thanks for presenting the draft in the last IETF and bring this to dhc wg discussion. Sorry for the delayed response.

Yes, we still have strong interests to complete this work. MSFT is working to implement it in Azure. We will report the results when ready.
At the meantime, we’ll post a new version without content change.

Thanks,
Luyuan

From: "Bernie Volz (volz)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 23, 2016 at 10:50 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: WG meeting follow-up - Forcerenew Reconfiguration Extensions for DHCPv4

Hi:

At the IETF-97 (Seoul) DHC WG meeting, Tomek had a brief presentation regarding draft-ietf-dhc-dhcpv4-forcerenew-extensions (see https://www.ietf.org/proceedings/97/slides/slides-97-dhc-next-steps-for-draft-ietf-dhc-dhcpv4-forcerenew-extensions-00.pdf).

This document has been inactive since WG adoption and has now expired. The co-chairs made several attempts to contact the authors, but they were unresponsive. Tomek asked those in the room if there was any interest from someone to take on this work. There was no interest expressed, but we want to take it to the WG mailing list to see if anyone has any interest.

If you do have interest in working on this, please contact the DHC WG chairs ([email-masked]<mailto:[email-masked]>).

You can view the current (expired) draft at https://tools.ietf.org/html/draft-ietf-dhc-dhcpv4-forcerenew-extensions-00.

If there is no interest, the document will just be left as it is today (expired). Work on it can always be revived sometime in the future if a need develops.

Thanks.

-          Tomek & Bernie

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 10 Feb 2017 21:38:20 +0000

Hi:

Thanks.

- Bernie (from iPad)

On Feb 10, 2017, at 12:29 AM, Fang, Luyuan <[email-masked]<mailto:[email-masked]>> wrote:

Hi Bernie,

Thank you for your review and discussion. Sorry for the late reply.
MSFT Azure is working to have an implementation in CY17, we'll wait a bit before WGLC.

Thanks,
Luyuan

From: "Bernie Volz (volz)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 7, 2016 at 9:09 AM
To: "Fang, Luyuan" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Deepak Bansal (AZURE)" <[email-masked]<mailto:[email-masked]>>, Fabio Chiussi <[email-masked]<mailto:[email-masked]>>
Subject: RE: WG meeting follow-up - Forcerenew Reconfiguration Extensions for DHCPv4

Thanks Luyuan.

So, at this point the next step is really to up to you ... seems to be:

2.       Initiate WGLC (either now or after 1 - perhaps waiting is best)

It seems to me that this might be worth either removing? That 2.3 section also has an odd sentence (This further aligns the client behavior in DHCPv4 server-initiated reconfiguration with the corresponding behavior in DHCPv6.) as I don't recall any such capability in DHCPv6? In DHCPv6 a client can indicate whether it supports Reconfigure, but not which of the Reconfigure messages (Renew, Rebind, or Information-Request).

And, an issue with #1 is that you'd have to pick a message number to use as IANA won't have assigned a new one for the DHCPFORCEINFORENEW message (and that could possible conflict if there was something else assigned in the interim, though I am not aware of anything.)

-          Bernie

From: Fang, Luyuan [mailto:[email-masked]]
Sent: Friday, December 02, 2016 12:14 AM
To: Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Deepak Bansal (AZURE) <[email-masked]<mailto:[email-masked]>>; Fabio Chiussi <[email-masked]<mailto:[email-masked]>>
Subject: Re: WG meeting follow-up - Forcerenew Reconfiguration Extensions for DHCPv4

Hi Tomek and Bernie,

Yes, we still have strong interests to complete this work. MSFT is working to implement it in Azure. We will report the results when ready.
At the meantime, we'll post a new version without content change.

Thanks,
Luyuan

Hi:

Thanks.

-          Tomek & Bernie