Subject: Re: [dhcwg] [v6ops] DHCPv6 Prefix Delegation (DHCPv6 PD) on cellular links - works ok

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 30 Nov 2017 16:42:59 +0000

Good new!!

- Bernie (from iPhone)

On Nov 30, 2017, at 11:18 AM, Alexandre Petrescu <[email-masked]<mailto:[email-masked]>> wrote:

v6opsers,

We succeeded in making DHCPv6 PD work natively on a cellular link.
I would claim it to be a first[*].
Packet dump available upon request.

The UE device is a Huawei E392u-12 USB dongle produced in 2011.  It hosts a baseband processor Qualcomm model MDM9600 (or model MDM9200, or an Intel - not sure).  It lets all standard DHCPv6 messaging through. The DHCPv6 client 'odhcpv6' is running on linux laptop.

The mobile operator's PGW assigns a /56 and sets proper forwarding for it.  The PGW runs on a big Cisco platform.

After the successful DHCP exchange the laptop is able to ping google with a src address which is manually derived out of the /56 delegated prefix.

That said,

DHCPv6-PD on cellular links is relevant for a few RFCs and Internet Drafts.  They should be improved because at places these documents are a little bit wrong.

DHCPv6-PD is blocked on other baseband processors, including Qualcomm and Balong versions; they are hosted by many smartphones, USB cellular dongles, mobile personal WiFi hotspots and IoT devices.  A sample list is available upon request.

Last but not least,

[*] earlier DHCPv6 PD on cellular links was shown on tunnel virtual interfaces, like VPN.

Alex

_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Bjørn Mork <[email-masked]>
Date: Thu, 30 Nov 2017 20:03:13 +0100

> The UE device is a Huawei E392u-12 USB dongle produced in 2011.  It
> hosts a baseband processor Qualcomm model MDM9600 (or model MDM9200,
> or an Intel - not sure).

MDM9200.  Not that it matters much...

> It lets all standard DHCPv6 messaging through. The DHCPv6 client
> 'odhcpv6' is running on linux laptop.

Can't help being a bit curious about the Linux driver used for this
test? PPP?  qmi_wwan?  Something else?

(crossing fingers for qmi_wwan :-)

> DHCPv6-PD is blocked on other baseband processors, including Qualcomm
> and Balong versions; they are hosted by many smartphones, USB cellular
> dongles, mobile personal WiFi hotspots and IoT devices.  A sample list
> is available upon request.

Yes, the "smarter" these things get, the harder it is to make them work
properly.

Bjørn