Subject: Re: [dhcwg] I-D Action: draft-ietf-dhc-rfc3315bis-09.txt - questions about Solicit Prefix Delegation - src LL vs GUA

From: Roy Marples <[email-masked]>
Date: Wed, 15 Nov 2017 08:50:03 +0000

On 20/10/17 20:52, Ted Lemon wrote:
> On Oct 20, 2017, at 4:46 PM, Templin, Fred L <[email-masked] 
> <mailto:[email-masked]>> wrote:
>> Sorry I am late to this discussion, but AERO uses link-local source 
>> address for
>> all DHCPv6 PD messaging. It works in the public domain implementations I
>> have been working with.
> 
> It's actually nonsensical to use some other address.   One of the 
> purposes of DHCP is to get addresses, so if the server assumes you 
> already have one, how's that going to work?

That's not true.
Often you need to use a non link-local source address when the server 
sends OPTION_UNICAST with a non link-local address and you want to renew 
the lease.

Roy

---

From: Ted Lemon <[email-masked]>
Date: Wed, 15 Nov 2017 17:09:25 +0800

I would have to review, but isn't unicast support optional?

On Nov 15, 2017 16:50, "Roy Marples" <[email-masked]> wrote:

>> purposes of DHCP is to get addresses, so if the server assumes you already
>> have one, how's that going to work?
>>
>
> That's not true.

---

From: Ted Lemon <[email-masked]>
Date: Wed, 15 Nov 2017 17:10:07 +0800

Also, it's not nonsensical to use an address once you have one.

---

From: Roy Marples <[email-masked]>
Date: Wed, 15 Nov 2017 09:59:31 +0000

> I would have to review, but isn't unicast support optional?

Yes it is as written in the RFC.

However, during development of dhcpcd there are at least two upstreams 
who don't renew if it's not unicast when the unicast option is given.

Roy

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 15 Nov 2017 10:03:36 +0000

If I understand you, there is no requirement that unicast be used & so the servers (upstreams) are broken.

- Bernie (from iPhone)

On Nov 15, 2017, at 5:58 PM, Roy Marples <[email-masked]<mailto:[email-masked]>> wrote:

However, during development of dhcpcd there are at least two upstreams who don't renew if it's not unicast when the unicast option is given.

Roy

_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Roy Marples <[email-masked]>
Date: Wed, 15 Nov 2017 10:32:18 +0000

You are correct.

What I don't understand is if it's optional, why does the option exist 
in the first place if people here are saying not to use it?

Roy

On 15/11/2017 10:03, Bernie Volz (volz) wrote:
>> [email-masked] <mailto:[email-masked]>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 15 Nov 2017 18:36:27 +0800

On Nov 15, 2017, at 6:32 PM, Roy Marples <[email-masked]> wrote:
> What I don't understand is if it's optional, why does the option exist in the first place if people here are saying not to use it?

The point is that even if you use it, you still can't use it for the initial message.

---

From: <[email-masked]>
Date: Wed, 15 Nov 2017 14:10:16 +0000

Hi Ted,

There are networks where the host gets first a /64, and then uses DHCP-PD to get a longer prefix (e.g., /56). You can refer to RFC 6603, for example.

It may be tempting for some to restrict prefix delegation only to hosts that are already assigned a /64 is such case (that is, assume that the solicit request will be from a GUA address), but I do personally think this will lead to troubles given that a host does not have a clear guidance on which address to pick.

Cheers,
Med

De : dhcwg [mailto:[email-masked]] De la part de Ted Lemon
Envoyé : vendredi 20 octobre 2017 22:53
À : Templin, Fred L
Cc : [email-masked]; Alexandre Petrescu; Bernie Volz (volz)
Objet : Re: [dhcwg] I-D Action: draft-ietf-dhc-rfc3315bis-09.txt - questions about Solicit Prefix Delegation - src LL vs GUA

On Oct 20, 2017, at 4:46 PM, Templin, Fred L <[email-masked]<mailto:[email-masked]>> wrote:
Sorry I am late to this discussion, but AERO uses link-local source address for
all DHCPv6 PD messaging. It works in the public domain implementations I
have been working with.

It's actually nonsensical to use some other address.   One of the purposes of DHCP is to get addresses, so if the server assumes you already have one, how's that going to work?