Subject: [Dime] Media Independent Handover & draft-stupar-dime-mos-options-00.txt

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 01 Mar 2008 20:13:24 +0200

Folks,

I got some information from the IETF MIPSHOP chairs regarding
a recently submitted draft: draft-stupar-dime-mos-options-00.txt

----

The MIPSHOP WG is working on a solution for a mobile node to
discover 802.21 MIH servers when the mobile node attaches to
an access router. Part of the solution involves delivering
the MIH server information from a AAA server to the NAS on
the access link. DHCP is then used to deliver the information
to the mobile node. We need the DIME WG's help in completing
the Diameter extensions for this.

The IEEE 802.21 WG is very interested in the MIH work we are
doing in the IETF. They have sent a couple of liaison
statements to the MIPSHOP WG saying they want this work
completed in the IETF. I have attached one liaison letter we
got from them recently.

---

I told the MIPSHOP chairs that it would be nice to get a bit
of information about  the Media Independent Handover work so
that DIME working group members are able to judge the
specific solution.

Ciao
Hannes

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: "Patrick Stupar" <[email-masked]>
Date: Mon, 3 Mar 2008 18:50:11 +0100

Dear all,

Please find some additional info about the MIH work that's currently being done in MIPSHOP. Among this work's tasks, the one related to DIME WG is the definition of a solution enabling the discovery of the functional elements in the network providing the services defined by IEEE 802.21 - Media Independent Handover (MIH) draft. Such services, named Mobility Services (MoS) or MIH services, are meant to enable efficient handover procedures among heterogeneous technologies. To achieve this, IEEE 802.21 draft defines three types of services:
- Information Service (IS), providing network topology information. 
- Event Service (ES), indicating changes in state and transmission behavior of the physical, data link and logical link layers of a device.
- Command Service (CS), providing a way to control the physical, data link, and logical link layers of a mobile terminal.

The solution for the discovery of such services defines DNS and DHCP extensions to provide the IP address or the FQDN of the MIH Servers. The use of one solution rather than the other depends on the location of the MIH server (which can be in the home, visited or a third party network) and of the mobile node (home or visited network).  

For further information, please see:
Draft-ietf-mipshop-mstp-solution
Draft-bajko-mos-dhcp-options
Draft-bajko-mos-dns-discovery

To complete the DHCP solution, Diameter AVP extensions are required. As already explained by Hannes, in this case MIH servers information (IP address or FQDN) is transported from AAA server to the NAS, where it is transferred to DHCP Relay (which in turn delivers it to the node). Draft-stupar-dime-mos-options-00 defines such AVPs.
The DHCP-based solution is quite similar to the one defined for MIPv6 bootstrapping for the integrated scenario. 

Comments and reviews are welcome and appreciated

Regards,

Patrick

--
Patrick Stupar
Research Staff Member
NEC Europe Ltd.
NEC Laboratories Europe
Network Division			
Kurfürsten-Anlage 36		
69115 Heidelberg
GERMANY	
		
phone  +49 6221 4342 215		
fax    +49 6221 4342 155
eMail: [email-masked]

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Hannes Tschofenig
> Sent: Saturday, March 01, 2008 7:13 PM
> To: [email-masked]
> Subject: [Dime] Media Independent Handover 
> &draft-stupar-dime-mos-options-00.txt
> 
> Folks,
>