Subject: Re: [Dime] Transient Failures in DCCA

From: Preeti Shandilya <[email-masked]>
Date: Wed, 12 Mar 2008 20:42:00 +0530

Hi !

Server should not wait to get terminate request from client after sending CCA with result code 4010 or 4011 or 4012. The reason is that client shall clear the session contexts , on receiving any of these result codes from server and then it shall never send terminate request

regards

preeti

[email-masked] wrote: -----

To: [email-masked]
From: ?Ï?Á <[email-masked]>
Sent by: [email-masked]
Date: 02/29/2008 01:31PM
Subject: [Dime] Transient Failures in DCCA

Hello,
Please, give the comments upon  RFC 4006 on next conclusion:
When server in CCA Update return Result_Code = 4010 or 4011 or 4012.
Server MUST  or not MUST wait from client CCR Terminate?
Thank You.

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

*****Aricent-Unclassified *****=

"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of
the individual to whom it is addressed. It may contain privileged or confidential information and should not be
circulated or used for any purpose other than for what it is intended. If you have received this message in error,
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for
loss or damage arising from the use of the information transmitted by this email including damage from virus."

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: Igor Mammedov <[email-masked]>
Date: Mon, 31 Mar 2008 14:00:53 +0400

> Server should not wait to get terminate request from client after sending CCA with result code 4010 or 4011 or 4012. The reason is that client shall clear the session contexts > on receiving any of these result codes from server and then it shall never send terminate request

Then we possibly have a typo in rfc4006.

It says that client MUST send stop CCR.
Page 16,
"
5.1.   General Principles
...
   If service specific re-authorization fails, the user will be
   disconnected, and the credit-control client MUST send a final
   interrogation to the credit-control server.
"

But:
account being empty = 4012 (transient failure)
Page 47,
"
   The event 'Not successfully processed' means that the credit-control
   server could not process the message; e.g., due to an unknown end
   user, account being empty, or errors defined in [DIAMBASE].
"

and server's state machine says that session is gone after such error:

Page 55,
"
    Open      CC update request              Send          Idle
              received but not               CC update
              successfully processed         answer with
                                             Result-Code
                                             != SUCCESS,
                                             debit used
                                             units

"

Client's state machine does not mention the event 'Not successfully processed'
at all.

So it looks like rfc conflicts within itself and do not completely describe
behavior in case of "Transient Failures".

PS:
Is it reasonable to kill session, lets say on error 4012, and possibly loose
the last granted units because server is not going wait for service termination
and 'final interrogation'.