Subject: [Dime] Review of draft-jones-3gpp-eps-command-codes-00

From: Victor Fajardo <[email-masked]>
Date: Thu, 04 Dec 2008 15:55:47 -0500

Hi Mark/Lionel,

Comments on draft-jones-3gpp-eps-command-codes-00:

* Maybe add the following sentence to the introduction to clarify the 
purpose of the doc:

"This document defines the assigned values of the command codes used in 
these applications."

* Change 1st paragraph of Sec 3 from:

"As described in [TS29.272], the 3GPP S6a application specifies the
 following command pairs:"

to:

"3GPP S6a application in [TS29.272] requires the definition of command 
code values for
 the following command pairs:"

* Change 2nd paragraph of Sec 3 from:

"Also described in [TS29.272], the 3GPP S13 application specifies the
 following command pair:"

to:

"3GPP S13 application in [TS29.272] requires the definition of the 
command code values for
 the following command pairs:"

* Change 2nd paragraph of the IANA considerations from:

"This document defines values in the namespaces that have been created
  and defined in the Diameter Base [RFC3588]. The IANA Considerations
 section of that document details the assignment criteria. Values ..."

to:

"This document defines values in the namespaces that have been created
 and defined in Sec 11.2.1 of the Diameter Base [RFC3588].  Sec 11,
 IANA Considerations of [RFC3588] details the assignment criteria.
 Values ..."

* Are the values intended to forward compatible with bis ? If so, does 
it need to
  fall in the 0x800000 - 0xfffffd range ? If so, do we need to mention
  that in the IANA actions (since this is absent in 3588) ?

As it is, the document complies with the 3588 command code allocation 
process.

regards,
victor

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: Mark Jones <[email-masked]>
Date: Mon, 8 Dec 2008 12:06:09 -0500

Thanks for the review, Victor.

Responses/Comments inline. I'll incorporate your changes into the -01 version and publish shortly.

> -----Original Message-----
> From: Victor Fajardo [mailto:[email-masked]]
> Sent: December 4, 2008 15:56
> To: [email-masked]; Mark Jones; MORAND Lionel RD-CORE-ISS
> Subject: Review of draft-jones-3gpp-eps-command-codes-00
>
> Hi Mark/Lionel,
>

Ok.

>  the following command pairs:"

Ok

>  the following command pairs:"

Ok

>  IANA Considerations of [RFC3588] details the assignment criteria.

Ok but would prefer "Section" instead of "Sec".

> As it is, the document complies with the 3588 command code allocation

My understanding is that IANA must follow the rules in 3588 until 3588bis is ratified. That unfortunately means that the 3GPP S6a/S13 values will be taken from the IETF range as proposed in 3588bis but I see no means to give any alternative guidance to IANA.

Thanks
Mark

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 8 Dec 2008 20:18:00 +0100

Victor,

What is your recommendation of behalf of DIME? Assuming that the
comments you made are resolved is the document at the appropriate
quality level to be undertaken as an AD-sponsored document? 

Any other opinions from other DIME WG participants? 

Dan

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Victor Fajardo
> Sent: Thursday, December 04, 2008 10:56 PM
> Subject: [Dime] Review of draft-jones-3gpp-eps-command-codes-00
> 
> Hi Mark/Lionel,
> 
> * Maybe add the following sentence to the introduction to 
> clarify the purpose of the doc:
> 
> "This document defines the assigned values of the command 
> codes used in these applications."
> 
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 8 Dec 2008 20:19:25 +0100

Mark,

Do not forget that in order to complete the submission process you need
to find a proto-shepherd, and the shepherd needs to submit a proto
write-up. 

Thanks and Regards,

Dan

> Behalf Of Mark Jones
> Sent: Monday, December 08, 2008 7:06 PM
> To: Victor Fajardo; [email-masked]
> Subject: Re: [Dime] Review of draft-jones-3gpp-eps-command-codes-00
> 
> My understanding is that IANA must follow the rules in 3588 
> until 3588bis is ratified. That unfortunately means that the 
> 3GPP S6a/S13 values will be taken from the IETF range as 
> proposed in 3588bis but I see no means to give any 
> alternative guidance to IANA.
> 
> Thanks
> Mark

---

From: Victor Fajardo <[email-masked]>
Date: Mon, 08 Dec 2008 16:22:34 -0500

Hi Dan,
> Victor,
>
> What is your recommendation of behalf of DIME? 

I think the document can move forward under AD-sponsorship.

> Assuming that the

Yes I believe so.

regards,
victor

---

From: Mark Jones <[email-masked]>
Date: Tue, 9 Dec 2008 09:15:55 -0500

> Behalf Of Romascanu, Dan (Dan)
> Sent: December 8, 2008 14:19
> To: Mark Jones; Victor Fajardo; [email-masked]

Understood, Dan. A draft PROTO write-up is being prepared by the authors while we continue the search for a doc shepherd.

Thanks
Mark

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Tue, 9 Dec 2008 16:19:21 +0200

I will do the shepherd. 

>Behalf Of ext Mark Jones
>Sent: 09 December, 2008 16:16
>To: Romascanu, Dan (Dan); Victor Fajardo; [email-masked]
>> From: [email-masked] [mailto:[email-masked]] On Behalf 
>> Of Romascanu, Dan (Dan)
>> Do not forget that in order to complete the submission process you 
>> need to find a proto-shepherd, and the shepherd needs to submit a 
>> proto write-up.
>>
>
>Understood, Dan. A draft PROTO write-up is being prepared by 
>the authors while we continue the search for a doc shepherd.
>
>Thanks
>Mark
>
>
>
>> Thanks and Regards,
>>
>> Dan
>>
>>
>> > From: [email-masked] [mailto:[email-masked]] 
>On Behalf 
>> > Of Mark Jones
>> > > command code values for  the following command pairs:"
>> > >
>> >
>> > Ok
>> >
>> > >
>> > My understanding is that IANA must follow the rules in 3588 until 
>> > 3588bis is ratified. That unfortunately means that the 
>3GPP S6a/S13 
>> > values will be taken from the IETF range as proposed in 
>3588bis but 
>> > I see no means to give any alternative guidance to IANA.
>> >
>> > Thanks
>> > Mark

---

From: Mark Jones <[email-masked]>
Date: Tue, 9 Dec 2008 09:22:11 -0500

> From: Tschofenig, Hannes (NSN - FI/Espoo)
> [mailto:[email-masked]]
> Sent: December 9, 2008 09:19
> To: Mark Jones; Romascanu, Dan (Dan); Victor Fajardo; [email-masked]
> Subject: RE: [Dime] Review of draft-jones-3gpp-eps-command-codes-00
>
> I will do the shepherd.
>

Thanks Hannes. Very much appreciated.

Regards
Mark

---

From: "Glen Zorn" <[email-masked]>
Date: Wed, 10 Dec 2008 09:00:42 +0700

> Any other opinions from other DIME WG participants?

Actually, I liked the draft better w/o Victor's changes, which in one case
at least introduce linguistic inaccuracy ("3GPP S13 application in
[TS29.272] requires the definition of the command code values for the
following command pairs": there is only one command code pair following).
In any case, the doc looks fine to me.

...

---

From: Mark Jones <[email-masked]>
Date: Wed, 10 Dec 2008 07:54:41 -0500

Thanks for the review Glen. I'll fix the linguistic inaccuracy.

Regards
Mark

> From: Glen Zorn [mailto:[email-masked]]
> Sent: December 9, 2008 21:01
> To: 'Romascanu, Dan (Dan)'
> Cc: [email-masked]; 'Victor Fajardo'; Mark Jones; 'MORAND
> Lionel RD-CORE-ISS'