Subject: [Dime] Comments on draft-ietf-dime-priority-avps-00.txt

From: Janet P Gunn <[email-masked]>
Date: Tue, 4 May 2010 16:06:33 -0400

Mostly Nits

End of sec 1- What is [draft.rsvp-priority-extension]?   Do you mean 
draft-ietf-tsvwg-emergency-rsvp? (And it is now up to rev 15, rather than 
the 14 cited in your references)

Sec 3.2  I think "the admission priority parameter defined in Section 3.1 
of   [I-D.ietf-tsvwg-emergency-rsvp]." should refer to sec 5.1

Sec 3.3, 3.4

It might be a good idea to put something in the text explaining the 
rationale for specifying both the full text "Namespace, Value" pair and 
the numerical encoding defined in sec 5.2 and sec 7 of 
[I-D.ietf-tsvwg-emergency-rsvp].  They contain the same information, 
though in quite different formats. It is presumably because SIP uses one 
format and RSVP uses a different format, but it wouldn't hurt to add a 
sentence of explanation.

Lower level question-
If you are using the full text "Namespace, value" pair, I suggest calling 
it "RPH-Namespace" or "SIP-RPH-Namespace" rather than "SIP-Namespace". 
(Same for SIP-Value), to avoid confusion with other SIP Namespaces and 
other SIP Values.

Sec 3.4
The subsections should be renumbered 3.4.1 and 3.4.2.

Janet

This is a PRIVATE message. If you are not the intended recipient, please 
delete without copying and kindly advise us by e-mail of the mistake in 
delivery. 
NOTE: Regardless of content, this e-mail shall not operate to bind CSC to 
any order or other contract unless pursuant to explicit written agreement 
or government initiative expressly permitting the use of e-mail for such 
purpose.

---

From: ken carlberg <[email-masked]>
Date: Wed, 5 May 2010 09:35:48 -0400

Hi Janet,

Thanks for the comments.

> Mostly Nits 
> 
> End of sec 1- What is [draft.rsvp-priority-extension]?   Do you mean draft-ietf-tsvwg-emergency-rsvp? (And it is now up to rev 15, rather than the 14 cited in your references) 

yes, good catch.  I'll correct this

> Sec 3.2  I think "the admission priority parameter defined in Section 3.1 of   [I-D.ietf-tsvwg-emergency-rsvp]." should refer to sec 5.1 

yes, another good catch.

> Sec 3.3, 3.4 
> 
> It might be a good idea to put something in the text explaining the rationale for specifying both the full text "Namespace, Value" pair and the numerical encoding defined in sec 5.2 and sec 7 of [I-D.ietf-tsvwg-emergency-rsvp].  They contain the same information, though in quite different formats. It is presumably because SIP uses one format and RSVP uses a different format, but it wouldn't hurt to add a sentence of explanation. 

Your understanding is correct, and I'll add some text to make this clear to the reader.

> Lower level question- 
> If you are using the full text "Namespace, value" pair, I suggest calling it "RPH-Namespace" or "SIP-RPH-Namespace" rather than "SIP-Namespace". (Same for SIP-Value), to avoid confusion with other SIP Namespaces and other SIP Values. 

ok, I'll alter the text to be more descriptive to relate to the optional RPH field.

> The subsections should be renumbered 3.4.1 and 3.4.2. 

right.

thanks again,

-ken