Subject: [Dime] Origin-State-Id AVP

From: Vipul2 Aggarwal <[email-masked]>
Date: Thu, 6 May 2010 18:33:51 +0530

Hi,

I have a query regarding usage of Origin-State-Id AVP in Diameter.

The Diameter Base Protocol RFC 3588 says that Origin-State-Id AVP MAY be included in any diameter message.

Now, some diameter based application (like a 3GPP defined application) defines new commands and in those commands' ABNF Origin-State-Id AVP is not present.
Then does this imply that Origin-State-Id AVP MUST not be sent in these commands or it can be sent because RFC 3588 says it can be sent in any diameter message?

Thanks n Regards,
Vipul Aggarwal
ARICENT
Gurgaon
India

________________________________
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

---

From: Jouni <[email-masked]>
Date: Thu, 6 May 2010 21:22:40 +0300

Hi,

Eventually it is up to the command ABNF. If the command ABNF has *[AVP] then including Origin-State-Id AVP is ok. 

- Jouni

On May 6, 2010, at 4:03 PM, Vipul2 Aggarwal wrote:

> Now, some diameter based application (like a 3GPP defined application) defines new commands and in those commands’ ABNF Origin-State-Id AVP is not present.
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime

---

From: Vipul2 Aggarwal <[email-masked]>
Date: Fri, 7 May 2010 11:06:49 +0530

Hi,

Thanks Jouni for the clarification.

I think now I need to take my query with 3GPP.
But, in case, anyone can help me here, I am describing my query below.

========================================================================
I am specifically concerned about 3GPP S6a application defined in 29.272.
S6a is the interface between MME and HSS.
The Origin-State-Id AVP is not present in any of the 8 commands' ABNF defined in 29.272. However, there is *[AVP].
So, I now know that Origin-State-Id AVP can theoretically come.
But, I doubt whether it is really required in S6a, as the Auth-Session-State AVP for S6a is NO_STATE_MAINTAINED i.e. no state information about a session is maintained?
Moreover, there is a Reset Request command from HSS to indicate to the MME about the restart of HSS.
So, I think Origin-State-Id AVP is not required in S6a Application. Does anyone have different views?
========================================================================

Thanks n Regds,
Vipul

-----Original Message-----
From: Jouni [mailto:[email-masked]]
Sent: Thursday, May 06, 2010 11:53 PM
To: Vipul2 Aggarwal
Cc: [email-masked]
Subject: Re: [Dime] Origin-State-Id AVP

Hi,

- Jouni

---

From: jouni korhonen <[email-masked]>
Date: Fri, 7 May 2010 10:24:40 +0300

Hi,

> But, in case, anyone can help me here, I am describing my query below.

Yes, it can. However, in this particular case my concern would be the content of M-bit. As S6a is based on base protocol, it would sound logical that S6a application should then understand RFC3588 AVPs with M-bit set. Based on the earlier experience on 3GPP interfaces such assumption would be rather risky though ;)

> So, I think Origin-State-Id AVP is not required in S6a Application. Does anyone have different views?

There are people here who are familiar with S6a (and basically the whole plethora of 3GPP Diameter interfaces). However, the question as such is rather specific to 3GPP, especially as the S6a *is* a 3GPP vendor specific application. We really don't have much control over it. So I advice you to bring your question to 3GPP CT4 mailing list (http://list.etsi.org/3gpp_tsg_ct_wg4.html) and ask there.

- Jouni