Subject: Re: [Dime] Another round of WGLCs and WG status

From: jouni korhonen <[email-masked]>
Date: Mon, 24 May 2010 22:37:13 +0300

Hi all,

We can conclude from the WGLC that local-keytran and also pririty-avps (though we got only 2 comments..) can move on. Authors, provide revisions that addresses all comments on your documents and we'll move them forward.

Jouni & Lionel

On Apr 26, 2010, at 2:29 PM, jouni korhonen wrote:

> Hi all,
> 
> The following drafts have been in kind of a limbo for quite some time.
> 
> 1) draft-ietf-dime-priority-avps       WGLC ended 16th Mar
> 2) draft-ietf-dime-capablities-update  WGLC ended 23rd Jan
> 3) draft-ietf-dime-local-keytran       WGLC ended 7th Mar
> 4) draft-ietf-dime-rfc3588bis          WGLC ended 5th July 
> 5) draft-ietf-dime-app-design-guide
> 
> The WGLC for draft-ietf-dime-local-keytran-01 ended 7th Match. We received only *one* review and a subsequent draft revision. Although, a WGLC stands for the "last call", we decided to run one quick more due the low number of reviews. Please, review the document and give any indication whether you are fine with it or not. The WGLC#2 ends 10th May.
> 
> The WGLC for draft-ietf-dime-priority-avps ended 16th March. We received *one* comment and decided to run one more based on the same reasons as above. Please, review the document and give any indication whether you are fine with it or not. The WGLC#2 ends 10th May.
> 
> Although it may not look like it, we definitely intend to move above two documents forward as soon as possible. I encourage respective authors to work offline to get people to review their documents.
> 
> Lionel and I will have a look at draft-ietf-dime-app-design-guide, and hopefully get the document move forward soon.
> 
> Jouni will write a proto write-up and shepherd the rfc3588bis (after I actually have read latest revision).
> Lionel will write a proto write-up and shepherd the capablities-update.
> 
> 
> 
> Jouni & Lionel

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 25 May 2010 12:49:18 +0700

jouni korhonen [mailto://[email-masked]] writes:

> Hi all,
> 
> We can conclude from the WGLC that local-keytran and also pririty-avps
> (though we got only 2 comments..) can move on. Authors, provide
> revisions that addresses all comments on your documents and we'll move
> them forward.

It would be helpful if the chairs would provide a list of the accepted
changes since (in the case of local-keytran, at least) not all comments were
valid.

...

---

From: jouni korhonen <[email-masked]>
Date: Tue, 25 May 2010 12:10:18 +0300

> changes since (in the case of local-keytran, at least) not all comments were

We could hold your hand as well ;) Anyway, seriously, I though to put all stuff to tracker (just like RADEXT started to do) if folks would be OK with that. It is a bit more spam on the list but would be rather clear to follow each separate topic assuming folks would use it systematically.

Regarding the local-keytran case, which part of the comments you refer here? Domains?

- Jouni

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 25 May 2010 16:40:13 +0700

jouni korhonen [mailto:[email-masked]] writes:

> We could hold your hand as well ;) 

The last time I checked, modifications to WG drafts were made by WG
consensus _only_ & the responsibility for determining WG consensus was that
of the WG Chairs, _not_ the document editor(s).  

> Anyway, seriously, I though to put
> all stuff to tracker (just like RADEXT started to do) if folks would be
> OK with that. 

It's a great idea, but only if you want to stop all progress (as the "tool"
was used to great effect by the radext chairs).

> It is a bit more spam on the list but would be rather
> clear to follow each separate topic assuming folks would use it
> systematically.

This includes you, of course: you still have to make clear which changes are
OK & which are not.  Is it too much trouble to send an email stating the
changes to be made?

> Regarding the local-keytran case, which part of the comments you refer

All of them: the only comments I've seen on any of Joe's or Tom's comments
have been mine.

---

From: jouni korhonen <[email-masked]>
Date: Tue, 25 May 2010 13:52:59 +0300

> of the WG Chairs, _not_ the document editor(s).  

Sure thing.. However, the only thing imho that really deviated from "how about - ok" discussion was the domain stuff and that was then specifically said to be left out.

> was used to great effect by the radext chairs).

Heh ;) That is what I am afraid off. Any other views? 

> OK & which are not.  Is it too much trouble to send an email stating the

Looking at the thread put into wiki..

o Frank Xia's review (1/3) and  Glen's response -> ok
   * I don't have a problem with an AVP occurrence table. Though, I would
     generalize the table to just Req & Rep 'general purpose commands' that
     are not actually tied to a specific command. Though such general purpose
     commands might need text saying they behave like DER/DEA etc..

o Joe Salowey's review (2/3) --
   * for domain that was agreed to be left out (as no one came up with
     a good use case).
   * rest of for Key types Joe provided text. Did not see objections to it.
   * Key-SPI stays.
   * others where text was proposed were acked as 'good' or 'ok' so
     those fly in.

o Tom Taylor's comments (3/3) --
  * comment 2 - up to the editor. I am ok with the current 5.2 content.

> All of them: the only comments I've seen on any of Joe's or Tom's comments

After all these weeks we can conclude that the silence means acceptance for the comments/proposals above. Others seem to be fine with you three.

- Jouni

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 25 May 2010 20:44:28 +0700

...

>      commands might need text saying they behave like DER/DEA etc..

Actually, the more I think about this idea, the less I like it: as you
imply, AVP occurrence tables actually belong in application specs, which
this is not.

...

---

From: jouni korhonen <[email-masked]>
Date: Tue, 25 May 2010 23:57:33 +0300

> imply, AVP occurrence tables actually belong in application specs, which

Good point. In past we had few similar cases (general purpose AVPs) and if we had some recommendations on the use of the AVPs, then we used e.g. the Req & Rep approach.

- JOuni

---

From: "Glen Zorn" <[email-masked]>
Date: Wed, 26 May 2010 08:14:12 +0700

jouni korhonen [mailto:[email-masked]] writes:

> Good point. In past we had few similar cases (general purpose AVPs) and
> if we had some recommendations on the use of the AVPs, then we used e.g.
> the Req & Rep approach.

OK, but it seems to me that only one (grouped) AVP is being defined here; a
table seems to be overkill...