Subject: Request for addition to disman WG charter

From: Randy Presuhn <[email-masked]>
Date: Wed, 27 Dec 2000 16:44:57 -0800 (PST)

Hi Bert -

As disman WG chair, I'd like to formally request the addition
of the work on an "Alarm Management MIB" to our charter.  I
would like Sharon Chisholm and Dan Romascano to serve as the
document editors.

There appears to be strong consensus in the WG that we should
take on this work, and that it would have significant value
for the industry.

The work on the Alarm MIB will take into consideration existing
standards and practices, such as ITU-T X.733.  Whether any
mappings to these other standards appear in the Alarm MIB or
in separate documents will be decided by the WG.

The proposed timetable, based on feedback from the WG:

   January 2001: First WG draft of Alarm Management MIB.

   February 2001: WG agreement on direction regarding mappings
                  to / from other alarm frameworks.

   February 2001: Submit updated draft of Alarm MIB for IETF meeting.

   March 2001: Meet at the 50th IETF in Minneapolis, Minnesota

   July 2001: Submit updated draft of Alarm MIB for IETF meeting.

   August 2001: Meet at 51st IETF in London, England

   August 2001: WG last call on Alarm Management MIB

   September 2001: Alarm Management MIB delivered to IESG for
              consideration as proposed standard.

Your feedback and comments would be appreciated; let me know
when it's OK to forward this to the secretariat.

 -------------------------------------------------------
 Randy Presuhn           [email-masked]
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141
 Fax:   +1 408 965-0359  2141 North First Street
 http://www.bmc.com/     San José, California 95131  USA
 -------------------------------------------------------
 My opinions and BMC's are independent variables.
 -------------------------------------------------------

---

From: Dan Romascanu <[email-masked]>
Date: Thu, 28 Dec 2000 10:18:11 +0200

Randy,

As part of the current discussion, we are considering the option of issuing
two separate MIB modules - one including the model neutral MIB functions,
and the second mappings of the ITU-I X.733 model alarms. If we decide for
two documents, I would suggest that the wording in the charter allows to
include the second document in the same timeframe as the first one.

Regards,

Dan

> -----Original Message-----
> From:	Randy Presuhn [SMTP:[email-masked]]
> Sent:	Thu December 28 2000 2:45
> To:	[email-masked]
> Cc:	[email-masked]
> Subject:	Request for addition to disman WG charter
> 
> 
> Hi Bert -
>

---

From: Randy Presuhn <[email-masked]>
Date: Thu, 28 Dec 2000 12:20:58 -0800 (PST)

Hi -

> Message-ID: <[email-masked]>
> From: Dan Romascanu <[email-masked]>
> To: "'Randy Presuhn'" <[email-masked]>, [email-masked]
> Subject: RE: Request for addition to disman WG charter
> Date: Thu, 28 Dec 2000 10:18:11 +0200
...
> include the second document in the same timeframe as the first one.
...

> > in separate documents will be decided by the WG.
...

Does anyone have any ideas how we could make this clearer without
committing to two separate documents at this time?

---

From: Randy Presuhn <[email-masked]>
Date: Thu, 28 Dec 2000 13:47:55 -0800 (PST)

Hi -

I'm forwarding a post by Jon.  I've added this alternate address to
this disman "posters" list.

> Received: from tattler.bmc.com (tattler.bmc.com [172.17.0.117])
> 	by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) with ESMTP id NAA06411;
> 	Thu, 28 Dec 2000 13:09:51 -0800 (PST)
> Received: from fw-us-hou1.bmc.com (localhost [127.0.0.1])
> 	by tattler.bmc.com (8.10.2/8.10.2) with SMTP id eBSL8g920014;
> 	Thu, 28 Dec 2000 15:08:47 -0600 (CST)
> Received: from europa-h0001027441c5.ne.mediaone.net (sun.ne.mediaone.net [192.168.20.40])
> 	by h0001027441c5.ne.mediaone.net (8.9.3/8.8.7) with ESMTP id QAA19692;
> 	Thu, 28 Dec 2000 16:10:44 -0500
> Received: from europa (localhost [127.0.0.1])
> 	by europa-h0001027441c5.ne.mediaone.net (8.9.3+Sun/8.9.3) with ESMTP id PAA20017;
> 	Thu, 28 Dec 2000 15:05:20 -0500 (EST)
> Message-Id: <[email-masked]>
> To: Dan Romascanu <[email-masked]>
> cc: "'Randy Presuhn'" <[email-masked]>, [email-masked],
>         [email-masked]
> Subject: Re: Request for addition to disman WG charter 
> From: Jon Saperia <[email-masked]>
> In-reply-to: Your message of Thu, 28 Dec 2000 10:18:11 +0200.
>              <[email-masked]> 
> Date: Thu, 28 Dec 2000 15:05:20 -0500
> Sender: [email-masked]
> 
> > 
> > Randy,
> > 
> Folks, I too believe in the value of a common alarm MIB Module and the
> Disman WG is as good a place as any to do it. I am not sure I know what
> others had in mind in the paragraphs above. The problem that I would
> like addresses is a MIB module that can be used to configure and control
> alarm generation from devices that send notification. It can aggregate,
> control absolute number of notifications generated per unit time, and a
> number of other features. Is that what is meant by the work item?
> 
> Thanks
> /jon
> 
> 
> Jon Saperia		     [email-masked]
> 			     Phone: 617-744-1079
> 			     Fax:   617-249-0874
> 			     http://www.jdscons.com/
>

---

From: Randy Presuhn <[email-masked]>
Date: Thu, 28 Dec 2000 14:10:54 -0800 (PST)

Hi -

...
...
...

We're looking at a different problem.  The submission that
spurred this effort, draft-chisholm-disman-active-alarm-01.txt,
"describes management objects used for maintaining a list of
alarms currently active on a network element."

The problem you're describing sounds more like it belongs
in an extension/companion to RFC 2573's SNMP-NOTIFICATION-MIB.
I agree that someone should look at it, but it's not
on our plate (yet).

---

From: Dan Romascanu <[email-masked]>
Date: Fri, 29 Dec 2000 18:26:15 +0200

> committing to two separate documents at this time?
	[Dan]  Wherever you mention 'draft' in the schedules write
'draft(s)' instead. Or is this too 'creative' for a WG Charter?

---

From: Randy Presuhn <[email-masked]>
Date: Fri, 29 Dec 2000 10:33:03 -0800 (PST)

Hi -

> Message-ID: <[email-masked]>
> Date: Fri, 29 Dec 2000 18:26:15 +0200
> 
> 
...

I have no problem with it.  Bert?

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 29 Dec 2000 21:10:02 +0100

Inline

> ----------
> From: 	Randy Presuhn[SMTP:[email-masked]]
> Sent: 	Friday, December 29, 2000 7:33 PM
> To: 	[email-masked]
I don't think that we (IESG members, ADs) really get hung up over
the outcome to be in 1 or 2 documents. And so wording to allow
for that is OK (but not required ... can be handled while we go as well).

Bert

---

From: Randy Presuhn <[email-masked]>
Date: Fri, 29 Dec 2000 12:43:17 -0800 (PST)

Hi -

> Message-ID: <[email-masked]>
> From: "Wijnen, Bert (Bert)" <[email-masked]>
> To: Randy Presuhn <[email-masked]>
> Cc: [email-masked], Randy Bush <[email-masked]>
> Date: Fri, 29 Dec 2000 21:10:02 +0100
> List-Id: IETF disman Working Group mailing list <[email-masked]>
...
...

Ok.  So, may we make the addition?

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sat, 30 Dec 2000 11:42:55 +0100

Randy, in principle I am OK with adding this work item to the WG
charter. I also see there are two new I-Ds for script and schedule mib.
And... there was discussion on the issue of a possible need to
recycle notif log mib as a result of performance issues. I undestand
that this was just a possibility.... but it needs discussion and/or work.

So... I would like to see a complete writeup of the charter that
includes all these work items, and that also lists milestones for
decisions on all these items.

Once I have that, I need to check with IESG/IAB for approval of
adding the new work item (I expect no problems, but I want
to make sure we follow the process properly.

So... while you and I work out the admon/process details, the
other volunteers can start working on their tasks as well.

OK?
Bert

> Sent: 	Thursday, December 28, 2000 1:44 AM
> To: 	[email-masked]

---

From: "Sharon Chisholm" <[email-masked]>
Date: Sat, 30 Dec 2000 10:19:28 -0500

hi

Sounds good.

Sharon

-----Original Message-----
From: Wijnen, Bert (Bert) [mailto:[email-masked]]
Sent: Saturday, December 30, 2000 5:43 AM
To: Randy Presuhn
Cc: [email-masked]; Randy Bush
Subject: RE: Request for addition to disman WG charter

OK?
Bert