Subject: script mib updates

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 8 Jun 2001 17:43:05 +0200

Some issues were raised during IANA/IESG review that required us to
post another revision of the script mib. Despite some minor editorial
changes, I had to make some more changes to get the compliance and
conformance definitions right.

There are now a bunch of new compliance and conformance definitions
that take care of the new objects/notifications. The old definitions
have been deprecated. Below is a unified context diff of my nroff
sources so that you can easily check what has been touched.

Lets hope this is the final one...

/js

Index: sm.me
===================================================================
RCS file: /usr/home/schoenw/CVS/ietf/disman/src/sm.me,v
retrieving revision 1.13
diff -u -r1.13 sm.me
--- sm.me	2001/04/11 15:35:38	1.13
+++ sm.me	2001/06/08 15:32:00
@@ -12,7 +12,7 @@
 .nr sf R
 .nr bm 0.5i
 .nr fm 0 \}
-.he 'Internet-Draft'Script MIB'April 2001'
+.he 'Internet-Draft'Script MIB'June 2001'
 .fo 'Levi & Schoenwaelder'Standards Track'[Page %ENDPAGE'
 .hy 0
 .de $0
@@ -28,14 +28,14 @@
 Internet-Draft                                           Nortel Networks
 Expires September 2001                                  J. Schoenwaelder
                                                          TU Braunschweig
-                                                              April 2001
+                                                               June 2001
 .sp 1
 .ce 2
 Definitions of Managed Objects for the
 Delegation of Management Scripts
 .sp 1
 .ce 1
-<draft-ietf-disman-script-mib-v2-03.txt>
+<draft-ietf-disman-script-mib-v2-04.txt>
 
 .ti 0
 Status of this Memo
@@ -72,6 +72,8 @@
 for use with network management protocols in the Internet
 community. In particular, it describes a set of managed objects that
 allow the delegation of management scripts to distributed managers.
+.PP
+This document obsoletes RFC 2592.
 
 .bp
 .PP
@@ -324,22 +326,22 @@
 objects can be used to control how entries in the history are aged out
 if the table fills up.
 
-.sh 1 "The Structure of the MIB"
+.sh 1 "Structure of the MIB"
 .PP
 This section presents the structure of the MIB. The objects are
 arranged into the following groups:
 .ip "   o" 8
-language group (smLanguageGroup)
+language group (smLangTable, smExtsnTable)
 .ip "   o" 8
-script group (smScriptGroup)
+script group (smScriptTable)
 .ip "   o" 8
-script code group (smCodeGroup)
+script code group (smCodeTable)
 .ip "   o" 8
-script launch group (smLaunchGroup)
+script launch group (smLaunchTable)
 .ip "   o" 8
-running script group (smRunGroup)
+running script group (smRunTable)
 
-.sh 2 "The smLanguageGroup"
+.sh 2 "Language Group"
 .PP
 The smLanguageGroup is used to provide information about the languages
 and the language extensions supported by a Script MIB implementation.
@@ -348,7 +350,7 @@
 smExtsnTable lists the extensions that are available for a given
 language.
 
-.sh 2 "The smScriptGroup"
+.sh 2 "Script Group"
 .PP
 The smScriptGroup consists of a single table, called the
 smScriptTable. The smScriptTable lists all scripts known to a Script
@@ -391,7 +393,7 @@
 state `enabled'. Errors during the retrieval or compilation phase will
 result in an error state such as `compilationFailed'.
 
-.sh 2 "The smCodeGroup"
+.sh 2 "Code Group"
 .PP
 The smCodeGroup consists of a single table, called the smCodeTable,
 which provides the ability to transfer and modify scripts via SNMP
@@ -411,7 +413,7 @@
 .PP
 The implementation of the smCodeGroup is optional.
 
-.sh 2 "The smLaunchGroup"
+.sh 2 "Launch Group"
 .PP
 The smLaunchGroup contains a single table, the smLaunchTable. An entry
 in the smLaunchTable represents a launch button which can be used to
@@ -432,7 +434,7 @@
 An entry in the smLaunchTable also defines the owner which will be
 used to associate permissions with the script execution.
 
-.sh 2 "The smRunGroup"
+.sh 2 "Run Group"
 .PP
 The smRunGroup contains a single table, called the smRunTable, which
 lists all scripts that are currently running or have terminated
@@ -482,7 +484,7 @@
         FROM SNMP-FRAMEWORK-MIB;
 
 scriptMIB MODULE-IDENTITY
-    LAST-UPDATED "200104110000Z"
+    LAST-UPDATED "200106080000Z"
     ORGANIZATION "IETF Distributed Management Working Group"
     CONTACT-INFO
         "WG EMail:  [email-masked]
@@ -515,7 +517,7 @@
     DESCRIPTION
         "This MIB module defines a set of objects that allow to
          delegate management scripts to distributed managers."
-    REVISION    "200104110000Z"
+    REVISION    "200106080000Z"
     DESCRIPTION
         "Revised version, published as RFC XXXX.
 
@@ -532,6 +534,9 @@
          A new smScriptException notification has been added to
          support runtime error notifications.
 
+	 Created new conformance and compliance statements that
+	 take care of the new objects and notifications.
+
 	 Clarifications have been added in several places to remove
 	 ambiguities or contradictions that were discovered and
 	 reported by implementors."
@@ -1078,7 +1083,7 @@
     DESCRIPTION
 	"The date and time when this script table entry was last
 	 modified. The value '0000000000000000'H is returned if
-         the launch table entry has not yet been modified.
+         the script table entry has not yet been modified.
 
 	 Note that the resetting of smScriptError is not considered
 	 a change of the script table entry."
@@ -1982,14 +1987,15 @@
 
 -- compliance statements
 
-smCompliance MODULE-COMPLIANCE
+smCompliance2 MODULE-COMPLIANCE
     STATUS	current
     DESCRIPTION
 	"The compliance statement for SNMP entities which implement
 	 the Script MIB."
     MODULE	-- this module
     MANDATORY-GROUPS { 
-	    smLanguageGroup, smScriptGroup, smLaunchGroup, smRunGroup
+	    smLanguageGroup, smScriptGroup2, smLaunchGroup2, 
+	    smRunGroup2, smNotificationsGroup2
     }
     GROUP   smCodeGroup
     DESCRIPTION
@@ -2024,20 +2030,15 @@
 	 when the smRunControl is set to `suspend' and remain in this
 	 state until smRunControl is set to `resume' or the script 
 	 terminates."
-    ::= { smCompliances 1 }
+    ::= { smCompliances 2 }
 
 smLanguageGroup OBJECT-GROUP
     OBJECTS {
-	smLangLanguage,
-	smLangVersion,
-	smLangVendor,
-	smLangRevision,
-	smLangDescr,
-	smExtsnExtension,
-	smExtsnVersion,
-	smExtsnVendor,
-	smExtsnRevision,
-	smExtsnDescr
+	smLangLanguage, smLangVersion,
+	smLangVendor, smLangRevision,
+	smLangDescr, smExtsnExtension,
+	smExtsnVersion, smExtsnVendor,
+	smExtsnRevision, smExtsnDescr
     }
     STATUS	current
     DESCRIPTION
@@ -2045,28 +2046,23 @@
 	 capabilities of the scripting engine."
     ::= { smGroups 1 }
 
-smScriptGroup OBJECT-GROUP
+smScriptGroup2 OBJECT-GROUP
     OBJECTS {
-	smScriptDescr,
-	smScriptLanguage,
-	smScriptSource,
-	smScriptAdminStatus,
-	smScriptOperStatus,
-	smScriptStorageType,
-	smScriptRowStatus,
-	smScriptError,
+	smScriptDescr, smScriptLanguage,
+	smScriptSource, smScriptAdminStatus,
+	smScriptOperStatus, smScriptStorageType,
+	smScriptRowStatus, smScriptError,
 	smScriptLastChange
     }
     STATUS	current
     DESCRIPTION
 	"A collection of objects providing information about
 	 installed scripts."
-    ::= { smGroups 2 }
+    ::= { smGroups 7 }
 
 smCodeGroup OBJECT-GROUP
     OBJECTS {
-	smCodeText,
-	smCodeRowStatus
+	smCodeText, smCodeRowStatus
     }
     STATUS	current
     DESCRIPTION
@@ -2074,54 +2070,40 @@
 	 by using SNMP set requests."
     ::= { smGroups 3 }
 
-smLaunchGroup OBJECT-GROUP
+smLaunchGroup2 OBJECT-GROUP
     OBJECTS {
-        smLaunchScriptOwner,
-        smLaunchScriptName,
-	smLaunchArgument,
-	smLaunchMaxRunning,
-	smLaunchMaxCompleted,
-	smLaunchLifeTime,
-	smLaunchExpireTime,
-	smLaunchStart,
-	smLaunchControl,
-	smLaunchAdminStatus,
-	smLaunchOperStatus,
-	smLaunchRunIndexNext,
-	smLaunchStorageType,
-	smLaunchRowStatus,
-	smLaunchError,
-	smLaunchLastChange,
+        smLaunchScriptOwner, smLaunchScriptName,
+	smLaunchArgument, smLaunchMaxRunning,
+	smLaunchMaxCompleted, smLaunchLifeTime,
+	smLaunchExpireTime, smLaunchStart,
+	smLaunchControl, smLaunchAdminStatus,
+	smLaunchOperStatus, smLaunchRunIndexNext,
+	smLaunchStorageType, smLaunchRowStatus,
+	smLaunchError, smLaunchLastChange,
         smLaunchRowExpireTime
     }
     STATUS	current
     DESCRIPTION
 	"A collection of objects providing information about scripts
 	 that can be launched."
-    ::= { smGroups 4 }
+    ::= { smGroups 8 }
 
-smRunGroup OBJECT-GROUP
+smRunGroup2 OBJECT-GROUP
     OBJECTS {
-	smRunArgument,
-	smRunStartTime,
-	smRunEndTime,
-	smRunLifeTime,
-	smRunExpireTime,
-	smRunExitCode,
-	smRunResult,
-	smRunState,
-	smRunControl,
-	smRunError,
-	smRunResultTime,
-	smRunErrorTime
+	smRunArgument, smRunStartTime,
+	smRunEndTime, smRunLifeTime,
+	smRunExpireTime, smRunExitCode,
+	smRunResult, smRunState,
+	smRunControl, smRunError,
+	smRunResultTime, smRunErrorTime
     }
     STATUS	current
     DESCRIPTION
 	"A collection of objects providing information about running
 	 scripts."
-    ::= { smGroups 5 }
+    ::= { smGroups 9 }
 
-smNotificationsGroup NOTIFICATION-GROUP
+smNotificationsGroup2 NOTIFICATION-GROUP
     NOTIFICATIONS {
 	smScriptAbort,
 	smScriptResult,
@@ -2130,6 +2112,108 @@
     STATUS	current
     DESCRIPTION
 	"The notifications emitted by the Script MIB."
+    ::= { smGroups 10 }
+
+--
+-- Deprecated compliance and conformance group definitions 
+-- from RFC 2592.
+--
+
+smCompliance MODULE-COMPLIANCE
+    STATUS	deprecated
+    DESCRIPTION
+	"The compliance statement for SNMP entities which implement
+	 the Script MIB."
+    MODULE	-- this module
+    MANDATORY-GROUPS { 
+	    smLanguageGroup, smScriptGroup, smLaunchGroup, smRunGroup
+    }
+    GROUP   smCodeGroup
+    DESCRIPTION
+	"The smCodeGroup is mandatory only for those implementations
+	 that support the downloading of scripts via SNMP."
+    OBJECT  smScriptSource
+    MIN-ACCESS	read-only
+    DESCRIPTION
+	"The smScriptSource object is read-only for implementations
+	 that are not able to download script code from a URL."
+    OBJECT smCodeText
+    DESCRIPTION
+	"A compliant implementation need only support write access
+	 to the smCodeText object during row creation."
+    OBJECT smLaunchArgument
+    DESCRIPTION
+	"A compliant implementation has to support a minimum size
+	 for smLaunchArgument of 255 octets."
+    OBJECT smRunArgument
+    DESCRIPTION
+	"A compliant implementation has to support a minimum size
+	 for smRunArgument of 255 octets."
+    OBJECT smRunResult
+    DESCRIPTION
+	"A compliant implementation has to support a minimum size
+	 for smRunResult of 255 octets."
+    OBJECT smRunState
+    DESCRIPTION
+	"A compliant implementation does not have to support script
+	 suspension and the smRunState `suspended'. Such an 
+	 implementation will change into the `suspending' state
+	 when the smRunControl is set to `suspend' and remain in this
+	 state until smRunControl is set to `resume' or the script 
+	 terminates."
+    ::= { smCompliances 1 }
+
+smScriptGroup OBJECT-GROUP
+    OBJECTS {
+	smScriptDescr, smScriptLanguage,
+	smScriptSource, smScriptAdminStatus,
+	smScriptOperStatus, smScriptStorageType,
+	smScriptRowStatus
+    }
+    STATUS	deprecated
+    DESCRIPTION
+	"A collection of objects providing information about
+	 installed scripts."
+    ::= { smGroups 2 }
+
+smLaunchGroup OBJECT-GROUP
+    OBJECTS {
+        smLaunchScriptOwner, smLaunchScriptName,
+	smLaunchArgument, smLaunchMaxRunning,
+	smLaunchMaxCompleted, smLaunchLifeTime,
+	smLaunchExpireTime, smLaunchStart,
+	smLaunchControl, smLaunchAdminStatus,
+	smLaunchOperStatus, smLaunchRunIndexNext,
+	smLaunchStorageType, smLaunchRowStatus
+    }
+    STATUS	deprecated
+    DESCRIPTION
+	"A collection of objects providing information about scripts
+	 that can be launched."
+    ::= { smGroups 4 }
+
+smRunGroup OBJECT-GROUP
+    OBJECTS {
+	smRunArgument, smRunStartTime,
+	smRunEndTime, smRunLifeTime,
+	smRunExpireTime, smRunExitCode,
+	smRunResult, smRunState,
+	smRunControl, smRunError
+    }
+    STATUS	deprecated
+    DESCRIPTION
+	"A collection of objects providing information about running
+	 scripts."
+    ::= { smGroups 5 }
+
+smNotificationsGroup NOTIFICATION-GROUP
+    NOTIFICATIONS {
+	smScriptAbort,
+	smScriptResult
+    }
+    STATUS	deprecated
+    DESCRIPTION
+	"The notifications emitted by the Script MIB."
     ::= { smGroups 6 }
 
 END
@@ -2531,15 +2615,15 @@
 .sh 1 "IANA Considerations"
 .PP
 The Internet Assigned Numbers Authority (IANA) is responsible for
-maintaining a MIB module which provides OID registrations for well-known
-languages. The IANA language registry is intented to reduce
-interoperability problems by providing a single list of well-known
-languages. However, it is of course still possible to register
-languages in private OID spaces. Registering languages in private
-spaces is especially attractive if a language is used for
+maintaining a MIB module (IANA-LANGUAGE-MIB) which provides OID
+registrations for well-known languages. The IANA language registry is
+intented to reduce interoperability problems by providing a single
+list of well-known languages. However, it is of course still possible
+to register languages in private OID spaces. Registering languages in
+private OID spaces is especially attractive if a language is used for
 experimentation or if a language is only used in environments where
-the distribution of MIB modules with the language registration does not
-cause any maintenance problems.
+the distribution of MIB modules with the language registration does
+not cause any maintenance problems.
 .PP
 Any additions or changes to the list of languages registered via IANA
 require Designated Expert Review as defined in the IANA guidelines
@@ -2670,6 +2754,11 @@
 .ip "   -" 6
 Updated the smCompliances statement to not require write access to the
 smCodeText object after row creation.
+.ip "   -" 6
+Deprecated smCompliance, smScriptGroup, smLaunchGroup, smRunGroup,
+smNotificationsGroup and created smCompliance2, smScriptGroup2,
+smLaunchGroup2, smRunGroup2 and smNotificationsGroup2 that take care
+of the new objects and notifications.
 
 .sh 1 "Acknowledgments"
 .PP

---

From: Randy Presuhn <[email-masked]>
Date: Fri, 15 Jun 2001 16:36:34 -0700 (PDT)

Hi -

> Date: Fri, 8 Jun 2001 17:43:05 +0200
> Message-Id: <[email-masked]>
> From: Juergen Schoenwaelder <[email-masked]>
> To: disman <[email-masked]>
> Subject: script mib updates
> List-Id: IETF disman Working Group mailing list <disman.dorothy.bmc.com>
> 
> 
...

It's been a week since the diffs were posted, and I have
seen no adverse reactions.  So, as disman WG chair I'd like
to request that our area director take the updated draft
draft-ietf-disman-script-mib-v2-04.txt to the IESG as soon
as it appears.

 -------------------------------------------------------
 Randy Presuhn           [email-masked]
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141
 Fax:   +1 408 965-0359  2141 North First Street
 http://www.bmc.com/     San José, California 95131  USA
 -------------------------------------------------------
 My opinions and BMC's are independent variables.
 -------------------------------------------------------

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sat, 16 Jun 2001 15:07:27 +0200

On my plate (again).

Bert

> ----------
> From: 	Randy Presuhn[SMTP:[email-masked]]
> Sent: 	Saturday, June 16, 2001 1:36 AM
> To: 	[email-masked]
> Cc: 	[email-masked]
> Subject: 	Re:  script mib updates
> 
> Hi -
>