Subject: Expression MIB

From: "Rui Lopes" <[email-masked]>
Date: Fri, 22 Jun 2001 10:57:08 GMT

After developing the Event and Expression MIB I realized that it is not 
possible to define expressions with objects retrieved from SNMP agents on 
different hosts. If this is true, I do not see a clear usefulness of the 
Expression MIB, since it will be integrated, tipically, in a DM (or am I 
missing something?).

This is rather odd, because the Event MIB allows retrieving values from 
different hosts and the Expression MIB, although designed to be integrated 
with it, does not... 

Cheers, 

Rui Pedro Lopes

---

From: Randy Presuhn <[email-masked]>
Date: Fri, 22 Jun 2001 10:49:47 -0700 (PDT)

Hi -

> Message-ID: <[email-masked]>
> From: "Rui Lopes" <[email-masked]>
> To: [email-masked]
> Subject: Expression MIB
> Date: Fri, 22 Jun 2001 10:57:08 GMT
> List-Id: IETF disman Working Group mailing list <disman.dorothy.bmc.com>
> 

Implementation experience!  Congratulations!  Let me buy you a
beer in London!

> Expression MIB, since it will be integrated, tipically, in a DM (or am I 

The expectation (and this was hotly debated) was that the
expression mib would be implemented on managed elements.
If implementation experience (like yours) indicates that
makes sense for this MIB to be able to access information
in a way more like the Event MIB, this will need to be taken
into account when it comes time to consider whether we want
to advance to Draft Standard or cycle at Proposed.

> different hosts and the Expression MIB, although designed to be integrated 
...

I agree that they are not consistent.  I think it's
quite reasonable to ask that they be made consistent.
If a consensus emerges that we should do so, I think we'd
also need to once again take up the question of explicitly
(rather than implicitly) managing delegated credentials.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------