Subject: Fwd: I-D ACTION:draft-bierman-rmonmib-hc-alarm-mib-00.txt

From: Andy Bierman <[email-masked]>
Date: Tue, 13 Nov 2001 08:18:56 -0800

Hi,

I want to bring this I-D to the attention of the RMONMIB and DISMAN WGs.
This MIB is a essentially a clone of the RMON-1 alarmTable, adapted
for proper thresholding of Counter64 MIB objects.  During the process
of writing HC-RMON, this feature was omitted.  However, significant
customer demand indicates this decision was a mistake.

This work may partially overlap with the Alarm MIB and Condition & ARC MIB,
under development in the DISMAN WG, but not enough to be of any concern.
RMON alarms/events is a simple tool with a simple interface, with 10+
years of deployment and a large installed base.  Thresholding of 
complicated conditions requires a more comprehensive tool with a more 
complex interface, and in this case, the DISMAN MIBs would be more 
appropriate.  

thanks,
Andy

>To: IETF-Announce: ;
>From: [email-masked]
>Reply-to: [email-masked]
>Subject: I-D ACTION:draft-bierman-rmonmib-hc-alarm-mib-00.txt
>Date: Tue, 13 Nov 2001 07:08:27 -0500
>Sender: [email-masked]
>
>A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>
>        Title           : Remote Monitoring MIB Extensions for High Capacity 
>                          Alarms
>        Author(s)       : A. Bierman, K. McCloghrie
>        Filename        : draft-bierman-rmonmib-hc-alarm-mib-00.txt
>        Pages           : 25
>        Date            : 12-Nov-01
>        
>This memo defines a portion of the Management Information Base (MIB) for
>use with network management protocols in the Internet community.  In
>particular, it describes managed objects for extending the alarm
>thresholding capabilities found in the RMON MIB [RFC2819], to provide
>similar threshold monitoring of objects based on the Counter64 data
>type.
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-bierman-rmonmib-hc-alarm-mib-00.txt
>
>To remove yourself from the IETF Announcement list, send a message to 
>ietf-announce-request with the word unsubscribe in the body of the message.
>
>Internet-Drafts are also available by anonymous FTP. Login with the username
>"anonymous" and a password of your e-mail address. After logging in,
>type "cd internet-drafts" and then
>        "get draft-bierman-rmonmib-hc-alarm-mib-00.txt".
>
>A list of Internet-Drafts directories can be found in
>http://www.ietf.org/shadow.html 
>or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
>Internet-Drafts can also be obtained by e-mail.
>
>Send a message to:
>        [email-masked].
>In the body type:
>        "FILE /internet-drafts/draft-bierman-rmonmib-hc-alarm-mib-00.txt".
>        
>NOTE:   The mail server at ietf.org can return the document in
>        MIME-encoded form by using the "mpack" utility.  To use this
>        feature, insert the command "ENCODING mime" before the "FILE"
>        command.  To decode the response(s), you will need "munpack" or
>        a MIME-compliant mail reader.  Different MIME-compliant mail readers
>        exhibit different behavior, especially when dealing with
>        "multipart" MIME messages (i.e. documents which have been split
>        up into multiple messages), so check your local documentation on
>        how to manipulate these messages.
>                
>                
>Below is the data which will enable a MIME compliant mail reader
>implementation to automatically retrieve the ASCII version of the
>Internet-Draft.
>Content-Type: text/plain
>Content-ID:     <[email-masked]>
>
>ENCODING mime
>FILE /internet-drafts/draft-bierman-rmonmib-hc-alarm-mib-00.txt
>
><ftp://ftp.ietf.org/internet-drafts/draft-bierman-rmonmib-hc-alarm-mib-00.txt>

---

From: Randy Presuhn <[email-masked]>
Date: Tue, 13 Nov 2001 15:56:35 -0800 (PST)

Hi -

> Message-Id: <[email-masked]>
> Date: Tue, 13 Nov 2001 08:18:56 -0800
> To: [email-masked], [email-masked]
> From: Andy Bierman <[email-masked]>
> Subject: Fwd: I-D ACTION:draft-bierman-rmonmib-hc-alarm-mib-00.txt
...
> complex interface, and in this case, the DISMAN MIBs would be more 
...

Thanks for bringing this internet draft to our attention.
We're currently in the midst of a call for implementation
experience on the Event MIB, which is even more closely
related to the RMON alarm table.  I'd love to see more
discussion of how the extension of the concepts pioneered
in RMON did (or didn't) work in the real world.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------