Subject: Re: RFC 2982 (disman expression MIB) Implementation Experience

From: Randy Presuhn <[email-masked]>
Date: Fri, 2 Nov 2001 07:43:57 -0800 (PST)

Hi -

> Date: Fri, 2 Nov 2001 11:15:00 +0100
> Message-Id: <[email-masked]>
> From: Juergen Schoenwaelder <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]
> In-reply-to: <[email-masked]> (message from Randy
> 	Presuhn on Thu, 1 Nov 2001 14:53:47 -0800 (PST))
> Subject: Re: RFC 2982 (disman expression MIB) Implementation Experience
> References:  <[email-masked]>
> 
> 
> >>>>> Randy Presuhn writes:
> 
> Randy> In <draft-ietf-ngtrans-ipv4survey-01.txt>, "Survey of IPv4
> Randy> Addresses in Currently Deployed IETF Standards", it is written:
> 
> |expValueIpAddressVal OBJECT-TYPE
> |    SYNTAX      IpAddress
> |    MAX-ACCESS  read-only
> |    STATUS      current
> |    DESCRIPTION
> |     "The value when expExpressionValueType is 'ipAddress'."
> |    ::= { expValueEntry 6 }
> 
> Randy> Do we need to do anything to properly support IPv6 here?
> 
> I do not think so.
> 
> The only thing we could consider is to add a comment saying that this
> object is only for backwards compatibility with the IpAddress base
> type which exists in the SMIv2 and that it does not restrict this MIB
> to IPv4 only.
...

This seems like a reasonable solution.

Ram: You'll fix?

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: Ramanathan Kavasseri <[email-masked]>
Date: Wed, 14 Nov 2001 01:28:18 -0800

I used the following text for resolving this issue:

expValueIpAddressVal OBJECT-TYPE
    SYNTAX      IpAddress
    MAX-ACCESS  read-only
    STATUS      current
    DESCRIPTION
     "The value when expExpressionValueType is \'ipAddress'.

     This object exists only for backward compatibility with
     the IpAddress type which exists in SMIv2. This object DOES
     NOT restrict this MIB to the use of IPv4 addresses only."

Ram