Subject: Re: RFC 2982 (disman expression MIB) Implementation Experience

From: Randy Presuhn <[email-masked]>
Date: Thu, 1 Nov 2001 14:53:47 -0800 (PST)

Hi -

In <draft-ietf-ngtrans-ipv4survey-01.txt>, "Survey of IPv4
Addresses in Currently Deployed IETF Standards", it is written:

|5.544 RFC 2982 Distributed Management Expression MIB
|
|This MIB states:
|
|     IpAddresses are treated as 32-bit, unsigned integers in
|     network byte order, that is, the hex version of 255.0.0.0 is
|     0xff000000.
|
|and defineds the OID:
|
|expValueIpAddressVal OBJECT-TYPE
|    SYNTAX      IpAddress
|    MAX-ACCESS  read-only
|    STATUS      current
|    DESCRIPTION
|     "The value when expExpressionValueType is 'ipAddress'."
|    ::= { expValueEntry 6 }
|
|A new OID must be defined to deal with IPv6 addresses.

Do we need to do anything to properly support IPv6 here?

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 2 Nov 2001 11:15:00 +0100

>>>>> Randy Presuhn writes:

Randy> In <draft-ietf-ngtrans-ipv4survey-01.txt>, "Survey of IPv4
Randy> Addresses in Currently Deployed IETF Standards", it is written:

Randy> Do we need to do anything to properly support IPv6 here?

I do not think so.

The only thing we could consider is to add a comment saying that this
object is only for backwards compatibility with the IpAddress base
type which exists in the SMIv2 and that it does not restrict this MIB
to IPv4 only.

/js