Subject: RE: RFC 2981 (disman event MIB) Implementation Experience

From: "Dale Francisco" <[email-masked]>
Date: Wed, 14 Nov 2001 07:55:43 -0800

I think we may be getting down into the semantic
weeds.  ;^)

Anyway...

I think that that a trigger being "in use" and the act of
"sampling" are two different things.

A trigger is "in use" continuously from the moment it
becomes active, whereas "sampling" is a discrete,
recurring event, and is only one of the things (from
an implementor's point of view) that a trigger "does".
For example, in addition to sampling, a trigger may
store previous sample values, and run various algorithms
on a sample value or the delta of two sample values.
Of course the line between what is the "trigger" and
what is the "agent" is fuzzy.

Also, there are five or six trigger-related tables,
with some sixty or seventy objects, so intuitively
it seems to me that whatever a trigger is (and I
know the definition isn't crystal clear), it isn't
as simple as the mere act of sampling.

Just my two cents,
Dale

> -----Original Message-----
> From: Ramanathan Kavasseri [mailto:[email-masked]]
> Sent: Wednesday, November 14, 2001 12:34 AM
> To: Dale Francisco
> Cc: Randy Presuhn; [email-masked]
> Subject: Re: RFC 2981 (disman event MIB) Implementation Experience
> 
> 
> 
> 
> Dale Francisco wrote:
> 
> > Some possible clarifying text for the DESCRIPTION
> > of 'mteTriggerEnabled':
> >
> > > mteTriggerEnabled OBJECT-TYPE
> > >     SYNTAX      TruthValue
> > >     MAX-ACCESS  read-create
> > >     STATUS      current
> > >     DESCRIPTION
> > >         "A control to allow a trigger to be configured but not used.
> > >         When the value is 'false' the trigger is not sampled.
> 
> FYI, the above two lines use the words "used" and
> "sampled" for the same purpose. I chose to use "sampled"
> consistently in both places. Please let me know if some other
> wording should be used, or if I should use the original text as is.
> 
> Ram
> 
> >
> > >
> > >         Whenever the value goes from 'false' to 'true', the trigger
> > >         is treated as being initialized.  That is, no history is kept
> > >         of any trigger sample values from previous times when this
> > >         control may have been enabled."
> > >     DEFVAL { false }
> > >     ::= { mteTriggerEntry 14 }
> > >
>

---

From: Ramanathan Kavasseri <[email-masked]>
Date: Wed, 14 Nov 2001 11:24:39 -0800

> on a sample value or the delta of two sample values.

Point taken - I changed the text back to what you proposed
when I submitted the drafts last night.

Ram