Subject: RE: RFC 2981 (disman event MIB) Implementation Experience

From: [email-masked]
Date: Mon, 12 Nov 2001 22:00:08 -0500

> As a clarification, if an mteTrigger is of type threshold,
> at the time its mteTriggerEnabled value is set to true, what
> should the behavior be if the measured value is already above
> the threshold (at the first reading)?
>

    Isn't this covered by 'mteTriggerThresholdStartup'?

> Also, when the mteTriggerEnabled value is set to true, what
> should the behavior be if we set the value to true again, without
> setting it to false? Should this be an implicit (true-false-true)
> transition, or should this be rejected as an inconsistentValue (i.e.
> once true, the only settable value is false)?

    I think the least surprising thing to do would be nothing.
    That is, there is no re-initialization, and there is no
    error.

    Dale

---

From: "Ram Kavasseri" <[email-masked]>
Date: Tue, 13 Nov 2001 14:04:00 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, November 12, 2001 7:00 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: RFC 2981 (disman event MIB) Implementation Experience
> 
> 

Yes it is. :-)

>     That is, there is no re-initialization, and there is no

So should we add text that mentions this? Or
is that overkill?

Ram

---

From: "Dale Francisco" <[email-masked]>
Date: Tue, 13 Nov 2001 21:43:52 -0800

> So should we add text that mentions this? Or

    I see no harm (and possibly some benefit for
    implementors) in adding a sentence such as:

      "If this object is set to 'true' when its value
       is already 'true', the operation has no effect;
       that is, the trigger is not re-initialized, and
       there is no error."

    Dale

---

From: Ramanathan Kavasseri <[email-masked]>
Date: Wed, 14 Nov 2001 01:45:35 -0800

FYI,

similar changes need to be made for mteEventEntryStatus.

Ram