Subject: RE: RFC 2981 (disman event MIB) Implementation Experience

From: Randy Presuhn <[email-masked]>
Date: Mon, 12 Nov 2001 12:05:00 -0800 (PST)

Hi -

> From: "Ram Kavasseri" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>, <[email-masked]>
> Subject: RE: RFC 2981 (disman event MIB) Implementation Experience
> Date: Fri, 9 Nov 2001 19:49:08 -0800
> Message-ID: <[email-masked]>
> In-Reply-To: <[email-masked]>
> List-Id: IETF disman Working Group mailing list <disman.dorothy.bmc.com>
...
> I suspect we're talking about the mteTriggerEntry?
> It contains the mteTriggerEnabled object for enabling
> or disabling triggers.
> 
> The DESCRIPTION for mteTriggerEntryStatus states:
> 
> mteTriggerEntryStatus OBJECT-TYPE
>     SYNTAX      RowStatus
>     MAX-ACCESS  read-create
>     STATUS      current
>     DESCRIPTION
>         "The control that allows creation and deletion of entries.
>         Once made active an entry may not be modified except to
>         delete it."
>     ::= { mteTriggerEntry 15 }
> 
> Hence the scenario Wes highilghted will not arise.
> 
> Cisco's implementation does not permit modifications to the
> row, as per the DESCRIPTION above.
> 
> Which brings up the next question - if you cannot modify a row,
> why bother providing mteTriggerEnabled?

:-)

> My 2 cents would be to change the above DESCRIPTION to permit
> modifications ONLY to the mteTriggerEnabled object. If the
> value of this object transitions from enabled to disabled, all
> state information should be dropped for that trigger. 
> 
> Comments?
...

This seems reasonable.

Ram - could you gather this and any other
fixes you've accumulated and post them in an i-d
<draft-ietf-disman-event-mib-v2-00.txt>, keeping in mind the
fast approach of the cut-off date?

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: "Ram Kavasseri" <[email-masked]>
Date: Mon, 12 Nov 2001 12:26:17 -0800

Will do that today.

Ram

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Randy Presuhn
> Sent: Monday, November 12, 2001 12:05 PM
> To: [email-masked]
>  Tel: +1 408 546-1006   San Josi, California 95131  USA