Subject: Re: ResourceType & ResourceId

From: David Partain <[email-masked]>
Date: Mon, 21 Jan 2002 13:48:01 +0100

Hi,

Regarding use of ResourceType/ResourceId versus using an OID,
Jürgen wrote:

> We obviously both fail to convince each other of the right solution.
> So instead of trying one more time to convince you, I just recognize
> that we to disagree on this issue.
>
> I would be helpful if other folks on this list could share their
> thoughts with us.

I've only just recently started looking at this document
seriously.  I completely agree with Jürgen that naming of
resources with two integers, one of which is an enumeration
and the other an index into a singly-indexed table (correct
me if I'm wrong), is very limiting.  It disallows pointing at
enterprise specific stuff.  It disallows pointing at things that
are not covered by the enumeration (other doesn't count :-)).
I would MUCH prefer to have a OID and I don't believe that
it's much more complicated.

Cheers,

-- 
David Partain                  [email-masked]
Ericsson Research's LinLab     Tel: +46 13 28 41 44
P.O. Box 1248                  Fax: +46 13 28 75 67
SE-581 12 Linköping, Sweden    #include <stddisclaimer.h>

---

From: "Stefan Wallin" <[email-masked]>
Date: Mon, 21 Jan 2002 14:01:04 +0100

Hi!
It is of vital importance to pinpoint the alarming object.
Alarm management applications typically have a data dictionary based on MIB
compilation. If we send OIDs as resource identification the alarm management
app can perform a look-up in the dictionary in order to identify the
resource. If we go for integers we have to manually implement the
translation from integer value to OID in the manager, this is too much
manual work and more seriously; error prone. My agent might refer to a
camera as an integer but since it is not an OID another manager interprets
as an ifIndex :(

So OIDs instead of integers would help us:
- support automation
- avoid errors

cheers Stefan

-----Ursprungligt meddelande-----
Från: [email-masked]
[mailto:[email-masked]]För David Partain
Skickat: den 21 januari 2002 13:48
Till: Juergen Schoenwaelder; [email-masked]
Kopia: [email-masked]
Ämne: Re: ResourceType & ResourceId

Hi,

Cheers,