Subject: RE: ALARM-MIB shared indices and row pointers for alarmModelEntry & ituAlarmEntry

From: "Sharon Chisholm" <[email-masked]>
Date: Tue, 22 Jan 2002 07:52:04 -0500

hi

The alarmGenericModel pointer was added after 
someone trying to implement the MIBs asked how
you related back to the generic model in the case
when the alarm state and the severity are not the
same. 

True, this information could also be obtained by
going back to the alarmModelTable and trying to
find a matching alarmModelSpecificPointer. But,
trying to relate different tables together is 
a very common management activity, so I thought
an object that aided this was a good thing.

Your first two arguments against it make sense,
but the third argument assumes managers retrieve
entire rows of data, which in my experience is
not usually the case.

Sharon

-----Original Message-----
From: David Partain [mailto:[email-masked]]
Sent: Monday, January 21, 2002 8:31 AM
To: DISMAN Mailing List
Subject: ALARM-MIB shared indices and row pointers for alarmModelEntry &
ituAlarmEntry

Hi all,

In looking at the indexing and the various RowPointers in the
ALARM-MIB, my brain started hurting.  I realize that may be based
on its capacity...

In any case, the alarmModelEntry has:

->Indices:
  1: alarmListName
  2: alarmModelIndex
  3: alarmModelState

and alarmModelSpecificPointer, a RowPointer which might be a
pointer to an ituAlarmEntry

Then we have the ituAlarmEntry, which has:
->Indices
  1: alarmListName (shared)
  2: alarmModelIndex (shared)
  3: ituAlarmPerceivedSeverity

and that in turn has ituAlarmGenericModel, a RowPointer to the
"corresponding row in the alarmModelTable." So, we not only
have shared indices, we also have circular RowPointers.

Why do we need the pointer from the ituAlarmTable back to
the alarmModelTable?

I suggest that ituAlarmGenericModel be removed.  Why?

1) In general: maintaining references pointing both ways
   in an agent system is tricky

2) It is not needed, since a manager should start in the base
   table alarmModelEntry and follow the pointers to specific
   tables, not the opposite

3) Fewer OID columns in table retrieval

Cheers,

dlp

---

From: David Partain <[email-masked]>
Date: Wed, 23 Jan 2002 11:56:07 +0100

Hi Sharon,

> when the alarm state and the severity are not the

Ahhh.... I see.  They don't share all the indices, they only
share two of the three.  Now I understand.  Chalk this up to me
not thinking about what I was asking before asking :-)

Cheers,

dlp