Subject: Fwd: NOTIFICATION-LOG-MIB value objects instantiation question

From: Randy Presuhn <[email-masked]>
Date: Tue, 8 Jan 2002 18:07:20 -0800 (PST)

Hi -

I'm forwarding a posting from Reva Bailey to the disman
WG mailing list.  I've added her posting address to the
disman "posters" list. 

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

> Received: from tattler.bmc.com (tattler.bmc.com [172.17.0.117])
> 	by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) with ESMTP id PAA27742
> 	for <[email-masked]>; Tue, 8 Jan 2002 15:44:37 -0800 (PST)
> Received: from mx-us-hou-1-int.bmc.com (localhost [127.0.0.1])
> 	by tattler.bmc.com (8.10.2/8.10.2) with ESMTP id g08NhNA15240
> 	for <[email-masked]>; Tue, 8 Jan 2002 17:43:23 -0600 (CST)
> Received: from mail.timetra.timetra.com (unknown [63.104.212.2])
> 	by mx-us-hou-1-int.bmc.com (Postfix) with SMTP id EC83520EFE0
> 	for <[email-masked]>; Tue,  8 Jan 2002 23:34:27 -0600 (CST)
> Received: from rbailey ([192.168.1.197]) by mail.timetra.timetra.com with Microsoft SMTPSVC(5.0.2195.3779);
> 	 Tue, 8 Jan 2002 15:34:41 -0800
> Reply-To: <[email-masked]>
> From: "Reva Bailey" <[email-masked]>
> To: <[email-masked]>
> Subject: NOTIFICATION-LOG-MIB value objects instantiation question
> Date: Tue, 8 Jan 2002 15:51:18 -0800
> Message-ID: <[email-masked]>
> MIME-Version: 1.0
> Content-Type: text/plain;
> 	charset="iso-8859-1"
> Content-Transfer-Encoding: 7bit
> X-Priority: 3 (Normal)
> X-MSMail-Priority: Normal
> X-Mailer: Microsoft Outlook IMO, Build 9.0.2416 (9.0.2910.0)
> X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
> Importance: Normal
> X-OriginalArrivalTime: 08 Jan 2002 23:34:41.0879 (UTC) FILETIME=[0BD39E70:01C1989D]
> 
> This is a basic SNMP object instantiation question, but I need help to
> interpret correctly the description clause of nlmLogVariableValueType
> because I am having problems getting my agent tool-kit to work the way
> I think it should :-(.
> 
> nlmLogVariableValueType OBJECT-TYPE
>     SYNTAX      INTEGER { counter32(1), unsigned32(2), timeTicks(3),
>                  integer32(4), ipAddress(5), octetString(6),
>                  objectId(7), counter64(8), opaque(9) }
>     MAX-ACCESS  read-only
>     STATUS      current
>     DESCRIPTION
>      "The type of the value.  One and only one of the value
>      objects that follow must be instantiated, based on this type."
>     ::= { nlmLogVariableEntry 3 }
> 
> I interpret this to mean that if I have only one entry in the nlmLogTable
> and I do a getnext walk on the nlmLogVariableTable, I expect to see
> results like this:
> 
> nlmLogVariableID."".8.1 = OID: sysUpTime.0
> nlmLogVariableID."".8.2 = OID: snmpTrapOID.0
> nlmLogVariableID."".8.3 = OID: ifIndex
> nlmLogVariableID."".8.4 = OID: ifAdminStatus
> nlmLogVariableID."".8.5 = OID: ifOperStatus
> nlmLogVariableValueType."".8.1 = timeTicks(3)
> nlmLogVariableValueType."".8.2 = objectId(7)
> nlmLogVariableValueType."".8.3 = integer32(4)
> nlmLogVariableValueType."".8.4 = integer32(4)
> nlmLogVariableValueType."".8.5 = integer32(4)
> nlmLogVariableTimeTicksVal."".8.1 = Timeticks: (305023) 0:50:50.23
> nlmLogVariableInteger32Val."".8.3 = 5
> nlmLogVariableInteger32Val."".8.4 = 1
> nlmLogVariableInteger32Val."".8.5 = 2
> nlmLogVariableOidVal."".8.2 = OID: linkDown
> 
> But not like this:
> 
> nlmLogVariableID."".8.1 = OID: sysUpTime.0
> nlmLogVariableID."".8.2 = OID: snmpTrapOID.0
> nlmLogVariableID."".8.3 = OID: ifIndex
> nlmLogVariableID."".8.4 = OID: ifAdminStatus
> nlmLogVariableID."".8.5 = OID: ifOperStatus
> nlmLogVariableValueType."".8.1 = timeTicks(3)
> nlmLogVariableValueType."".8.2 = objectId(7)
> nlmLogVariableValueType."".8.3 = integer32(4)
> nlmLogVariableValueType."".8.4 = integer32(4)
> nlmLogVariableValueType."".8.5 = integer32(4)
> nlmLogVariableCounter32Val."".8.1 = Counter32: 0
> nlmLogVariableCounter32Val."".8.2 = Counter32: 0
> nlmLogVariableCounter32Val."".8.3 = Counter32: 0
> nlmLogVariableCounter32Val."".8.4 = Counter32: 0
> nlmLogVariableCounter32Val."".8.5 = Counter32: 0
> nlmLogVariableUnsigned32Val."".8.1 = Gauge32: 0
> nlmLogVariableUnsigned32Val."".8.2 = Gauge32: 0
> nlmLogVariableUnsigned32Val."".8.3 = Gauge32: 0
> nlmLogVariableUnsigned32Val."".8.4 = Gauge32: 0
> nlmLogVariableUnsigned32Val."".8.5 = Gauge32: 0
> nlmLogVariableTimeTicksVal."".8.1 = Timeticks: (305023) 0:50:50.23
> nlmLogVariableTimeTicksVal."".8.2 = Timeticks: (0) 0:00:00.00
> nlmLogVariableTimeTicksVal."".8.3 = Timeticks: (0) 0:00:00.00
> nlmLogVariableTimeTicksVal."".8.4 = Timeticks: (0) 0:00:00.00
> nlmLogVariableTimeTicksVal."".8.5 = Timeticks: (0) 0:00:00.00
> nlmLogVariableInteger32Val."".8.1 = 0
> nlmLogVariableInteger32Val."".8.2 = 0
> nlmLogVariableInteger32Val."".8.3 = 5
> nlmLogVariableInteger32Val."".8.4 = 1
> nlmLogVariableInteger32Val."".8.5 = 2
> nlmLogVariableOctetStringVal."".8.1 = ""
> nlmLogVariableOctetStringVal."".8.2 = ""
> nlmLogVariableOctetStringVal."".8.3 = ""
> nlmLogVariableOctetStringVal."".8.4 = ""
> nlmLogVariableOctetStringVal."".8.5 = ""
> nlmLogVariableIpAddressVal."".8.1 = IpAddress: 0.0.0.0
> nlmLogVariableIpAddressVal."".8.2 = IpAddress: 0.0.0.0
> nlmLogVariableIpAddressVal."".8.3 = IpAddress: 0.0.0.0
> nlmLogVariableIpAddressVal."".8.4 = IpAddress: 0.0.0.0
> nlmLogVariableIpAddressVal."".8.5 = IpAddress: 0.0.0.0
> nlmLogVariableOidVal."".8.1 = OID: ccitt
> nlmLogVariableOidVal."".8.2 = OID: linkDown
> nlmLogVariableOidVal."".8.3 = OID: ccitt
> nlmLogVariableOidVal."".8.4 = OID: ccitt
> nlmLogVariableOidVal."".8.5 = OID: ccitt
> nlmLogVariableCounter64Val."".8.1 = Counter64: 0
> nlmLogVariableCounter64Val."".8.2 = Counter64: 0
> nlmLogVariableCounter64Val."".8.3 = Counter64: 0
> nlmLogVariableCounter64Val."".8.4 = Counter64: 0
> nlmLogVariableCounter64Val."".8.5 = Counter64: 0
> nlmLogVariableOpaqueVal."".8.1 = OPAQUE:
> nlmLogVariableOpaqueVal."".8.2 = OPAQUE:
> nlmLogVariableOpaqueVal."".8.3 = OPAQUE:
> nlmLogVariableOpaqueVal."".8.4 = OPAQUE:
> nlmLogVariableOpaqueVal."".8.5 = OPAQUE:
> 
> Am I correct?  Are both styles correct?
> 
> Thanks,
> 
> Reva Bailey
> 
> TiMetra Inc.
> [email-masked]
> 650-237-5123
> 
> Experience is that marvelous thing that enables you to recognize a mistake
> when you make it again. -Franklin P. Jones
> 
>  
>

---

From: Randy Presuhn <[email-masked]>
Date: Mon, 14 Jan 2002 17:06:55 -0800 (PST)

Hi Reva -

> To: <[email-masked]>
> Subject: FW: NOTIFICATION-LOG-MIB value objects instantiation question
> Date: Mon, 14 Jan 2002 16:27:32 -0800
> Message-ID: <[email-masked]>
...
> Well, no-one has answered my question.  Too basic, I guess.
> Will you please give me your opinion?  If the first case
> below is what is intended, then I'll have to go try and
...

As I read the RFC, your interpretation (the first example)
of the description is correct.  Since the language is "must",
an implementation that follows the second interpretation
would have to be considered non-conformant.

As a one-time toolkit developer, I know that supporting
tables like this is possible in at least one environment,
although it's really really ugly.

...
> > From: Reva Bailey [mailto:[email-masked]]
> > Sent: Tuesday, January 08, 2002 3:51 PM
> > To: [email-masked]
...