Subject: alarmModelEntry notInService

From: "Stefan Wallin" <[email-masked]>
Date: Tue, 15 Jan 2002 12:33:26 +0100

Hi!
Is there a definition of an alarmModelEntry being in state notInService?
Possible interpretations:

1) In conflict with NOTIFICATION-MIB, so I assume wrong
- notifications not sent
- activeAlarmTable NOT updated

2) The entry does not represent a possible alarm:
- notifications sent, (depending on NOTIFICATION-MIB)
- activeAlarmTable NOT updated

best regards Stefan Wallin

---

From: Randy Presuhn <[email-masked]>
Date: Wed, 16 Jan 2002 00:12:15 -0800 (PST)

Hi -

> From: "Stefan Wallin" <[email-masked]>
> To: "Sharon Chisholm" <[email-masked]>,
>         "Disman" <[email-masked]>
> Subject: SV: alarmModelEntry notInService
> Date: Wed, 16 Jan 2002 09:03:10 +0100
> Message-ID: <[email-masked]>
> In-Reply-To: <[email-masked]>
...
> My question is how a alarmModelEntry in state notInService shall be
> handled by the agent. My guess is that the correct behaviour is my
> alternative 2:
> activeAlarmTable is NOT updated when the corresponding event occurs.
> Of course it does not affect notification sending.

That would be my expectation.

> See def of notInService in SMIv2-TC:
> - `notInService', which indicates that the conceptual
>  	     row exists in the agent, but is unavailable for use by
>  	     the managed device
> 
> Assuming that interpretation, we have a transactional concern, it is
> confusing to make only some of the entries of the same alarmindex out of
> service. It should affect all entries with the same alarmModelIndex.
...

Note well that the notInService value of the RowStatus textual
convention is probably NOT appropriate as a "control" value
here, since the row may disappear due to the provisions at
the bottom of page 16 of RFC 2579.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------