Subject: Re: DMTF ProbableCause beyond X.733

From: "Robert Moore" <[email-masked]>
Date: Tue, 15 Jan 2002 08:27:37 -0500

Hi Randy,

I can answer this question as well as Andrea can.
Understand, though, that I don't even participate in
the Events WG, so all I can give you is what's in the
current (i.e., Version 2.6 Preliminary) CIM Schema.
I doubt that the WG is tweaking this further as we
speak, but I don't know this for sure.

I've also lost track of how these code points ended
up in X.733, so I can't do the comparison for you.
Here's the full set of values in the Events MOF,
though:

    [Required, Description (
      "An enumerated value that describes the probable cause of the "
      "situation which resulted in the AlertIndication."),
     Values {"Unknown", "Other", "Adapter Error",
        "Application Subsystem Failure", "Bandwidth Reduced",
         "Connection Establishment Error",
         "Communications Protocol Error",
         "Communications Subsystem Failure",
         "Configuration/Customization Error", "Congestion",
         "Corrupt Data", "CPU Cycles Limit Exceeded",
         "Dataset/Modem Error", "Degraded Signal",
         "DTE-DCE Interface Error", "Enclosure Door Open",
         "Equipment Malfunction", "Excessive Vibration",
         "File Format Error", "Fire Detected", "Flood Detected",
         "Framing Error", "HVAC Problem", "Humidity Unacceptable",
         "I/O Device Error", "Input Device Error", "LAN Error",
         "Non-Toxic Leak Detected", "Local Node Transmission Error",
         "Loss of Frame", "Loss of Signal",
         "Material Supply Exhausted", "Multiplexer Problem",
         "Out of Memory", "Output Device Error",
         "Performance Degraded", "Power Problem",
         "Pressure Unacceptable",
         "Processor Problem (Internal Machine Error)",
         "Pump Failure", "Queue Size Exceeded", "Receive Failure",
         "Receiver Failure", "Remote Node Transmission Error",
         "Resource at or Nearing Capacity", "Response Time Excessive",
         "Retransmission Rate Excessive", "Software Error",
         "Software Program Abnormally Terminated",
         "Software Program Error (Incorrect Results)",
         "Storage Capacity Problem", "Temperature Unacceptable",
         "Threshold Crossed", "Timing Problem",
         "Toxic Leak Detected", "Transmit Failure",
         "Transmitter Failure", "Underlying Resource Unavailable",
         "Version MisMatch", "Previous Alert Cleared",
         "Login Attempts Failed", "Software Virus Detected",
         "Hardware Security Breached", "Denial of Service Detected",
         "Security Credential MisMatch",
         "Invalid Access of Data Detected"},
     MappingStrings {"Recommendation.ITU|X733.Probable cause"} ]
    uint16 ProbableCause;

Regards,
Bob

Bob Moore
Advanced Design and Technology
Application Integration Middleware Division
IBM Software Group
+1-919-254-4436
[email-masked]

                    Randy Presuhn                                                               
                    <rpresuhn@dorothy.       To:     [email-masked]                          
                    bmc.com>                 cc:     [email-masked]                     
                    Sent by:                 Subject:     DMTF ProbableCause beyond X.733       
                    owner-disman@dorot                                                          
                    hy.bmc.com                                                                  

                    01/14/02 07:50 PM                                                           

Hi Andrea -

In Salt Lake City we chatted about the DMTF's use of X.733
"probable cause" codes, and how the DMTF's events work had
found it necessary to extend this list.

We in the IETF disman (distributed management) working group
would like to know what the DMTF extensions are, so that
our related work, which also includes the M.3100 codes,
does not diverge unnecessarily from what the DMTF has done
in this space.

We appreciate your help.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: "Andrea Westerinen" <[email-masked]>
Date: Tue, 15 Jan 2002 08:33:00 -0800

Bob and Randy, I did the original mapping from the X.733 spec (since much of
the AlertIndication is indeed based on X.733).  Then, the DMTF Event WG
added other values to the enum, that they felt were missing.  I took the
action from Randy (at the Policy SLA meeting) to indicate what we added - so
that we could have a consistent list of values across the standards, and
also will look at M.3100 probable cause (since it addresses more info than
X.733).

I actually responded to Randy (privately) that I would send this info next
week.

Andrea

-----Original Message-----
From: Robert Moore [mailto:[email-masked]]
Sent: Tuesday, January 15, 2002 5:28 AM
To: Randy Presuhn
Cc: [email-masked]; [email-masked];
[email-masked]
Subject: Re: DMTF ProbableCause beyond X.733

Hi Randy,

    [Required, Description (

Regards,
Bob

Bob Moore

                    Randy Presuhn

                    Sent by:                 Subject:     DMTF ProbableCause
beyond X.733
                    owner-disman@dorot
                    hy.bmc.com

                    01/14/02 07:50 PM

Hi Andrea -

We appreciate your help.