Subject: Alarm MIB Issues 1-13

From: "Sharon Chisholm" <[email-masked]>
Date: Tue, 15 Jan 2002 19:31:16 -0500

hi

Ok, last email of the evening. Here is an updated issue
list for the Alarm MIB.

Closed Issues
-------------
Alarm#1 TimeFilter as index to Active Alarm Table
Alarm#2 Cleared Alarm Table 
Alarm#3 Resource Identifier for Application
Alarm#5 EngineId versus ContextEngineId
Alarm#6 Telcordia Alarm Models
Alarm#7 Alarm Example Error
Alarm#8 Matching Notifications
Alarm#10 Detecting Alarm State Change

Open Issues
-----------

Alarm#4 Relation to Event MIB
  There does not seem to be any particular relation between these MIBs, 
  compared with other MIBs, but the commonality in terms may cause 
  confusion if not clarified.

Alarm#9 Example showing relation to Condition and Arc MIB
  Currently missing from -04

Alarm#11 Resource Identification
  The resource identification method in -04 uses a type and 
  integer value pair to identify a resource. There has
  been some support for using an OID instead. There are
  pros and cons to each approach.

Alarm#12 Time Zone in DataAndTime
  There are concerns that the optional zone part of DateAndTime
  might not be implemented. As time zones are an important piece
  of information in a distributed manager. Test should
  be added the textual descriptions of the DateAndTime object
  to encourage the correct behaviour. Randy suggested some
  text on which there was some agreement.

Alarm#13 DMTF input into probable cause
  We have some input from DMTF as to potential additional probable
  cause values. When these are available, the initial set of
  probable causes can be updated.

Sharon Chisholm
Preside Management
Nortel Networks
Ottawa, Ontario

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 17 Jan 2002 04:20:54 +0200

Let me try to shorten the list:

Alarm #4 - I suggest the following text.

x.y Relationship with the Event MIB 

During the work and discussions in the Working Group, the issue of the
relationship between the MIB modules and the Event MIB [RFC...] was
raised. There is no direct relation or dependency between the Alarm MIB
and the Event MIB. Some common terms (like 'event') are being used in
both MIB modules, and the user is directed to the sections that define
terminology in the two documents for clarification.

Alarm#12 

I suggest to adopt the additional text proposed by Randy

Alarm #13 

This issue seems similar with Alarm#6. Mentioning a possible source of
information without bringing a concrete proposal does not help. I
suggest to close this item. If somebody will bring a specific proposal
for additional probable cause values from DMTF or any other source, we
will consider it.

Assuming that we will fill in the example required at Alarm #9 in the
next I-D, the only real open issue remains Alarm #11. IMO both
approaches would work, and which one we pick is more an issue of
culinary taste or religion ('do you like the flexibility of the OIDs? do
you believe that it is that difficult to implement OIDs?). I would
suggest to let our Chair rule, so that the process is not stalled for an
issue that might be rather 'don't care' at the end of the day.

Regards,

Dan

> -----Original Message-----
> From: Sharon Chisholm [mailto:[email-masked]]
> Sent: Wednesday, January 16, 2002 2:31 AM
> To: [email-masked]
> Subject: Alarm MIB Issues 1-13
> 
> 
> hi
>