Subject: RE: more comments...

From: "Sharon Chisholm" <[email-masked]>
Date: Sun, 20 Jan 2002 16:55:42 -0500

hi

<Stefan>
alarmModelRowStatus
=====================
Current description of alarmModelRowStatus:
 
"Control for creating and deleting entries.  Entries may be modified
while active.
This row can not be deleted while it is being referenced by a value of
alarmActiveModelPointer"
 
I assume we should expand the restrictions to:
This row can not be deleted or _modified_ while it is being referenced by
a value of alarmActiveModelPointer.
</Stefan>

Yes. Thanks, I'll make this change.

<Stefan>
Comments of editorial art:

1) The ITU-ALARM-TC and ITU-IANA-ALARM-TC are missing MODULE-IDENTITY
</Stefan>

I was hoping to get away without one as not all textual conventions
have them. I've looked, but I don't think I ever found anything
that said they were mandatory.
 
<Stefan>
2) The module name starts with ITU which normally should indicate the
   enterprise owning the module, I wonder what ITU says...
</Stefan>

Good question. Study group 4 has certainly seen the MIB but the expectation
is that disman owns the MIB.
 
<Stefan>
3) Groups in ITU-ALARM-MIB have strange names considering their contained
   objects.
</Stefan>

The group names are actually from the group names as defined in one of the
ITU documents. I think it was X.733.

<Stefan> 
4) Page 44: examples section:

<misc. errors>
</Stefan>

Thanks,

Sharon

---

From: David Partain <[email-masked]>
Date: Mon, 21 Jan 2002 08:51:46 +0100

Hi,

> that said they were mandatory.

See Page 12, RFC 2578, the last paragraph of section 3:

   All information modules start with exactly one invocation of the
   MODULE-IDENTITY macro, which provides contact information as well as
   revision history to distinguish between versions of the same
   information module.  This invocation must appear immediately after
   any IMPORTs statements.

It must be there.

> is that disman owns the MIB.

I too find this rather confusing.  Since the ITU isn't really
involved, and the module name generally helps (at least me)
understand who's responsible for the module, it might be a
good idea to have DISMAN-ITU rather than just ITU (or something
else to remove any confusion).

Cheers,

-- 
David Partain                  [email-masked]
Ericsson Research's LinLab     Tel: +46 13 28 41 44
P.O. Box 1248                  Fax: +46 13 28 75 67
SE-581 12 Linköping, Sweden    #include <stddisclaimer.h>