Subject: RE: time stamp of alarms in ALARM MIB

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 9 Jan 2002 20:19:27 +0200

> I do not think there is a problem with the DateAndTime TC. It says:
> 
>             Note that if only local time is known, then timezone
>             information (fields 8-10) is not present."
> 
> Perhaps the language could be stronger, but it basically says the
> right thing to me: Report the timezone except in cases where the
> timezone information is not available.
> 
> Defining a ZoneDateAndTime which requires to report the timezone even
> if your box has no clue about the timezone is not a step forward and
> people will just report GMT or something like that which is worse.
> 

I was not meaning the context of this MIB. However, for a MIB and
applications that clearly would require objects distributed at different
time zones I would use this new TC, and include text mandating time zone
awareness in the agents implementing the TC.

Regards,

Dan

---

From: Randy Presuhn <[email-masked]>
Date: Thu, 10 Jan 2002 16:57:02 -0800 (PST)

Hi -

Proposed wording for both of the objects with DateAndTime
syntax:

   Implementations MUST include the offset from UTC,
   if available.  Implementation in environments in which
   the UTC offset is not available is NOT RECOMMENDED.

Just a bit stronger than the "SHOULD", leaving very
little wiggle room.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 14 Jan 2002 23:02:24 +0200

The proposed change is fine with me. Regards, Dan

> -----Original Message-----
> From: Randy Presuhn [mailto:[email-masked]]
> Sent: Friday, January 11, 2002 2:57 AM
> To: [email-masked]
> Subject: RE: time stamp of alarms in ALARM MIB
> 
> 
> Hi -
>