Subject: Alarm MIB et al; identifying a Trap

From: "Tom Petch" <[email-masked]>
Date: Tue, 16 Apr 2002 13:23:45 +0100

Two thoughts on identifying a SNMPv1 Trap in the Alarm MIB
and others.
1) The community name is an OCTET STRING of up to 255
octets;this gets stored in an SnmpAdmin String eg
alarmActiveContextName which is limited to 32 octets; does
the community name get truncated?
2) What is the OID for an SNMPv1 trap such as linkUp eg as
in alarmActiveNotificationID?  Does the Alarm MIB agent used
the SNMPv2/3 definitions eg .1.3.6.1.6.3.1.1.5.4 ?

Tom Petch, Network Consultant
[email-masked]

---

From: "David T. Perkins" <[email-masked]>
Date: Tue, 16 Apr 2002 13:03:29 -0700

HI,

An SNMPv1 community string value and a CONTEXT name are not
necessarily identical. That is, you cannot say the mapping
is "always" one-to-one. 

For both the context name and the OID for the notification,
you would follow the instructions found in RFC 2576

>[email-masked]

Regards,
/david t. perkins

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 17 Apr 2002 16:46:19 +0200

>>>>> Tom Petch writes:

Tom> 2) What is the OID for an SNMPv1 trap such as linkUp eg as in
Tom> alarmActiveNotificationID?  Does the Alarm MIB agent used the
Tom> SNMPv2/3 definitions eg .1.3.6.1.6.3.1.1.5.4 ?

Yes. The Alarm MIB uses SMIv2 (a full standard since 1999) which
identifies notifications via OIDs. There are appropriate mappings
defined in RFC 2576 if you have to use SNMPv1 with SMIv2 MIB modules.

/js

-- 
Juergen Schoenwaelder    <http://www.informatik.uni-osnabrueck.de/schoenw/>