Subject: Alarm MIB et al; monotonic increasing

From: "Tom Petch" <[email-masked]>
Date: Tue, 16 Apr 2002 09:41:04 +0100

I am concerned about the use of monotonic increasing in the
Alarm MIB and others.

My university text book - E.G. Philips A Course of Analysis
(1960) - defines monotonic increasing as
s1 LTE s2 LTE s3 LTE s4 ...
eg 1 1 3 5  7 7 9 10 ..
which won't do for an INDEX such as
alarmActiveVariableIndex or alarmActiveIndex.

Any thoughts?

Tom Petch, Network Consultant
[email-masked]

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 16 Apr 2002 14:55:28 +0300

With all due respect to your text book - this is the widely spread way we are defining the 'arbitrary'  indices in many IETF MIBs. 

Actually what do you suggest? would 'strictly monotonic increasing' be OK?

Thanks,

Dan

> -----Original Message-----
> From: Tom Petch [mailto:[email-masked]]
> Sent: Tuesday, April 16, 2002 11:41 AM
> To: disman
> Subject: Alarm MIB et al; monotonic increasing
> 
>

---

From: "Tom Petch" <[email-masked]>
Date: Tue, 16 Apr 2002 13:56:21 +0100

Yes, I was taught 'strictly increasing' or 'strictly
monotonic increasing' or 'increasing in the strict sense'
and have used that in the engineering I have done since.  I
have looked at more modern mathematics books and see no
change in the language.

-----Original Message-----
From: Romascanu, Dan (Dan) <[email-masked]>
To: Tom Petch <[email-masked]>; disman
<[email-masked]>
Date: 16 April 2002 12:57
Subject: RE: Alarm MIB et al; monotonic increasing

With all due respect to your text book - this is the widely
spread way we are defining the 'arbitrary'  indices in many
IETF MIBs.

Actually what do you suggest? would 'strictly monotonic
increasing' be OK?

Thanks,

Dan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 17 Apr 2002 11:10:15 +0300

Sounds OK. We'll do the change in the next round. Thanks, Dan

> Sent: Tuesday, April 16, 2002 3:56 PM
> To: Romascanu, Dan (Dan); disman
> Subject: Re: Alarm MIB et al; monotonic increasing
> 
>