Subject: Re: Alarm MIB WG last call

From: Randy Presuhn <[email-masked]>
Date: Fri, 19 Apr 2002 18:06:33 -0700 (PDT)

Hi -

> Message-ID: <[email-masked]>
> Date: Thu, 18 Apr 2002 18:36:36 -0500
> From: Tammy Ferris <[email-masked]>
> To: "Romascanu, Dan (Dan)" <[email-masked]>, [email-masked]
> Subject: Re: Alarm MIB WG last call
> References: <[email-masked]>
...
> > I proposed a fix of having 2 timestamps in the active alarm
> > table rather than one :  One time stamp (the time the alarm
> > was reported) be the one to use for indexing and a second
> > time stamp (the time the error occurred).
...
(much discussion / elaboration deleted)

I'm thinking about this problem from an implementation
perspective, specifically with an AgentX bias.  Now I
know that we don't want to *require* the use of agentx,
but the pervasiveness of subagent technologies requires
us to at least give some thought to its implications.

If we would like to have both timestamps in the active
alarm table, where would the values come from?  If we rely
on "in-band" information in AgentX, we are left with few
reasonable choices:

    1) the subagent could supply a sysUpTime.0 varbind
       reflecting the time the condition occurred, and
       the Active Alarm MIB implementation could use its
       local time to populate the "reported" field.

    2) the subagent could supply a sysUpTime.0 varbind
       reflecting the time the condition was reported, and
       add another variable binding to reflect when the
       condition occurred.

Though I personally prefer (1) (and would like to see
appropriate language in the condition mib), both of these
alternatives have a really interesting property: the
information recording when the condition was detected ends
up in the alarmActiveVariableTable, though perhaps not in
the most convenient form imaginable.

Am I missing something here?

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: Tammy Ferris <[email-masked]>
Date: Mon, 22 Apr 2002 15:57:12 -0500

Randy,
If I understand your proposal correctly, it seems to me also that 1) meets the identified
need  better and provides a cleaner separation of the alarm and condition (or is it now
called error?) MIBs.
Tammy