Subject: Re: Alarm MIB WG last call

From: Randy Presuhn <[email-masked]>
Date: Mon, 22 Apr 2002 14:17:26 -0700 (PDT)

Hi -

> Message-ID: <[email-masked]>
> Date: Mon, 22 Apr 2002 15:43:51 -0500
> From: Tammy Ferris <[email-masked]>
> To: "Romascanu, Dan (Dan)" <[email-masked]>
> Cc: [email-masked]
> Subject: Re: Alarm MIB WG last call
> References: <[email-masked]>
...
> Does this reply indicate that you prefer two timestamps 
> over some other solution to fix this problem?

I can't speak for Dan, but my point was that the information
recording when the condition was detected would already be present
in the variable bindings, so that there's no need for a second object.

...
> For systems that cannot either produce and/or store error occurance
> timestamps, how about setting the time the error occurred equal to
> the time the alarm information was added to the alarm table?
...

Why would we need to support such a beast?  A notification by
definition includes a timestamp.  Take a look at the agentx
protocol spec.  Infrastructure lacking this information is
arguably broken.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: Tammy Ferris <[email-masked]>
Date: Mon, 22 Apr 2002 17:35:44 -0500

Randy,
See my comments below.
Tammy

> in the variable bindings, so that there's no need for a second object.

I apologize that I don't understand your point.  Are you saying that the timestamp used
for the index should be the 'time that the error information was added to the alarm table'
and that the 'time the error occured' would be in the variable bindings?  Or are you
saying that there doesn't need to be a timestamp for the time the error information was
added into the active alarm table?

> protocol spec.  Infrastructure lacking this information is

Clarify for me - what I think you are saying here is that all 'subagents' and 'agents'
have the capability (memory and clock) to support the recording and reporting the time of
the occurance of every error.  Is that correct?  If so, then I agree that Dan should not
worry about what to do if such capability does not exist.