Subject: RE: Pairing instances

From: Randy Presuhn <[email-masked]>
Date: Mon, 22 Apr 2002 17:08:03 -0700 (PDT)

Hi -

> content-class: urn:content-classes:message
> Subject: RE: Pairing instances
> Date: Thu, 18 Apr 2002 16:07:41 +0300
> Message-ID: <[email-masked]>
> From: "Romascanu, Dan (Dan)" <[email-masked]>
> To: "David T. Perkins" <[email-masked]>, <[email-masked]>
...
> Do you think that there is need for
> more explanation, or maybe do you think that an alarm may be
> triggered on interface 1 and cleared on interface 9? (I do
> not think this is a practical case)
...

Consider the case where the ifStackTable is used to associate
DS0s with their underlying T1.  For something on interface
1 to potentially clear the alarms on interfaces 2 through 25
does not seem far-fetched.  However, do we see this as being
within the scope of this MIB?

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: "David T. Perkins" <[email-masked]>
Date: Mon, 22 Apr 2002 17:39:12 -0700

HI,

The example below is interesting, but I'm talking about something
really basic. Lets assume we are using unique notifications
for "state transitions". Then the model table (alarmModelTable)
maps notifications to "next state" severity levels of alarms.
Assume the value for alarmListName is the zero length string.

Say, we have alarm "A", that is identified with value 23
as specified for index object alarmModelIndex, and has
the following assignments for values for perceived severity
and notifications:
  clear - notification n1 is sent
  minor - notification n2 is sent
  critical - critical n3 is sent
The three objects alarmModelNotificationId, alarmModelVarbindIndex,
and alarmModelVarbindValue perform the mapping. However, how the
code would determine the value of "alarmActiveResourceId" from
the notifications is not described. If this mapping is "hard
coded", so new entries could not be created in table alarmModelTable,
then the problem is solved. But if so, then I'm note sure
why we need the model table.

> Randy Presuhn          BMC Software, Inc.  1-3141
Regards,
/david t. perkins

---

From: "Stefan Wallin" <[email-masked]>
Date: Tue, 23 Apr 2002 16:43:29 +0200

Hi!
I have problems with the RMON example and some of the issues I think is
connected to what Perkins describe.
1) In general the example is a little bit strange since it does not use
fallingAlarm and risingAlarm
as alarm on/off notifications.

2) However the more general question is:
Lets say I define two alarms in the RMON alarmTable:
alarmVariable X, risingThreshold 10, fallingthreshold 8
alarmVariable Y, risingThreshold 20, fallingthreshold 16

In this case it is extremely important that fallingAlarm Threshold on Y
does not clear any active alarm on X.
How do we describe that? Miss something in the alarmModelTable to point to
resource var-bind in case the generic notifications are not used.
(Resembles Perkins ifIndex example). What is the conclusion on the
previous issue here?

3) Minor error in 6.1 Alarms Based on linkUp/linkDown Notification
 alarmActiveModelPointer          alarmModelEntry.3 <<<<<<<<<<<<<< missing
index

-----Ursprungligt meddelande-----
Fran: [email-masked]
[mailto:[email-masked]]For David T. Perkins
Skickat: den 23 april 2002 02:39
Till: Randy Presuhn; [email-masked]
Amne: RE: Pairing instances

HI,

At 05:08 PM 4/22/2002 -0700, Randy Presuhn wrote:
>> Message-ID:
<[email-masked]>
Regards,
/david t. perkins