Subject: [Disman] To-do items left over from San Francisco

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 13 Jun 2003 09:24:20 -0700

Hi -

I looked through the minutes from our meeting in San Francisco, and
it looks like the following items remain to be done:

| 1. Sharon Chisholm tasked with drafting a "Thank You" message to the
| ITU-T Liaison, and sending the draft to the DISMAN wg.

Sharon?

| 8. For Script MIB and Schedule MIB - Randy to look at a questionnaire
| for implementation requests on these MIBs.

Mea culpa.

| 9. Remops MIB - if anyone is interested in assiting with edits, to
| contact RP on the disman mailing list.
|
| 10. Octet String in Remops MIB for payload - has a constraint related to
| ipv4 - computes
| pkt size - ipv4 hdr size. Need description clarification on what the
| object should do (return an error or silently truncate payload size)
| when transport type is ipv6 - Randy Presuhn suggested silently
| truncating. Need further
| discussion on the mailing list. This action item is assigned to Randy
| Presunhn.

Juergen Quittek accepted the job of handling
the edits.  Juergen, where are we?

| 10. Ram Kavasseri to initiate thread on taking Expression MIB to
| historic status.

This happened, but I don't feel like we really reached much of
a conlusion.  The current practice is to produce an informational
RFC to explain a decision to reclassify a document as "historic".
I didn't see a massive outpouring of volunteer effort to produce
such a document, so I'd rather spend our editor cycles on things
that clearly have a higher priority.

| 12. Need interoperability results (for event and notif-log mibs) summary
| on wg mailing list.
| Ram Kavasseri to drive the interoperability test effort. Results
|need to be posted to the wg by May.

Ram?

| 13. NetSNMP implements the EVENT-MIB - this MIB is the target of
| internal polling
| for NetSNMP apps. Wes Hardaker to provide pointers on how to set up a
| copy
| of NetSNMP running the EVENT-MIB for interoperability testing.

Wes?

| 14. Sharon to check and report back on implementations of log MIB at
| Nortel.

Sharon?

| 15. Updates for Expr, Event, Notif-Log MIB expected by April 1st.
| Editor needs to look at latest version of ID nits doc, the update to the
| RFC authors
| guidelines - for the ARC MIB update, as well as the latest guidelines
| for MIB reviewers.

Ram has already responded on this; beware the fast-approaching i-d cutoff.

| 16. Ram to repost implementation requests for the event, expression and
| notif-log mibs on the disman wg.

Ram?

If any of these are already done, please let me know.
If any of the items that I thought was done isn't, I'd like
to know about that as well.

Randy

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 13 Jun 2003 20:03:36 +0200

Hi Randy,

> the edits.  Juergen, where are we?

I collected all remops issues from the mailing list since
publication of the RFC incluing the issue on the RFC errata
web page.

I will reply on your suggestion in a separate message.

    Juergen

>| need to be posted to the wg by May.
>
> Ram?
>

---

From: Ramanathan Kavasseri <[email-masked]>
Date: Fri, 13 Jun 2003 10:31:52 -0700

I was about to post the revised event mib draft, but realized
that I don't have Bob Stewart's latest contact information.

The info in the draft still points to "Cisco Systems, Inc.",
which isn't true anymore.

Anyone have a more upto-date address? Or an alternative suggestion?

Ram

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 13 Jun 2003 11:05:55 -0700

Hi -

> From: "Juergen Quittek" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "Disman (E-mail)" <[email-masked]>
> Cc: "Ram Kavasseri" <[email-masked]>; "Sharon Chisholm" <[email-masked]>; "Wes Hardaker" <[email-masked]>
> Sent: Friday, June 13, 2003 11:03 AM
> Subject: Re: To-do items left over from San Francisco

....
> I will reply on your suggestion in a separate message.
...

Great!  Thanks for the quick response.

Randy

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 13 Jun 2003 20:03:36 +0200

Hi Randy,

    Juergen

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 13 Jun 2003 11:04:32 -0700

Hi -

> From: "Ramanathan Kavasseri" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: "Disman (E-mail)" <[email-masked]>; "Sharon Chisholm" <[email-masked]>; <[email-masked]>; "Wes Hardaker"
<[email-masked]>
> Sent: Friday, June 13, 2003 10:31 AM
> Subject: Re: [Disman] To-do items left over from San Francisco
>

...

I think the solution adopted in http://www.ietf.org/rfc/rfc3410.txt
is fine.

Randy

---

From: Ramanathan Kavasseri <[email-masked]>
Date: Fri, 13 Jun 2003 10:31:52 -0700

Ram

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 13 Jun 2003 11:05:55 -0700

Hi -

....
...

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 13 Jun 2003 11:04:32 -0700

Hi -

<[email-masked]>

...

Randy

---

From: Wes Hardaker <[email-masked]>
Date: Mon, 16 Jun 2003 06:58:36 -0700

>>>>> On Fri, 13 Jun 2003 09:24:20 -0700, "Randy Presuhn" <[email-masked]> said:

Randy> | 13. NetSNMP implements the EVENT-MIB - this MIB is the target
Randy> | of internal polling for NetSNMP apps. Wes Hardaker to provide
Randy> | pointers on how to set up a copy of NetSNMP running the
Randy> | EVENT-MIB for interoperability testing.

Randy> Wes?

Download a copy from http://www.Net-SNMP.org/download/
tar xzf net-snmp-5.0.8.tar.gz
cd net-snmp-5.0.8
./configure --with-mibs="disman/event-mib"
make
make install
net-snmp-config --create-snmpv3-user
  [answer questions about creating your first user]
snmpd

At which point the snmp agent is up and running and the
disman-event-mib objects (most of them) should be configurable.  Note
that the main-branch of the CVS server has additional code not
available in 5.0.8 to support the custom notification generation.
5.0.8 only includes support for generating the mteHotTrigger trap.

Also, note that the snmpd.conf manual page contains information on how
to set up the snmpd.conf file to include event monitoring using
"boolean like" expressions in the snmpd.conf file.
-- 
"In the bathtub of history the truth is harder to hold than the soap,
 and much more difficult to find."  -- Terry Pratchett

---

From: Wes Hardaker <[email-masked]>
Date: Mon, 16 Jun 2003 06:58:36 -0700

Randy> Wes?