Subject: RE: [Disman] Section 5.1 in draft-ietf-disman-alarm-mib-15.txt

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 22 Oct 2003 18:20:18 +0200

> -----Original Message-----
> From: Randy Presuhn [mailto:[email-masked]]
> Sent: 22 October, 2003 6:00 PM
> To: Disman (E-mail)
> Subject: Re: [Disman] Section 5.1 in 
> draft-ietf-disman-alarm-mib-15.txt
> 
> 
> Hi -
> 
> > From: "Romascanu, Dan (Dan)" <[email-masked]>
> > To: "Randy Presuhn" <[email-masked]>; "Disman 
> (E-mail)" <[email-masked]>
> > Sent: Wednesday, October 22, 2003 1:38 AM
> > Subject: RE: [Disman] Section 5.1 in 
> draft-ietf-disman-alarm-mib-15.txt
> >
> > > >    In the case of the ITU Alarm MIB, for each row in the
> > > >    alarm model table there is one row in the ITU alarm 
> model table.
> ...
> > > I believe the proposed text preclude the third possibility
> > >     (c) an entry in the other extension MIB, but not in the
> > > ITU alarm MIB.
> >
> > I do not believe this is the case. The text refers to the 
> ITU Alarm MIB, but does not preclude the third possibility.
> 
> ???  Sharon's proposed text says that for each row in the 
> alarm model table there
> will be one row in the ITU alarm model table.  (See quote 
> above.)  This cannot
> be true if it is possible for there to be an entry without a 
> corresponding entry
> in the ITU alarm MIB.

The quoted text starts with 'In the case of the ITU Alarm MIB' !

Would inserting the adjective 'relevant' between 'each' and 'row' help clarify?

Thanks,

Dan

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 22 Oct 2003 17:12:51 -0700

Hi -

> To: "Randy Presuhn" <[email-masked]>; "Disman (E-mail)" <[email-masked]>
> Sent: Wednesday, October 22, 2003 9:20 AM
> Subject: RE: [Disman] Section 5.1 in draft-ietf-disman-alarm-mib-15.txt
...
> > > > >    alarm model table there is one row in the ITU alarm model table.
>

That doesn't affect the meaning.

> Would inserting the adjective 'relevant' between 'each' and 'row' help clarify?

Not really.  :-(  I think we agree what it's supposed to mean, but the words that
are there are say the wrong thing. In the interest of keeping changes to the absolute
minimum, I'd be OK with:

In the case of the ITU Alarm MIB, for each row in the ITU alarm model table
there would be a corresponding row in the alarm model table.

or perhaps

In the case of the ITU Alarm MIB, for each row in the alarm model table there
MAY be one row in the ITU alarm model table.

I think we really do agree that the relationship between usable generic and
extension model entries isn't 1:1, but rather 1:(0,1), and just need to make sure
that the text is sufficiently clear.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 22 Oct 2003 17:12:51 -0700

Hi -

...

or perhaps

Randy