Subject: RE: [Disman] alarmActiveEngineAddress

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 8 Oct 2003 14:18:30 -0400

Hi

The following is the proposed resolution to Randy-58. Assuming no objection,
this item will be considered closed conditional on the proposed edit being
done.

In the description for alarmActiveEngineAddress, replace

"       "The Address of the SNMP engine on which the alarm is"

With

"       "The address of the SNMP engine on which the alarm is"

No change will be done to address the second observation. The Engine ID
object indicates that it identifies the source of the alarm and this
indicates it is used when that isn't available.

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Wednesday, October 01, 2003 9:51 PM
To: Disman (E-mail)
Subject: [Disman] alarmActiveEngineAddress

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: "Disman (E-mail)" <[email-masked]>
> Cc: <[email-masked]>; "Randy Presuhn" 
> <[email-masked]>; "Romascanu, Dan (Dan)"
<[email-masked]>
> Sent: Monday, September 29, 2003 7:34 AM
> Subject: [Disman] RE: Comments on draft-ietf-disman-alarm-mib-14.txt
...

...
> 58) alarmActiveEngineAddress: "IP Address" -> "address"
>     ditto alarmClearEngineAddress
...

One step forward, two steps back.  :-) * 0.5
   - "Address" should be "address"
   - the sentence "This is used to identify the source of an SNMPv1
       trap, since an alarmActiveEngineId cannot be extracted from the
       SNMPv1 trap PDU." leaves me wondering why it's there, since even
       if one can extract an SnmpEngineId from a wrapper, it still won't
       reliably yield an address.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 8 Oct 2003 12:14:16 -0700

Hi -

> Cc: "Randy Presuhn" <[email-masked]>
> Sent: Wednesday, October 08, 2003 11:18 AM
> Subject: RE: [Disman] alarmActiveEngineAddress
...
...

But that's not what the description says.

The sentence "This is used to identify the source of an SNMPv1
trap, since an alarmActiveEngineId cannot be extracted from the
SNMPv1 trap PDU."  is still wrong.  Even if one has an EngineId,
one *still* needs an address to get there.

Proposed replacement: Delete the sentence.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 8 Oct 2003 12:14:16 -0700

Hi -

...
...

Randy