Subject: RE: [Disman] zero-based counters in draft-ietf-disman-alarm-mib-1 5.txt?

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 8 Oct 2003 16:26:18 -0400

Hi

Do we really feel that the current description and data type will result in
non-interoperable implementations? Other than the fact there was a neater
data type that we could have used instead, I don't really see a problem
here. I think the text is sufficient for people to know to start the thing
at 0 if nothing has happened.

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Thursday, October 02, 2003 10:54 PM
To: Disman (E-mail)
Subject: [Disman] zero-based counters in draft-ietf-disman-alarm-mib-15.txt?

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: "Disman (E-mail)" <[email-masked]>
> Cc: <[email-masked]>; "Randy Presuhn" 
> <[email-masked]>; "Romascanu, Dan (Dan)"
<[email-masked]>
> Sent: Monday, September 29, 2003 7:34 AM
> Subject: [Disman] RE: Comments on draft-ietf-disman-alarm-mib-14.txt
...
> 62) alarmActiveStatsActives, the SYNTAX says this is a Counter32,
>     but the DESCRIPTION sure makes it sound like it's supposed to
>     be zero-based.
>
> 71) ituAlarmActiveStatsIndeterminates,
>     ituAlarmActiveStatsCriticals,
>     ituAlarmActiveStatsMajors,
>     ituAlarmActiveStatsMinors, and
>     ituAlarmActiveStatsWarnings are all Counter32, but their
>     DESCRIPTIONs sound like they're assumed to be zero-based.
>
> Sharon-> Counter32 can have a value of 0.
...

Let me put it another way:
  if none of these events have occured since system restart,
  what will the value of these objects be?

  a) zero, since the descriptions say they are counts "since system restart"
     if this is the case, they should use the ZeroBasedCounter32 TC
  b) not predictable, given the defnition of Counter32 in RFC 2578 clause
7.1.6
     if this is the case, then the "since system restart" words are
misleading

Randy (technical contributor)

---

From: "Sharon Chisholm" <[email-masked]>
Date: Fri, 10 Oct 2003 10:32:44 -0400

Hi

The following is the proposed resolution to Randy-62 and Randy-71. Assuming
no objection, this item will be considered closed conditional on the
proposed edit being done.

In the Alarm MIB imports section, replace
"     NOTIFICATION-GROUP                  FROM SNMPv2-CONF;"
With
"     NOTIFICATION-GROUP                  FROM SNMPv2-CONF
      ZeroBasedCounter32 			FROM RMON2-MIB;"

In the definition of AlarmActiveStatsEntry, replace
"              alarmActiveStatsActives        Counter32,"
To
"              alarmActiveStatsActives        ZeroBasedCounter32 ,"

In the object definition, replace
"   alarmActiveStatsActives OBJECT-TYPE
         SYNTAX Counter32"
With
"   alarmActiveStatsActives OBJECT-TYPE
         SYNTAX ZeroBasedCounter32 "

In the ITU-ALARM-MIB imports section, replace
"      MODULE-COMPLIANCE, OBJECT-GROUP     FROM SNMPv2-CONF;"
With
"      MODULE-COMPLIANCE, OBJECT-GROUP     FROM SNMPv2-CONF
      ZeroBasedCounter32 			FROM RMON2-MIB;"

In the definition of ItuAlarmActiveStatsEntry, replace
"      ituAlarmActiveStatsIndeterminates       Counter32,
      ituAlarmActiveStatsCriticals            Counter32,
      ituAlarmActiveStatsMajors               Counter32,
      ituAlarmActiveStatsMinors               Counter32,
      ituAlarmActiveStatsWarnings             Counter32"
With
"      ituAlarmActiveStatsIndeterminates      ZeroBasedCounter32 ,
      ituAlarmActiveStatsCriticals            ZeroBasedCounter32 ,
      ituAlarmActiveStatsMajors               ZeroBasedCounter32 ,
      ituAlarmActiveStatsMinors               ZeroBasedCounter32 ,
      ituAlarmActiveStatsWarnings             ZeroBasedCounter32
"

In the object definitions, replace
"   ituAlarmActiveStatsIndeterminates OBJECT-TYPE
      SYNTAX      Counter32
"
With
"ituAlarmActiveStatsIndeterminates OBJECT-TYPE
      SYNTAX      ZeroBasedCounter32 "

"   ituAlarmActiveStatsCriticals OBJECT-TYPE
      SYNTAX      Counter32"
With
"   ituAlarmActiveStatsCriticals OBJECT-TYPE
      SYNTAX      ZeroBasedCounter32 "

"   ituAlarmActiveStatsMajors OBJECT-TYPE
      SYNTAX      Counter32"
With
"   ituAlarmActiveStatsMajors OBJECT-TYPE
      SYNTAX      ZeroBasedCounter32 "

"   ituAlarmActiveStatsMinors OBJECT-TYPE
      SYNTAX      Counter32"
With
"   ituAlarmActiveStatsMinors OBJECT-TYPE
      SYNTAX      ZeroBasedCounter32 "

"   ituAlarmActiveStatsWarnings OBJECT-TYPE
      SYNTAX      Counter32"
With
"   ituAlarmActiveStatsWarnings OBJECT-TYPE
      SYNTAX      ZeroBasedCounter32 "

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Thursday, October 02, 2003 10:54 PM
To: Disman (E-mail)
Subject: [Disman] zero-based counters in draft-ietf-disman-alarm-mib-15.txt?

Hi -

<[email-masked]>
...
...

---

From: "Sharon Chisholm" <[email-masked]>
Date: Fri, 10 Oct 2003 10:32:44 -0400

Hi

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Thursday, October 02, 2003 10:54 PM
To: Disman (E-mail)
Subject: [Disman] zero-based counters in draft-ietf-disman-alarm-mib-15.txt?

Hi -

<[email-masked]>
...
...