Subject: [Disman] Re: alarm MIB question...

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 14 Oct 2003 09:21:44 -0700

Hi -

> From: "David Partain (LM/EAB)" <[email-masked]>
> To: <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>
> Sent: Tuesday, October 14, 2003 4:10 AM
> Subject: alarm MIB question...
>

> Hi,
>
> Can you remind me of the reasoning behind including
> alarmActiveVariableOpaqueVal with a syntax of Opaque?
> Its inclusion violates RFC 2578: on page 24, section
> 7.1.9, it states: "The Opaque type is provided solely for
> backward-compatibility, and shall not be used for newly-defined
> object types."  Seems pretty clear to me.  Perhaps you're
> doing so in the name of backward-compatibility? Or are you just
> choosing to ignore this for the possibility there are enterprise
> MIBs that use Opaque for varbinds they sends in a notification?
>
> I think the document should clearly state that it violates
> the Standard but "we know and here's why".
>
> Cheers,
>
> David
>
> -- 
> Wireless Access Networks       E-mail:  [email-masked]
> Ericsson Research              Tel:  +46 13 28 41 44
> P.O. Box 1248                  Fax:  +46 13 28 75 67
> SE-581 12 Linköping, Sweden    http://linlab.ericsson.se/ietf

You're quite right, and we went through the same discussion during the
IESG review of the Log MIB.  Consequently, I agree that a note to the
effect of "we know and here's why" would save us some grief.  I
suggest the following words be added to the end of the DESCRIPTION
text for alarmActiveVariableOpaqueVal:

Note: although the SMI [RFC2578] forbids the use of Opaque in
'standard' MIB modules, this particular usage is driven by the
need to be able to accurately represent any well-formed notification,
and justified by the need for backward compatibility.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 14 Oct 2003 09:21:44 -0700

Hi -

Randy