Subject: RE: [Disman] ituAlarmGenericModel is redundant?

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 15 Oct 2003 13:14:55 -0400

Hi

The following is the proposed resolution to Randy-68. Assuming no objection,
this item will is closed with no changes to the draft.

ituAlarmGenericModel is useful, not redundant.

alarmModelTable has
	
      INDEX       { alarmListName, alarmModelIndex, alarmModelState }
      
ituAlarmTable has
	
      INDEX       { alarmListName, alarmModelIndex,
                   ituAlarmPerceivedSeverity }
      
Where alarmModelState != ituAlarmPerceivedSeverity 

You may be able to figure out which row in the alarmModelTable this refers
to but maintaining the pointer makes this much faster and reliable.

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Tuesday, October 07, 2003 3:25 PM
To: Disman (E-mail)
Subject: [Disman] ituAlarmGenericModel is redundant?

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: "Disman (E-mail)" <[email-masked]>
> Cc: <[email-masked]>; "Randy Presuhn" 
> <[email-masked]>; "Romascanu, Dan (Dan)"
<[email-masked]>
> Sent: Monday, September 29, 2003 7:34 AM
> Subject: [Disman] RE: Comments on draft-ietf-disman-alarm-mib-14.txt

...
> 68) ituAlarmGenericModel: why is this object needed? the indexing
>     information needed to find the model entry is the same for both
>     tables.
...

ituAlarmGenericModel seems comepletely redundant.
All the information needed to find the alarmModelEntry corresponding to an
ituAlarmEntry is already present in that entry's indexes.  This object
serves no purpose.

Proposal:  remove ituAlarmGenericModel.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 16 Oct 2003 09:17:57 -0700

Hi -

> Sent: Wednesday, October 15, 2003 10:14 AM
> Subject: RE: [Disman] ituAlarmGenericModel is redundant?
...
...

Ah.  Thank you.  The purpose of this object is to avoid having to scan the
alarmModelSpecificPointers for a given model to figure out the mapping.
Though I think that's kinda weak, I'm willing to accept the rationale.

HOWEVER,

Now I *really* want to know how these itu entries come into (and go out of)
existence as alarm models come and go.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 16 Oct 2003 09:17:57 -0700

Hi -

...
...

HOWEVER,

Randy