Subject: RE: [Disman] Section 5.1 in draft-ietf-disman-alarm-mib-15.txt

From: "Sharon Chisholm" <[email-masked]>
Date: Fri, 10 Oct 2003 14:59:18 -0400

Hi

For every A, there is a B. For every B there is an A. Therefore the # of A =
# of B. QED.

The number of itu active alarms is equal to the active alarms for the whole
system, if we define the whole system to be the whole alarm system.

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Wednesday, October 08, 2003 3:23 PM
To: Disman (E-mail)
Subject: Re: [Disman] Section 5.1 in draft-ietf-disman-alarm-mib-15.txt

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: "Disman (E-mail)" <[email-masked]>
> Cc: "Randy Presuhn" <[email-masked]>
> Sent: Wednesday, October 08, 2003 12:01 PM
> Subject: RE: [Disman] Section 5.1 in 
> draft-ietf-disman-alarm-mib-15.txt
>

> Hi
>
> The following is the proposed resolution to Randy-65. Assuming no 
> objection, this item will is closed with no changes to the draft.
>
> Section 4.1.1 says
>
> "The relationship between the Alarm MIB and the other alarm model MIB
>    modules is expressed by the following: The alarmModelTable has a
>    corresponding table in the specific MIB. For each row in the
>    specific MIB alarm model table there is one row in the
>    alarmModelTable."
>
> Therefore the distinction that Randy is making is a moot point.
...

I disagree.  The current text effectively says that for each entry in the
alarmModelTable there will be zero or one entries in any given specific MIB
alarm model table, though one might argue whether the limitations of
alarmModelSpecificPointer result in a total limit of
1:(0,1) or 1:(0,n) where n is the number of specific models possible.  So my
question still stands:

Are the numbers in ituAlarmActiveStatsTable for stuff modeled using the
ituAlarmTable, or for the whole system?

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 10 Oct 2003 20:50:32 -0700

Hi -

> Sent: Friday, October 10, 2003 11:59 AM
> Subject: RE: [Disman] Section 5.1 in draft-ietf-disman-alarm-mib-15.txt
>

...

Wrong.  The current language says for every B there is an A.  It does NOT
say that for every A there is a B.  Furthermore, if it did, then only ONE
extension MIB could exist in a system, due to the way
alarmModelSpecificPointer works.  If someone defined a DMTF-ALARM-MIB,
it could not under your reasoning exist in a system that also supported
the ITU alarm stuff.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 10 Oct 2003 20:50:32 -0700

Hi -

...

Randy