Subject: RE: [Disman] ituAlarmGenericModel is redundant?

From: "Sharon Chisholm" <[email-masked]>
Date: Sun, 19 Oct 2003 15:09:02 -0400

Hi

The following is the proposed resolution to Randy-68. Assuming no objection,
this item will is closed with no changes to the draft.

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Thursday, October 16, 2003 12:18 PM
To: Disman (E-mail)
Subject: Re: [Disman] ituAlarmGenericModel is redundant?

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: "Disman (E-mail)" <[email-masked]>
> Sent: Wednesday, October 15, 2003 10:14 AM
> Subject: RE: [Disman] ituAlarmGenericModel is redundant?
...
> The following is the proposed resolution to Randy-68. Assuming no 
> objection, this item will is closed with no changes to the draft.
>
> ituAlarmGenericModel is useful, not redundant.
>
> alarmModelTable has
>
>       INDEX       { alarmListName, alarmModelIndex, alarmModelState }
>
> ituAlarmTable has
>
>       INDEX       { alarmListName, alarmModelIndex,
>                    ituAlarmPerceivedSeverity }
>
> Where alarmModelState != ituAlarmPerceivedSeverity
>
> You may be able to figure out which row in the alarmModelTable this 
> refers to but maintaining the pointer makes this much faster and 
> reliable.
...

Ah.  Thank you.  The purpose of this object is to avoid having to scan the
alarmModelSpecificPointers for a given model to figure out the mapping.
Though I think that's kinda weak, I'm willing to accept the rationale.

HOWEVER,

Now I *really* want to know how these itu entries come into (and go out of)
existence as alarm models come and go.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 21 Oct 2003 17:53:27 -0700

Hi -

I think we'll need to keep this one open until we reach a conclusion on 69-1,
since the more recent proposals in that thread would change the underlying
assumptions about the relationship (or lack thereof) between alarmModelState
and ituAlarmPerceivedSeverity.  If for each ituAlarmPerceivedSeverity value
the corresponding alarmModelState ends up having the same value, then
ituAlarmGenericModel would end up being totally redundant.

Randy

> Sent: Sunday, October 19, 2003 12:09 PM

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 21 Oct 2003 17:53:27 -0700

Hi -

Randy