Subject: RE: [Disman] "table wrapping" in alarm MIB -15-

From: "Sharon Chisholm" <[email-masked]>
Date: Fri, 10 Oct 2003 14:18:12 -0400

Hi

The following is the proposed resolution to Randy-74-4. Assuming no
objection, this item will is closed with no changes to the draft.

In the definition of alarmActiveEntry is
"
          "Entries appear in this table when alarms are raised.  They
          are removed when the alarm is cleared."

One of the indices into this table is DataAndTime object. This table
therefore will not wrap, so discussing what happens when the table wraps
does not make sense. The statement that indicates that entries are removed
when the alarm is cleared implies that entries stay in the table while they
are active. End of story.

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Friday, October 03, 2003 1:31 AM
To: Disman (E-mail)
Subject: [Disman] "table wrapping" in alarm MIB -15-

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: "Disman (E-mail)" <[email-masked]>
> Cc: <[email-masked]>; "Randy Presuhn" 
> <[email-masked]>; "Romascanu, Dan (Dan)"
<[email-masked]>
> Sent: Monday, September 29, 2003 7:34 AM
> Subject: [Disman] RE: Comments on draft-ietf-disman-alarm-mib-14.txt
...

...
> 75-4) I missed anything like an "alarmActiveMaximum", yet the document 
> doesn't seem to describe what should happen if there are too many 
> active alarms, as might happen if there are lots of instances of a 
> particular type of resource, and an administrator inadvertently 
> specifies a frequent, innocuous event as being of interest.
>
> Sharon->The design was normal table wrapping
...

What is "normal table wrapping"?  This is a new one for me.
The document still needs to specify what happens.  For example, if the alarm
raise is lost, will the clear also be siletly suppressed? Even with
frequency throttling in place, if alarms are sufficiently long lived there
may still accumulate a very large number of them.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 10 Oct 2003 21:03:22 -0700

Hi -

> Sent: Friday, October 10, 2003 11:18 AM
> Subject: RE: [Disman] "table wrapping" in alarm MIB -15-
...
...

...

The issue still stands.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 10 Oct 2003 21:03:22 -0700

Hi -

...
...

...

The issue still stands.

Randy