Subject: RE: [Disman] alarmModelRowStatus

From: "Sharon Chisholm" <[email-masked]>
Date: Fri, 3 Oct 2003 16:10:55 -0400

Hi

We have a proposed resolution to Randy-49 - since all objects in the table
have default values, no further changes are required.

Objections?

Sharon

-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Thursday, October 02, 2003 3:51 AM
To: Randy Presuhn; Disman (E-mail)
Subject: RE: [Disman] alarmModelRowStatus

> > 49) alarmModelRowStatus should spell out that the
> >     alarmModelVarbindIndex and alarmModelVarbindValue
> >     MUST be set before row can go active.
> >
> > Sharon-> I've fixed this another way.
> ...
> 
> AlarmModelRowStatus *still* needs to spell out what objects
> are necessary
> for the row to be activated.  See
> http://www.ietf.org/internet-drafts/draft-ietf-ops-mib-review-
> guidelines-02.txt
> 
> 
>      - The DESCRIPTION clause of the status column MUST specify which
>        columnar objects (if any) have to be set to valid values before
>        the row can be activated.  If any objects in cascading tables
>        have to be populated with related data before the row can be
>        activated, then this MUST also be specified.
> 
> 
> Randy
> 

Actually all read-create objects have a DEFVAL clause. If one would create a
row without setting any of them, no harm would happen, other than a useless
row being created. Do we need to say in this case that 'syntactically you
can do it, bit it would be a loss of time'?

Dan

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 3 Oct 2003 19:40:19 -0700

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: "Disman (E-mail)" <[email-masked]>
> Cc: "Romascanu, Dan (Dan)" <[email-masked]>; "Randy Presuhn" <[email-masked]>
> Sent: Friday, October 03, 2003 1:10 PM
...
...

Yes.  As MIB reviewer, I must point out yet again that the
MIB review guidelines require us to specify "which columnar objects
(if any) have to be set."  Dan's comments (or something to similar
effect) need to be reflected in the DESCRIPTION.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 3 Oct 2003 19:40:19 -0700

Hi -

...
...

Randy