Subject: RE: [Disman] ituAlarmGenericModel is redundant?

From: "Sharon Chisholm" <[email-masked]>
Date: Fri, 24 Oct 2003 15:05:03 -0400

Hi

Well, the object may be redundant but technically it's not really a
duplicate. It's a reasonable compromise though. Documenting that technically
this information could be derived from other sources is reasonable and may
be helpful for people less familiar with SNMP. Most of my complaints of the
"efficiencies" we do in SNMP is that they are often at the expense of the
understanding of less experienced users.

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Thursday, October 23, 2003 2:01 PM
To: Disman (E-mail)
Subject: Re: [Disman] ituAlarmGenericModel is redundant?

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: "Disman (E-mail)" <[email-masked]>
> Sent: Wednesday, October 22, 2003 6:57 AM
> Subject: RE: [Disman] ituAlarmGenericModel is redundant?
...
> It's a useful object. The working felt it was a useful object. I think 
> it's a useful object. We've never claimed that there wasn't another 
> means to get this mapping. Why are we suddenly deciding we don't want 
> this object?
...

Redundant objects have long been discouraged.  If you believe that there is
overwhelming support to retain it, then I suggest we follow Bert's advice
from the Mreview mailing list:

| In general I discuourage people to create redundant MIB objects. But 
| ... if they have good reasons, I think we should try to understand 
| them and make them document it in the MIB documents, preferebaly in 
| the "duplicate" object DESCRIPTION clause.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 24 Oct 2003 15:48:17 -0700

Hi -

> Sent: Friday, October 24, 2003 12:05 PM
..
...

Ok, so If I understand the latest proposal for mapping between
ITU and generic alarm models, then for a given instance
{ ituAlarmGenericModel x y z }, its value will always be
{ alarmModelNotificationId x y z}, where "x" is the length and value of the
list name, "y" is the integer index, and "z" is the severity level.
Did I get it right?
If this is how it's supposed to work, we just need to explain in the
description how this adds value.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 24 Oct 2003 15:48:17 -0700

Hi -

..
...

Randy