Subject: RE: [Disman] "table wrapping" in alarm MIB -15-

From: "Sharon Chisholm" <[email-masked]>
Date: Sat, 18 Oct 2003 19:21:04 -0400

Hi

Ok. I don't understand your issue. There is no maximum because alarms MUST
stay in the table while they are active. There is no wrapping because one of
the indices is DataAndTime so therefore always increasing (unless I'm
missing something).

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Saturday, October 11, 2003 12:03 AM
To: Disman (E-mail)
Subject: Re: [Disman] "table wrapping" in alarm MIB -15-

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: "Disman (E-mail)" <[email-masked]>
> Sent: Friday, October 10, 2003 11:18 AM
> Subject: RE: [Disman] "table wrapping" in alarm MIB -15-
...
> The following is the proposed resolution to Randy-74-4. Assuming no 
> objection, this item will is closed with no changes to the draft.
>
> In the definition of alarmActiveEntry is
> "
>           "Entries appear in this table when alarms are raised.  They
>           are removed when the alarm is cleared."
>
> One of the indices into this table is DataAndTime object. This table 
> therefore will not wrap, so discussing what happens when the table 
> wraps does not make sense. The statement that indicates that entries 
> are removed when the alarm is cleared implies that entries stay in the 
> table while they are active. End of story.
...

Sorry, it's not.  Please re-read my original comment:

> > 75-4) I missed anything like an "alarmActiveMaximum", yet the 
> > document doesn't seem to describe what should happen if there are 
> > too many active alarms, as might happen if there are lots of 
> > instances of a particular type of resource, and an administrator 
> > inadvertently specifies a frequent, innocuous event as being of 
> > interest.
...

The issue still stands.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 21 Oct 2003 18:45:22 -0700

Hi -

> Sent: Saturday, October 18, 2003 4:21 PM

...

Now let's finish the thought:

Storage is finite.  When the number of active alarms would cause available
storage to be exceeded, X happens.  What is X?

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 21 Oct 2003 18:45:22 -0700

Hi -

...

Randy