Subject: RE: [Disman] alarmActiveContextName in draft-ietf-disman-alarm-mib-15.txt

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 2 Oct 2003 10:55:32 +0300

> > 59) alarmActiveContextName: this is defined to be an 
> SnmpAdminString.
> >     This is fine for the case where its value is a context name.
> >     However, in the case where it is a community, provision needs
> >     to be made for the possibility that the community name would not
> >     be a well-formed SnmpAdminString.  (for example, 0xFF would be
> >     a legal community, but would violate the rules for UTF-8.)
> >     ditto alarmClearContextName
> ...
> 
> I think this probalem hasn't been addressed.
> The current text says:
> 
>    alarmClearContextName OBJECT-TYPE
>       SYNTAX      SnmpAdminString (SIZE(0..32))
>       MAX-ACCESS  read-only
>       STATUS      current
>       DESCRIPTION
>           "The name of the SNMP MIB context from which the alarm came.
>           For SNMPv1 traps this is the community string from the Trap.
>           Note that care needs to be taken when selecting community
>           strings to ensure that these can be represented as a
>           well-formed SnmpAdminString.
> 
> If an SNMPv1 trap had a community string with a value of 0xFF,
> what value would the corresponding instance of this object have?
> The alarm MIB implementation has no control over the community
> strings it might encounter.
> 
>           If the alarm's source SNMP engine is known not to support
>           multiple contexts, this object is a zero length string."
>       ::= { alarmClearEntry 6 }
> 
> 
> Is this intended to be a MUST or a MAY?
> 
> Randy

The solution is to make the text crisper that community strings can be represented. This means a couple of MUSTs in the two places quoted by Randy.

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 2 Oct 2003 09:38:29 -0700

Hi -

> From: "Romascanu, Dan (Dan)" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "Disman (E-mail)" <[email-masked]>
> Sent: Thursday, October 02, 2003 12:55 AM
> Subject: RE: [Disman] alarmActiveContextName in draft-ietf-disman-alarm-mib-15.txt
...

...
...

I think this does not solve the problems.
In the first case, adding a "MUST" to

>           well-formed SnmpAdminString.

still doesn't tell us what a system is supposed to do when its handling
a trap with a community string of, say, 0xff.

In the second case,
>           multiple contexts, this object is a zero length string."

how is an implementation supposed to know whether a given source
doesn't support multiple contexts?  For example, in AgentX and
SMUX protocols, there is no registration mechanism for notifications,
so a master agent has no way of knowing in advance whether it will
receive notifications from multiple contexts or not.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 2 Oct 2003 09:38:29 -0700

Hi -

...

...
...

In the second case,

Randy