Subject: RE: [Disman] (not) supporting multiple extensions via alarmModelS pecificPointer

From: "Sharon Chisholm" <[email-masked]>
Date: Fri, 3 Oct 2003 15:46:12 -0400

Hi

Without further object then, I will consider Randy-33 closed

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Wednesday, October 01, 2003 6:57 PM
To: Disman (E-mail)
Subject: [Disman] (not) supporting multiple extensions via
alarmModelSpecificPointer

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: "Disman (E-mail)" <[email-masked]>
> Cc: <[email-masked]>; "Randy Presuhn" 
> <[email-masked]>; "Romascanu, Dan (Dan)"
<[email-masked]>
> Sent: Monday, September 29, 2003 7:34 AM
> Subject: [Disman] RE: Comments on draft-ietf-disman-alarm-mib-14.txt

...
> 33) Section 4.1.1: one consequence of this approach is that
>     one cannot use multiple extensions for a single alarm.
>     So, for example, one couldn't make an extension to the
>     ITU Alarm MIB and have it work using the method described here.
>     This may be the intent, but it would be good to be explicit about 
> it.
...

The -15- text for section 4.1.1 still doesn't really acknowledge the
inherent limitation of alarmModelSpecificPointer.  Its syntax limits it to
referring to a single extension.  If one were to define another MIB
containing a table augmenting the ITU alarm stuff, the value of
alarmModelSpecificPointer would still presumably point to the ITU alarm
stuff rather than the augmentation, so a management station would be left to
grope around for this (and any other second-
level) extensions.  I'm *not* proposing that we change the design. I was
(and still am) concerned as a technical contributor that we be upfront about
the (perhaps theoretical) design limitation.

If no one else cares about this, as WG chair I'm willing to let it go as is.
but as a technical contributor I wanted to be sure that folks understood why
I'm not 100% happy with the revised text here.

Randy

Randy

---

From: "Sharon Chisholm" <[email-masked]>
Date: Fri, 3 Oct 2003 15:46:12 -0400

Hi

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Wednesday, October 01, 2003 6:57 PM
To: Disman (E-mail)
Subject: [Disman] (not) supporting multiple extensions via

Hi -

<[email-masked]>

...
...

Randy

Randy