Subject: RE: [Disman] changes to ping MIB conformance material

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 6 Oct 2004 12:56:47 +0200

> On Tue, Oct 05, 2004 at 05:58:35PM -0700, Randy Presuhn wrote:
>  
> > Merging in another implementation report on the DISMAN-PING-MIB
> > module has left me wondering whether it was a good idea to remove
> > the pingCompliance and pingGroup OBJECT-GROUP.  I find that I
> > have to go back to RFC 2925 to make sense of implementation reports,
> > and that when someone says they implement the pingGroup, that
> > has no meaning in terms of the current i-d.  This doesn't 
> seem right.
> 
> FWIW, smidiff flags the removal as serious errors:
> 
> DISMAN-PING-MIB:1118 [1] group `pingGroup' has been deleted
> DISMAN-PING-MIB:1163 [1] group `pingTimeStampGroup' has been deleted
> DISMAN-PING-MIB:1017 [1] compliance `pingCompliance' has been deleted
> 
> You can deprecate or obsolete things, but not remove things since other
> definitions might depend on things (e.g. agent capability statements).
> 

Exactly. When advancing from PS to DS (or recycling at PS), it is allowed
to "remove" things. But for our MIB modules, that "remove" should indeed
be translated into "deprecate" or "obsolete".

The old compliance statement(s) should also be deprecated/obsoleted and
new ones should be defined that no longer have the depreacted/obsoleted
groups present.

Bert
> /js
> 
> -- 
> Juergen Schoenwaelder		    International University Bremen
> <http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 
> 28725 Bremen, Germany
>

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 06 Oct 2004 17:47:27 +0200

> new ones should be defined that no longer have the depreacted/obsoleted

OK, I will insert the old groups and the compliance statements for all
three MIB modules.

As their new status I prefer "deprecated".  Any objections?

    Juergen
-- 
Juergen Quittek        [email-masked]       Tel: +49 6221 90511-15
NEC Europe Ltd.,       Network Laboratories        Fax: +49 6221 90511-55
Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.netlab.nec.de

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 6 Oct 2004 10:30:46 -0700

Hi -

> From: "Juergen Quittek" <[email-masked]>
> To: "Wijnen, Bert (Bert)" <[email-masked]>; <[email-masked]>; "Randy Presuhn" <[email-masked]>
> Cc: "Disman (E-mail)" <[email-masked]>
> Sent: Wednesday, October 06, 2004 8:47 AM
> Subject: RE: [Disman] changes to ping MIB conformance material
...
> As their new status I prefer "deprecated".  Any objections?
...

I understand why the new "minimal conformance" material was added.
Could someone remind me why the old material would need to
be deprecated?

Randy

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 07 Oct 2004 01:43:07 +0200

Randy,

> Could someone remind me why the old material would need to

You'll find the discussion in the messages we exchanged on the
list in early July.

We split the pingGroup into the pingMinimumGroup and the
pingCtlRowStatusGroup, because we wanted to have the
pingCtlRowStatus optional in the minimumCompliancy.

Furthermore, we had different compliancy constraints for
the two members pingResultsLastGoodProbe and
pingProbeHistoryTime of the pingTimeStampGroup and gave up
this group.

In order to use the same groups in both compliancy
statements (full and minimum), we replaced pingCompliancy
by pingFullCompliancy.  This lead to a clean definition,
but probably it is not good considering the existing
implementations referencing RFC 2925.

pingCompliancy and pingFullCompliancy are semantically almost
identical. The only difference concerns object
pingProbeHistoryTime.

We could also stick with the compliancy definitions of RFC 2925
and use different groups for the new minimumCompliancy.

    Juergen