Subject: Re: [Disman] Problem advancing remote operations

From: Juergen Quittek <[email-masked]>
Date: Tue, 05 Oct 2004 17:49:04 +0200

Randy,

I also have a clear preference for option 1.

    Juergen
-- 
Juergen Quittek        [email-masked]       Tel: +49 6221 90511-15
NEC Europe Ltd.,       Network Laboratories        Fax: +49 6221 90511-55
Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.netlab.nec.de

--On 29.09.2004 15:29 Uhr -0700 Randy Presuhn wrote:

> Hi -
>
> I've merged the information from the various implementation reports
> in preparation for requesting advancement to Draft Standard.  There's
> just one little problem: I can find only one implementation report for
> the DISMAN-NSLOOKUP-MIB module.  As I see it, we have a few options.
>
>     1 Give draft-ietf-disman-remops-mib-v2-04.txt to our AD now,
>        recomending cycling at Proposed Standard, and, if another implementation
>        report shows up, ask the IESG to advance it to Draft Standard without
>        issuing a new RFC.
>
>     2 Wait until another DISMAN-NSLOOKUP-MIB implementation report
>       shows up, and then hand draft-ietf-disman-remops-mib-v2-04.txt
>       to our AD to take to the IESG for consideration as Draft Standard.
>
>     3 Remove DISMAN-NSLOOKUP-MIB from the document, and request that
>        the updated document be advanced.  Put the lookup MIB into a new
>        document, requesting that it start out at Proposed Standard.
>
> My personal preference would be option (1), but I'd like to hear from the
> rest of the WG before proceding.
>
> Please check the combined implementation report for errors or omissions.
> (Best displayed using a monospace font.)  I'm really surprised that only one
> implementation report for DISMAN-NSLOOKUP-MIB has shown up.
>
> Randy
> ======================================================
>
>
> Implementation |  Submitted By   |         Submitter's        |
>      Report    |                 |           Address          |
> ---------------+-----------------+----------------------------+
>         B      | J. Chen         | [email-masked]       |
>         R      | Govind Haridass | [email-masked] |
>         J      | Daniel Chuang   | [email-masked]        |
>
>
> Report | Implementation Source
> -------+-------------------------------------------------------
>    B   | Beijing University of Posts and Telecommunications
>        | Network Information Center
>    J   | Juniper
>    R   | SNMP Research
>
>
> Module: DISMAN-PING-MIB
>
> Groups                 | Implementation |
> Implemented            | B  |  J  |  R  |
> -----------------------+----+-----+-----+
> pingGroup              |  y |  y  |  y  |
> pingNotificationsGroup |  y |  y  |  y  |
> pingTimeStampGroup     |  y |  y  |  y  |
>
>
> There were reports on three independent implementations, and all
> supported all three object groups in this MIB module.  Additional
> details on the individual objects implemented:
>
> OBJECT-TYPE                    | Implementation |
> access supported               | B  |  J  |  R  |
> -------------------------------+----+-----+-----+
> pingMaxConcurrentRequests      | -  | rw  | rw  |
> pingCtlStorageType             | rw | rw  | rw  |
> pingCtlType                    | rw | rw  | rw  |
> pingCtlByPassRouteTable        | rw | rw  | rw  |
> pingCtlSourceAddressType       | rw | rw  | rw  |
>             unknown            | n  | y   | n   |
>             ipv4               | n  | y   | y   |
>             ipv6               | n  | n   | n   |
> pingCtlSourceAddress           | rw | rw  | rw  |
> pingCtlIfIndex                 | rw | rw  | rw  |
> pingCtlDSField                 | rw | rw  | rw  |
> pingResultsIpTargetAddressType | ro | ro  | ro  |
>             unknown            | y  | y   | n   |
>             ipv4               | y  | y   | y   |
>             ipv6               | y  | n   | n   |
> pingResultsIpTargetAddress     | ro | ro  | ro  |
>      0                         | y  | y   |     |
>      4                         | y  | y   |     |
>      16                        | y  | n   |     |
>
>
>
>
> Module: DISMAN-TRACEROUTE-MIB
>
> There were reports on three independent implementations of
> the DISMAN-TRACROUTE-MIB, and all three supported all four
> groups.
>
> Groups                       | Implementation |
> Implemented                  | B  |  J  |  R  |
> -----------------------------+----+-----+-----+
> traceRouteGroup              | y  |  Y  |  Y  |
> traceRouteTimeStampGroup     | y  |  Y  |  Y  |
> traceRouteNotificationsGroup | y  |  Y  |  Y  |
> traceRouteHopsTableGroup     | y  |  Y  |  Y  |
>
>
> Additional details on support of specific OBJECT-TYPES:
>
> OBJECT-TYPE                     | Implementation |
> access supported                | B  |  J  |  R  |
> --------------------------------+----+-----+-----+
> traceRouteMaxConcurrentRequests | -  | rw  | rw  |
> traceRouteCtlByPassRouteTable   | rw | rw  | rw  |
> traceRouteCtlSourceAddressType  | rw | rw  | rw  |
> traceRouteCtlSourceAddress      | rw | rw  | rw  |
> traceRouteCtlIfIndex            | rw | rw  | rw  |
> traceRouteCtlMiscOptions        | rw | rw  | ro  |
> traceRouteCtlStorageType        | rw | rw  | rw  |
> traceRouteCtlDSField            | rw | rw  | rw  |
> traceRouteCtlType               | rw | rw  | rw  |
> traceRouteResultsIpTgtAddrType  |    |     |     |
>         unknown                 | y  | y   | n   |
>         ipv4                    | y  | y   | y   |
>         ipv6                    | y  | n   | n   |
> traceRouteResultsIpTgtAddr      |    |     |     |
>         0                       | y  | y   |     |
>         4                       | y  | y   |     |
>         16                      | y  | n   |     |
> traceRouteProbeHistoryHAddrType |    |     |     |
>         unknown                 | y  | y   | n   |
>         ipv4                    | y  | y   | y   |
>         ipv6                    | y  | n   | n   |
> traceRouteProbeHistoryHAddr     |    |     |     |
>         0                       | y  | y   |     |
>         4                       | y  | y   |     |
>         16                      | y  | n   |     |
> traceRouteHopsIpTgtAddressType  |    |     |     |
>         unknown                 | y  | y   | n   |
>         ipv4                    | y  | y   | n   |
>         ipv6                    | y  | n   | n   |
> traceRouteHopsIpTgtAddress      |    |     |     |
>         0                       | y  | y   |     |
>         4                       | y  | y   |     |
>         16                      | y  | n   |     |
>
>
> Module: DISMAN-NSLOOKUP-MIB
>
>
> There was one report of implementations of the DISMAN-NSLOOKUP-MIB
> module.  It implemented the mandatory object group.
>
>
> Groups                       | Implementation |
> Implemented                  |       B        |
> -----------------------------+----------------+
> lookupGroup                  |       y        |
>
>
> Additional details on support of specific OBJECT-TYPES:
>
> OBJECT-TYPE                     | Implementation      |
> access supported                |       B             |
> --------------------------------+---------------------+
> lookupMaxConcurrentRequests     | n (not implemented?)
> lookupPurgeTime                 | n (not implemented?)
> lookupCtlTargetAddressType      |
>       ipv4                      |       y
>       ipv6                      |       y
>       dns                       |       y
> lookupCtlTargetAddress          |
>       ipv4                      |       y
>       ipv6                      |       y
>       dns                       |       y
> lookupResultsAddressType        |
>       ipv4                      |       y
>       ipv6                      |       y
>       dns                       |       y
> lookupResultsAddress            |
>       ipv4                      |       y
>       ipv6                      |       y
>       dns                       |       y
>
>
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 5 Oct 2004 13:31:15 -0700

Hi Bert -

In preparation for advancing the disman Remote Operations MIB
modules to Draft Standard, here are implementation reports for the
DISMAN-PING-MIB, the DISMAN-TRACROUTE-MIB, and the
DISMAN-NSLOOKUP-MIB.  There were at least two independent
implementations of each of these.  There was at least
one freely-available implementation ("B") for all
three MIB modules.

        E      | John Scano      | [email-masked]         |

Note that "E" and "J" were done by different groups at
Juniper, and were reported separately.

   E   | Juniper (E-Series routers)
   J   | Juniper
   R   | SNMP Research

Module: DISMAN-PING-MIB

There were two reports of implementations of the
DISMAN-NSLOOKUP-MIB module.  Both implemented the
mandatory object group for lookupCompliance, which
is a superset of the lookupMinimumComplaince.

Implemented                  |   B   |   E    |
lookupGroup                  |   y   |   y    |

OBJECT-TYPE                     | Implementation |
access supported                |   B     |  E   |
--------------------------------+---------+------+
lookupMaxConcurrentRequests     | n (?)   |  y   |
lookupPurgeTime                 | n (?)   |  y   |
lookupCtlTargetAddressType      |         |      |
      ipv4                      |   y     |  y   |
      ipv6                      |   y     |  y   |
      dns                       |   y     |  y   |
lookupCtlTargetAddress          |         |      |
      ipv4                      |   y     |  y   |
      ipv6                      |   y     |  y   |
      dns                       |   y     |  y   |
lookupResultsAddressType        |         |      |
      ipv4                      |   y     |  y   |
      ipv6                      |   y     |  y   |
      dns                       |   y     |  y   |
lookupResultsAddress            |         |      |
      ipv4                      |   y     |  y   |
      ipv6                      |   y     |  y   |
      dns                       |   y     |  y   |