Subject: RE: [Disman] Fw: MIB Doctor review: publishdraft-ietf-disman-remops-mib-v2-06.tx t

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Wed, 4 May 2005 14:11:03 +0300

I agree with Juergen on this one.Tracepath information, even if read-only, is considered to be privacy sensitive in many environments. 

To quote from http://www.ietf.org/internet-drafts/draft-ietf-ops-mib-review-guidelines-04.txt, Section 3.4:

  Each specification that defines one or more MIB modules MUST contain
   a section that discusses security considerations relevant to those
   modules.  This section MUST be patterned after the latest approved
   template (available at http://www.ops.ietf.org/mib-security.html).
   In particular, writeable MIB objects that could be especially
   disruptive if abused MUST be explicitly listed by name and the
   associated security risks MUST be spelled out;  similarly, readable
   MIB objects that contain especially sensitive information or that
   raise significant privacy concerns MUST be explicitly listed by name
   and the reasons for the sensitivity/privacy concerns MUST be
   explained.  

It looks like this is one of the cases where the objects 'MUST be explicitly listed by name and the reasons for the sensitivity/privacy concerns MUST be explained.'  

Regards,

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of Randy Presuhn
> Sent: 04 May, 2005 6:56 AM
> To: Disman
> Subject: [Disman] Fw: MIB Doctor review: 
> publishdraft-ietf-disman-remops-mib-v2-06.tx t
> 
> 
> Hi -
> 
> Forwarded for your information.
> 
> Randy
> 
> ----- Original Message ----- 
> > From: "Juergen Schoenwaelder" <[email-masked]>

....

> >
> > 5.  Security Considerations
> >
> > - The following is stated:
> >
> >    However, the only information that might be
> >    disclosed is the configuration and results of 
> measurements that are
> >    performed by implementations of the MIB modules.  This 
> information
> >    can only be mis-used in conjunction with the mis-use of further
> >    information.
> >
> >   I am not sure what the last sentence hints at. It sounds 
> like it is
> >   trying to make this less a security problem. Note sure 
> this is true.
> >   Tracepaths reveals information about paths which some 
> people tend to
> >   block (actually becoming more and more popular in enterprise
> >   networks it seems).
> >
> >
> > -- 
> > Juergen Schoenwaelder     International University Bremen
> > <http://www.eecs.iu-bremen.de/>     P.O. Box 750 561, 28725 
> Bremen, Germany
> 
> 
> 
> 
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 4 May 2005 17:28:07 -0700

Hi -

We've heard from Dan Romascanu agreeing with the comment on the sensitivity
of traceroute logs.  We should have caught that one ourselves.

Does anyone on this mailing list *disagree* with any of Jürgen Schönwälder's
review comments, or have specific proposals for handling any of them?
If not, then I'll just ask the editor (Jürgen Quittek) to make a best-effort
attempt to address the comments, and post an updated i-d.

Randy, disman WG chair

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 05 May 2005 21:56:34 +0200

Randy,

I agree with most of Juergen's suggestions.  But he also has some issues that he
wants to discuss.  As he suggested, I will try to have this discussion with him
first on the phone in the next days.  If we cannot solve the issues we will post
them on the list.

Thanks,

    Juergen Q.
-- 
Juergen Quittek        [email-masked]       Tel: +49 6221 90511-15
NEC Europe Ltd.,       Network Laboratories        Fax: +49 6221 90511-55
Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.netlab.nec.de

--On 5/4/2005 5:28 PM -0700 Randy Presuhn wrote:

> Does anyone on this mailing list *disagree* with any of J¸rgen Sch?nw?lder's
> If not, then I'll just ask the editor (J¸rgen Quittek) to make a best-effort

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 13 May 2005 17:26:30 -0700

Hi -

> From: "Juergen Quittek" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "Disman" <[email-masked]>
> Sent: Thursday, May 05, 2005 12:56 PM
> Subject: Re: [Disman] Fw: MIB Doctor review: publishdraft-ietf-disman-remops-mib-v2-06.tx t
...
> first on the phone in the next days.  If we cannot solve the issues we will post
...

Ok.  Also, please post a brief summary of any agreed changes to the WG
mailing list.  That way, if anyone has a problem with a resolution, they'll
have a chance to speak up before the update appears.

Randy