Subject: Re: [Diversity] year for highest number of IETF participants

From: Aaron Yi DING <[email-masked]>
Date: Tue, 08 Oct 2013 14:51:01 +0100

Hi Adrian,

True, that also puzzled me a bit since the numbers do not match, 
registration and attendee - the registration number is in general higher 
than that of attendees.

Cheers,
Aaron

On 08/10/13 13:51, Adrian Farrel wrote:
> Curiously these numbers do not match those at
> https://www.ietf.org/meeting/past.html
> 
> Registration, we may conclude, does not equate to attendance.
> 
> Adrian
> 
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf 
>> Of Joe
>> Abley
>> Sent: 08 October 2013 02:38
>> To: Ted Lemon
>> Cc: [email-masked]; IETF
>> Subject: Re: year for highest number of IETF participants
>> 
>> [krill:~]% for n in $(jot 15 73); do
>> curl -s "https://www.ietf.org/registration/ietf${n}/attendance.py" | \
>>   awk -v n=${n} '/ registrations:/ { sub(/ registrations:.*$/, "");
> sub(/^.*\>/, "");
>> print n, $0; }'
>> done
>> 73 1111
>> 74 1332
>> 75 1230
>> 76 1249
>> 77 1350
>> 78 1304
>> 79 1337
>> 80 1317
>> 81 1244
>> 82 1051
>> 83 1529
>> 84 1356
>> 85 1351
>> 86 1223
>> 87 1585
>> [krill:~]%
> 
> _______________________________________________
> diversity mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/diversity

---

From: Aaron Yi DING <[email-masked]>
Date: Tue, 08 Oct 2013 14:56:07 +0100

The registration number may include remote participants while attendee 
number shows how many actually went on-site.

Cheers,
Aaron

On 08/10/13 14:06, Richard Barnes wrote:
> Indeed, the number Joe was counting was the number who filled out a 
> registration form.  Counting those who actually paid their registration 
> yields closer numbers.
> rbarnes$ for n in $(jot 15 73); do
> att=$(curl -s 
> "https://www.ietf.org/registration/ietf${n}/attendance.py" | grep -o 
> ">Yes<" | wc -l);
> echo $n $att;
> done
> 73 969
> 74 1170
> 75 1102
> 76 1129
> 77 1242
> 78 1159
> 79 1144
> 80 1231
> 81 1127
> 82 948
> 83 1395
> 84 1199
> 85 1157
> 86 1115
> 87 1435
> 
> 
> On Tue, Oct 8, 2013 at 8:51 AM, Adrian Farrel <[email-masked]> 
> wrote:
> 
>     > From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Joe
>     > Abley
>     > curl -s 
> "https://www.ietf.org/registration/ietf${n}/attendance.py" | \