Subject: [Diversity] Working with Universities

From: "Moriarty, Kathleen" <[email-masked]>
Date: Mon, 7 Oct 2013 08:57:41 -0400

Hello,

I had the opportunity to assist ISOC and represent women in the IETF at the Grace Hopper Celebration last week.  This is a conference and recruiting fair for women in Computer Science.   After talking to numerous young women in school and some professors there seemed to be some unique opportunities we could work with to get them involved in IETF work before they graduate.

Many working groups have opportunities for software development.  Students have projects where they need to code.  If we were to create a site that enabled easy access for students to identify coding opportunities that could potentially live on beyond their project, we may get valuable input.  A listing of working groups matched with existing implementations or a listing of what is needed would make it easier for students to see where they could help (jumping into something brand new to them).  We could make this compelling for them and get interoperability testing feedback as a great way to have them be able to provide meaningful comments on list.

Right now, many of use non-IETF sites to track implementations, but this does not show the obvious connection of IETF standards work to the growing open source movement.  I think we could greatly benefit from showing that relationship.  For some students, they may be able to participate in interoperability testing.  This could be great for job interviews where they can say they tested their open source code against an implementation from X company and provided solid feedback to the working group to improve the interoperability of the protocol in development.

Since we are just tracking what has been done (and on numerous sites), we are not making it easy for students to find opportunities where they could help.  A match-up web site pulling this all together could be helpful.  Working groups could also identify opportunities where they want help.  Students could then look at each of those WGs and see what interests them most.  I talked to a professor in Chili who may start doing this with her students.  Making this easier could really expand this involvement and get them used to talking on mailing lists in a way that lets them feel like they are providing solid contributions.  Some people shy away from contributing otherwise.

Is this something we think could be set up, some sort of match-up for working groups and development opportunities?

Thanks,
Kathleen

---

From: Vinayak Hegde <[email-masked]>
Date: Mon, 7 Oct 2013 19:04:27 +0530

On Mon, Oct 7, 2013 at 6:27 PM, Moriarty, Kathleen <
[email-masked]> wrote:
[snipped]

> Right now, many of use non-IETF sites to track implementations, but this
> does not show the obvious connection of IETF standards work to the growing
> open source movement.  I think we could greatly benefit from showing that
> relationship.  For some students, they may be able to participate in
> interoperability testing.  This could be great for job interviews where
> they can say they tested their open source code against an implementation
> from X company and provided solid feedback to the working group to improve
> the interoperability of the protocol in development.****
>
> ** **
>
> Since we are just tracking what has been done (and on numerous sites), we
> are not making it easy for students to find opportunities where they could
> help.  A match-up web site pulling this all together could be helpful.
> Working groups could also identify opportunities where they want help.
> Students could then look at each of those WGs and see what interests them
> most.  I talked to a professor in Chili who may start doing this with her
> students.  Making this easier could really expand this involvement and get
> them used to talking on mailing lists in a way that lets them feel like
> they are providing solid contributions.  Some people shy away from
> contributing otherwise.****
>
> ** **
>
> Is this something we think could be set up, some sort of match-up for
> working groups and development opportunities?
>

I think this is a great idea. I think there are a number of groups that are
testing implementations for eg. http/2.0
https://github.com/http2 and https://github.com/molnarg/node-http2

Is there some sort of a wiki which people can join and update it would be
really useful not only to women but all people who are interested in
participating in the IETF. Another suggestion would be to have a column
with email addresses of people who are happy to hand-hold others to
contribute code to implementations or help test on varied platforms. That
would really help. It would be like GSoC (without the funding)(
https://developers.google.com/open-source/soc/)

-- Vinayak

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Mon, 7 Oct 2013 09:44:50 -0400

Would the tools wiki be the right place and then we figure out how to get it promoted to universities and open source communities?  I am not sure what the right answer is, but copying Henrik in case that is a good answer.

Thanks,
Kathleen

From: Vinayak Hegde [mailto:[email-masked]]
Sent: Monday, October 07, 2013 9:34 AM
To: Moriarty, Kathleen
Cc: [email-masked]; [email-masked]
Subject: Re: [Diversity] Working with Universities

On Mon, Oct 7, 2013 at 6:27 PM, Moriarty, Kathleen <[email-masked]<mailto:[email-masked]>> wrote:
[snipped]
Right now, many of use non-IETF sites to track implementations, but this does not show the obvious connection of IETF standards work to the growing open source movement.  I think we could greatly benefit from showing that relationship.  For some students, they may be able to participate in interoperability testing.  This could be great for job interviews where they can say they tested their open source code against an implementation from X company and provided solid feedback to the working group to improve the interoperability of the protocol in development.

I think this is a great idea. I think there are a number of groups that are testing implementations for eg. http/2.0
https://github.com/http2 and https://github.com/molnarg/node-http2
Is there some sort of a wiki which people can join and update it would be really useful not only to women but all people who are interested in participating in the IETF. Another suggestion would be to have a column with email addresses of people who are happy to hand-hold others to contribute code to implementations or help test on varied platforms. That would really help. It would be like GSoC (without the funding)(https://developers.google.com/open-source/soc/)

-- Vinayak

---

From: Arturo Servin <[email-masked]>
Date: Mon, 07 Oct 2013 11:55:49 -0200

I think is a great idea.

    There are various ways that occurs to me in how to implement it
(they could be all of them), a special wiki is one, a new section in the
IETF page, and links from the WG pages to the developments requests.

Regards,
as
   
> Hello,
<snip>
> _______________________________________________
> diversity-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/diversity-dt

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 07 Oct 2013 14:58:25 +0100

And suck in drafts with an RFC 6982 implementation status
section too. If lots of drafts had those, then a tools
based solution might be simple enough.

S.

On 10/07/2013 02:55 PM, Arturo Servin wrote:
> diversity mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/diversity
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 7 Oct 2013 15:10:57 +0100

Yaron [added to this thread] and I had been considering setting up a wiki for
tracking 6982 implementation status details.

It might be less confusing to the world in general if we could combine the
activities.

Adrian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Stephen Farrell
> Sent: 07 October 2013 14:58
> To: Arturo Servin; Moriarty, Kathleen
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Diversity] [Diversity-dt] Working with Universities
> 
>

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Mon, 07 Oct 2013 11:02:29 -0300

A total +1. In fact, I've been proposing for some years IPv6-related
projects for CS undergrads, and I usually have a hard time getting
interested students. Having projects listed in an IETF web page would be
a huge motivator for students.

regards

~C.

On 10/7/13 10:55 AM, Arturo Servin wrote:
> (they could be all of them), a special wiki is one, a new section in
> the IETF page, and links from the WG pages to the developments requests.
>
>
> Regards,
> as
>

---

From: "Carlos M. martinez" <[email-masked]>
Date: Mon, 07 Oct 2013 11:07:35 -0300

regards

~C.

---

From: Yaron Sheffer <[email-masked]>
Date: Mon, 07 Oct 2013 17:25:18 +0300

Sorry for coming into this discussion out of context. But actually the 
RFC 6982 wiki page is already up, see the "Soliciting Implementation 
Feedback" section of the WG Chairs wiki [1], or a direct link [2].

Thanks,
	Yaron

[1] http://wiki.tools.ietf.org/group/wgchairs/wiki/WikiStart
[2] http://wiki.tools.ietf.org/group/wgchairs/wiki/RunningCode

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Mon, 7 Oct 2013 10:36:00 -0400

Thanks, Yaron!

Here is my initial message that folks are proposing get combined with the work you and Adrian are doing (which makes perfect sense).

----

Thanks,
Kathleen

-----Original Message-----
From: Yaron Sheffer [mailto:[email-masked]] 
Sent: Monday, October 07, 2013 10:25 AM
To: [email-masked]; 'Stephen Farrell'; 'Arturo Servin'; Moriarty, Kathleen
Cc: [email-masked]; [email-masked]
Subject: Re: [Diversity] [Diversity-dt] Working with Universities

Sorry for coming into this discussion out of context. But actually the RFC 6982 wiki page is already up, see the "Soliciting Implementation Feedback" section of the WG Chairs wiki [1], or a direct link [2].

Thanks,
	Yaron

On 10/07/2013 05:10 PM, Adrian Farrel wrote:
> Yaron [added to this thread] and I had been considering setting up a 
> wiki for tracking 6982 implementation status details.
>
> It might be less confusing to the world in general if we could combine 
> the activities.
>
> Adrian
>
>> From: [email-masked] [mailto:[email-masked]] 
>> On Behalf Of Stephen Farrell
>> And suck in drafts with an RFC 6982 implementation status section 
>> too. If lots of drafts had those, then a tools based solution might 
>> be simple enough.
>>
>> S.
>>
>>>> Is this something we think could be set up, some sort of match-up 
>>>> for working groups and development opportunities?
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> Thanks,
>>>>
>>>> Kathleen
>>>>
>>>>
>>>>

---

From: Eric Burger <[email-masked]>
Date: Mon, 7 Oct 2013 11:34:07 -0400

This is a great idea. One thing that would really help is to tie in not only the work that needs to be done, but pointers to organizations willing to fund the work as well. You can maybe get an undergraduate to do a project for free, but then the scope of the project has to be microscopic. To get a grad student to work on a project or to get an undergraduate's attention for more than a week requires some level of support.

On Oct 7, 2013, at 10:07 AM, Carlos M. martinez <[email-masked]> wrote:

> A total +1. In fact, I've been proposing for some years IPv6-related projects for CS undergrads, and I usually have a hard time getting interested students. Having projects listed in an IETF web page would be a huge motivator for students.
> 
> regards
> 
> ~C.
> 
> 
>>     There are various ways that occurs to me in how to implement it (they could be all of them), a special wiki is one, a new section in the IETF page, and links from the WG pages to the developments requests.
>> 
>> 
>> Regards,
>> as
>>

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 7 Oct 2013 15:52:35 +0000

Hi,

> Many working groups have opportunities for software development.  Students have projects where they need to code.  If we were to create a site that enabled easy access for students to identify codi…

this is very similar to what we had discussed for an IRTF/ISOC joint program. Basically, a "summer of code"-style program where we support a student over the summer in exchange for getting some RFC or ID content converted into open source code.

(I think ISOC Latin America was trying to pilot this during 2013, but I have not heard back.)

> Is this something we think could be set up, some sort of match-up for working groups and development opportunities?

I think it's a great idea. When we discussed this in the past, we came to the conclusion that it would need to be driven by folks (professors, IETF participants) from the regions we'd be targeting with this program, and not by the IETF/IRTF. Because these folks can reach out to the students much more effectively.

Lars

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Mon, 7 Oct 2013 13:36:44 -0400

I'd like us to leverage social networking concepts so this can go farther in scope and let it take on a life of its own by providing a match up home...  We could integrate all of the other great ideas that are related in a social style to provide funding as Eric suggested, but allow for directed as well non-directed opportunities.

This might be used by a few universities at first, but could expand beyond that once the site was available and people understood more of how the IETF works - rough consensus and running code.  Others  may be interested in working with the IETF WGs or coding that otherwise would be unaware of this work.  

There was one student that came by who had heard of the IETF, but then complained about IEEE standards thinking they were IETF documents.  There is clearly an awareness problem.  I also spoke to other engineers that were there recruiting, they also asked if their company was involved and for ways for them to be involved.

If we could provide a tool, then work with ISOC and others to reach students, that may get this off the ground.  It is good to hear that there are related efforts that we can tie together to hit the various points and leverage the good outcomes of previous efforts.

Thanks!
Kathleen

-----Original Message-----
From: Eggert, Lars [mailto:[email-masked]] 
Sent: Monday, October 07, 2013 11:53 AM
To: Moriarty, Kathleen
Cc: [email-masked]; [email-masked]
Subject: Re: [Diversity] Working with Universities

Hi,

Lars

---

From: Alejandro Acosta <[email-masked]>
Date: Mon, 07 Oct 2013 15:04:48 -0430

Excellent idea
+  1

---

From: Christian O'Flaherty <[email-masked]>
Date: Tue, 8 Oct 2013 21:06:12 +0000

Hi,

On 10/7/13 1:52 PM, "Eggert, Lars" <[email-masked]> wrote:

>> Many working groups have opportunities for software development.
>>Students have projects where they need to code.  If we were to create a
>>site that enabled easy access for students to identify coding
>>opportunities that could potentially live on beyond their project, we
>>may get valuable input.  A listing of working groups matched with
>>existing implementations or a listing of what is needed would make it
>>easier for students to see where they could help (jumping into something
>>brand new to them).  We could make this compelling for them and get
>>interoperability testing feedback as a great way to have them be able to
>>provide meaningful comments on list.
>
>this is very similar to what we had discussed for an IRTF/ISOC joint
>program. Basically, a "summer of code"-style program where we support a
>student over the summer in exchange for getting some RFC or ID content
>converted into open source code.

Even though I would not call it a program yet, there were several
universities in Latam contacted and most of them were interested. Some
people got involved in different ways since then, but none of them as
developers for someone else's research.

I fully support the publication of "a listing of what is needed". It can
help us engage the appropriate groups within Universities more
effectively.  

Having said that, I would start with a small list and a few people from
the IETF involved before creating a "program". Sometimes the expectations
in the Universities are not fully aligned with the IETF needs (timeframe,
support, research leadership, etc.)

Christian

>I think it's a great idea. When we discussed this in the past, we came to
>the conclusion that it would need to be driven by folks (professors, IETF
>participants) from the regions we'd be targeting with this program, and
>not by the IETF/IRTF. Because these folks can reach out to the students
>much more effectively.
>
>Lars

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 10 Oct 2013 10:16:48 +0100

On Mon, Oct 7, 2013 at 1:57 PM, Moriarty, Kathleen <
[email-masked]> wrote:

> ****
> contributing otherwise.

I support that our IETF WGs need participation from students and more
university memebrs, students comments IMHO are the most important ones, and
awareness is more important for the IETF future.

> ****

Absolutly can match-up, I always encourage students to participate but
seems there are still some who do discourage in IETF, or that you may
participate and editors ignore acknowledging and take/use your
work, however, WGs Chairs in IETF need to consider your ideas because they
seem not able to handle the volume of partcipation for developing the WGs'
opportunities and the IETF's opportunity/awareness.

AB