Subject: [Diversity] year for highest number of IETF participants

From: Aaron Yi DING <[email-masked]>
Date: Tue, 08 Oct 2013 00:29:20 +0100

Hello,

Is there a pointer (maybe from IETF secretary)? The year with highest 
number of attendees - which one is that? The exact number of 
participants will be even better.

Thanks,
Aaron

---

From: Aaron Yi DING <[email-masked]>
Date: Tue, 08 Oct 2013 01:03:20 +0100

Thanks for the pointer from Ray Pelletier.

It seems IETF-49 got the highest number - 2810.

2nd is IETF-46, 2379.

Cheers,
Aaron

---

From: Ted Lemon <[email-masked]>
Date: Mon, 7 Oct 2013 21:08:49 -0400

On Oct 7, 2013, at 7:29 PM, Aaron Yi DING <[email-masked]> wrote:
> Is there a pointer (maybe from IETF secretary)? The year with highest number of attendees - which one is that? The exact number of participants will be even better.

Wasn't it in Berlin?   ISTR that we had a remarkably good attendance.   If not, it would have been probably the IETF in San Jose, quite some time ago.

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 8 Oct 2013 13:51:20 +0100

Curiously these numbers do not match those at
https://www.ietf.org/meeting/past.html

Registration, we may conclude, does not equate to attendance.

Adrian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe
> Abley
> Sent: 08 October 2013 02:38
> To: Ted Lemon
> Cc: [email-masked]; IETF
> Subject: Re: year for highest number of IETF participants
>
> [krill:~]% for n in $(jot 15 73); do
> curl -s "https://www.ietf.org/registration/ietf${n}/attendance.py" | \
>   awk -v n=${n} '/ registrations:/ { sub(/ registrations:.*$/, "");
sub(/^.*\>/, "");
> print n, $0; }'
> done
> 73 1111
> 74 1332
> 75 1230
> 76 1249
> 77 1350
> 78 1304
> 79 1337
> 80 1317
> 81 1244
> 82 1051
> 83 1529
> 84 1356
> 85 1351
> 86 1223
> 87 1585
> [krill:~]%

---

From: Joe Abley <[email-masked]>
Date: Mon, 7 Oct 2013 18:37:33 -0700

> Wasn't it in Berlin?   ISTR that we had a remarkably good attendance.   If not, it would have been probably the IETF in San Jose, quite some time ago.

Attendance numbers for the last 14 meetings are trivially available from the command-line (and figuring that out was about two minutes' work following a search for "ietf 87 attendance").

Berlin was the best-attended meeting in that period. And also the meeting with the most unexpectedly high ambient temperatures, although I have no science to back up that claim, just recurring nightmares.

Joe

[krill:~]% for n in $(jot 15 73); do 
curl -s "https://www.ietf.org/registration/ietf${n}/attendance.py" | \
  awk -v n=${n} '/ registrations:/ { sub(/ registrations:.*$/, ""); sub(/^.*\>/, ""); print n, $0; }'
done
73 1111
74 1332
75 1230
76 1249
77 1350
78 1304
79 1337
80 1317
81 1244
82 1051
83 1529
84 1356
85 1351
86 1223
87 1585
[krill:~]%

---

From: Tony Hansen <[email-masked]>
Date: Mon, 07 Oct 2013 23:43:27 -0400

> It seems IETF-49 got the highest number - 2810.

For those wondering where to see a list of attendees by meeting, see

http://www.ietf.org/meeting/past.html

    Tony Hansen

---

From: Richard Barnes <[email-masked]>
Date: Tue, 8 Oct 2013 09:06:55 -0400

Indeed, the number Joe was counting was the number who filled out a
registration form.  Counting those who actually paid their registration
yields closer numbers.

rbarnes$ for n in $(jot 15 73); do
att=$(curl -s "https://www.ietf.org/registration/ietf${n}/attendance.py" |
grep -o ">Yes<" | wc -l);
echo $n $att;
done
73 969
74 1170
75 1102
76 1129
77 1242
78 1159
79 1144
80 1231
81 1127
82 948
83 1395
84 1199
85 1157
86 1115
87 1435

---

From: Ray Pelletier <[email-masked]>
Date: Tue, 8 Oct 2013 10:04:40 -0400

All;

Prior to this Vancouver meeting in which Remote Participants will have an opportunity to register, registrations did -not- include Remote Participants.

Attendees are those who showed up.  Registrations are typically a much higher number.  Not all those who register attend.

Ray
IAD

On Oct 8, 2013, at 9:06 AM, Richard Barnes <[email-masked]> wrote:

> Indeed, the number Joe was counting was the number who filled out a registration form.  Counting those who actually paid their registration yields closer numbers.
> 
> att=$(curl -s "https://www.ietf.org/registration/ietf${n}/attendance.py" | grep -o ">Yes<" | wc -l);
> echo $n $att; 
> done
> 73 969
> 74 1170
> 75 1102
> 76 1129
> 77 1242
> 78 1159
> 79 1144
> 80 1231
> 81 1127
> 82 948
> 83 1395
> 84 1199
> 85 1157
> 86 1115
> 87 1435
> 
>