Subject: [dix] background: system with similar goals: Higgins

From: John Schnizlein <[email-masked]>
Date: Wed, 1 Mar 2006 19:09:20 -0500

It might be useful to look at another open source effort to empower 
users. One point where the description at the following URL seems to 
diverge from recent discussion here is its explicit support for 
multiple identities.

One never knows what an announcement of support such as that from IBM 
and Novell might mean for the project.

John

http://spwiki.editme.com/HigginsIntroduction

Begin forwarded message:

> From: "Linux and Open Source Report" 
> <[email-masked]>
> Date: March 1, 2006 10:46:17 AM EST
> ...
> IBM-LED GROUP BACKS NEW IDENTITY MANAGER TOOL
>
> IBM and Novell announced their support Monday for an open-source 
> project
> aiming to give users more control over how information such as 
> passwords
> and financial details are shared across multiple Web sites.
> http://newsletter.infoworld.com/t?ctl=112BB5B:1F5DA10
>
_______________________________________________
dix mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dix

---

From: John Merrells <[email-masked]>
Date: Thu, 2 Mar 2006 19:31:16 -0800

On 1-Mar-06, at 4:09 PM, John Schnizlein wrote:

> users. One point where the description at the following URL seems  
> to diverge from recent discussion here is its explicit support for  
> multiple identities.

Yeah, Higgins is good stuff (tm).

I'm in favor of multiple identities... in the sense that an identity  
can have multiple
identifiers, which I think is technically what Higgins supports, and  
what I think
dmd0 supports. I confess I don't know what format a Higgins  
identifier is, but I
imagine it's just a string, with an associated known type. In dmd0 I  
specced
it as a URL and then went into detail about how a URL based  
identifier scheme
would work. I'm sure other schemes could be made to work too.

> One never knows what an announcement of support such as that from  
> IBM and Novell might mean for the project.

Not quite sure what that statement means. Project being DIX? For sure  
if if the
Higgins team are interested in DIX I should think that to be a  
positive thing.

John

---

From: David Boreham <[email-masked]>
Date: Thu, 02 Mar 2006 21:14:17 -0700

> diverge from recent discussion here is its explicit support for 

Interesting. But if I were trying so solve 'the identity problem'
I don't think I'd want to do it by defining a Java API...
Protocol-based solutions seem more productive.

Reading the material on the site, I'm not 100% convinced that there
is anything profound there wrt multiple and related identities :
to me it seems that there is the notion of a query ('get me the
stuff for the identities in my buddy list' is the example given),
and there's a notion of an identity hierarchy. Having worked
with LDAP for some time, I can attest that any attempt to
define a (single) hierarchy will not succeed because everyone
has a different idea of how the hierarchy should be structured.

The query concept is potentially useful.