Subject: [dmarc-ietf] Ticket #120 - Unique IDs

From: "Brotman, Alex" <[email-masked]>
Date: Mon, 6 Dec 2021 19:57:22 +0000

Hello folks,

We received a ticket about the unique IDs that are included with reporting:

--------------------------
unique-id, msg-id, and report_id are loosely defined.

The spec needs to say that they are semantically the same thing and must have the same content.

In addition:

    Message-ID should also be based on unique-id if possible (for example, msg-id@domain-name),
    make optional the final part of the Subject:, [Report-ID: msg-id] (like the filename).
--------------------------

I agree, the references should be made to the point to the same identifying string definition.  Today, the msg-id is required via the Subject, report_id is required in the XSD, and the unique-id is optional in the filename of the attached report.  Proposed is adding a suggestion to use the same ID attached to the Message-Id header.  Thoughts about making all required or optional?

--
Alex Brotman
Sr. Engineer, Anti-Abuse & Messaging Policy
Comcast

---

From: Alessandro Vesely <[email-masked]>
Date: Wed, 8 Dec 2021 12:34:04 +0100

> We received a ticket about the unique IDs that are included with reporting:

I think some should be mandatory while others should be optional.  Two examples:

*filename*:
Some record producers issue multiple messages for the same period in order to 
overcome size limit restrictions.  In that case the unique-id is the only means 
to recognize duplicate filenames without digging into their content.  I'd say 
this has to be required.

*Subject*:
This field is only relevant for humans who see the reports in a message list 
pane.  In that case, it is unavoidably truncated and duplicated messages are 
more easily spotted by other means.  Rather than overturning RFC 7489's rule, 
I'd make it optional.

Best
Ale
--