Subject: [dmarc-ietf] I-D Action: draft-ietf-dmarc-dmarcbis-07.txt

From: [email-masked]
Date: Wed, 06 Apr 2022 07:51:02 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Domain-based Message Authentication, Reporting & Conformance WG of the IETF.

        Title           : Domain-based Message Authentication, Reporting, and Conformance (DMARC)
        Authors         : Todd M. Herr
                          John Levine
	Filename        : draft-ietf-dmarc-dmarcbis-07.txt
	Pages           : 62
	Date            : 2022-04-06

Abstract:
   This document describes the Domain-based Message Authentication,
   Reporting, and Conformance (DMARC) protocol.

   DMARC permits the owner of an email author's domain name to enable
   verification of the domain's use, to indicate the Domain Owner's or
   Public Suffix Operator's message handling preference regarding failed
   verification, and to request reports about use of the domain name.
   Mail receiving organizations can use this information when evaluating
   handling choices for incoming mail.

   This document obsoletes RFC 7489.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dmarc-dmarcbis/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-dmarc-dmarcbis-07.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dmarc-dmarcbis-07

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Todd Herr <[email-masked]>
Date: Wed, 6 Apr 2022 10:53:59 -0400

I believe this rev has the proposed text that was submitted in various
messages in the thread titled "*5.5.4. Publish a DMARC Policy for the
Author Domain - dmarcbis-06"*

On Wed, Apr 6, 2022 at 10:51 AM <[email-masked]> wrote:

> _______________________________________________
> dmarc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmarc
>

-- 

*Todd Herr * | Technical Director, Standards and Ecosystem
*e:* [email-masked]
*m:* 703.220.4153

This email and all data transmitted with it contains confidential and/or
proprietary information intended solely for the use of individual(s)
authorized to receive it. If you are not an intended and authorized
recipient you are hereby notified of any use, disclosure, copying or
distribution of the information included in this transmission is prohibited
and may be unlawful. Please immediately notify the sender by replying to
this email and then delete it from your system.

---

From: Scott Kitterman <[email-masked]>
Date: Wed, 06 Apr 2022 16:27:04 +0000

I believe it does.

Thanks,

Scott K

---

From: Scott Kitterman <[email-masked]>
Date: Sun, 17 Apr 2022 16:54:03 -0400

I've finished going through this and also updated authheaders [1] to match.  It 
now has a script called dmarc-policy-find which you can used to determine the 
DMARC policy to be applied for a domain.  You can use RFC 7489, RFC 7489 + RFC 
9091, and DMARCbis-07.  

It does currently cheat and assume psd=y is in the records for domains on the 
PSD DMARC registry list, since no one has actually published that yet.

Scott K

[1] https://github.com/ValiMail/authentication-headers (also on pypi)

On Wednesday, April 6, 2022 12:27:04 PM EDT Scott Kitterman wrote:
> I believe it does.
> 
> Thanks,
> 
> Scott K
> 
> On April 6, 2022 2:53:59 PM UTC, Todd Herr 
<todd.herr=[email-masked]> wrote:
> >>         Title           : Domain-based Message Authentication, Reporting,
> >> 
> >> and Conformance (DMARC)
> >> 
> >>         Authors         : Todd M. Herr
> >>         
> >>                           John Levine
> >>