Subject: [DMM] Copying Traffic in FPC

From: Lyle Bertz <[email-masked]>
Date: Tue, 6 Oct 2015 10:38:01 -0500

When looking at the latest draft I was curious about how copying for the
purpose of troubleshooting / probes would be supported?

My thought would be some sort of property on a port that copies the traffic
and notes the PRT that it could be forwarded to.

Could we support this use case (I am not married to the suggestion above)
in the specification given its importance to trouble management?   This is
easy enough to support in underlying DPN technologies such as SDN and I see
no reason to not specify it in FPC and avoid using yet another protocol for
forwarding.

Comments / Thoughts would be appreciated on this matter.

Thank you.

Lyle

---

From: Marco Liebsch <[email-masked]>
Date: Thu, 8 Oct 2015 14:00:21 +0000

You think about something like flow sampling, correct? From FPC protocol point of view, I don’t see
issues with adding such properties. AFAIK there is even some support from data plane nodes, so
enforcement of these properties should work.

Now, I understand you’re requesting control on which traffic should be probed. In that case a
new property should be added. The associated attribute should then also indicate how often
packets should be probed (Every 1min, ever 1000th packet, whatever).
Since the forwarding of the copy packet is different than for the actual data packet, the
probe property should also indicate a destination, where the copy should be sent to.
That’s the protocol part and it should be feasible if wanted.

Is it the C-Plane function that is aware of policies for packet probes? To exploit such extension,
it should be, otherwise the probe configuration may be accomplished via a different interface.

Thanks,
Marco

From: Lyle Bertz [mailto:[email-masked]]
Sent: Dienstag, 6. Oktober 2015 17:38
To: [email-masked]; [email-masked]
Subject: Copying Traffic in FPC

When looking at the latest draft I was curious about how copying for the purpose of troubleshooting / probes would be supported?

My thought would be some sort of property on a port that copies the traffic and notes the PRT that it could be forwarded to.

Could we support this use case (I am not married to the suggestion above) in the specification given its importance to trouble management?   This is easy enough to support in underlying DPN technologies such as SDN and I see no reason to not specify it in FPC and avoid using yet another protocol for forwarding.

Thank you.

Lyle

---

From: Lyle Bertz <[email-masked]>
Date: Thu, 8 Oct 2015 10:02:27 -0500

Marco,

wrt
> You think about something like flow sampling, correct?

Yes, I am thinking about sampling or trouble management (engineer working
directly with a customer to fix 'something' or sampling based upon other
OSS data that indicates issues in the area), in such cases
a.  The customer (and engineer) will not know anything about mobility
information so this is initiated through the control plane, e.g. the
customer can tell us the phone # of a mobile and we can initiate the trace
through the control plane.
b.  In general sampling is good enough but for direct troubleshooting with
a knowledgeable customer we would analyze a direct copy of the traffic
(taking all packets) so view the range as sample from whatever the probe /
sampling rate should be

> Is it the C-Plane function that is aware of policies for packet probes?
As I mention above, no one knows their current address - especially when IP
mobility is involved.    The C-plane can correlate other mobility network
Identifiers to an IP address and then send a command.

If fully automated, the C-plane can do targeted diagnostics for offload
and, because it is the C-plane by sending commands to move users or take
other actions - it is, after all the C-plane.   < This could be a future
possibility - I am not proposing re-homing and AF mobility is a different
matter entirely we are addressing in other work in the group

Thanks.

Lyle

On Thu, Oct 8, 2015 at 9:00 AM, Marco Liebsch <[email-masked]>
wrote:

> *From:* Lyle Bertz [mailto:[email-masked]]
> *Sent:* Dienstag, 6. Oktober 2015 17:38
> *To:* [email-masked]; [email-masked]
> *Subject:* Copying Traffic in FPC
>
>
>
> My thought would be some sort of property on a port that copies the
> traffic and notes the PRT that it could be forwarded to.
>
>
>

---

From: Marco Liebsch <[email-masked]>
Date: Thu, 8 Oct 2015 15:31:53 +0000

Ok, understand. It’s not for cases like charging/monitoring based on samples, but you plan using it
on/off under control of the C-Plane and only on demand and only for selected traffic.

So if we assume this enforcement goes via the mobility C-Plane function, it could be a feature that
can be added.

Others’ opinion on this?

marco

From: Lyle Bertz [mailto:[email-masked]]
Sent: Donnerstag, 8. Oktober 2015 17:02
To: Marco Liebsch
Cc: [email-masked]; [email-masked]
Subject: Re: Copying Traffic in FPC

Marco,

wrt
> You think about something like flow sampling, correct?

Yes, I am thinking about sampling or trouble management (engineer working directly with a customer to fix 'something' or sampling based upon other OSS data that indicates issues in the area), in such cases
a.  The customer (and engineer) will not know anything about mobility information so this is initiated through the control plane, e.g. the customer can tell us the phone # of a mobile and we can initiate the trace through the control plane.
b.  In general sampling is good enough but for direct troubleshooting with a knowledgeable customer we would analyze a direct copy of the traffic (taking all packets) so view the range as sample from whatever the probe / sampling rate should be

> Is it the C-Plane function that is aware of policies for packet probes?
As I mention above, no one knows their current address - especially when IP mobility is involved.    The C-plane can correlate other mobility network Identifiers to an IP address and then send a command.

If fully automated, the C-plane can do targeted diagnostics for offload and, because it is the C-plane by sending commands to move users or take other actions - it is, after all the C-plane.   < This could be a future possibility - I am not proposing re-homing and AF mobility is a different matter entirely we are addressing in other work in the group

Thanks.

Lyle

On Thu, Oct 8, 2015 at 9:00 AM, Marco Liebsch <[email-masked]<mailto:[email-masked]>> wrote:
You think about something like flow sampling, correct? From FPC protocol point of view, I don’t see
issues with adding such properties. AFAIK there is even some support from data plane nodes, so
enforcement of these properties should work.

Thanks,
Marco

From: Lyle Bertz [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Dienstag, 6. Oktober 2015 17:38
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Copying Traffic in FPC

Thank you.

Lyle