Subject: [DMM] Fwd: New Version Notification for draft-jhlee-dmm-dnpp-00.txt

From: Jong-Hyouk Lee <[email-masked]>
Date: Fri, 9 Oct 2015 01:53:09 +0900

Hello,

For the mobile node moved from a previous network to a new network, the access router (having a forwarding function) at the new network may need to obtain the previous network prefix information (i.e., deprecated network prefix information at the new network) of the mobile node for data packet forwarding of the mobile node. The draft introduces new extensions to router advertisement (RA) and router solicitation (RS) messages.  The extension to RS messages is used by the mobile node to provide the previous network prefix information to an access router. The extension to RA messages is used by the access router to request the previous network prefix information in a RS message.

Comments on the draft “deprecated network prefix provision" are welcome.

J.
--
Jong-Hyouk Lee, living somewhere between /dev/null and /dev/random
Protocol Engineering Lab., Sangmyung University

#email: [email-masked]
#webpage: https://sites.google.com/site/hurryon

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-jhlee-dmm-dnpp-00.txt
> Date: October 9, 2015 at 1:19:25 AM GMT+9
> To: "Jong-Hyouk Lee" <[email-masked]>, "Zhiwei Yan" <[email-masked]>, "Jong-Hyouk Lee" <[email-masked]>, "Zhiwei Yan" <[email-masked]>
> 
> 
> A new version of I-D, draft-jhlee-dmm-dnpp-00.txt
> has been successfully submitted by Jong-Hyouk Lee and posted to the
> IETF repository.
> 
> Name:		draft-jhlee-dmm-dnpp
> Revision:	00
> Title:		Deprecated Network Prefix Provision
> Document date:	2015-10-08
> Group:		Individual Submission
> Pages:		5
> URL:            https://www.ietf.org/internet-drafts/draft-jhlee-dmm-dnpp-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-jhlee-dmm-dnpp/
> Htmlized:       https://tools.ietf.org/html/draft-jhlee-dmm-dnpp-00
> 
> 
> Abstract:
>   This document introduces new extensions to router advertisement and
>   router solicitation messages.  The extensions are used to provide a
>   mobile node's deprecated network prefix information to an access
>   router.  This document updates [RFC4861].
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> 
> 
>

---

From: Jouni <[email-masked]>
Date: Thu, 8 Oct 2015 14:04:12 -0700

I would love to see the security considerations for this proposal and more discussion on the reliability of this method. Also what happens if the access router cannot add filters for the “deprecated network prefix” i.e. the prefix does not belong to the new link from routing point of view?

- Jouni

> On 08 Oct 2015, at 09:53, Jong-Hyouk Lee <[email-masked]> wrote:
> 
> Hello,
> 
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm

---

From: Jong-Hyouk Lee <[email-masked]>
Date: Fri, 9 Oct 2015 10:43:34 +0900

Thanks for the comments. Plz see inline.
--
Jong-Hyouk Lee, living somewhere between /dev/null and /dev/random
Protocol Engineering Lab., Sangmyung University

> On Oct 9, 2015, at 6:04 AM, Jouni <[email-masked]> wrote:
> 
> I would love to see the security considerations for this proposal and more discussion on the reliability of this method.

Let me update these aspects later. A short response is that the extended RS and RA messages can be protected with SEND. Are you concerning about the deprecated address ownership? 

> Also what happens if the access router cannot add filters for the “deprecated network prefix” i.e. the prefix does not belong to the new link from routing point of view?

The provided deprecated network prefix information will be used by the new AR. It can be used to establish a tunnel with the previous AR for the MN’s data forwarding. It can be also used to update filtering rules (e.g., ingress filtering rules for the MN’s data packets can be updated directly by the new AR or the relevant information is transferred). In case that the provided deprecated network prefix is not relevant to the new link from routing point of view, the AR simply does nothing with the deprecated network prefix and informs about it to the MN by sending a RA message. Note that for this we will update the draft. Is it what you wanted to know? Otherwise, let me explain in other ways. 

J.