Subject: [DMM] I-D Action: draft-ietf-dmm-4283mnids-01.txt

From: [email-masked]
Date: Mon, 19 Oct 2015 13:21:34 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Distributed Mobility Management Working Group of the IETF.

        Title           : MN Identifier Types for RFC 4283 Mobile Node Identifier Option
        Authors         : Charles E. Perkins
                          Vijay Devarapalli
	Filename        : draft-ietf-dmm-4283mnids-01.txt
	Pages           : 8
	Date            : 2015-10-19

Abstract:
   Additional Identifier Types are proposed for use with the Mobile Node
   Identifier Option for MIPv6 (RFC 4283).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dmm-4283mnids/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-dmm-4283mnids-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dmm-4283mnids-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 19 Oct 2015 13:39:23 -0700

Hello folks,

The updated MNIDs draft has been posted.

I've incorporated potential resolutions for the recent comments, 
especially from Sri.  I did not make subsections for each type of MNID, 
because I am hoping that won't be considered necessary.  I hope to get 
some more discussion about it from folks on this mailing list.  Or, if I 
get a sample text for one of the MNIDs, I can attempt to create similar 
text for the other MNIDs.  Notably, doing so would make the short draft 
about 5 times longer.

Regards,
Charlie P.

On 10/19/2015 1:21 PM, [email-masked] wrote:
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm
>

---

From: Charlie Perkins <[email-masked]>
Date: Thu, 29 Oct 2015 13:06:27 -0700

Hello Hakima,

I am O.K. with including more MNID types.  The short addresses in Zigbee 
are purely local; that might be a consideration that affects inclusion 
within a Mobile-IP / dmm oriented draft.  I could see arguments either way.

Regarding the other identifiers for IoT -- are they proprietary?

If there is support for the identifiers listed below I will include them 
in the next revision.

It has been suggested to include short sections that describe each MNID 
type.  Would you be willing to contribute some sample section text for 
one or more of the RFID types?  I don't think it should be very long, 
and should not be misconstrued as specifying any of the behavior for 
RFID, only as a description.

Regards,
Charlie P.

On 10/19/2015 10:51 PM, Hakima Chaouchi wrote:
> Hi Charles, all,
>
> The draft is not mentioning the short addresses in Zigbee (16bits), 
> lot of sensors use that.
>
> What about the new long range technologies in IoT (Sig Fox, LORA)
>
>
> Do you think we should consider in this draft a possibility of having 
> logical identifiers as the Internet of Things main architectures today 
> are pushing to have an abstraction layer between the application 
> servers processing the data of the objects (that might be mobile)....
>
> Cheers,
>
> Hakima
>
> 2015-10-19 22:39 GMT+02:00 Charlie Perkins 
> <[email-masked] <mailto:[email-masked]>>:
>
>     Hello folks,
>
>     especially from Sri.  I did not make subsections for each type of
>     MNID, because I am hoping that won't be considered necessary.  I
>     hope to get some more discussion about it from folks on this
>     mailing list.  Or, if I get a sample text for one of the MNIDs, I
>     can attempt to create similar text for the other MNIDs.  Notably,
>     doing so would make the short draft about 5 times longer.
>
>     Regards,
>     Charlie P.
>
>
>
>     On 10/19/2015 1:21 PM, [email-masked]
>     <mailto:[email-masked]> wrote:
>
>         until the htmlized version and diff are available at
>         tools.ietf.org <http://tools.ietf.org>.
>
>         [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Thu, 29 Oct 2015 20:13:29 +0000

Charlie,

I had the same comment on the missing  LORA identifiers. Is that a standard ?  This is another SDO standard. I can provide the text for LORA.

Regards
Sri

From: dmm <[email-masked]<mailto:[email-masked]>> on behalf of Charlie Perkins <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 29, 2015 at 1:06 PM
To: Hakima Chaouchi <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [DMM] I-D Action: draft-ietf-dmm-4283mnids-01.txt

Hello Hakima,

I am O.K. with including more MNID types.  The short addresses in Zigbee are purely local; that might be a consideration that affects inclusion within a Mobile-IP / dmm oriented draft.  I could see arguments either way.

If there is support for the identifiers listed below I will include them in the next revision.

It has been suggested to include short sections that describe each MNID type.  Would you be willing to contribute some sample section text for one or more of the RFID types?  I don't think it should be very long, and should not be misconstrued as specifying any of the behavior for RFID, only as a description.

Regards,
Charlie P.

The draft is not mentioning the short addresses in Zigbee (16bits), lot of sensors use that.

Do you think we should consider in this draft a possibility of having logical identifiers as the Internet of Things main architectures today are pushing to have an abstraction layer between the application servers processing the data of the objects (that might be mobile)....

Cheers,

Hakima

2015-10-19 22:39 GMT+02:00 Charlie Perkins <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>:
Hello folks,

I've incorporated potential resolutions for the recent comments, especially from Sri.  I did not make subsections for each type of MNID, because I am hoping that won't be considered necessary.  I hope to get some more discussion about it from folks on this mailing list.  Or, if I get a sample text for one of the MNIDs, I can attempt to create similar text for the other MNIDs.  Notably, doing so would make the short draft about 5 times longer.

Regards,
Charlie P.

On 10/19/2015 1:21 PM, [email-masked]<mailto:[email-masked]> wrote:
A New Internet-Draft is available from the on-line Internet-Drafts directories.
  This draft is a work item of the Distributed Mobility Management Working Group of the IETF.

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
dmm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dmm

_______________________________________________
dmm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dmm