Subject: Re: [DMM] white paper for optimized mobile user plane solutions for 5G

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Wed, 17 Jan 2018 22:53:23 +0000

Arashmid  - We do have regular DMM working group meeting during the IETF week. I guess, what you are asking for is a WG-chair scheduled conference calls? DMM List may be very quite, but there have been regular conf calls between authors of some of the WG documents. Authors of FPC host those calls regularly. For the new work item that Kalyani is proposing, we need to have some discussions in the mailer and once the document is adopted as a WG document, we can certainly host some calls (author/chair scheduled) on a need basis. So, the first step is to post comments on the documents and trigger some discussions.

Sri

From: dmm <[email-masked]<mailto:[email-masked]>> on behalf of Arashmid Akhavain <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, January 17, 2018 at 2:16 PM
To: "Bogineni, Kalyani" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [DMM] white paper for optimized mobile user plane solutions for 5G

Hi everyone,
Online meetings on a regular basis can perhaps help moving things forward.

Arashmid

From: dmm [mailto:[email-masked]] On Behalf Of Bogineni, Kalyani
Sent: 17 January 2018 15:20
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [DMM] white paper for optimized mobile user plane solutions for 5G

Folks:

Here is the draft with 3GPP architecture described as much as relevant to N9 interface.
I have extracted some diagrams from 3GPP specs and will redo them in ASCII after I get
some feedback on whether to include them or not in this document.

Kalyani

From: Bogineni, Kalyani
Sent: Wednesday, December 13, 2017 4:14 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Bogineni, Kalyani <[email-masked]<mailto:[email-masked]>>
Subject: white paper for optimized mobile user plane solutions for 5G

Folks:

In response to the 3GPP CT4 study item on user plane protocols, we propose that a white paper
be developed that can compare the different IETF protocols. Attached is an outline. Please let me
know if you would like to contribute.

Kalyani Bogineni
Verizon

---

From: Arashmid Akhavain <[email-masked]>
Date: Thu, 18 Jan 2018 14:38:13 +0000

Hi Sri,
Thank you for your reply and clarifications.
I think Kalyani's work is extremely valuable, but we also need to set an strategy for our reply back to 3GPP. Currently most discussions are about individual protocols such as SRV6, LISP/ILSP, ILNP, ILA, etc. which are really in one form or another a type of ID-Location approach.  I believe we first need to address 3GPP's request from the architecture point of view, before we dive into implementation details. Is there any discussion around different competing network architectures?

Not sure if you have seen a white paper titled "Evolving 5G Routing" by Docomo, Huawei and others. We also hosted a live webcast demo that shows two LTE slices using ID-Location for data path and distribute ID-Location information to interested eNodeBs via public cloud pub/sub service. The result is very promising and shows the capability of this architecture.

I believe the combination of the white paper and the demo could perhaps serve as a good starting point to get the architecture discussion going and that's where conference calls can come handy. I agree though let's start with the mailing list and move to calls next.

Best regards,
Arashmid Akhavain

From: Sri Gundavelli (sgundave) [mailto:[email-masked]]
Sent: 17 January 2018 17:53
To: Arashmid Akhavain <[email-masked]>; Bogineni, Kalyani <[email-masked]>; [email-masked]
Subject: Re: [DMM] white paper for optimized mobile user plane solutions for 5G

Sri

Hi everyone,

Arashmid

Folks:

Kalyani

From: Bogineni, Kalyani

Folks:

Kalyani Bogineni
Verizon

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Thu, 18 Jan 2018 15:21:01 +0000

Arashmid:

The individual sections are supposed to allow the proponents of the protocols to show how the 5G architecture will be when
their protocol is used with the focus on N9. The criteria section lists the evaluation criteria from architectural perspective.

Do you see a need for a different kind of format?

Kalyani

From: Arashmid Akhavain [mailto:[email-masked]]
Sent: Thursday, January 18, 2018 9:38 AM
To: Sri Gundavelli (sgundave) <[email-masked]>; Bogineni, Kalyani <[email-masked]>; [email-masked]
Cc: AshwoodsmithPeter <[email-masked]>; TongWen <[email-masked]>
Subject: [E] RE: [DMM] white paper for optimized mobile user plane solutions for 5G

Hi Sri,

Best regards,
Arashmid Akhavain

From: Sri Gundavelli (sgundave) [mailto:[email-masked]]
Sent: 17 January 2018 17:53
To: Arashmid Akhavain <[email-masked]<mailto:[email-masked]>>; Bogineni, Kalyani <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [DMM] white paper for optimized mobile user plane solutions for 5G

Sri

Hi everyone,

Arashmid

Folks:

Kalyani

From: Bogineni, Kalyani

Folks:

Kalyani Bogineni
Verizon

---

From: Arashmid Akhavain <[email-masked]>
Date: Thu, 18 Jan 2018 16:09:27 +0000

Hi Kalyani,

I was thinking something along this:

A section on each competing architecture where we first provide a description of each architecture.
A section on the list and set of features that 3GPP requires and must be supported.

In the following sections we then make a deep dive into each architecture and describe/analyse how different architectures would support
each of the requested features.

Going through the above exercise we can perhaps tabulate the outcome of the investigation in a format like:

Arch1      Arch-2     Arch-N
Feature-1
Feature-2
Feature-N

Considering pros and cons of each architecture against the request features, at this point we should be ready to reply back to 3GPP with our recommended architecture.

We then continue the work, and go into more details and follow the same format for different protocols supporting the recommended architecture and tabulate the outcome as

Arch1.1         Arch1.2    Arch1.n
Feature-1
Feature-2
Feature-N

Taking ID-Location architecture as an example,  LISP/ILSR, ILNP, ILA, etc. will be Arch1.1, Arch1.2, Arch1.3, etc.

Now, here is my question. Have we already decided to go with the recommendation that ID-Location architecture should be the next generation of data path?
If everyone is on board with this, then your suggested outline fits the bill and we can start working on it right away. If the decision hasn't been made then it would be perhaps a good idea to go one level up and talk about different architectures first. Mind you that I don't know and am simply curious to know what our starting point is.

Arashmid

From: Bogineni, Kalyani [mailto:[email-masked]]
Sent: 18 January 2018 10:21
To: Arashmid Akhavain <[email-masked]>; Sri Gundavelli (sgundave) <[email-masked]>; [email-masked]
Cc: AshwoodsmithPeter <[email-masked]>; TongWen <[email-masked]>; Bogineni, Kalyani <[email-masked]>
Subject: RE: [DMM] white paper for optimized mobile user plane solutions for 5G

Arashmid:

Kalyani

From: Arashmid Akhavain [mailto:[email-masked]]
Sent: Thursday, January 18, 2018 9:38 AM
To: Sri Gundavelli (sgundave) <[email-masked]<mailto:[email-masked]>>; Bogineni, Kalyani <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: AshwoodsmithPeter <[email-masked]<mailto:[email-masked]>>; TongWen <[email-masked]<mailto:[email-masked]>>
Subject: [E] RE: [DMM] white paper for optimized mobile user plane solutions for 5G

Hi Sri,

Best regards,
Arashmid Akhavain

Sri

Hi everyone,

Arashmid

Folks:

Kalyani

From: Bogineni, Kalyani

Folks:

Kalyani Bogineni
Verizon

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Thu, 18 Jan 2018 16:48:03 +0000

Responses inline as [KB]

Kalyani

From: Arashmid Akhavain [mailto:[email-masked]]
Sent: Thursday, January 18, 2018 11:09 AM
To: Bogineni, Kalyani <[email-masked]>; Sri Gundavelli (sgundave) <[email-masked]>; [email-masked]
Cc: AshwoodsmithPeter <[email-masked]>; TongWen <[email-masked]>
Subject: [E] RE: [DMM] white paper for optimized mobile user plane solutions for 5G

Hi Kalyani,

A section on each competing architecture where we first provide a description of each architecture.
[KB] Right now the outline has sections 7, 8, 9, and 10 for this purpose.

A section on the list and set of features that 3GPP requires and must be supported.
[KB] Section 4 in the white paper can be used to create a table of requirements to be used by each architecture

In the following sections we then make a deep dive into each architecture and describe/analyse how different architectures would support
each of the requested features.
[KB] That is the intent of Sections 7, 8, 9, and 10. There could be subsections for describing each architecture, show how this would
be in the 5G architecture framework, high-level flows for different scenarios listed in section 5, impacts to the existing 5G architecture,
self-evaluation of how the architecture compares to the requirements from section 4,

[KB] The following fits into Section 11. Table of requirements with added entries from the self-evaluation in sections 7, 8, 9, and 10.
Going through the above exercise we can perhaps tabulate the outcome of the investigation in a format like:

Arch1      Arch-2     Arch-N
Feature-1
Feature-2
Feature-N

[KB] Section 12 has the summary.

Arch1.1         Arch1.2    Arch1.n
Feature-1
Feature-2
Feature-N

Now, here is my question. Have we already decided to go with the recommendation that ID-Location architecture should be the next generation of data path?
[KB] Are there any other protocols for consideration beyond Section 7, 8, 9, and 10? If so, they can be added.

Arashmid

From: Bogineni, Kalyani [mailto:[email-masked]]
Sent: 18 January 2018 10:21
To: Arashmid Akhavain <[email-masked]<mailto:[email-masked]>>; Sri Gundavelli (sgundave) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: AshwoodsmithPeter <[email-masked]<mailto:[email-masked]>>; TongWen <[email-masked]<mailto:[email-masked]>>; Bogineni, Kalyani <[email-masked]<mailto:[email-masked]>>
Subject: RE: [DMM] white paper for optimized mobile user plane solutions for 5G

Arashmid:

Kalyani

Hi Sri,

Best regards,
Arashmid Akhavain

Sri

Hi everyone,

Arashmid

Folks:

Kalyani

From: Bogineni, Kalyani

Folks:

Kalyani Bogineni
Verizon

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Thu, 25 Jan 2018 12:46:23 +0000

Sri, Arashmid:

I can host a call to review the requirements documented. It seems like folks would like to understand more before they can
provide feedback and comments.

I can host a call on Monday, January 29th. Can you suggest a time that would work for most time zones? I am located on US
East Coast.

Kalyani

Hi Sri,

Best regards,
Arashmid Akhavain

Sri

Hi everyone,

Arashmid

Folks:

Kalyani

From: Bogineni, Kalyani

Folks:

Kalyani Bogineni
Verizon

---

From: Arashmid Akhavain <[email-masked]>
Date: Thu, 25 Jan 2018 16:02:28 +0000

HI Kalyani,
Yes, a call to better understand the requirement will be great. I asked for some clarifications from CT4 Chair and copied [email-masked]<mailto:[email-masked]>. But didn't get a reply so far. So, a call would definitely help.

I am on Canada East Coast. 10am East Coast usually works for Europe, but might not work for folks in China, Japan, or people on the West Coast.

If people have presentations, I can arrange a WebEx meeting as well. Either way, a call will be very helpful.

Arashmid

Sent: 25 January 2018 07:46

Sri, Arashmid:

Kalyani

Hi Sri,

Best regards,
Arashmid Akhavain

Sri

Hi everyone,

Arashmid

Folks:

Kalyani

From: Bogineni, Kalyani

Folks:

Kalyani Bogineni
Verizon

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Thu, 25 Jan 2018 16:48:47 +0000

Hi Kalyani,

Call sounds great.  Wed or later works for me, but you can pick the day/time based on the feedback from all the interested folks.

Sri

From: "Bogineni, Kalyani" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, January 25, 2018 at 4:46 AM
To: Arashmid Akhavain <[email-masked]<mailto:[email-masked]>>, Sri Gundavelli <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: AshwoodsmithPeter <[email-masked]<mailto:[email-masked]>>, TongWen <[email-masked]<mailto:[email-masked]>>
Subject: RE: [DMM] white paper for optimized mobile user plane solutions for 5G

Sri, Arashmid:

Kalyani

Hi Sri,
Thank you for your reply and clarifications.
I think Kalyani’s work is extremely valuable, but we also need to set an strategy for our reply back to 3GPP. Currently most discussions are about individual protocols such as SRV6, LISP/ILSP, ILNP, ILA, etc. which are really in one form or another a type of ID-Location approach.  I believe we first need to address 3GPP’s request from the architecture point of view, before we dive into implementation details. Is there any discussion around different competing network architectures?

Not sure if you have seen a white paper titled “Evolving 5G Routing” by Docomo, Huawei and others. We also hosted a live webcast demo that shows two LTE slices using ID-Location for data path and distribute ID-Location information to interested eNodeBs via public cloud pub/sub service. The result is very promising and shows the capability of this architecture.

I believe the combination of the white paper and the demo could perhaps serve as a good starting point to get the architecture discussion going and that’s where conference calls can come handy. I agree though let’s start with the mailing list and move to calls next.

Best regards,
Arashmid Akhavain

Sri

Hi everyone,

Arashmid

Folks:

Kalyani

From: Bogineni, Kalyani

Folks:

Kalyani Bogineni
Verizon

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Thu, 25 Jan 2018 17:04:16 +0000

I can host a call on Thursday 1st February at 8:00 - 9:30 AM US ET. I think that works for most folks.
Folks who are interested can let me know and I will set up the WebEx.

Kalyani

From: Sri Gundavelli (sgundave) [mailto:[email-masked]]
Sent: Thursday, January 25, 2018 11:49 AM
To: Bogineni, Kalyani <[email-masked]>; Arashmid Akhavain <[email-masked]>; [email-masked]
Cc: AshwoodsmithPeter <[email-masked]>; TongWen <[email-masked]>
Subject: [E] Re: [DMM] white paper for optimized mobile user plane solutions for 5G

Hi Kalyani,

Sri

Sri, Arashmid:

Kalyani

Hi Sri,

Best regards,
Arashmid Akhavain

Sri

Hi everyone,

Arashmid

Folks:

Kalyani

From: Bogineni, Kalyani

Folks:

Kalyani Bogineni
Verizon

---

From: Arashmid Akhavain <[email-masked]>
Date: Thu, 25 Jan 2018 18:05:44 +0000

Hi Kalyani,
Please add me to the list.

Thanks,
Arashmid

From: Bogineni, Kalyani [mailto:[email-masked]]
Sent: 25 January 2018 12:04
To: Sri Gundavelli (sgundave) <[email-masked]>; Arashmid Akhavain <[email-masked]>; [email-masked]
Cc: AshwoodsmithPeter <[email-masked]>; TongWen <[email-masked]>
Subject: RE: [DMM] white paper for optimized mobile user plane solutions for 5G

Kalyani

To: Bogineni, Kalyani <[email-masked]<mailto:[email-masked]>>; Arashmid Akhavain <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Hi Kalyani,

Sri

Sri, Arashmid:

Kalyani

Hi Sri,

Best regards,
Arashmid Akhavain

Sri

Hi everyone,

Arashmid

Folks:

Kalyani

From: Bogineni, Kalyani

Folks:

Kalyani Bogineni
Verizon

---

From: Arashmid Akhavain <[email-masked]>
Date: Fri, 26 Jan 2018 16:39:43 +0000

Hi Kalyani,
Do you know if anyone from 3GPP will attend?

Arashmid

Kalyani

Hi Kalyani,

Sri

Sri, Arashmid:

Kalyani

Hi Sri,

Best regards,
Arashmid Akhavain

Sri

Hi everyone,

Arashmid

Folks:

Kalyani

From: Bogineni, Kalyani

Folks:

Kalyani Bogineni
Verizon

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Fri, 26 Jan 2018 16:45:09 +0000

Arashmid:

I was going to go through the process I followed to create the requirements in this white paper.

Ideal would be if some of the vendors can invite their SA2/CT4 counterparts to give an overview
of the architecture and of the interfaces/protocols in DMM WG.

Then we can see if what we captured as requirements in the white paper need modification.

Is there any vendor who can volunteer to do that?

Kalyani

Sent: Friday, January 26, 2018 11:40 AM

Hi Kalyani,

Arashmid

To: Sri Gundavelli (sgundave) <[email-masked]<mailto:[email-masked]>>; Arashmid Akhavain <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Kalyani

Hi Kalyani,

Sri

Sri, Arashmid:

Kalyani

Hi Sri,

Best regards,
Arashmid Akhavain

Sri

Hi everyone,

Arashmid

Folks:

Kalyani

From: Bogineni, Kalyani

Folks:

Kalyani Bogineni
Verizon

---

From: Arashmid Akhavain <[email-masked]>
Date: Fri, 26 Jan 2018 19:34:28 +0000

Hi Kalyani,

I like your practical approach. In addition to the vendors though, I think It will help if we could get people from the service providers to
present their point of view as well.  It might take some time though before we get more clarifications from the vendors or carriers.
In the meantime, let's keep going forward with your plan and make modifications as we receive feedback.

Arashmid

Sent: 26 January 2018 11:45

Arashmid:

Kalyani

To: Bogineni, Kalyani <[email-masked]<mailto:[email-masked]>>; Sri Gundavelli (sgundave) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Hi Kalyani,

Arashmid

Kalyani

Hi Kalyani,

Sri

Sri, Arashmid:

Kalyani

Hi Sri,

Best regards,
Arashmid Akhavain

Sri

Hi everyone,

Arashmid

Folks:

Kalyani

From: Bogineni, Kalyani

Folks:

Kalyani Bogineni
Verizon

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Wed, 31 Jan 2018 03:17:19 +0000

Here is the WebEx information to review the requirements for the white paper.

-- Do not delete or change any of the following text. --

Join WebEx meeting<https://verizonone.webex.com/verizonone/j.php?MTID=m4a7177e3858a885e6e746d8e39a5ec88>
Meeting number (access code): 590 108 895
Meeting password: 7326kb

Join from a video system or application
Dial [email-masked]<sip:[email-masked]>

Join by phone
+1-800-365-8460 US Toll Free
+1-210-795-0492 US San Antonio Toll
Global call-in numbers<https://verizonone.webex.com/verizonone/globalcallin.php?serviceType=MC&ED=634564952&tollFree=1>  |  Toll-free calling restrictions<https://www.webex.com/pdf/tollfree_restrictions.pdf>

Can't join the meeting?<https://help.webex.com/docs/DOC-5412>

If you are a host, go here<https://verizonone.webex.com/verizonone/j.php?MTID=m9a37d3d7ae551f2fc9af4c9cfb70f408> to view host information.

IMPORTANT NOTICE: Please note that this WebEx service allows audio and other information sent during the session to be recorded, which may be discoverable in a legal matter. By joining this session, you automatically consent to such recordings. If you do not consent to being recorded, discuss your concerns with the host or do not join the session.

From: dmm [mailto:[email-masked]] On Behalf Of Bogineni, Kalyani
Sent: Thursday, January 25, 2018 12:04 PM
To: Sri Gundavelli (sgundave) <[email-masked]>; Arashmid Akhavain <[email-masked]>; [email-masked]
Cc: TongWen <[email-masked]>; AshwoodsmithPeter <[email-masked]>
Subject: [E] Re: [DMM] white paper for optimized mobile user plane solutions for 5G

Kalyani

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Thu, 1 Feb 2018 04:21:37 +0000

Folks have asked about an architecture with network slices. Here is a sample diagram.
We can review this also on the call to ensure that N9 use cases are covered properly.

I have also attached a powerpoint version.