Subject: Re: [DMM] New Liaison Statement, "CP-173160: New Study Item on User Plane Protocol in 5GC"

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Fri, 6 Jul 2018 17:48:58 +0000

We plan to send the following response to 3GPP CT4.  If you have any quick
comments/corrections/suggestions, please let us know in a day.

³
Thank you for your Liaison request (Reference: CP-173160) and for sharing
the information on the status of the CT4 study item on user-plane protocol
for 5GC. The IETF DMM working group wants to acknowledge your request and
want to share the following update.

IETF DMM working is currently reviewing various proposals on approaches
for realizing optimizations in user-plane for mobile packet core. These
proposals include protocol specifications based on new/existing protocols
and proposals covering requirements/analysis/comparison of various
approaches. At this point of time, some of these documents are working
group documents and some are individual submissions and yet to be adopted
as working group documents.  Based on the working group interest, feedback
charter-scope, the working group may choose to adopt some of these work
items as working group documents and at that time will seek feedback from
3GPP. 

We also would like to state that the DMM working group will not be in a
position to pick a single approach/solution as THE approach for user-plane
optimization. Most likely the working group may standardize more than one
approach, but will characterize each of these approaches based on its
technical capabilities and limitations. This approach would be consistent
with the approach that IETF took with IPv6 transitioning work, where IETF
standardized multiple approaches including DSLite, NAT64, Gi-DSLite and
other approaches. 

Finally, IETF would like to point 3GPP to the following documents under
consideration. 

http://www.ietf.org/id/draft-bogineni-dmm-optimized-mobile-user-plane-01.tx
t (Individual submission)

https://www.ietf.org/internet-drafts/draft-hmm-dmm-5g-uplane-analysis-00.tx
t (Individual submission)

Related Documents:

https://www.ietf.org/id/draft-ietf-dmm-srv6-mobile-uplane-02.txt (Working
group document)

Link to DMM Pages:

https://datatracker.ietf.org/wg/dmm/documents/

Please let us know if you need any additional information.
"

-----

On 4/11/18, 11:16 AM, "Liaison Statement Management Tool" <[email-masked]>
wrote:

>Title: CP-173160: New Study Item on User Plane Protocol in 5GC
>Submission Date: 2018-04-11
>URL of the IETF Web page: https://datatracker.ietf.org/liaison/1572/
>Please reply by 2018-07-20
>From: Satoru Matsushima <[email-masked]>
>To: Sri Gundavelli <[email-masked]>,Dapeng Liu <[email-masked]>
>Cc: Dapeng Liu <[email-masked]>,Terry Manderson
><[email-masked]>,Distributed Mobility Management Discussion
>List <[email-masked]>,Sri Gundavelli <[email-masked]>,Suresh Krishnan
><[email-masked]>
>Response Contacts: [email-masked],[email-masked]
>Technical Contacts:
>Purpose: For action
>
>Body: 1. Overall Description:
>3GPP working group of CT4 (Core and Terminal) would like to inform the
>IETF that CT4 has initiated a study item on user plane protocol in 5GC
>for Release-16 of 5G phase 2 (see CP-173160).
>
>Based on the outcome from the IETF / 3GPP Coordination meeting at
>IETF#100, 3GPP CT4 got aware that IETF DMM WG is currently working on a
>possible candidate protocol for the 3GPP 5G user plane protocol.
>
>3GPP CT4 wants to emphasize that currently there is no related evaluation
>ongoing in 3GPP. Nevertheless, a study item was approved for such a study
>to start in the second half of 2018. The study will evaluate between
>existing solutions within 3GPP and other protocols, based on the Release
>16 stage 2 (system architecture) requirements.
>
>3GPP CT4 would like to point IETF DMM to the following specifications on
>GTP-U. The Release 16 stage 2 requirements are not yet known but it is
>worth looking at latest GTP-U spec which will be evaluated through the
>study as the existing protocol.
>
>€	[1] 3GPP TS 29.281 (V15.1.0): GPRS Tunnelling Protocol User Plane
>(GTPv1-U)
>
>
>Following technical report provides information of how 3GPP considered
>GTP-U apply to user plane of 5G_ph1:
>
>€	[2] 3GPP TR 29.891 (V15.0.0): 5G System  Phase 1; CT4 Aspects
>
>
>Furthermore, 3GPP would like to give the following general guidance to
>IETF DMM, regarding user plane transport within 3GPP networks. These are
>technical specifications that include also the necessary information to
>understand which architectural, QoS, security-related and high-level
>requirements GTP-U currently complies to within 5G_ph1.
>
>€	[3] 3GPP TS 23.501 (V15.0.0): System Architecture for the 5G System
>€	[4] 3GPP TS 23.502 (V15.0.0): Procedures for the 5G System
>€	[5] 3GPP TS 23.503 (V15.0.0): Policy and Charging Framework for the 5G
>System
>€	[6] 3GPP TS 33.501 (V0.6.0): Security Architecture (work in progress)
>
>2. Actions:
>To IETF DMM:
>ACTION: 	CT4 respectfully asks IETF DMM to provide any information that
>may be relevant to the above CT4 work by July 2018.
>
>
>3. Date of Next CT and CT4 Meetings:
>CT4#83	26th Feb  2nd Mar 2018	Montreal, CAN
>CT#79	19th  20th Mar 2018	Chennai, India
>CT4#84	16th  20th April 2018	Kunming, China
>CT4#85	21st  25th May 2018	Osaka, Japan
>CT#80	11th  12th June 2018	La Jolla, USA
>CT4#85-bis	  9th 13th July 2018	TBD, France
>CT4#86	20st  24th Aug 2018	TBD, USA
>Attachments:
>
>    CP-180116
>    
>https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2018-04-11-3gpp-tsgc
>t-ct4-dmm-cp-173160-new-study-item-on-user-plane-protocol-in-5gc-attachmen
>t-1.doc
>

---

From: Arashmid Akhavain <[email-masked]>
Date: Fri, 6 Jul 2018 20:56:52 +0000

Hi Sri,

We might also want to add draft-camarillo-dmm-srv6-mobile-pocs-00
under "Related Documents".

Also, we might want to say something like:
"Although we will NOT pick a particular approach, 
we will be ready to provide further assistance to 3GPP regarding 
the technical details of different candidates."

So, what happens next? We wait for their reply? 

Cheers,
Arashmid

> -----Original Message-----
> From: dmm [mailto:[email-masked]] On Behalf Of Sri Gundavelli
> (sgundave)
> Sent: 06 July 2018 13:49
> To: [email-masked]
> Subject: Re: [DMM] New Liaison Statement, "CP-173160: New Study Item on
> User Plane Protocol in 5GC"
> 
> for 5GC. The IETF DMM working group wants to acknowledge your request
> and want to share the following update.
> 
> group documents and some are individual submissions and yet to be
> adopted as working group documents.  Based on the working group interest,
> feedback charter-scope, the working group may choose to adopt some of
> these work items as working group documents and at that time will seek
> feedback from 3GPP.
> 
> technical capabilities and limitations. This approach would be consistent with
> the approach that IETF took with IPv6 transitioning work, where IETF
> >Submission Date: 2018-04-11 URL of the IETF Web page:
> >https://datatracker.ietf.org/liaison/1572/
> ><[email-masked]> Response Contacts:
> >[email-masked],[email-masked]
> >Technical Contacts:
> >Purpose: For action
> >
> >3GPP CT4 wants to emphasize that currently there is no related
> >evaluation ongoing in 3GPP. Nevertheless, a study item was approved for
> >such a study to start in the second half of 2018. The study will
> >evaluate between existing solutions within 3GPP and other protocols,
> >based on the Release
> >3GPP CT4 would like to point IETF DMM to the following specifications
> >on GTP-U. The Release 16 stage 2 requirements are not yet known but it
> >is worth looking at latest GTP-U spec which will be evaluated through
> >the study as the existing protocol.
> >
> >IETF DMM, regarding user plane transport within 3GPP networks. These
> >are technical specifications that include also the necessary
> >information to understand which architectural, QoS, security-related
> >and high-level requirements GTP-U currently complies to within 5G_ph1.
> >
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Sat, 7 Jul 2018 06:25:28 +0000

Hi Arashmid,

Thanks for the feedback.

I have added a link to the DMM WG pages and it has links to all the DMM
documents. I think that should be OK, we don’t have to explicitly list out
every single I-D at this stage. As we move forward and based on WG
discussions/progress, we can provide more detailed feedback on each
document. I suggest we keep this simple for now.

> So, what happens next? We wait for their reply?

This is just a response to the LS; more an information exchange on the
status/progress.

Regards
Sri

---

From: Arashmid Akhavain <[email-masked]>
Date: Sun, 8 Jul 2018 21:14:52 +0000

Hi Sri,
Thank you for the reply. Pablo's draft is rather different as it describes the two POCs addressing the mobile core data plane.
Referencing the POCs in the LS can help put things into perspective and sort of backs up all the analysis work that everyone have been involved in for the last while.

I agree, we do want to keep it simple, but the POCs can certainly add to the strength of the LS.

Regards,
Arashmid

-----Original Message-----
From: Sri Gundavelli (sgundave) [mailto:[email-masked]] 
Sent: Saturday, July 07, 2018 2:25 AM
To: Arashmid Akhavain <[email-masked]>; [email-masked]
Subject: Re: New Liaison Statement, "CP-173160: New Study Item on User Plane Protocol in 5GC"

Hi Arashmid,

Thanks for the feedback.

I have added a link to the DMM WG pages and it has links to all the DMM documents. I think that should be OK, we don’t have to explicitly list out every single I-D at this stage. As we move forward and based on WG discussions/progress, we can provide more detailed feedback on each document. I suggest we keep this simple for now.

> So, what happens next? We wait for their reply?

This is just a response to the LS; more an information exchange on the status/progress.

Regards
Sri

On 7/6/18, 1:56 PM, "Arashmid Akhavain" <[email-masked]>
wrote:

>"Although we will NOT pick a particular approach, we will be ready to 
>provide further assistance to 3GPP regarding the technical details of 
>different candidates."
>
>> Subject: Re: [DMM] New Liaison Statement, "CP-173160: New Study Item 
>> on User Plane Protocol in 5GC"
>> 
>> We plan to send the following response to 3GPP CT4.  If you have any 
>>quick  comments/corrections/suggestions, please let us know in a day.
>> 
>> 
>> 
>> ³
>> Thank you for your Liaison request (Reference: CP-173160) and for 
>>sharing  the information on the status of the CT4 study item on 
>>user-plane protocol  for 5GC. The IETF DMM working group wants to 
>>acknowledge your request  and want to share the following update.
>> 
>> IETF DMM working is currently reviewing various proposals on 
>>approaches  for realizing optimizations in user-plane for mobile 
>>packet core. These  proposals include protocol specifications based on 
>>new/existing protocols  and proposals covering 
>>requirements/analysis/comparison of various  approaches. At this point 
>>of time, some of these documents are working  group documents and some 
>>are individual submissions and yet to be  adopted as working group 
>>documents.  Based on the working group interest,  feedback 
>>charter-scope, the working group may choose to adopt some of  these 
>>work items as working group documents and at that time will seek  
>>feedback from 3GPP.
>> 
>> We also would like to state that the DMM working group will not be in 
>>a  position to pick a single approach/solution as THE approach for 
>>user-plane  optimization. Most likely the working group may 
>>standardize more than one  approach, but will characterize each of 
>>these approaches based on its  technical capabilities and limitations. 
>>This approach would be consistent with  the approach that IETF took 
>>with IPv6 transitioning work, where IETF  standardized multiple 
>>approaches including DSLite, NAT64, Gi-DSLite and  other approaches.
>> 
>> Finally, IETF would like to point 3GPP to the following documents 
>> under consideration.
>> 
>> http://www.ietf.org/id/draft-bogineni-dmm-optimized-mobile-user-plane
>> -
>> 01.tx
>> https://www.ietf.org/internet-drafts/draft-hmm-dmm-5g-uplane-analysis
>> -
>> 00.tx
>> >3GPP working group of CT4 (Core and Terminal) would like to inform 
>> >the IETF that CT4 has initiated a study item on user plane protocol 
>> >in 5GC for Release-16 of 5G phase 2 (see CP-173160).
>> >
>> >IETF#100, 3GPP CT4 got aware that IETF DMM WG is currently working 
>> >on a possible candidate protocol for the 3GPP 5G user plane protocol.
>> >
>> >evaluation ongoing in 3GPP. Nevertheless, a study item was approved 
>> >for such a study to start in the second half of 2018. The study will 
>> >3GPP CT4 would like to point IETF DMM to the following 
>> >specifications on GTP-U. The Release 16 stage 2 requirements are not 
>> >yet known but it is worth looking at latest GTP-U spec which will be 
>> >evaluated through the study as the existing protocol.
>> >
>> >Following technical report provides information of how 3GPP 
>> >considered GTP-U apply to user plane of 5G_ph1:
>> >
>> >Furthermore, 3GPP would like to give the following general guidance 
>> >to IETF DMM, regarding user plane transport within 3GPP networks. 
>> >These are technical specifications that include also the necessary 
>> >https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2018-04-11-3gp
>> >p-t
>> >sgc
>> >t-ct4-dmm-cp-173160-new-study-item-on-user-plane-protocol-in-5gc-att
>> >ach
>> >men
>> >t-1.doc
>> >
>>

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Sun, 8 Jul 2018 23:28:38 +0000

Hi Arashmid,

We were trying to avoid this debate on inclusion/exclusions of individual
I-D’s, but looks like we are just doing that. That is fine. Lets review
the situation.

The approach on what documents to be explicitly listed is based on the
following principles.

#1 Provide references to DMM WG documents that have any relation to the
study item in 5GC. 
#2 Include references to individual I-D’s that have done broader
requirement/solution analysis/comparative study on the topic of mobile
user plane optimization; documents that are not advocating a specific
solution. We also wanted to apply the constraint of documents that have
had substantial discussions in the working group. In other words,
documents that were reviewed by the WG and received significantly high
number of comments.

For #1: we have included draft-ietf-dmm-srv6-mobile-uplane-02.txt, as its
a WG document on track for standardization.

For #2: we have included draft-bogineni as there were many
discussions/presentations/conference calls on that draft. We have also
included draft-hmm-dmm-5g-uplane-analysis-00, but however this draft was
published recently and had near zero discussions in the WG. But given the
quality of the document and noting that its about requirement analysis and
as its not advocating a specific solution, we chose to keep this document
in the list. 

We have not included any other I-D’s which have not had enough discussions
and which are solution specific documents. Not that we have not
established the draft applicability to the 3GPP study item. These include:
 	
draft-auge-dmm-hicn-mobility-00, 	
draft-auge-dmm-hicn-mobility-deployment-options-00, 	
draft-camarillo-dmm-srv6-mobile-pocs-00, 	
draft-gundavelli-dmm-mfa-00
draft-homma-dmm-5gs-id-loc-coexistence-01,

Now, if this sounds unreasonable or unfair, we have two options.

#1 Remove references to all individual drafts and only include WG
documents 
#2: Include every single I-D (WG and non WG) documents.

All - Please comment.

Sri

On 7/8/18, 2:14 PM, "Arashmid Akhavain" <[email-masked]>
wrote:

>Hi Sri,
>Thank you for the reply. Pablo's draft is rather different as it
>describes the two POCs addressing the mobile core data plane.
>Referencing the POCs in the LS can help put things into perspective and
>sort of backs up all the analysis work that everyone have been involved
>in for the last while.
>
>documents. I think that should be OK, we don’t have to explicitly list
>out every single I-D at this stage. As we move forward and based on WG

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Mon, 9 Jul 2018 11:29:36 +0000

Sri:

During the last DMM WG meeting at IETF 101, there were several comments about 3GPP and IETF collaborating
on this analysis. Even though the 3GPP study on potential replacement for GTP as user plane protocol triggered this
discussion in IETF, there are several aspects that need to be considered in network evolution towards 5G that
have been brought up in this Forum: user plane optimization of different kinds (reduced packet overhead, line rate
degradation, session state reduction, others); anchor-less mobility; privacy/security; scalability; etc. There were
also comments about getting feedback from 3GPP regarding evaluation criteria and the candidate protocols.
draft-hmm-dmm-5g-uplane-analysis-00 tries to capture criteria based on analysis by some companies. 3GPP
could point us to other documents if available that will allow IETF to compare the candidate protocols, if appropriate.
That feedback would help IETF to allocate time/resources to progress the right candidate protocols. The LS
response can mention these aspects.

Regarding individual protocol drafts/documents, the LS can mention that the different candidate protocols
are in different stages of progress (some in WG document state, some as individual documents, etc.) based
on the requirements in IETF. The draft-bogineni document has provided all the references. This point can
be mentioned and avoid the need to explicitly mention them in the LS. 

Kalyani

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of Sri Gundavelli (sgundave)
Sent: Sunday, July 8, 2018 7:29 PM
To: Arashmid Akhavain <[email-masked]>; [email-masked]
Subject: [E] Re: [DMM] New Liaison Statement, "CP-173160: New Study Item on User Plane Protocol in 5GC"

Hi Arashmid,

We were trying to avoid this debate on inclusion/exclusions of individual I-D’s, but looks like we are just doing that. That is fine. Lets review the situation.

The approach on what documents to be explicitly listed is based on the following principles.

#1 Provide references to DMM WG documents that have any relation to the study item in 5GC. 
#2 Include references to individual I-D’s that have done broader requirement/solution analysis/comparative study on the topic of mobile user plane optimization; documents that are not advocating a specific solution. We also wanted to apply the constraint of documents that have had substantial discussions in the working group. In other words, documents that were reviewed by the WG and received significantly high number of comments.

For #1: we have included draft-ietf-dmm-srv6-mobile-uplane-02.txt, as its a WG document on track for standardization.

For #2: we have included draft-bogineni as there were many discussions/presentations/conference calls on that draft. We have also included draft-hmm-dmm-5g-uplane-analysis-00, but however this draft was published recently and had near zero discussions in the WG. But given the quality of the document and noting that its about requirement analysis and as its not advocating a specific solution, we chose to keep this document in the list. 

We have not included any other I-D’s which have not had enough discussions and which are solution specific documents. Not that we have not established the draft applicability to the 3GPP study item. These include:

#1 Remove references to all individual drafts and only include WG documents
#2: Include every single I-D (WG and non WG) documents.

All - Please comment.

Sri

On 7/8/18, 2:14 PM, "Arashmid Akhavain" <[email-masked]>
wrote:

>>> https://urldefense.proofpoint.com/v2/url?u=http-3A__www.ietf.org_id_draft-2Dbogineni-2Ddmm-2Doptimized-2Dmobile-2Duser-2Dplane&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=N9JJ3kCdvEYYv5mUvHyejAsgOeEBhX_ItxxAAty2mqg&s=xpTWFIfi0s3QsTIph60UP67Z2eWDvinI_xN0ZjJPiHE&e=
>>> -
>>> 01.tx
>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_internet-2Ddrafts_draft-2Dhmm-2Ddmm-2D5g-2Duplane-2Danalysis&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=N9JJ3kCdvEYYv5mUvHyejAsgOeEBhX_ItxxAAty2mqg&s=2WqUl7p7jLcWgCmO2EQotABLovqcO8t0T0dq9LTV398&e=
>>> -
>>> 00.tx
>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_id_draft-2Dietf-2Ddmm-2Dsrv6-2Dmobile-2Duplane-2D02.txt&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=N9JJ3kCdvEYYv5mUvHyejAsgOeEBhX_ItxxAAty2mqg&s=qo58N-p2j4kEchDNNAZlkv3yeuPexcK86GP7QIjWdCY&e=
>>>(Working
>>> group document)
>>> 
>>> 
>>> Link to DMM Pages:
>>> 
>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_wg_dmm_documents_&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=N9JJ3kCdvEYYv5mUvHyejAsgOeEBhX_ItxxAAty2mqg&s=KCifng4u9Y_y0KG9gerBDHSlBdKdl7Z-EI4RlPzgYNc&e=
>>> 
>>> 
>>> 
>>> >https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_liaison_1572_&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=N9JJ3kCdvEYYv5mUvHyejAsgOeEBhX_ItxxAAty2mqg&s=5_z2D01JeUbF2pQvB8_hq7G0F_24_CGEJmtaPggwjbc&e=
>>> >https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_lib_dt_documents_LIAISON_liaison-2D2018-2D04-2D11-2D3gp&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=N9JJ3kCdvEYYv5mUvHyejAsgOeEBhX_ItxxAAty2mqg&s=Fg50aPytwdLUcPd1f1oNpo_DZO8KMDWApW8YqStkp1Q&e=
>>> >p-t
>>> >sgc
>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_dmm&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=N9JJ3kCdvEYYv5mUvHyejAsgOeEBhX_ItxxAAty2mqg&s=72LdUYLwOA8NcXdinwsRTB9JDm9jz8XROTBEOx3WtyU&e=
>

_______________________________________________
dmm mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_dmm&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=N9JJ3kCdvEYYv5mUvHyejAsgOeEBhX_ItxxAAty2mqg&s=72LdUYLwOA8NcXdinwsRTB9JDm9jz8XROTBEOx3WtyU&e=

---

From: Arashmid Akhavain <[email-masked]>
Date: Mon, 9 Jul 2018 14:23:29 +0000

Hi Sri,

Thank you for your clarifying email. The POC draft talks about the SRv6 demos and I can see how it can be seen as a
document advocating a particular solution strategy. 
So, I agree that we should stay away from specific POCs and drafts in the LS. Having said that however,
I think a general statement about proof of concepts can help the cause. 

At this point I think it is more important to discuss the GAPs in existing system rather than focusing on different
solutions. That's why I really like what draft-hmm-dmm-5g-uplane-analysis-00 is trying to do.

Cheers,
Arashmid

> Sent: 08 July 2018 19:29
> We were trying to avoid this debate on inclusion/exclusions of individual I-
> D’s, but looks like we are just doing that. That is fine. Lets review the
> situation.
> 
> requirement/solution analysis/comparative study on the topic of mobile user
> plane optimization; documents that are not advocating a specific solution.
> We also wanted to apply the constraint of documents that have had
> substantial discussions in the working group. In other words, documents that
> were reviewed by the WG and received significantly high number of
> comments.
> 
> 
> For #1: we have included draft-ietf-dmm-srv6-mobile-uplane-02.txt, as its a
> WG document on track for standardization.
> 
> as its not advocating a specific solution, we chose to keep this document in
> the list.
> 
> and which are solution specific documents. Not that we have not established
> the draft applicability to the 3GPP study item. These include:
>

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Mon, 9 Jul 2018 15:50:46 +0000

Hi Arashmid/Kalyani,

Thank you both for your feedback.

Yes, we thought its better to keep the focus on problem statement and
requirement analysis. We don’t want to prematurely high-light any solution
documents to SDO. Which did not go through proper review process, as it
will only result in confusing them.

> Having said that however, I think a general statement about proof of
>concepts can help the cause.

The current text provides an high-level update and status on where the WG
is going, and a also a pointer to all documents under review. I am
personally not keen on making additional edits, unless you guys think the
change is absolutely needed and will make a difference in CT4 discussion.
So, if you are keen on seeing any such changes, please propose the exact
text. But, if you have no objections to the current response, we can let
this go. In future liaisons we can have detailed technical exchanges.

Sri

On 7/9/18, 7:23 AM, "Arashmid Akhavain" <[email-masked]>
wrote:

>Hi Sri,
>
>Thank you for your clarifying email. The POC draft talks about the SRv6
>demos and I can see how it can be seen as a
>At this point I think it is more important to discuss the GAPs in
>existing system rather than focusing on different
>solutions. That's why I really like what
>draft-hmm-dmm-5g-uplane-analysis-00 is trying to do.
>
>Cheers,
>Arashmid
> 	
>
>>user
>>established
>> >I agree, we do want to keep it simple, but the POCs can certainly add
>>to
>> >the strength of the LS.
>> >
>> >Regards,
>> >Arashmid
>> >
>> >>> >€	[5] 3GPP TS 23.503 (V15.0.0): Policy and Charging Framework for
>>the
>> >>> 5G
>> >>> >System

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Mon, 9 Jul 2018 16:41:05 +0000

Sri:

Here is one edit in the last sentence to allow IETF to take feedback from 3GPP:

"Please let us know if you need any additional information. Also please provide any evaluation criteria that
could help us in progressing our work to support 5G."

Kalyani

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of Sri Gundavelli (sgundave)
Sent: Monday, July 9, 2018 11:51 AM
To: Arashmid Akhavain <[email-masked]>; [email-masked]
Subject: [E] Re: [DMM] New Liaison Statement, "CP-173160: New Study Item on User Plane Protocol in 5GC"

Hi Arashmid/Kalyani,

Yes, we thought its better to keep the focus on problem statement and requirement analysis. We don’t want to prematurely high-light any solution documents to SDO. Which did not go through proper review process, as it will only result in confusing them.

>concepts can help the cause.

The current text provides an high-level update and status on where the WG is going, and a also a pointer to all documents under review. I am personally not keen on making additional edits, unless you guys think the change is absolutely needed and will make a difference in CT4 discussion.
So, if you are keen on seeing any such changes, please propose the exact text. But, if you have no objections to the current response, we can let this go. In future liaisons we can have detailed technical exchanges.

Sri

On 7/9/18, 7:23 AM, "Arashmid Akhavain" <[email-masked]>
wrote:

>demos and I can see how it can be seen as a document advocating a 
>particular solution strategy.
>So, I agree that we should stay away from specific POCs and drafts in 
>the LS. Having said that however, I think a general statement about 
>proof of concepts can help the cause.
>
>existing system rather than focusing on different solutions. That's why 
>I really like what
>> We were trying to avoid this debate on inclusion/exclusions of 
>>individual I-  D’s, but looks like we are just doing that. That is 
>>fine. Lets review the  situation.
>> 
>>solution.
>>substantial discussions in the working group. In other words, 
>>documents that  were reviewed by the WG and received significantly 
>>high number of  comments.
>> 
>> 
>> For #1: we have included draft-ietf-dmm-srv6-mobile-uplane-02.txt, as 
>>its a  WG document on track for standardization.
>> 
>>included draft-hmm-dmm-5g-uplane-analysis-00, but however this draft 
>>was  published recently and had near zero discussions in the WG. But 
>>given the  quality of the document and noting that its about 
>>requirement analysis and  as its not advocating a specific solution, 
>>we chose to keep this document in  the list.
>> 
>> We have not included any other I-D’s which have not had enough 
>>discussions  and which are solution specific documents. Not that we 
>>have not established  the draft applicability to the 3GPP study item. 
>>These include:
>> 
>> >Referencing the POCs in the LS can help put things into perspective 
>> >and sort of backs up all the analysis work that everyone have been 
>> >involved in for the last while.
>> >
>> >I have added a link to the DMM WG pages and it has links to all the 
>> >DMM documents. I think that should be OK, we don’t have to 
>> >explicitly list out every single I-D at this stage. As we move 
>> >forward and based on WG discussions/progress, we can provide more 
>> >detailed feedback on each document. I suggest we keep this simple for now.
>> >
>> >
>> >
>> >>"Although we will NOT pick a particular approach, we will be ready 
>> >>to provide further assistance to 3GPP regarding the technical 
>> >>details of different candidates."
>> >>
>> >>> Subject: Re: [DMM] New Liaison Statement, "CP-173160: New Study 
>> >>> Item on User Plane Protocol in 5GC"
>> >>>
>> >>> We plan to send the following response to 3GPP CT4.  If you have 
>> >>>any quick  comments/corrections/suggestions, please let us know in a day.
>> >>>
>> >>>
>> >>>
>> >>> ³
>> >>>packet core. These  proposals include protocol specifications 
>> >>>based
>>on
>> >>>charter-scope, the working group may choose to adopt some of  
>> >>>these work items as working group documents and at that time will 
>> >>>seek feedback from 3GPP.
>> >>>
>> >>> We also would like to state that the DMM working group will not 
>> >>> be
>>in
>> >>>This approach would be consistent with  the approach that IETF 
>> >>>took with IPv6 transitioning work, where IETF  standardized 
>> >>>multiple approaches including DSLite, NAT64, Gi-DSLite and  other approaches.
>> >>>
>> >>> https://urldefense.proofpoint.com/v2/url?u=http-3A__www.ietf.org_
>> >>> id_draft-2Dbogineni-2Ddmm-2Doptimized-2Dmobile-2Duser-2D&d=DwIGaQ
>> >>> &c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeG
>> >>> gd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=2P43xC8rAQdTzO
>> >>> xlE8TFN4JHtDNiS3-Bla-NW2dy5Uc&s=7RmBb1eJcy68WgzP737vKuNKmsGjjWUmb
>> >>> ENKWvLWLJY&e=
>> plane
>> >>> -
>> >>> 01.tx
>> >>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org
>> >>> _internet-2Ddrafts_draft-2Dhmm-2Ddmm-2D5g-2Duplane-2D&d=DwIGaQ&c=
>> >>> udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9
>> >>> MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=2P43xC8rAQdTzOxlE
>> >>> 8TFN4JHtDNiS3-Bla-NW2dy5Uc&s=_QrVEL6buvQq2wBhoWgfcFZKIJLyrfZDYEwC
>> >>> 6mO-CFo&e=
>> analysis
>> >>> -
>> >>> 00.tx
>> >>>https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_
>> >>>id_draft-2Dietf-2Ddmm-2Dsrv6-2Dmobile-2Duplane-2D02.txt&d=DwIGaQ&c
>> >>>=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9
>> >>>MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=2P43xC8rAQdTzOxlE8
>> >>>TFN4JHtDNiS3-Bla-NW2dy5Uc&s=s5Mrhsk2KGDvDJYa2umatkWJhLp7OQnN-rehy2
>> >>>P6CfM&e=
>> >>>(Working
>> >>> group document)
>> >>>
>> >>>
>> >>> Link to DMM Pages:
>> >>>
>> >>> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.
>> >>> ietf.org_wg_dmm_documents_&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ
>> >>> 3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47o
>> >>> ilzaXYRYETcBynUdpT&m=2P43xC8rAQdTzOxlE8TFN4JHtDNiS3-Bla-NW2dy5Uc&
>> >>> s=fbdx74z160V0ofF_QGl3zisnC1lGoz-ix8hnyN5FW94&e=
>> >>>
>> >>>
>> >>>
>> >>> >https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker
>> >>> >.ietf.org_liaison_1572_&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3L
>> >>> >Rxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oi
>> >>> >lzaXYRYETcBynUdpT&m=2P43xC8rAQdTzOxlE8TFN4JHtDNiS3-Bla-NW2dy5Uc&
>> >>> >s=2EW4NXxag3StwsHSo-kLf1TVYy91iIrLG36RP93FC4A&e=
>> >>> >3GPP working group of CT4 (Core and Terminal) would like to 
>> >>> >inform the IETF that CT4 has initiated a study item on user 
>> >>> >plane protocol in 5GC for Release-16 of 5G phase 2 (see CP-173160).
>> >>> >
>> >>> >Based on the outcome from the IETF / 3GPP Coordination meeting 
>> >>> >at IETF#100, 3GPP CT4 got aware that IETF DMM WG is currently 
>> >>> >working on a possible candidate protocol for the 3GPP 5G user 
>> >>> >plane
>>protocol.
>> >>> >
>> >>> >evaluation ongoing in 3GPP. Nevertheless, a study item was 
>> >>> >approved for such a study to start in the second half of 2018. 
>> >>> >The study
>>will
>> >>> >yet known but it is worth looking at latest GTP-U spec which 
>> >>> >will
>>be
>> >>> >Furthermore, 3GPP would like to give the following general 
>> >>> >guidance to IETF DMM, regarding user plane transport within 3GPP networks.
>> >>> >These are technical specifications that include also the 
>> >>> >necessary information to understand which architectural, QoS,
>>security-related
>> >>> >https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.or
>> >>> >g_lib_dt_documents_LIAISON_liaison-2D2018-2D04-2D11-2D&d=DwIGaQ&
>> >>> >c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeG
>> >>> >gd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=2P43xC8rAQdTz
>> >>> >OxlE8TFN4JHtDNiS3-Bla-NW2dy5Uc&s=7a5vvBhjxirYnfOGe1Ybd3Cw_dkvUOR
>> >>> >MXVmz7rGOz1o&e=
>> 3gp
>> >>> >p-t
>> >>> >sgc
>> >>> >t-ct4-dmm-cp-173160-new-study-item-on-user-plane-protocol-in-5gc
>> >>> >-
>> att
>> >>> >ach
>> >>> >men
>> >>> >t-1.doc
>> >>> >
>> >>>
>> >>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org
>> >>> _mailman_listinfo_dmm&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxp
>> >>> b6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaX
>> >>> YRYETcBynUdpT&m=2P43xC8rAQdTzOxlE8TFN4JHtDNiS3-Bla-NW2dy5Uc&s=Xoj
>> >>> mbv_pldmDBAq78n8x2Q1nER3sJkwnAWTknTrtyQg&e=
>> >
>

_______________________________________________
dmm mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_dmm&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=2P43xC8rAQdTzOxlE8TFN4JHtDNiS3-Bla-NW2dy5Uc&s=Xojmbv_pldmDBAq78n8x2Q1nER3sJkwnAWTknTrtyQg&e=

---

From: Arashmid Akhavain <[email-masked]>
Date: Mon, 9 Jul 2018 17:19:53 +0000

Hi Sri,

A minor addition to the end of this sentence would perhaps do the trick.

These proposals include protocol specifications based on new/existing protocols, proposals covering requirements/analysis/comparison of various approaches, and building proof of concept demos.

Arashmid

> Sent: 09 July 2018 11:51
> is going, and a also a pointer to all documents under review. I am personally
> not keen on making additional edits, unless you guys think the change is
> absolutely needed and will make a difference in CT4 discussion.
> text. But, if you have no objections to the current response, we can let this
> go. In future liaisons we can have detailed technical exchanges.
> 
> 
> Sri
> 
> 
> 
> >> >>> >ACTION: 	CT4 respectfully asks IETF DMM to provide any
> information
> >> >>> that
> >> >>> >https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2018-04-11
> >> >>> >-
> >> 3gp
> >> >>> >p-t
> >> >>> >sgc

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Mon, 9 Jul 2018 17:35:49 +0000

Ok!  Thank you Kalyani and Arashmid.

Change-1: Add to the last sentence.

"Also please provide any evaluation criteria that could help us in progressing our work to support 5G."

Change-2: Add to the second sentence, of second paragraph

+ “ and building proof of concept demos."

Now, I need to pull this back for edits. Let me do that.  I hope this makes a difference in CT4 discussions.

All - Let us know if you have any issue with these additions, or to the original proposed text.

Sri

On 7/9/18, 9:41 AM, "Bogineni, Kalyani" <[email-masked]<mailto:[email-masked]>> wrote:

Sri:

Kalyani

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of Sri Gundavelli (sgundave)
Sent: Monday, July 9, 2018 11:51 AM
To: Arashmid Akhavain <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [E] Re: [DMM] New Liaison Statement, "CP-173160: New Study Item on User Plane Protocol in 5GC"

Hi Arashmid/Kalyani,

Sri

On 7/9/18, 7:23 AM, "Arashmid Akhavain" <[email-masked]<mailto:[email-masked]>>
wrote:

Hi Sri,

Cheers,
Arashmid

-----Original Message-----
From: Sri Gundavelli (sgundave) [mailto:[email-masked]]
Sent: 08 July 2018 19:29
To: Arashmid Akhavain <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: New Liaison Statement, "CP-173160: New Study Item on
The approach on what documents to be explicitly listed is based on
the following principles.
#1 Provide references to DMM WG documents that have any relation to
the  study item in 5GC.
On 7/8/18, 2:14 PM, "Arashmid Akhavain"
<[email-masked]<mailto:[email-masked]>>
to
>To: Arashmid Akhavain <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
>On 7/6/18, 1:56 PM, "Arashmid Akhavain"
<[email-masked]<mailto:[email-masked]>>
>>> To: [email-masked]<mailto:[email-masked]>
on
in
plane
analysis
>>> On 4/11/18, 11:16 AM, "Liaison Statement Management Tool"
>>> <[email-masked]<mailto:[email-masked]>>
>>> wrote:
>>>
>>> >From: Satoru Matsushima <[email-masked]<mailto:[email-masked]>>
>>> >To: Sri Gundavelli <[email-masked]<mailto:[email-masked]>>,Dapeng Liu
>>> ><[email-masked]<mailto:[email-masked]>>
>>> >Cc: Dapeng Liu <[email-masked]<mailto:[email-masked]>>,Terry Manderson
>>> ><[email-masked]<mailto:[email-masked]>>,Distributed Mobility Management
>>> Discussion
>>> >List <[email-masked]<mailto:[email-masked]>>,Sri Gundavelli <[email-masked]<mailto:[email-masked]>>,Suresh
>>> Krishnan
>>> ><[email-masked]<mailto:[email-masked]>> Response Contacts:
>>> >[email-masked]<mailto:[email-masked]>,[email-masked]<mailto:[email-masked]>
>>> >Technical Contacts:
>>> >Purpose: For action
>>> >
protocol.
will
be
security-related
the
3gp
att
>>> [email-masked]<mailto:[email-masked]>

_______________________________________________
dmm mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_dmm&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=2P43xC8rAQdTzOxlE8TFN4JHtDNiS3-Bla-NW2dy5Uc&s=Xojmbv_pldmDBAq78n8x2Q1nER3sJkwnAWTknTrtyQg&e=

---

From: Arashmid Akhavain <[email-masked]>
Date: Mon, 9 Jul 2018 17:39:32 +0000

Thank you Sri,
I sure hope that we can make a difference too.

Arashmid

From: Sri Gundavelli (sgundave) [mailto:[email-masked]]
Sent: 09 July 2018 13:36
To: Bogineni, Kalyani <[email-masked]>; Arashmid Akhavain <[email-masked]>; [email-masked]
Subject: Re: New Liaison Statement, "CP-173160: New Study Item on User Plane Protocol in 5GC"

Sri

Sri:

Kalyani

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of Sri Gundavelli (sgundave)
Sent: Monday, July 9, 2018 11:51 AM
To: Arashmid Akhavain <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [E] Re: [DMM] New Liaison Statement, "CP-173160: New Study Item on User Plane Protocol in 5GC"

Hi Arashmid/Kalyani,

Sri

Hi Sri,

Cheers,
Arashmid

-----Original Message-----
From: Sri Gundavelli (sgundave) [mailto:[email-masked]]
Sent: 08 July 2018 19:29
To: Arashmid Akhavain <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: New Liaison Statement, "CP-173160: New Study Item on
to
on
in
plane
analysis
protocol.
will
be
security-related
the
3gp
att