Subject: [DMM] I-D Action: draft-ietf-dmm-srv6-mobile-uplane-04.txt

From: [email-masked]
Date: Mon, 11 Mar 2019 13:12:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Distributed Mobility Management WG of the IETF.

        Title           : Segment Routing IPv6 for Mobile User Plane
        Authors         : Satoru Matsushima
                          Clarence Filsfils
                          Miya Kohno
                          Pablo Camarillo Garvia
                          Daniel Voyer
                          Charles E. Perkins
	Filename        : draft-ietf-dmm-srv6-mobile-uplane-04.txt
	Pages           : 28
	Date            : 2019-03-11

Abstract:
   This document shows the applicability of SRv6 (Segment Routing IPv6)
   to the user-plane of mobile networks.  The network programming nature
   of SRv6 accomplish mobile user-plane functions in a simple manner.
   The statelessness of SRv6 and its ability to control both service
   layer path and underlying transport can be beneficial to the mobile
   user-plane, providing flexibility and SLA control for various
   applications.  This document describes the SRv6 mobile user plane
   behavior and defines the SID functions for that.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dmm-srv6-mobile-uplane/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dmm-srv6-mobile-uplane-04
https://datatracker.ietf.org/doc/html/draft-ietf-dmm-srv6-mobile-uplane-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dmm-srv6-mobile-uplane-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Sridhar Bhaskaran <[email-masked]>
Date: Tue, 12 Mar 2019 05:47:16 +0000

Dear authors,

I have the following comments on the draft.
 
1. Section 4. The following statement is not clear

>> The user plane described in this document does not depend on any
   specific architecture.

What does "this document" mean here? The previous paragraph talks about TS 23.501. Does "this" document mean 23.501 or this IETF draft?

2. If "this document" meant 23.501, then the statement " does not depend on any specific architecture" is incorrect. 3GPP TS 23.501 requires, the packet detection and forwarding rules at every UPF in the forwarding path be controlled via N4. See TS 23.501 clause 5.8.2.4.1

******
The SMF is responsible for instructing the UP function about how to detect user data traffic belonging to a Packet Detection Rule (PDR). The other parameters provided within a PDR describe how the UP function shall treat a packet that matches the detection information.
*****

3. Section 4 - the following statement is not accurate

Sometimes multiple
   UPFs may be used, providing richer service functions.  A UE gets its
   IP address from the DHCP block of its UPF.

IP address allocation is not always by way of DHCP. A UPF may serve an IP pool and SMF may assign IP address to UE from the pool. Suggest to change it as "A UE gets its IP address via N1 SM NAS signaling from the SMF. The IP address management mechanism is specified in clause 5.8.2.2 of 3GPP TS 23.501"

4. Throughout the document there is this term "UE session" repeating. Its better to clarify that this refers to "UE PDU Session".

5. Section 5.1.1

         gNB_out : (gNB, U1::1) (A,Z)     -> T.Encaps.Red <U1::1>
         UPF1_out: (gNB, U2::1) (A,Z)     -> End.MAP

Also note that the conventions in section 2.2 says:

   *  U1::1 is an IPv6 address (SID) assigned to UPF1.
   o  U2::1 is an IPv6 address (SID) assigned to UPF2.

a. How does UPF1 identify the N4 session related to the UE PDU session? 
b. Does End.MAP function provide a PDU session specific mapping? 
c. Since U1::1 and U2::1 are just IPv6 addresses as specified in section 2.2, how does the UPF1 and UPF2 use it to identify the PDU session specific forwarding / packet handling rules?

6. Same question as above for downlink direction - in section 5.1.2
7. Section 5.2.1

gNB_out : (gNB, S1)(U2::1, C1; SL=2)(A,Z)-> T.Encaps.Red<S1,C1,U2::1>

If I understand correctly in enhanced mode, you propose to insert SID list. 

a. Isn't the SID list part of SRH? 
b. If so, why use T.Encaps.Red which is defined as encapsulation without SRH insertion? 
c. Aren't U2::1 and C1 part of the SID list?
d. How does UPF 2 identify the N4 session related to the UE PDU session?

8. Section 5.2.2

   UPF2_in : (Z,A)                              -> UPF2 maps the flow w/
                                                   SID list <C1,S1, gNB>
   UPF2_out: (U2::1, C1)(gNB, S1; SL=2)(Z,A)    -> T.Encaps.Red

First step talks about UPF 2 inserting SID list while second step talks about using T.Encaps.Red which is a function that does not insert SRH. So how is SID list inserted into the packet?
All other questions raised in /7/ above hold here as well.

9. Section 5.3.1

o  The SRGW removes GTP, finds the SID list related to DA, and adds
      SRH with the SID list.

Does the SID list added here only contain UPF or SR node addresses? How does each UPF in the SID list identify the specific N4 session related to the PDU session the packet belongs? How does each UPF apply the packet forwarding treatment as provided in the N4 session creation request into the UPF for the PDU session?

I may have number of other questions. But a basic clarity on the above is required first. Could the authors please clarify?

Regards
Sridhar Bhaskaran

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, March 12, 2019 1:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [DMM] I-D Action: draft-ietf-dmm-srv6-mobile-uplane-04.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
dmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dmm

---

From: Satoru Matsushima <[email-masked]>
Date: Thu, 14 Mar 2019 14:39:57 +0900

Hi,

We’ve updated the srv6 mobile u-plane draft. Thank you for your review comments and feedback on the draft.
Many of them have still not been covered but the authors are still going to work on it for the next meeting.

We’ll get back to you and hope to discuss for further updates during IETF104.

Best regards,
--satoru

> 2019/03/12 5:12、[email-masked]:
> 
>