Subject: Re: [DMM] Light review of draft-ietf-dmm-fpc-cpdp-12

From: <[email-masked]>
Date: Tue, 5 Mar 2019 18:49:04 +0000

Dear all,
searching for update on this (meanwhile expired) draft I only found the 103 minutes quoting Charlie with " We should get a solid architectural and informational yang that should be applicable." 
I also read Carlos' comment on more general applicability and wonder whether the topic of CUPS addressed might also apply to the recently approved BoF at #104 on BNG Control-plane And User-plane Separation (https://datatracker.ietf.org/wg/bcause/about/) as a 'disruptive approach' ;-)
BBF in liaison with 3GPP on 5GWWC (FMC) might also search for a more universal approach to DP/UP nodes as BNG ...
What do you think?
Kind regards
Dirk

-----Original Message-----
From: dmm <[email-masked]> On Behalf Of Carlos Jesús Bernardos Cano
Sent: Samstag, 3. November 2018 04:59
To: Lyle Bertz <[email-masked]>; Marco Liebsch <[email-masked]>
Cc: dmm <[email-masked]>
Subject: [DMM] Light review of draft-ietf-dmm-fpc-cpdp-12

Hi Lyle, Marco,

I committed to perform a review of the FPC draft. Though I have not been able to perform an in-depth one in time for Bangkok, please find attached a light one (among other things, I have not gone through the annexes).

I don't have major comments. I think the use of normative text should be improved, as there are parts that are not clear if the text is supposed to be normative or not.

Thanks, talk to you next week.

Carlos

---

From: "Bertz, Lyle T [CTO]" <[email-masked]>
Date: Wed, 6 Mar 2019 03:35:43 +0000

Dirk,

It is not difficult to extend FPC for BNG as most of the rules are similar in structure.   My team built an FPC agent and we are now building Sx (3GPP CUPS PFCP) but it is at best a subset of FPC and has some holes.  I am unsure I would materially update FPC based on what I have learned implementing the Sx protocol PFCP.

Generally extending the forward actions and filters, assuming you actually need to extend beyond the filter-rule which is based on RFC 5777 and a very generic structure, is not a difficult task.  The base structure is quite generic but many people get hung up on the 3GPP support and extensions later in the spec.

The spec can be overwhelming as the use cases for forwarding, integration with charging, ID allocation for forward, etc, is not trivial.

Lyle

________________________________
From: dmm <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Tuesday, March 5, 2019 12:49:04 PM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [DMM] Light review of draft-ietf-dmm-fpc-cpdp-12

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.

Dear all,
searching for update on this (meanwhile expired) draft I only found the 103 minutes quoting Charlie with " We should get a solid architectural and informational yang that should be applicable."
I also read Carlos' comment on more general applicability and wonder whether the topic of CUPS addressed might also apply to the recently approved BoF at #104 on BNG Control-plane And User-plane Separation (https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fwg%2Fbcause%2Fabout%2F&amp;data=02%7C01%7Clyle.t.bertz%40sprint.com%7C6e37a6bda84549e8c97708d6a19b4837%7C4f8bc0acbd784bf5b55f1b31301d9adf%7C0%7C0%7C636874085646715585&amp;sdata=700Fi5IEAkBMenqn1ecqN9kzWOzDtZ5IziwBGhQngrg%3D&amp;reserved=0) as a 'disruptive approach' ;-)
BBF in liaison with 3GPP on 5GWWC (FMC) might also search for a more universal approach to DP/UP nodes as BNG ...
What do you think?
Kind regards
Dirk

-----Original Message-----
From: dmm <[email-masked]> On Behalf Of Carlos Jesús Bernardos Cano
Sent: Samstag, 3. November 2018 04:59
To: Lyle Bertz <[email-masked]>; Marco Liebsch <[email-masked]>
Cc: dmm <[email-masked]>
Subject: [DMM] Light review of draft-ietf-dmm-fpc-cpdp-12

Hi Lyle, Marco,

Carlos
_______________________________________________
dmm mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdmm&amp;data=02%7C01%7Clyle.t.bertz%40sprint.com%7C6e37a6bda84549e8c97708d6a19b4837%7C4f8bc0acbd784bf5b55f1b31301d9adf%7C0%7C0%7C636874085646715585&amp;sdata=Q3F1FcxIGfE5KAetjKXyCnXfGVtpcv4Qlu5D8NRGzsA%3D&amp;reserved=0