Subject: Re: [dns-privacy] Dowse: "the privacy hub"

From: Sara Dickinson <[email-masked]>
Date: Wed, 3 Aug 2016 16:55:28 +0100

> On 29 Jul 2016, at 13:27, Shane Kerr <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Sara,
> 
> At 2016-07-29 11:25:39 +0100
> Sara Dickinson <[email-masked] <mailto:[email-masked]>> wrote:
> 
>>> On 28 Jul 2016, at 14:58, Stephane Bortzmeyer <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> For your information. This project is about a future home router
>>> which, by default, tries hard to preserve privacy. One of the
>>> interesting thing for us is that DNS requests are transparently
>>> intercepted by the router, encrypted (with DNScrypt) and sent to a
>>> public resolver.
>>> 
>>> http://dowse.equipment/ <http://dowse.equipment/>
>> 
>> Yes, interesting. Since it seems that both SIDN and NLnet Foundation
>> support the project perhaps they have an opinion about it moving to a
>> Standards based privacy mechanism in the future?  :-)
>> 
>> I also recently became aware of this browser (aimed at the Russian
>> market and based on Chromium) that encrypts DNS lookups, also uses
>> DNSCrypt: https://browser.yandex.com <https://browser.yandex.com/>
> 
> Do you think it makes sense to make an informational RFC describing the
> differences between DNSCrypt and DNS over TLS? (And perhaps DNS over
> DTLS since that appears to be moving towards RFC status...)

Shane,

I do think that would be worthwhile since DNSCrypt is used in a number of other places - I believe PowerDNS implements it and of course OpenDNS offers it.

Sara.

---

From: Sara Dickinson <[email-masked]>
Date: Wed, 3 Aug 2016 16:55:51 +0100

Shane,

Sara.

---

From: Sara Dickinson <[email-masked]>
Date: Wed, 3 Aug 2016 16:56:19 +0100

Shane,

Sara.

---

From: Sara Dickinson <[email-masked]>
Date: Wed, 3 Aug 2016 16:55:54 +0100

Shane,

Sara.

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Thu, 4 Aug 2016 08:41:27 +0000

From: dns-privacy [mailto:[email-masked]] On Behalf Of Sara Dickinson
Sent: Wednesday, August 3, 2016 9:26 PM
To: Shane Kerr <[email-masked]>
Cc: [email-masked]
Subject: Re: [dns-privacy] Dowse: "the privacy hub"

On 29 Jul 2016, at 13:27, Shane Kerr <[email-masked]<mailto:[email-masked]>> wrote:

Sara,

At 2016-07-29 11:25:39 +0100
Sara Dickinson <[email-masked]<mailto:[email-masked]>> wrote:

On 28 Jul 2016, at 14:58, Stephane Bortzmeyer <[email-masked]<mailto:[email-masked]>> wrote:

http://dowse.equipment/

I also recently became aware of this browser (aimed at the Russian
market and based on Chromium) that encrypts DNS lookups, also uses
DNSCrypt: https://browser.yandex.com

Shane,

We recently implemented DNSCrypt on Cisco routers for secure communication with OpenDNS servers.

-Tiru

Sara.