Subject: [dns-privacy] Blog post: DNS over TLS support in Android P Developer Preview

From: Warren Kumari <[email-masked]>
Date: Fri, 13 Apr 2018 15:49:05 -0400

Hi all,

As Erik Kline and Ben Schwartz seem to be too modest to toot their own
horn, I'll do it for them:
https://android-developers.googleblog.com/2018/04/dns-over-tls-support-in-android-p.html

Snippet from the above:
"The Android P Developer Preview includes built-in support for DNS
over TLS. We added a Private DNS mode to the Network & internet
settings.

By default, devices automatically upgrade to DNS over TLS if a
network's DNS server supports it. But users who don't want to use DNS
over TLS can turn it off."

W
-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Sara Dickinson <[email-masked]>
Date: Mon, 16 Apr 2018 12:45:10 +0100

> On 13 Apr 2018, at 20:49, Warren Kumari <[email-masked]> wrote:
> 
> Hi all,
> 
> https://android-developers.googleblog.com/2018/04/dns-over-tls-support-in-android-p.html <https://android-developers.googleblog.com/2018/04/dns-over-tls-support-in-android-p.html>

Yes - great work by those folks! Ben also gave a talk about this at the DNS Privacy workshop in February if you want to watch the video:

https://www.youtube.com/watch?v=9xO6kSgvtOQ&index=3&list=PL5i3urU7m33XR1GtR0UZWi4fdX01W2bOZ <https://www.youtube.com/watch?v=9xO6kSgvtOQ&index=3&list=PL5i3urU7m33XR1GtR0UZWi4fdX01W2bOZ>

> (Also posted to dprive)
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop