Subject: Re: [dnsext] Fwd: I-D Action:draft-hoffman-dnssec-ecdsa-04.txt

From: Alfred Hönes <[email-masked]>
Date: Thu, 2 Dec 2010 15:06:36 +0100 (MEZ)

Paul & Wouter:
  Ack for the changes,
  in particular for fixing "bit string" --> "octet string"
  for the signatures ( r | s ) .

  Wouldn't that change also make sense for the keys Q ( x | y ) ?
  (Doesn't matter actually for the two curves supported,
  but if someone goes on to add P-521 later ...)

All:
  Previous concerns addressed.

  Adopt <http://tools.ietf.org/html/draft-hoffman-dnssec-ecdsa-04> !

  I'd like the WG to consider Section 7.2 (and all preceding
  parts to which it refers) of draft-mcgrew-fundamental-ecc-03.
  This should help to counter potential IPR-related concerns.

BR,
  Alfred.

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 2 Dec 2010 07:37:47 -0800

>  but if someone goes on to add P-521 later ...)

If someone wants to add a different curve later, they have to deal with more than just this. We are defining the rule for the curves given.

>  This should help to counter potential IPR-related concerns.

Wouter and I would be open to that if people felt that this gave developers enough information.

--Paul Hoffman, Director
--VPN Consortium