Subject: [dnsext] edns0 in truncated response

From: "Damick, Jeffrey" <[email-masked]>
Date: Thu, 2 Dec 2010 09:26:28 -0500

In looking at the edns0 spec, it appears that the behavior is undefined in regard to truncated responses.  (please correct me)

Should the edns0 be included in response if the truncation occurred in populating any section?

It would seem that Bind does include the edns0 in its responses, however I don't see wording that suggests that edns0 MUST be included in the response to an edns0 request.

>From 2671, 4.1:

4.1. One OPT pseudo-RR can be added to the additional data section of
    either a request or a response.

Does anyone have any further clarification on this?

Thanks,

---

From: Paul Vixie <[email-masked]>
Date: Thu, 02 Dec 2010 14:54:48 +0000

by intent, the space needed for the OPT RR would be reserved before
building the response, so that if truncation occurred it would not
prevent adding the OPT RR.  we should have added a second TC bit in
the OPT RR to properly signal whether TC had occurred before the OPT
RR was added.

---

From: "George Barwood" <[email-masked]>
Date: Thu, 2 Dec 2010 15:13:22 -0000

edns0 in truncated responseI think this is addressed the the bis draft :

  The minimal response must be the DNS header, question section, and an
   OPT record.  This must also occur when an truncated response (using
   the DNS header's TC bit) is returned.

http://tools.ietf.org/html/draft-ietf-dnsext-rfc2671bis-edns0-04#section-7
  ----- Original Message ----- 
  From: Damick, Jeffrey 
  To: [email-masked] 
  Sent: Thursday, December 02, 2010 2:26 PM
  Subject: [dnsext] edns0 in truncated response

  From 2671, 4.1:

  Thanks,

------------------------------------------------------------------------------

  _______________________________________________
  dnsext mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/dnsext

---

From: "Damick, Jeffrey" <[email-masked]>
Date: Thu, 2 Dec 2010 10:32:11 -0500

That looks clear to me, thanks.

On 12/2/10 10:13 AM, "George Barwood" <[email-masked]> wrote:

I think this is addressed the the bis draft :

----- Original Message -----

From:  Damick, Jeffrey <mailto:[email-masked]>

To: [email-masked]

Thanks,

________________________________