Subject: Re: 2052bis miscellany

From: Bill Woodcock <[email-masked]>
Date: Tue, 1 Dec 1998 11:58:00 -0800 (PST)

> who is supposed to implement SRV RR lookups on clients? 
    
Apple is.
    
> For which protocols?
    
DNS, HTTP, HTTPS, LPR, SMTP, IMAP, and AFP-over-IP are the first
targets.

			-Bill

---

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Tue, 01 Dec 1998 22:24:07 -0500

I thought there was some consensus that it didn't make sense to do a
DNS retrieval to figure out where to do a DNS retrieval...

Donald

From:  Bill Woodcock <[email-masked]>
Date:  Tue, 1 Dec 1998 11:58:00 -0800 (PST)
Message-Id:  <[email-masked]>
To:  [email-masked], [email-masked]

---

From: Thomas Narten <[email-masked]>
Date: Wed, 02 Dec 1998 07:04:34 -0500

>> who is supposed to implement SRV RR lookups on clients? 

That's nice. Vendors can (and do) as they please.

The question here is what does the document recommend, i.e., who does
the standard apply to.

Saying that that *all* application protocols should now do SRV will
lead to strong pushback from the applications folk.
Letting each protocol decide for itself let's folks transition as
appropriate. 

Thomas

---

From: Jim Bound <[email-masked]>
Date: Wed, 02 Dec 1998 13:20:49 -0500

> Letting each protocol decide for itself let's folks transition as

Exactly correct anything else should be rejected.

/jim