Subject: WG last call: Kitchen Sink

From: Olafur Gudmundsson <[email-masked]>
Date: Thu, 14 Oct 1999 12:37:00 -0400

As indicated in the minutes of the DNSIND meeting, the WG meeting 
in Oslo concluded that the "Kitchen Sink" draft is ready for WG last 
call.

This is that WG last call. We will run it through October, deadline is
23:59:59 UTC October 31.  

The draft is: draft-ietf-dnsind-kitchen-sink-02.txt

The known problem with this draft is that it contains the word "nibble" where
"octet" should be used. 

Please send other comments to the list.

Issues raised during this last call can be resolved in the working group
meeting in Washington. 

Anyone that has raised issues with this document in the past and feels the
issues have not been adequately addressed, repost the issues. 

This draft is targeted to become Experimental, if you disagree with that
please state so during this last call. 

	Olafur 

----------------------------------------------------
Olafur Gudmundsson - NAI Labs 
the Security Research Division of Network Associates, Inc.
3060 Wasthington Road, Rt 97, Glenwood MD 21738
[email-masked]  [email-masked]
443-259-2389 
Private: [email-masked]

---

From: "Al Costanzo" <[email-masked]>
Date: Fri, 15 Oct 1999 10:54:04 -0500

I strongly oppose the concept behind the kitchen sink RR.  (As others have
already mentioned in this list)

My feeling is that RR should be defined in drafts and be moved along to an
RFC or disposed of.

Allowing people to clump any old thing willy-nilly into the DNS does not
seem to be a well thought out concept.

*** BESIDES *** The entire process, (IMO) IDs RFCs, etc. seems to be
circumveneted by this draft.

I oppose it being moved forward.

Al Costanzo

     | -----Original Message-----
     | From: [email-masked]
     | [mailto:[email-masked]]On Behalf Of
     | Olafur Gudmundsson
     | Sent: Thursday, October 14, 1999 11:37 AM
     | To: [email-masked]
     | Subject: WG last call: Kitchen Sink
     |
     |
     | As indicated in the minutes of the DNSIND meeting, the
     | WG meeting
     | in Oslo concluded that the "Kitchen Sink" draft is ready
     | for WG last
     | call.
     |
     | This is that WG last call. We will run it through
     | October, deadline is
     | 23:59:59 UTC October 31.
     |
     | The draft is: draft-ietf-dnsind-kitchen-sink-02.txt
     |
     | The known problem with this draft is that it contains
     | the word "nibble" where
     | "octet" should be used.
     |
     |
     | Please send other comments to the list.
     |
     | Issues raised during this last call can be resolved in
     | the working group
     | meeting in Washington.
     |
     | Anyone that has raised issues with this document in the
     | past and feels the
     | issues have not been adequately addressed, repost the issues.
     |
     | This draft is targeted to become Experimental, if you
     | disagree with that
     | please state so during this last call.
     |
     | 	Olafur
     |
     | ----------------------------------------------------
     | Olafur Gudmundsson - NAI Labs
     | the Security Research Division of Network Associates, Inc.
     | 3060 Wasthington Road, Rt 97, Glenwood MD 21738
     | [email-masked]  [email-masked]
     | 443-259-2389
     | Private: [email-masked]
     |
     |

---

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Fri, 15 Oct 1999 23:34:24 -0400

Al,

From:  "Al Costanzo" <[email-masked]>
To:  "'Olafur Gudmundsson'" <[email-masked]>, <[email-masked]>
Date:  Fri, 15 Oct 1999 10:54:04 -0500
Message-ID:  <[email-masked]>
In-reply-to:  <4.1.19991014121552.00a03600@localhost>

>already mentioned in this list)

Many others have stated that theu favor it, both on this list and at
IETF meetings.

>My feeling is that RR should be defined in drafts and be moved along to an

This is an RR being defined in a draft and moved along to an RFC.

>seem to be a well thought out concept.

Well, I've thought about it quite a bit and I assume that the other
people who support it have thought about it some.  So I guess you
don't have a very high opinion of our thought processes.  I would also
point out that, as far as I know, this is, or at least was, favored by
IANA as giving some place to sent those who currently apply directly
to IANA for an RR type for proprietary purpose.  Finally, I would
point out that it is only targeted at the Experimental status, which
usually implies a low threshold.  In other words, for Experimental,
one only has to think that its useful to play around and experiment
with, not that it's the greatest thing since sliced bread.

>circumveneted by this draft.

I really can't see what you mean by this.  I did start this draft as a
personal one some time ago and it went through many revisions in that
status responding to comments on this list and comments people made to
me in person, some of which were from IESG members.  I don't remember
which chair/co-chair suggested it move into the WG but I saw no reason
to object.  It has always been a public IETF ID subject to public
comment.  The consensus of the WG supports forwarding it as
Experimental as judged by the WG chair (and also be myself).  I do not
understnad what part of the WG or IETF process is circumvented.

>I oppose it being moved forward.

Thanks,
Donald