Subject: RE: How IPv6 host gets DNS address

From: "BELOEIL Luc FTRD/DMI/CAE" <[email-masked]>
Date: Mon, 6 Oct 2003 16:32:39 +0200

As far as I understand different opinions, some do think that DNS
autoconfiguration is not enough and other information are also in
concern (NTP, SMTP server addresses, search path list, ...). There I
admit that we need a mechanism that can at least integrate DNS discovery
needs but also evolute to support other "information" discovery. There I
don't think that is a work for dnsop.

Some do think DNS resolver address is enough. I agree with that, when
one trust its local network and/or when one just need simple Ip
connectivity (see Pekka Savola example), DNS resolver addresses is the
only "information" to add to stateless address autoconfiguration. There
I have the feeling that DHCP-lite is still to complicated, and that
well-known addresses are perhaps not appropriate cause it may involve
routing policies not in the scope of local network policies.

my 0.02 %
Luc

> -----Message d'origine-----
> De : Brad Knowles [mailto:[email-masked]]
> Envoye : jeudi 2 octobre 2003 11:03
> A : Pekka Savola
> Cc : Doug Barton; Bob Hinden; John Schnizlein; Soohong Daniel Park;
> [email-masked]
> Objet : Re: How IPv6 host gets DNS address
> 
> 
> At 8:03 AM +0300 2003/10/02, Pekka Savola wrote:
> 
> >  Why do you need a search list?  I certainly don't.
> 
> 	Maybe you don't, but I submit that you're not the 
> target typical consumer.
> 
> >  Just remember which scenarios we'd be targeting the 
> solution.  The target
> >  audience would _very probably_ *not* be the enterprise network.
> 
> 	One target audience would be the enterprise network.  Another 
> would be the home user.  I can see where search lists would be 
> important to both.
> 
> >  The one example I personally have used a couple of times 
> is my laptop at
> >  the IETF or in some other network I plug it to.  I don't 
> care less about
> >  DHCP, NTP (the clock is good enough already), Windows 
> environments, search
> >  paths, etc. -- I just want the DNS and be done with it..!
> 
> 	Again, I don't think you're the target typical consumer.
> 
> -- 
> Brad Knowles, <[email-masked]>
> 
> "They that can give up essential liberty to obtain a little temporary
> safety deserve neither liberty nor safety."
>      -Benjamin Franklin, Historical Review of Pennsylvania.
> 
> GCS/IT d+(-) s:+(++)>: a C++(+++)$ UMBSHI++++$ P+>++ L+ 
> !E-(---) W+++(--) N+
> !w--- O- M++ V PS++(+++) PE- Y+(++) PGP>+++ t+(+++) 5++(+++) 
> X++(+++) R+(+++)
> tv+(+++) b+(++++) DI+(++++) D+(++) G+(++++) e++>++++ h--- 
> r---(+++)* z(+++)
> #-------------------------------------------------------------
> ---------
> # To unsubscribe, send a message to <[email-masked]>.
> 

#----------------------------------------------------------------------
# To unsubscribe, send a message to <[email-masked]>.

---

From: "Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 7 Oct 2003 13:44:54 +0900

Hi all,

FYI, I would inform you of two new drafts related to RA-based DNS discovery.
One is mine and the other Daniel's.

1. ND-Proxy based Route and DNS Optimizations for Mobile Nodes in Mobile Network
    http://www.ietf.org/internet-drafts/draft-jeong-nemo-ro-ndproxy-01.txt

2. DNS Discovery for global connectivity in IPv6 Mobile Ad Hoc Networks 
    http://www.ietf.org/internet-drafts/draft-park-manet-dns-discovery-globalv6-00.txt

In these drafts, RA-based DNS discovery can find its applicability.
I would like to request the comments from both NEMO wg and MANET wg 
as well as DNSOP wg.
Thanks.

Regards,
Paul
------------------------------------------------------
Jaehoon Paul Jeong (Researcher)
TEL. +82-42-860-1664
161 Gajeong-Dong, Yuseong-Gu, Daejeon, 305-350, KOREA
NGI Standard Research Team/PEC/ETRI
Homepage: http://www.adhoc.6ants.net/~paul