Subject: [dnsop] IPv6 DNS Discovery Issues

From: Jaehoon Jeong <[email-masked]>
Date: Sun, 29 Feb 2004 23:18:10 -0800 (PST)

Hello DNSOP members,

I send a presentation material with which IPv6 DNS
Discovery has been discussed today.
You can find the material of two file formats in the
following links;
 - PPT file:
  
http://www.adhoc.6ants.net/~paul/data/dnsop-ipv6-dns-discovery-jaehoon.ppt

 - PDF file:
  
http://www.adhoc.6ants.net/~paul/data/dnsop-ipv6-dns-discovery-jaehoon.pdf

I am glad to join drafting our DNS Discovery document
with other volunteers.
Thanks.

Regards,
Paul

__________________________________
Do you Yahoo!?
Get better spam protection with Yahoo! Mail.
http://antispam.yahoo.com/tools
.
dnsop resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/dnsop.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/dnsop/index.html

---

From: Ted Lemon <[email-masked]>
Date: Mon, 1 Mar 2004 16:58:03 +0900

> I am glad to join drafting our DNS Discovery document

Cool.   So far I think the list of volunteers to work on the DNS 
Discovery document is:

Me
You
Pekka Savola
Ohta-san
Ralph Droms

Did I miss anybody?   Ohta-san suggested that I set up a mailing list 
for us to use for discussing the draft as we work on it.   Does that 
sound like a good idea?

(For those who weren't in the meeting today, and haven't been following 
what Rob (I think it was Rob!) posted on the mailing list a week or so 
ago, this is about a document that will describe the various proposals 
for DNS discovery, and talk about pros and cons for each proposal.   
The document needs to be submitted to the IESG by the time San Diego 
rolls around, so we're operating under significant time pressure.)

.

---

From: Jaehoon Jeong <[email-masked]>
Date: Mon, 1 Mar 2004 00:18:47 -0800 (PST)

Dear Lemon,

> for us to use for discussing the draft as we work on

Yes, ASAP.

> for DNS discovery, and talk about pros and cons for
   
For the discussion of pros and cons, we seem to draw
out several scenarios.
In some cases, two or all can be used together for DNS
discovery; e.g., Prefix Delegation Environment and
Mobile Environment, etc.

> rolls around, so we're operating under significant

Right, however, it will be valuable time to us :)

Thanks.

Regards,
Paul

---

From: Jaehoon Jeong <[email-masked]>
Date: Mon, 1 Mar 2004 07:22:54 -0800 (PST)

In order to speed up the progress, I have made a rough
framework of DNS Discovery document as follows;
http://www.adhoc.6ants.net/~paul/ietf/dnsop/draft-ietf-dnsop-ipv6-dns-discovery-00.txt

I will appreciate your comments. I would like to
suggest the title of the document as "Deployment
Guidelines for IPv6 DNS Discovery" at this time. Of
course, there can be better ones.

After the contributers are decided for drafting this
document, let's progress it by a new mailing list that
Ted Lemon will make.

Thanks.

Paul

--- Ted Lemon <[email-masked]> wrote:
> dnsop
resources:_____________________________________________________
> web user interface:
> http://darkwing.uoregon.edu/~llynch/dnsop.html
> mhonarc archive:
http://darkwing.uoregon.edu/~llynch/dnsop/index.html

---

From: Suresh Satapati <[email-masked]>
Date: Mon, 1 Mar 2004 10:05:10 -0800 (PST)

If there is room for more, count me in.

Thanks
--
Suresh

.

---

From: Pekka Savola <[email-masked]>
Date: Tue, 2 Mar 2004 14:22:08 +0200 (EET)

Hi,

As there seem to be enough (too many?) willing participants already, 
I'm withdrawing my "I'll work on it .. if I have to" name from the DNS 
discovery semi-DT hat.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

.

---

From: David Meyer <[email-masked]>
Date: Tue, 2 Mar 2004 23:52:06 -0800

>> I'm withdrawing my "I'll work on it .. if I have to" name from the DNS 

Pekka,

Thanks for volunteering, and we'll keep an eye on the "if I have
to" state. 

Dave
.

---

From: "Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 3 Mar 2004 20:58:23 +0900

David and Rob,

Now, after Pekka has left the list of authors, 
the rest are the following people;

T. Lemon 
R. Droms
R. Hinden
M. Ohta
Me

New volunteers are Juha Wiljakka, Suresh Satapati and Soohong Daniel Park.

Therefore, is it okay for these eight people to start work on the DNS draft?
It seems to need a coordinator or editor for our work?

Thanks.

Paul

----- Original Message ----- 
From: "David Meyer" <[email-masked]>
To: "Pekka Savola" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, March 03, 2004 4:52 PM
Subject: Re: [dnsop] IPv6 DNS Discovery Issues

.

---

From: Tim Chown <[email-masked]>
Date: Wed, 3 Mar 2004 13:34:25 +0000

Hi Paul,

You may find some content here relevant for DNS discovery (or rather
re-discovery :)

http://www.ietf.org/internet-drafts/draft-chown-dhc-stateless-dhcpv6-renumbering-00.txt

Tim

.

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 04 Mar 2004 09:15:38 +0900

Jaehoon Paul Jeong;

First, regardless of which approach one prefers, the issue is
not "discovery" but "configuration" that I have changed the
subject.

> Me

As we volunteered with which section of the draft we are interested
in contributing,

> New volunteers are Juha Wiljakka, Suresh Satapati and Soohong Daniel Park.

new volunteers should also express topics of their interest.

> It seems to need a coordinator or editor for our work?

A coordinator is fine, if WG co-chairs are not enough.

But, aren't we editors?

							Masataka Ohta

.

---

From: "Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 4 Mar 2004 09:54:39 +0900

Hi Tim,

I am sorry you are not here :)
Anyway, thanks for a good document.
After reading your draft, I absolutely agree to your suggestion.

As you know, our RA option draft has already considered 
both the renumbering situation and breakdown of DNS server.
 http://www.ietf.org/internet-drafts/draft-jeong-dnsop-ipv6-dns-discovery-01.txt

Like in your draft, RA-based DNS Discovery uses Lifetime field to handle these cases.

We can see the contents of Section 6.2 of ours as follows;
--------------------------------------------------------------------------------
 Step (c) : For each DNS Server option, check the following: If the 
              value of "Pref" and "Lifetime" fields is set to zero, 
              delete the corresponding RDNSS entry from both DNS Server 
              Cache and Resolver File in order to let the RDNSS not used 
              any more for certain reason in network management, e.g., 
              the breakdown of the DNS server and a renumbering 
              situation. 
--------------------------------------------------------------------------------

There is my opinion on Section 5, Solution Space of your draft.
I perfer the third to the others, because it need not any addtional functions from current stateless DHCP.
IMHO, we can inform IPv6 hosts of the change of configuration information through RA DNS option plus a hint flag.

Thanks.

Paul

----- Original Message ----- 
From: "Tim Chown" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, March 03, 2004 10:34 PM
Subject: Re: [dnsop] IPv6 DNS Discovery Issues

.

---

From: "Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 4 Mar 2004 10:21:13 +0900

I agree with Ohta-san.
The title can be changable through our consensus.
IMHO, DNS Discovery includes DNS Configuration implicitly.

Anyway, as the first step, it needs to decide the template or framework
of our draft with one suggested by me;
http://www.adhoc.6ants.net/~paul/ietf/dnsop/draft-ietf-dnsop-ipv6-dns-discovery-00.txt

Are there other sections you are going to add?

As I know, the previous volunteers will write each sub-section of Section 5 according to each solution.
 - RA: R. Hinden and me
 - DHCP: T. Lemon and R. Droms
 - Well-known: M. Ohta

The rest will be assigned after deciding the draft framework and author list.
I think that the next volunteers, especially, can contribute to Deployment Scenarios and Analysis of Section 5.
Please, let us know your contribution.

> A coordinator is fine, if WG co-chairs are not enough.

I think that our WG chairs have coordinated this topic well so far.

> But, aren't we editors?

Right. :)

Thanks.

Paul

.

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 04 Mar 2004 11:11:05 +0900

Jaehoon Paul Jeong;

> IMHO, DNS Discovery includes DNS Configuration implicitly.

My point is that no of the proposals actively discover
anything, except for DHCP approach actively discovering
DHCP, not DNS, servers.

>  - DHCP: T. Lemon and R. Droms

I volunteered to write about

	well-known approach

	usefulness of well-known approach for other proposals

	redundancy analysis of all the approaches

Others should restate their fields of interests.

							Masataka Ohta

.

---

From: Suresh Satapati <[email-masked]>
Date: Wed, 3 Mar 2004 23:23:54 -0800 (PST)

I wish to contribute towards DHCP approach, along with
Ted and Ralph.

--
Suresh

.

---

From: Tim Chown <[email-masked]>
Date: Thu, 4 Mar 2004 09:25:04 +0000

OK, thanks.

The document below I think has been accepted as a DHC WG document; Stig Venaas
presented it in Seoul.  There is also a (long) discussion about the issues
on the DHC mail list, which I will try to capture in the -01 draft.

Tim

.