Subject: [DNSOP] Fwd: New Version Notification for draft-gersch-dnsop-revdns-cidr-00.txt

From: Joseph Gersch <[email-masked]>
Date: Fri, 17 Feb 2012 10:16:56 -0700

All, 
  we have submitted a new draft that will be presented at the Paris IETF meeting.  
Please take the time to send any comments and suggestions regarding this idea on naming CIDR address blocks in the Reverse DNS.

Best regards,
   - Joe Gersch and Dan Massey

Begin forwarded message:

> From: [email-masked]
> Date: February 16, 2012 5:09:18 PM MST
> To: [email-masked]
> Cc: [email-masked], [email-masked]
> Subject: New Version Notification for draft-gersch-dnsop-revdns-cidr-00.txt
> 
> A new version of I-D, draft-gersch-dnsop-revdns-cidr-00.txt has been successfully submitted by Joe Gersch and posted to the IETF repository.
> 
> Filename:	 draft-gersch-dnsop-revdns-cidr
> Revision:	 00
> Title:		 Reverse DNS Naming Convention for CIDR Address Blocks
> Creation date:	 2012-02-14
> WG ID:		 Individual Submission
> Number of pages: 19
> 
> Abstract:
>   The current reverse DNS naming method is used to specify a complete
>   IP address.  It has not been used to handle address ranges; for
>   example, there is no formal mechanism for specifying a reverse DNS
>   name for the block of addresses specified by the IPv4 prefix
>   129.82.0.0/16.  Defining such a reverse DNS naming convention would
>   be useful for a number of applications.  These include applications
>   for secure BGP routing, and applications that need host-information
>   for a device owning a complete IPv6 address block.  This draft
>   proposes a naming convention for encoding CIDR address blocks in the
>   reverse DNS.
> 
> 
> 
> 
> The IETF Secretariat

Joseph Gersch
Chief Operating Officer
Secure64 Software Corporation

---

From: "Marc Lampo" <[email-masked]>
Date: Mon, 20 Feb 2012 14:21:51 +0100 (CET)

Hello,

Some “typographic” remarks :

1)      5.2 IPv4 Address Block Naming à IPv6 Address Block Naming

2)      In 5.2 there are 2 examples that have missing “::”,
(2607:fa88:8000:/33 à 2607:fa88:8000::/33 and
2607:fa88:8000:/35 à 2607:fa88:8000::/35)
in 5.3 there is 1 example with missing “::”.

From: Joseph Gersch [mailto:[email-masked]]
Sent: 17 February 2012 06:17 PM
To: [email-masked]
Subject: [DNSOP] Fwd: New Version Notification for
draft-gersch-dnsop-revdns-cidr-00.txt

All,

  we have submitted a new draft that will be presented at the Paris IETF
meeting.

Please take the time to send any comments and suggestions regarding this
idea on naming CIDR address blocks in the Reverse DNS.

Best regards,

Begin forwarded message:

Subject: New Version Notification for
draft-gersch-dnsop-revdns-cidr-00.txt

A new version of I-D, draft-gersch-dnsop-revdns-cidr-00.txt has been
successfully submitted by Joe Gersch and posted to the IETF repository.

Abstract:

The IETF Secretariat

Joseph Gersch

Chief Operating Officer

---

From: "Marc Lampo" <[email-masked]>
Date: Mon, 20 Feb 2012 14:41:16 +0100 (CET)

Hello,

(sorry – previously sent email was not finished …)

Some “typographic” remarks :
1) 5.2 IPv4 Address Block Naming → IPv6 Address Block Naming
2) In 5.2 there are 2 examples that have missing “::”,
(2607:fa88:8000:/33 → 2607:fa88:8000::/33 and
2607:fa88:8000:/35 → 2607:fa88:8000::/35)
in 5.3 there is 1 example with missing “::”.
(2607:fa88:8000:/36 → 2607:fa88:8000::/36)

About “content” :
1) 3. Design Requirement → 2. Coverage Authority.
“Any … with a data record or NXDOMAIN …”
to be completed with : NODATA
→ “Any … with a data record or NODATA or NXDOMAIN …”

2) In 5.2 IPv6 Address Block Naming
Why not add some examples to show conversion from a reverse-DNS name back to 
CIDR ?
(just like in 5.1)

Globally :
1) It is implied by the content of the present draft,
but should it be stated (in Design Requirements)
that the proposal should be valid for both IPv4 and IPv6 addresses ?

2) In the Introduction, where you correctly state that ISP’s pre-populate 
reverse DNS,
the problem is stated that the approach of pre-populating does not scale for 
IPv6.
However, by itself, this draft does not solve that problem, does it ?
(needs programmatic support)
(this example in the Introduction made me think/assume that this draft
 also applies to “simple” reverse mapping.  In which case I wondered how
 this draft does away with CNAME (a la RFC 2317).
 But then, after rereading it occurred to me that this draft is about 
storing
 CIDR info in revdns.
 → isn’t it confusing to give, in the intro, an example that does not apply 
to CIDR info ?
(it got at least me confused, not that I’d want to be taken as a reference 
;-)

Kind regards,

Marc Lampo
Security Officer
EURid

All,

Best regards,

Begin forwarded message:

Abstract:

The IETF Secretariat

Joseph Gersch
Chief Operating Officer

---

From: Joseph Gersch <[email-masked]>
Date: Mon, 20 Feb 2012 15:33:49 -0700

Hello Marco,

  Thanks for reading and commenting on our draft.  We have a couple of weeks to make corrections to draft-00 before they get frozen for the IETF meeting.  We appreciate your pointing out the typos (we found the ipv6 one ourselves, oops.....) and the suggestions for clarification.
  
   This draft on CIDR naming is mainly focused on  proposing a simple, direct way to name CIDR addresses and eliminates the need for CNAME indirection.  It can be used for a number of purposes.

 Regarding the intro on pre-populating the reverse-DNS... you are correct, this is a draft on CIDR naming, not on fixing that particular IPv6 issue.  We will make that clarification in our next draft.  The ipv6 issue "might" be able to be addressed with this approach, but more thought needs to be put in to it before a complete solution could be proposed.  We were mentioning this issue in order to give multiple examples of the reasons why CIDR naming is a useful concept.

    Again, thanks,

Joseph Gersch
Chief Operating Officer