Subject: [DNSOP] Question: unknown EDNS0 options and recursive resolvers?

From: Nicholas Weaver <[email-masked]>
Date: Thu, 8 Nov 2012 09:59:15 -0800

How do recursive resolvers react to unknown EDNS0 options?

Are the requests simply dropped?  
Is the unknown option removed and ignored?  
Passed to the authority unchanged?

---

From: Ray Bellis <[email-masked]>
Date: Thu, 8 Nov 2012 18:24:24 +0000

> Passed to the authority unchanged?

They certainly shouldn't do the latter - EDNS is supposed to be "hop by hop", not "end to end".

RFC 2671 appears silent on drop vs ignore.  2671bis explicitly says "ignore".

Ray

---

From: Mark Andrews <[email-masked]>
Date: Fri, 09 Nov 2012 07:09:51 +1100

> RFC 2671 appears silent on drop vs ignore.  2671bis explicitly says 

And it wouldn't be drop in any case.  It would be NOTIMP/FORMERR vs ignore.

Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]