Subject: Re: [DNSOP] Fwd: New Version Notification for draft-jabley-dnsop-anycast-mapping-00.txt

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 12 Apr 2013 16:54:38 +0200

On Mon, Mar 25, 2013 at 03:40:55PM -0400,
 Joe Abley <[email-masked]> wrote 
 a message of 66 lines which said:

> However, I am of course interested in accuracy and clarity in the
> text. If you have a few spare minutes and don't mind giving me a
> review, I'd appreciate it.

I believe it is useful, I liked the ideas (specially
IDENTITY.L.ROOT-SERVERS.ORG) and I would like to see more of such
documents for critical services.

On ther other hand, I'm not sure a RFC is the best way to publish
them. May be somewhere under <http://dns.icann.org/lroot/>?

Bug report: IDENTITY.L.ROOT-SERVERS.ORG does not work from my office:

% ping IDENTITY.L.ROOT-SERVERS.ORG
PING IDENTITY.L.ROOT-SERVERS.ORG (193.51.11.57) 56(84) bytes of data.
64 bytes from 193.51.11.57: icmp_req=1 ttl=59 time=203 ms
...

% dig -x 193.51.11.57

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> -x 193.51.11.57
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 3324
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags: do; udp: 4096
;; QUESTION SECTION:
;57.11.51.193.in-addr.arpa.	IN	PTR

;; AUTHORITY SECTION:
11.51.193.in-addr.arpa.	86380	IN	SOA	ns1.renater.fr. hostmaster.renater.fr. 2010052001 28800 7200 604800 86400

;; Query time: 56 msec
;; SERVER: ::1#53(::1)
;; WHEN: Fri Apr 12 16:50:29 2013
;; MSG SIZE  rcvd: 115

---

From: Joe Abley <[email-masked]>
Date: Fri, 12 Apr 2013 17:11:01 -0400

> documents for critical services.

Thanks!

> them. May be somewhere under <http://dns.icann.org/lroot/>?

That's certainly an option. The motivation for using the RFC series was partly to provide a stable, citation-friendly reference for other future work and partly to record these aspects of the L-Root service for the historical record.

The document is currently with the Independent Stream Editor who is looking for reviewers. I'm not especially familiar with that process, but it seems possible that volunteering to review would be appreciated (since you've already taken the time to read it).

> 64 bytes from 193.51.11.57: icmp_req=1 ttl=59 time=203 ms

So, this demonstrates that the IDENTITY.L.ROOT-SERVERS.ORG name is actually working fine for you (you looked for an A, and you got one). Geo-loc information is available by looking for a TXT.

> ;; WHEN: Fri Apr 12 16:50:29 2013

This seems to demonstrate that the particular L-Root host network you see from there does not have their reverse DNS set up for the address they assigned us. We'll follow up on that because we think reverse DNS is useful and good, but that's a separate issue from the functionality of the IDENTITY.L.ROOT-SERVERS.ORG name.

Joe