Subject: [DNSOP] AS112 work

From: Joe Abley <[email-masked]>
Date: Mon, 1 Jul 2013 13:32:01 -0400

Hi all,

We have two drafts on the table relating to extensions to AS112 service, in particular to accommodate delegation or redirection of new zones to the infrastructure:

  draft-wkumari-dnsop-omniscient-as112
  draft-jabley-dnsop-as112-dname

I suspect that it makes no sense to proceed with both approaches (although perhaps someone else here thinks differently).

I have talked to Warren, and the sensible approach seems to be to discuss both approaches here, and choose one of them. At that point we can merge useful text, authors, etc and proceed with the polish on the selected option.

Could we ask the chairs to help facilitate this discussion?

Thanks,

Joe

---

From: Tim Wicinski <[email-masked]>
Date: Mon, 1 Jul 2013 13:43:12 -0400

We (Peter and I) were going to discuss these coming up this week, but we 
felt the combining was the right direction.

If a disinterested third party would be willing to facilitate please 
step up, otherwise I will be able to (but a little thin on time till 
tomorrow).

tim

On 7/1/13 1:32 PM, Joe Abley wrote:
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: Warren Kumari <[email-masked]>
Date: Mon, 1 Jul 2013 13:45:23 -0400

> Could we ask the chairs to help facilitate this discussion?

In the mean time -- assuming that we test DNAME and find out that:
A: it is well supported
B: works well enough.
C: doesn't have any bad side effects
does anyone have any compelling reasons why we wouldn't simply go the DNAME route?

W

--
"When it comes to glittering objects, wizards have all the taste and self-control of a deranged magpie."
-- Terry Pratchett

---

From: Joe Abley <[email-masked]>
Date: Mon, 1 Jul 2013 13:53:40 -0400

> In the mean time -- assuming that we test DNAME and find out that:

A.5: the interactions between components are not harmful in the event that DNAME is not supported (i.e. that CNAME synthesis mitigates the lack of support, and that the interactions in that case are benign)

Joe

---

From: Warren Kumari <[email-masked]>
Date: Mon, 1 Jul 2013 13:58:38 -0400

On Jul 1, 2013, at 1:43 PM, Tim Wicinski <[email-masked]> wrote:

> We (Peter and I) were going to discuss these coming up this week, but we felt the combining was the right direction.
> 
> If a disinterested third party would be willing to facilitate please step up, otherwise I will be able to (but a little thin on time till tomorrow).

I think that we can try integrate this ourselves. If we run into any issues we can come back and ask for chair / mediator help.

I am not really expecting any contentious combining them -- we just want the best solution, and so far no-one has spoken out strongly against DNAME. Assuming we don't run into any huge road-blocks I (speaking only for myself) don't see an issue with using it as the "solution".

W 

--
"Let's just say that if complete and utter chaos was lightning, he'd be the sort to stand on a hilltop in a thunderstorm wearing wet copper armour and shouting 'All gods are bastards'."

    -- Rincewind discussing Twoflower (Terry Pratchett, The Colour of Magic)