Subject: [DNSOP] dnsxml - A standard XML representation of DNS data

From: Jay Daley <[email-masked]>
Date: Wed, 31 Jul 2013 12:05:33 +1200

Hi All

The title says it all.  I would be interested in your views and any support that might exist for this.  Apologies but I have yet to see how this fits with Stephane's work on a JSON representation of DNS as this has taken quite a few years to write.

cheers
Jay

A new version of I-D, draft-daley-dnsxml-00.txt
has been successfully submitted by Jay Daley and posted to the
IETF repository.

Filename:	 draft-daley-dnsxml
Revision:	 00
Title:		 dnsxml - A standard XML representation of DNS data
Creation date:	 2013-07-31
Group:		 Individual Submission
Number of pages: 54
URL:             http://www.ietf.org/internet-drafts/draft-daley-dnsxml-00.txt
Status:          http://datatracker.ietf.org/doc/draft-daley-dnsxml
Htmlized:        http://tools.ietf.org/html/draft-daley-dnsxml-00

Abstract:
  This memo describes a syntax for encoding DNS Resource Records in
  XML, and a schema to define that syntax written in XML Schema.  It
  can be used to represent all DNS RDATA.  This can be used by diverse
  applications as a common format.

  DNS Resource Records are represented as XML elements with the name of
  the element taken from the mnemonic used to represent the DNS
  Resource Record in presentation format.  The RDATA is represented as
  XML attributes or content of the element.  The attribute names are
  taken from the RDATA field names specified in the normative RFC.

-- 
Jay Daley
Chief Executive
.nz Registry Services (New Zealand Domain Name Registry Limited)
desk: +64 4 931 6977
mobile: +64 21 678840
linkedin: www.linkedin.com/in/jaydaley

---

From: Tim Wicinski <[email-masked]>
Date: Wed, 31 Jul 2013 08:05:43 +0200

Jay

Couple of things here:  It's a little last minute to throw it onto the 
agenda, and we'll need to have some of that discussion. Second, there is 
another document floating out there on rDNS 
http://tools.ietf.org/html/draft-manderson-rdns-xml-01

I would suspect that we'll need to break down how each one document 
affects the other (are the complimentary or overlapping, etc.).  Then 
there is the entire "if XML is the answer in 2013, what really is the 
question?" question.

If you're in town, I've been hunkered down in the Terminal Room 
hammering on several different things.

tim

---

From: Jay Daley <[email-masked]>
Date: Wed, 31 Jul 2013 19:10:19 +1200

Hi Tim

On 31/07/2013, at 6:05 PM, Tim Wicinski <[email-masked]> wrote:

> Jay
> 
> Couple of things here:  It's a little last minute to throw it onto the agenda, and we'll need to have some of that discussion.

I'm not there and don't worry I wasn't trying to get it onto the agenda.  I've sat on this for so long I just had to get it out this week or it would have been another year.

> Second, there is another document floating out there on rDNS http://tools.ietf.org/html/draft-manderson-rdns-xml-01

Thanks, I'll take a read.

> I would suspect that we'll need to break down how each one document affects the other (are the complimentary or overlapping, etc.).  

Agreed.  Mine is very much targeted at representing DNS data in the best way possible and not any protocol that wraps around it.

> Then there is the entire "if XML is the answer in 2013, what really is the question?" question.

My own view is that XML is already being used for DNS data in a number of places (e.g. control of Nominum servers) that the question has already been asked and answered.

cheers
Jay

> 
> If you're in town, I've been hunkered down in the Terminal Room hammering on several different things.
> 
> tim
> 
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 31 Jul 2013 09:53:54 +0200

Please also see draft-bortzmeyer-dns-json. JSON encoders and parsers are lighter-weight than XML ones, and for the data in question (everything DNS), it seems like JSON might be a better text format for the use cases (particularly logging).

--Paul Hoffman

---

From: Jay Daley <[email-masked]>
Date: Wed, 31 Jul 2013 20:01:27 +1200

Hi Paul

> Please also see draft-bortzmeyer-dns-json. JSON encoders and parsers are lighter-weight than XML ones, and for the data in question (everything DNS), it seems like JSON might be a better text forma…

I'm aware of Stephane's draft as noted in my original email but I haven't had a chance to read it.  I will though.

Rather than picking a winner between JSON and XML I've always found it prudent to recognise that the two have different characteristics that support different uses.  Not only can JSON and XML co-exist but also, if needed, the JSON can be derived from the XML via XSLT:

	http://controlfreak.net/xml-to-json-in-xslt-a-toolkit/

cheers
Jay

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 31 Jul 2013 12:13:51 +0200

On Wed, Jul 31, 2013 at 12:05:33PM +1200,
 Jay Daley <[email-masked]> wrote 

> Title:		 dnsxml - A standard XML representation of DNS data

Note that there is an implementation, based on a (earlier,
non-released) version of the draft:

http://www.bortzmeyer.org/dns-lg-usage.html