Subject: [DNSOP] Draft DNSOP Meeting Minutes

From: Tim Wicinski <[email-masked]>
Date: Fri, 2 Aug 2013 12:15:06 +0200

Hi

Draft minutes from Thursday meeting are available 
http://www.ietf.org/proceedings/87/minutes/minutes-87-dnsop . Please let 
the chairs know if find something incorrectly recorded.

Thanks to Olaf for the note taking.

tim

---

From: Jaap Akkerhuis <[email-masked]>
Date: Mon, 19 Aug 2013 11:32:24 +0200

Hi

    
    tim
    
    _______________________________________________
    DNSOP mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/dnsop

---

From: Jaap Akkerhuis <[email-masked]>
Date: Mon, 19 Aug 2013 11:34:02 +0200

(Oops, mail escaped too early, new trial).

It incorrectly quotes me as stating that prefetching in unbound "is
effective".

What I really said is that experience learns that this is hardly
effective.

	jaap

---

From: Joe Abley <[email-masked]>
Date: Mon, 19 Aug 2013 09:48:52 -0400

Hi Tim,

Some small comments below. These are not suggested revisions to the minutes, but rather points that derive from them.

> 2.1) AS112 v2 Joint Discussion
> draft-wkumari-dnsop-omniscient-as112
> draft-jabley-dnsop-as112-dname
> Slides: http://tools.ietf.org/agenda/87/slides/slides-87-dnsop-0.pdf
> Warren Kumari, Joe Abley
> 
> Warren cedes speaking to Joe. 
> 
> Problem statement: Zones are delegated to AS112 servers, but hard to extend as operation is distributed and would create widespread lame delegations.  Joe suggested adding DNAME which would fix the downstream requirements, but raises the larger question of whether DNAME is suitable for production? 
> 
> Next Steps:
>     Experiment with DNAME first, then test DNAME in production
>     If this runs into problems, fall back to the Omniscenet-AS112 as Plan B
> 
> Suggestion is to adopt both documents in the WG, proceed in parallel.
> 
> Chair asks room for adopting both documents, show of hands confirms WG wants both documents to move forward at this tim.

This is my recollection of the outcome of that discussion, but subsequent (off-list) discussion suggests that the chairs' recollection is that the working group agreed to adopt "the issue", and to defer adoption of the documents until clarity on the practicality of the DNAME approach is achieved.

I'm happy either way (I'm not sure I understand what "wg adopts an issue" means, however) but it seems reasonable to ask the Chairs to (a) clarify, and (b) ask the list what people want.

> 3.4a) Flushing DNS Caches
> draft-jabley-dnsop-dns-flush-00
> Slides: http://tools.ietf.org/agenda/87/slides/slides-87-dnsop-8.pdf
> Joe Abley
> 
> A different take on the cache flushing problem.  He mentions some TLDs which published incorrect zone information with long TTLs and caused user outages.   Equates this to a "Big Panic Button".  Talks about doing this using Notify on resolvers since that behavior has never been defined. 
> 
> Lots of people jumping into line with comments. 
> Antion: How is this scaleable? 
> PaulW: Scary censor ship
> Warren: Likes
> Johan: Your worst idea, only helps the bad operators 

I think the phrase was "this is the worst idea I have ever heard of". :-)

> Roy: Wants a button as it is but thinks the problem is complex, and not sure it is this right button 
> 
> Frank Martin: This will happen more often, 
> Dan York: relaying MarkA, 
> 
> Peter Koch poses the questions to the group: 
>     1. Is the problem worth pursuing? yes: strong,  no: medium 
>     2. Should we adopt this approach: yes: weak  no: stronger 
> 
> Action is to let this fester for now, may revisit. 

Warren and I have started discussing next steps. Our thought is to start with a problem statement and some working requirements, and then to think about solutions. If others are interested in helping to frame the question (with the goal of bringing the results to the working group for discussion) please let one of us know.

Joe