Subject: Re: [DNSOP] dnsxml - A standard XML representation of DNS data

From: Tim Wicinski <[email-masked]>
Date: Thu, 1 Aug 2013 13:21:36 +0200

Jay

I agree it's just "formats" and therefore it's just 'a simple bit of 
code', I tend to find the XML specifications get a bit heavy, and what I 
liked in Stephane's draft is that it has a very lightweight feel to it.

(I will mention that the IESG is looking for reviewers for 
draft-manderson-rdns-xml-01 in case anyone feels extra motivated to 
assist in this).

tim

On 7/31/13 10:01 AM, Jay Daley wrote:
> Hi Paul
>
> On 31/07/2013, at 7:53 PM, Paul Hoffman <[email-masked]> wrote:
>
>> Please also see draft-bortzmeyer-dns-json. JSON encoders and parsers are lighter-weight than XML ones, and for the data in question (everything DNS), it seems like JSON might be a better text format for the use cases (particularly logging).
> I'm aware of Stephane's draft as noted in my original email but I haven't had a chance to read it.  I will though.
>
> Rather than picking a winner between JSON and XML I've always found it prudent to recognise that the two have different characteristics that support different uses.  Not only can JSON and XML co-exist but also, if needed, the JSON can be derived from the XML via XSLT:
>
> 	http://controlfreak.net/xml-to-json-in-xslt-a-toolkit/
>
> cheers
> Jay
>
>> --Paul Hoffman
>> _______________________________________________
>> DNSOP mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Jay Daley <[email-masked]>
Date: Thu, 1 Aug 2013 23:50:06 +1200

On 1/08/2013, at 11:21 PM, Tim Wicinski <[email-masked]> wrote:

> Jay
> 
> I agree it's just "formats" and therefore it's just 'a simple bit of code', I tend to find the XML specifications get a bit heavy, and what I liked in Stephane's draft is that it has a very lightweight feel to it.

XML, especially in the IETF context, gets heavy because people use xml-schema or relaxng to define schemas to define and validate the XML.  JSON is not yet at that stage and so seems lighter, but that's generally due to simpler functionality.  When JSON schema is readily available I'm sure the differences will diminish.

> (I will mention that the IESG is looking for reviewers for draft-manderson-rdns-xml-01 in case anyone feels extra motivated to assist in this).

There's so little to it I'm happy to review and will do soon.

Jay

-- 
Jay Daley
Chief Executive
.nz Registry Services (New Zealand Domain Name Registry Limited)
desk: +64 4 931 6977
mobile: +64 21 678840
linkedin: www.linkedin.com/in/jaydaley

---

From: Terry Manderson <[email-masked]>
Date: Thu, 1 Aug 2013 04:52:49 -0700

Tim and all,

On 1/08/13 9:21 PM, "Tim Wicinski" <[email-masked]> wrote:

>code', 

Code is always changeable so long at there is solid motivation to do so.

>I tend to find the XML specifications get a bit heavy, and what I

Yes, XML can sometimes be a heavy solution, but also has a set of
positives. It really depends on the implementation in which it is being
used. Classic "it depends" response - sorry! ;)

>draft-manderson-rdns-xml-01 in case anyone feels extra motivated to

Love to iterate this, draft-manderson-rdns-xml-01 was submitted via the
rfc-ise as it really is a specific item targeted at a provisioning portion
of the DNS hierarchy that has been in production for a number of years.
The draft is more to allow the transparency of ICANN operations in such
areas that makes sense with the hope that it can provide information to
other folk looking to implement similar systems, or spark the thought
processes in others that might come up with viable improvements.

Cheers
Terry