Subject: [DNSOP] beta release of getdns stub resolver

From: "Wiley, Glen" <[email-masked]>
Date: Wed, 26 Feb 2014 18:46:38 +0000

Verisign and NLnet Labs are pleased to announce the first beta release (0.1.0) of an open source implementation of the getdns API specification.  The project's home page is at http://getdnsapi.net<http://getdnsapi.net/>.

getdns is a modern asynchronous DNS API. It implements DNS entry points from a design developed and vetted by application developers, in the specification at http://www.vpnc.org/getdns-api/ edited by Paul Hoffman. With the development of this API, we intend to offer application developers a modernized and flexible way to access DNS security (DNSSEC) and other powerful new DNS features; a particular hope is to inspire application developers towards innovative security solutions in their applications.

We invite everyone to take a look at the project and to provide feedback to us and even contribute back to the project!  We expect to have successive releases over the next few months that move us toward a more complete implementation and includes ports to even more platforms.

Signed…the getdns core team:

Craig Despeaux, Verisign, Inc.
Neel Goyal, Verisign, Inc.
Olaf Kolkman, NLnet Labs
Allison Mankin, Verisign Labs.
Melinda Shore, No Mountain Software LLC
Willem Toorop, NLnet Labs
Wouter Wijngaards, NLnet Labs
Glen Wiley, Verisign, Inc.

---

From: Richard Lamb <[email-masked]>
Date: Wed, 26 Feb 2014 11:02:28 -0800

Thank you guys!

This is exactly the kind of leadership the rest of the IT industry needs to help take DNSSEC to the next level.  Many of us were just going to hack up some code for Windows out of frustration but were stymied by what sort of interface would be the most attractive to developers (and therefore widespread DNSSEC adoption).  So we were waiting for someone else to take the first step.  You did it.

Thanks !!
-Rick Lamb (with entrepreneur hat on)

From: DNSOP [mailto:[email-masked]] On Behalf Of Wiley, Glen
Sent: Wednesday, February 26, 2014 10:47 AM
To: [email-masked]
Subject: [DNSOP] beta release of getdns stub resolver

Signed...the getdns core team:

---

From: "Wiley, Glen" <[email-masked]>
Date: Wed, 26 Feb 2014 19:20:44 +0000

Thanks Rick.

Paul's original commission to write the spec was I think largely motivated by the need for an API that non-DNS expert application developers could live with.  I am hoping that by building a fully open (BSD licensed) implementation that is willing to accept contributions from the community we will end up with something that will move DNSSEC adoption to the next level.

--
Glen Wiley
KK4SFV
Sr. Engineer
The Hive, Verisign, Inc.

From: Richard Lamb <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, February 26, 2014 2:02 PM
To: "Wiley, Glen" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: beta release of getdns stub resolver

Thank you guys!

Thanks !!
–Rick Lamb (with entrepreneur hat on)

From: DNSOP [mailto:[email-masked]] On Behalf Of Wiley, Glen
Sent: Wednesday, February 26, 2014 10:47 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [DNSOP] beta release of getdns stub resolver

---

From: Hector Santos <[email-masked]>
Date: Wed, 26 Feb 2014 17:03:16 -0500

Is there is a plug and play 32 bit and/or 64 bit Windows version?

On 2/26/2014 1:46 PM, Wiley, Glen wrote:
> Signed�the getdns core team:
>
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

-- 
HLS

---

From: Glen Wiley <[email-masked]>
Date: Wed, 26 Feb 2014 17:05:12 -0500

Not yet, but that us on the hit list for us.

On Wednesday, February 26, 2014, Hector Santos <[email-masked]> wrote:

>> Verisign and NLnet Labs are pleased to announce the first beta release
>> (0.1.0) of an open source implementation of the getdns API specification.
>>  The project's home page is at http://getdnsapi.net<http://getdnsapi.net/
>> >.
>>
>> getdns is a modern asynchronous DNS API. It implements DNS entry points
>> from a design developed and vetted by application developers, in the
>> specification at http://www.vpnc.org/getdns-api/ edited by Paul Hoffman.
>> With the development of this API, we intend to offer application developers
>> a modernized and flexible way to access DNS security (DNSSEC) and other
>> powerful new DNS features; a particular hope is to inspire application
>> developers towards innovative security solutions in their applications.
>>
>> We invite everyone to take a look at the project and to provide feedback
>> to us and even contribute back to the project!  We expect to have
>> successive releases over the next few months that move us toward a more
>> complete implementation and includes ports to even more platforms.
>>

-- 
Glen Wiley
KK4SFV

"A designer knows he has achieved perfection not when there is nothing left
to add, but when there is nothing left to take away." - Antoine de
Saint-Exupery

---

From: Hector Santos <[email-masked]>
Date: Wed, 26 Feb 2014 17:53:06 -0500

I should note that we invested heavy in DNS API development that 
allowed for single sourcing and caching across many applications (DNS 
clients users of the API).  If *local* caching is not part of it, it 
would not help in its consideration (for us).

--
HLS

-- 
HLS