Subject: [DNSOP] DNS terminology (Was: draft-bortzmeyer-dnsop-dns-privacy (was: DNS privacy : now at least two drafts)

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 16 Jul 2014 17:16:15 +0200

On Mon, May 19, 2014 at 01:09:48PM -0700,
 John Heidemann <[email-masked]> wrote 
 a message of 112 lines which said:

> what do we call the parts of the DNS resolver hierarchy?
> 
> draft-bortzmeyer-dnsop-dns-privacy-02 defines and uses the terms

...

> I recommend against use of resolver without an adjective for (2). 
> 
> Prior RFCs do not have consensus about what to use (both recursive resolver and
> recursive name server appear).  Personally I'd go with "recursive
> resolver".  Does the list have other recommendations?
...
> I looked over many (but certainly not all) existing RFCs, and there is
> some variation in terminology:

There was no answer to this message. It is clear there is no standard
DNS terminology, which is often a problem when talking about the
future of the DNS. Any idea about how to change that? Do we need a
"DNS terminology" RFC?

---

From: Hosnieh Rafiee <[email-masked]>
Date: Wed, 16 Jul 2014 15:21:22 +0000

Hi Stephane,

For DNS in general, I saw some terminologies in different RFCs. In other words, they are distributed in different RFCs. But probably it is a good idea to gather all in one RFC like what one of WGs did (If my memory helps me, I guess it was SACM)

Best,
Hosnieh

-----Original Message-----
From: DNSOP [mailto:[email-masked]] On Behalf Of Stephane Bortzmeyer
Sent: Wednesday, July 16, 2014 5:16 PM
To: [email-masked]
Subject: [DNSOP] DNS terminology (Was: draft-bortzmeyer-dnsop-dns-privacy (was: DNS privacy : now at least two drafts)

...

> Prior RFCs do not have consensus about what to use (both recursive 
> resolver and recursive name server appear).  Personally I'd go with 
> "recursive resolver".  Does the list have other recommendations?
...
> some variation in terminology:

There was no answer to this message. It is clear there is no standard DNS terminology, which is often a problem when talking about the future of the DNS. Any idea about how to change that? Do we need a "DNS terminology" RFC?

_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: Suzanne Woolf <[email-masked]>
Date: Wed, 16 Jul 2014 11:24:15 -0400

> future of the DNS. Any idea about how to change that? Do we need a

This idea has come up more than once, including an off-list conversation earlier this week about http://datatracker.ietf.org/doc/draft-klensin-dotless-terminology-harmful/ and some lengthy discussions extending years into the past about exactly what we mean by "resolver".

IMO a terminology document would be tremendously useful.

Next questions: is there some common view of scope, and is there a critical mass of interest to see it through?

best,
Suzanne

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 16 Jul 2014 17:26:39 +0200

On Wed, Jul 16, 2014 at 03:21:22PM +0000,
 Hosnieh Rafiee <[email-masked]> wrote 
 a message of 44 lines which said:

> For DNS in general, I saw some terminologies in different RFCs. In
> other words, they are distributed in different RFCs.

Not only distributed: it is also inconsistent ("resolver" being
sometimes "stub resolver" and sometimes "recursive cache").

---

From: Joe Abley <[email-masked]>
Date: Wed, 16 Jul 2014 11:27:56 -0400

Hi Hosnieh, Stéphane,

On 16 July 2014 at 11:21:34, Hosnieh Rafiee ([email-masked]) wrote:

> For DNS in general, I saw some terminologies in different RFCs. In other words, they are  
> distributed in different RFCs. But probably it is a good idea to gather all in one RFC like  
> what one of WGs did (If my memory helps me, I guess it was SACM)

I think it would be useful if we could produce an authoritative taxonomy of the DNS. I agree that many terms are frequently overloaded, and that it causes headaches for me every day.

Note that I'm not saying with any certainty that I think it will be possible to produce an authoritative taxonomy that everybody agrees with. But I think it's worth a try, and I'd be happy to volunteer to contribute.

I don't think it's practical to revisit every DNS-related RFC and normalise the language (enthusiasm to produce a unified DNS specification has never resulted in text in the past) but at the very least we could provide some assistance to help future document authors use terminology in a consistent fashion.

Joe

---

From: Hosnieh Rafiee <[email-masked]>
Date: Wed, 16 Jul 2014 15:31:21 +0000

>I don't think it's practical to revisit every DNS-related RFC and normalise the language (enthusiasm to produce a unified DNS specification has never resulted in text in the past) but at the very le…

+1

Sounds reasonable and useful.

Hosnieh

---

From: Olafur Gudmundsson <[email-masked]>
Date: Wed, 16 Jul 2014 11:45:16 -0400

On Jul 16, 2014, at 11:26 AM, Stephane Bortzmeyer <[email-masked]> wrote:

> sometimes "stub resolver" and sometimes "recursive cache”)

Stephane, 

RFC403x used explicit language that is a good start. 
 
Peter Koch and I have tried to introduce useful DNS terms in our DNS tutorials 
http://www.ietf.org/edu/documents/80DNS-Koch-Gudmundsson.pdf

I wrote up a document to address vocabulary for DANE specifications 
http://tools.ietf.org/html/draft-ogud-dane-vocabulary-02

You would have expected that RFC6950 would have done something in this space but it did not. 

I think you are right we NEED a single document/source that expresses a preferred vocabulary 
and translations from common RFC’s to the preferred modern vocabulary. 

I would be happy to work on extending the DANE vocabulary document to cover more DNS terms

	Olafur

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 16 Jul 2014 12:07:31 -0400

> and translations from common RFC’s to the preferred modern vocabulary. 

I will note that the last time DNSEXT came back from the dead, it was
supposed to issue a whole bunch of such clarifications, but little
actual work got done.  Perhaps a document just on terminology would be
a good start, because a little less ambitious.

A

-- 
Andrew Sullivan
[email-masked]

---

From: "Guangqing Deng" <[email-masked]>
Date: Thu, 17 Jul 2014 10:02:08 +0800

This sounds very needful and useful especially for new comers. And I once had been puzzled by "DNS recursive server" and "DNS caching server" for a relatively long time.

Guangqing Deng
CNNIC 
 
From: Andrew Sullivan
Date: 2014-07-17 00:07
To: dnsop
Subject: Re: [DNSOP] DNS terminology (Was: draft-bortzmeyer-dnsop-dns-privacy (was: DNS privacy : now at least two drafts)

A
 
-- 
Andrew Sullivan
[email-masked]

---

From: Steve Crocker <[email-masked]>
Date: Wed, 16 Jul 2014 22:09:35 -0400

Sent from my iPhone

> On Jul 16, 2014, at 10:02 PM, "Guangqing Deng" <[email-masked]> wrote:
> 

I still am :)

Steve