Subject: [DNSOP] Call for Adoption: draft-bortzmeyer-dns-qname-minimisation

From: Tim Wicinski <[email-masked]>
Date: Tue, 07 Oct 2014 00:04:22 -0400

Dear DNSOP WG,

After discussions about the landing spot of this document, DNSOP vs the 
newer DNS Privacy WG, it was realized the updated DNSOP charter 
specifically had work like this in mind.

This starts a Call for Adoption for draft-bortzmeyer-dns-qname-minimisation.

The draft is available here: 
https://datatracker.ietf.org/doc/draft-bortzmeyer-dns-qname-minimisation/

Please review this draft to see if you think it is suitable for adoption 
by DNSOP, and comments to the list, clearly stating your view.

Please also indicate if you are willing to contribute text, review, etc.

This call for adoption ends Monday 20-October-2014 at 23:59

Thanks
tim wicinski
DNSOP co-chair

---

From: Paul Vixie <[email-masked]>
Date: Mon, 06 Oct 2014 21:40:50 -0700

> Tim Wicinski <mailto:[email-masked]>
> Monday, October 06, 2014 9:04 PM
> ...
>
> Please review this draft to see if you think it is suitable for
> adoption by DNSOP, and comments to the list, clearly stating your view.
>

i favour adoption. i will review, and contribute.

-- 
Paul Vixie

---

From: David Conrad <[email-masked]>
Date: Mon, 6 Oct 2014 21:44:49 -0700

> i favour adoption. i will review, and contribute.

+1

Regards,
-drc

---

From: Olafur Gudmundsson <[email-masked]>
Date: Tue, 7 Oct 2014 01:08:46 -0400

On Oct 7, 2014, at 12:04 AM, Tim Wicinski <[email-masked]> wrote:

> 
> Please review this draft to see if you think it is suitable for adoption by DNSOP, and comments to the list, clearly stating your view.
Done, will hold off sending edits to editor until after document adoption period. 
> Please also indicate if you are willing to contribute text, review, etc.
Will do all above 
> This call for adoption ends Monday 20-October-2014 at 23:59

Strong support for adoption. 

	Olafur

---

From: Daniel Migault <[email-masked]>
Date: Tue, 7 Oct 2014 11:05:40 +0200

I support the draft. I will review/contribute.

BR,
Daniel

On Tue, Oct 7, 2014 at 7:08 AM, Olafur Gudmundsson <[email-masked]> wrote:

> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

-- 
Daniel Migault
Orange Labs -- Security
+33 6 70 72 69 58

---

From: Gilles Massen <[email-masked]>
Date: Tue, 07 Oct 2014 11:20:41 +0200

> https://datatracker.ietf.org/doc/draft-bortzmeyer-dns-qname-minimisation/

I support adoption, and am willing contribute/review.

Gilles

-- 
Fondation RESTENA - DNS-LU

---

From: Patrik Wallström <[email-masked]>
Date: Tue, 7 Oct 2014 13:22:16 +0200

On 07 Oct 2014, at 06:04, Tim Wicinski <[email-masked]> wrote:

> Dear DNSOP WG,
> 
> After discussions about the landing spot of this document, DNSOP vs the newer DNS Privacy WG, it was realized the updated DNSOP charter specifically had work like this in mind.
> 
> The draft is available here: https://datatracker.ietf.org/doc/draft-bortzmeyer-dns-qname-minimisation/
> 

I fully support adoption of this document.

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 7 Oct 2014 07:24:29 -0700

<no hat>

> Please review this draft to see if you think it is suitable for adoption by DNSOP, and comments to the list, clearly stating your view.

Yes, it is ready for adoption by DNSOP.

> Please also indicate if you are willing to contribute text, review, etc.

I will.

--Paul Hoffman

---

From: Paul Wouters <[email-masked]>
Date: Tue, 7 Oct 2014 10:44:25 -0400 (EDT)

On Tue, 7 Oct 2014, Tim Wicinski wrote:

> Please review this draft to see if you think it is suitable for adoption by 
> DNSOP, and comments to the list, clearly stating your view.

Yes, please adopt.

> Please also indicate if you are willing to contribute text, review, etc.

Willing to review.

Paul

---

From: Dan York <[email-masked]>
Date: Tue, 7 Oct 2014 15:56:15 +0000

On Oct 7, 2014, at 12:04 AM, Tim Wicinski <[email-masked]<mailto:[email-masked]>>
 wrote:

I support adoption of this draft.

Yes, I will.

Regards,
Dan

--
Dan York
Senior Content Strategist, Internet Society
[email-masked]<mailto:[email-masked]>   +1-802-735-1624
Jabber: [email-masked]<mailto:[email-masked]>
Skype: danyork   http://twitter.com/danyork

http://www.internetsociety.org/deploy360/

---

From: Francis Dupont <[email-masked]>
Date: Fri, 10 Oct 2014 16:38:38 +0200

+1 for adoption (and at the occasion contribute, review, implement, etc).

[email-masked]

---

From: Warren Kumari <[email-masked]>
Date: Fri, 10 Oct 2014 20:09:37 -0400

On Friday, October 10, 2014, Francis Dupont <[email-masked]>
wrote:

> [email-masked] <javascript:;>

<aol>
Me too!
</aol>

> [email-masked] <javascript:;>

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Mon, 20 Oct 2014 14:32:48 -0400

On Tue, Oct 7, 2014 at 12:04 AM, Tim Wicinski <[email-masked]> wrote:

> The draft is available here: https://datatracker.ietf.org/
> doc/draft-bortzmeyer-dns-qname-minimisation/
>

yes

> Please also indicate if you are willing to contribute text, review, etc.

<nohats>
yes
</nohats>

---

From: Peter Koch <[email-masked]>
Date: Mon, 20 Oct 2014 20:37:38 +0200

> by DNSOP, and comments to the list, clearly stating your view.

I do not support accepting the draft (or the proposal it carries) as a work item.

Other than the author - and obviously others - I believe that the resolution
algorithm of RFC 1034 is pretty clear about the QNAME being sent in full
and that has been operational reality for 25+ years.  A whole system has
been successfully built around it with complex interdependencies.
'parent centric' and 'child centric' resolvers and query patterns
evolved along that algorithm.  The fact that certain services may have experimented
(successfully, to them) with the proposed algorithm already gives anecdotal
evidence at most, but no evidence for the absence of harm.

Making the zone cut, an otherwise arbitrary boundary, a central search
element, is another huge paradigm shift that I see "with great interest".
Please don't anyone tell me that's the case with DNSSEC already - the story
there is different.

Finally, QNAME minimization is providing little gain in the traditional
forward tree and already needs kludges in deeper, nested name spaces.

Comparing the (little) gain with the unclear risk, I'd rather see work and
energy devoted to a long term solution.

-Peter

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Mon, 20 Oct 2014 15:04:48 -0400

Just to expand on my comments after some arguments made against.

The reason I think the WG should adopt the work item is that the original
design of DNS is now defective in the light of contemporary privacy
concerns. There is no reason that the operators of registries should have
sight of any information they do not have a need to know.

The business relationships built up over the years on the assumption that
this data will be available and for sale to the highest bidder are of
neither consequence nor concern.

These practices are going to be insisted on regardless of choices made by
this group. If indeed minimization has operational effects it is much
better to document them and allow parties to avoid unintended consequences.
At this point however, there is no evidence of harm.

Proof of very substantial showing of harm should be necessary to block
consideration of a proposal at the outset. Opponents will after all have
plenty of time to make objections in WG process, that being the point of WG
process.

It would be a terrible mistake to reject this work without a hearing
because of the mere possibility that a problem could occur. If indeed the
state of the DNS is as fragile as is suggested it will soon collapse of its
own accord. I rather suspect however that the fears are unfounded.

On Mon, Oct 20, 2014 at 2:32 PM, Phillip Hallam-Baker <[email-masked]

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 20 Oct 2014 12:47:11 -0700

On Oct 20, 2014, at 11:37 AM, Peter Koch <[email-masked]> wrote:

>  A whole system has

Please say more. What are those dependencies are from a protocol point of view?

> evolved along that algorithm.  

Please say more. Are they documented anywhere? How do they affect current operations?

> The fact that certain services may have experimented

This is the DNS: everything harms something else. We try to minimize known harm.

--Paul Hoffman

---

From: Paul Vixie <[email-masked]>
Date: Mon, 20 Oct 2014 14:21:45 -0700

this is a +1. see below.

> Phillip Hallam-Baker <mailto:[email-masked]>
> Monday, October 20, 2014 12:04 PM
> The reason I think the WG should adopt the work item is that the
> original design of DNS is now defective in the light of contemporary
> privacy concerns. There is no reason that the operators of registries
> should have sight of any information they do not have a need to know.
>
> The business relationships built up over the years on the assumption
> that this data will be available and for sale to the highest bidder
> are of neither consequence nor concern.
>
> These practices are going to be insisted on regardless of choices made
> by this group. If indeed minimization has operational effects it is
> much better to document them and allow parties to avoid unintended
> consequences. At this point however, there is no evidence of harm. 
>
> consideration of a proposal at the outset. Opponents will after all
> have plenty of time to make objections in WG process, that being the
> point of WG process. 
>
> because of the mere possibility that a problem could occur. If indeed
> the state of the DNS is as fragile as is suggested it will soon
> collapse of its own accord. I rather suspect however that the fears
> are unfounded.

+1, to all observations above.

-- 
Paul Vixie

---

From: Tim Wicinski <[email-masked]>
Date: Sat, 25 Oct 2014 15:43:25 -0400

All

The call period ended earlier this week. The only outspoken nay was 
Peter Koch.  His reasons may prove to be true, as many have said.  But 
the consensus is to adopt the work, and see where it takes us.

The new version has been submitted in the document list. Based on the 
discussion, I've initially labeled the draft 'Experimental', with the 
idea that if the initial research looks promising, this can be changed. 
Actually, this can be changed if there is some larger voice on this.

thanks all
tim