Subject: Re: [DNSOP] [dns-privacy] Qname minimization IPR

From: Stephane Bortzmeyer <[email-masked]>
Date: Sat, 25 Oct 2014 11:24:51 +0200

[Copy to dnsop since the qname minimisation draft is now a WG item at
dnsop.]

On Thu, Oct 23, 2014 at 10:21:57AM -0700,
 David Conrad <[email-masked]> wrote 
 a message of 56 lines which said:

> http://www.google.com/patents/EP2611116A1?cl=en

Well, some resolvers (the programs which will have to implement qname
m12n) are maintained in Europe (for instance Unbound) so they can
safely ignore these patents
<http://en.wikipedia.org/wiki/Software_patents_under_the_European_Patent_Convention>

Back to IETF issues: can someone who have read RFC 3979 more
thoroughly than me tell me if, as the draft author, I'm supposed to
file the IPR disclosure or is it up to Verisign employees?

---

From: Ted Lemon <[email-masked]>
Date: Sat, 25 Oct 2014 10:56:02 -0400

> file the IPR disclosure or is it up to Verisign employees?

You should, not must, file a third-party disclosure; you could ask Danny McPherson to file one so you don't have to, but one way or another the IPR disclosure needs to happen so people don't step on a land mine.   You are not obligated by the note well to do this--it's just the right thing to do, IMHO.   Of course, now that we all know about it, anyone who's read this mail could in principle file the third-party disclosure.   And also if anyone from Verisign is participating, they are required to disclose, because after this discussion they should be aware of the patent even if they weren't previously.

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 25 Oct 2014 16:51:53 +0100

On 25/10/14 15:56, Ted Lemon wrote:
> And also if anyone from Verisign is participating, they are required to disclose,

Well, only if they think that the IPR is relevant. Their claims
(I've not read 'em) could after all be unrelated to the draft,
e.g. if they've only claimed some madly complicated way of getting
the same effect as just leaving stuff out (which no doubt the
USPTO might still, in their infinite wisdom, consider patentable;-).

S.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sat, 25 Oct 2014 12:03:24 -0400

The claims are broad, not specific to one field of use.

But there isn't a patent yet and they may have been waiting to file after
grant.

It is possible for someone other than the IPR holder to file but best if
its the IPR holder.

The mere existence of a patent does not necessarily mean an intention to
enforce.

On Sat, Oct 25, 2014 at 11:51 AM, Stephen Farrell <[email-masked]
> wrote:

> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Rubens Kuhl <[email-masked]>
Date: Sat, 25 Oct 2014 14:54:13 -0200

> On Oct 25, 2014, at 2:03 PM, Phillip Hallam-Baker <[email-masked]> wrote:
> 
> But there isn't a patent yet and they may have been waiting to file after grant.
> 
> It is possible for someone other than the IPR holder to file but best if its the IPR holder.
> 
> The mere existence of a patent does not necessarily mean an intention to enforce. 
>  

Verisign has been telling its investors that they have intention to enforce and monetize patents. Excerpts from their SEC filings and investor calls can be found at:

http://domainnamewire.com/2013/01/25/heads-up-competing-registries-verisign-might-start-asserting-its-patents/ <http://domainnamewire.com/2013/01/25/heads-up-competing-registries-verisign-might-start-asserting-its-patents/>
http://domainnamewire.com/2014/09/24/verisigns-standards-group-patents/ <http://domainnamewire.com/2014/09/24/verisigns-standards-group-patents/>

Rubens

---

From: Paul Vixie <[email-masked]>
Date: Sat, 25 Oct 2014 10:53:01 -0700

> Stephane Bortzmeyer <mailto:[email-masked]>
> Saturday, October 25, 2014 2:24 AM

importantly, google's policy is to use patents only in defense. i've
requested that they make that explicit in the case of this particular
patent, but, that's a small detail. i believe that query minimization
should proceed as though this patent did not exist, for the good of the
internet economy. (if it fails to reach consensus that's a different
matter, but, let it not be because of this patent.)

-- 
Paul Vixie

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sat, 25 Oct 2014 14:04:22 -0400

Paul,

It is a VeriSign patent, its just being shown on the Google patent serach
engine

On Sat, Oct 25, 2014 at 1:53 PM, Paul Vixie <[email-masked]> wrote:

>
>
>   Stephane Bortzmeyer <[email-masked]>
> David Conrad <[email-masked]> <[email-masked]> wrote
>

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 25 Oct 2014 11:06:53 -0700

On Oct 25, 2014, at 10:53 AM, Paul Vixie <[email-masked]> wrote:
>> http://www.google.com/patents/EP2611116A1?cl=en <http://www.google.com/patents/EP2611116A1?cl=en>
> 
> importantly, google's policy is to use patents only in defense. i've requested that they make that explicit in the case of this particular patent, but, that's a small detail.

1) It is a patent application, not a patent.
2) The application was filed by Verisign, not Google.

--Paul Hoffman

---

From: Paul Vixie <[email-masked]>
Date: Sat, 25 Oct 2014 11:27:13 -0700

> Paul Hoffman <mailto:[email-masked]>
> Saturday, October 25, 2014 11:06 AM
>

thanks. however, i was told google also has one on Q-M. that's the one i
thought this thread referred to.

if verisign tries to enforce their patent against google, i will buy
popcorn, sit back, and watch.

i do not believe that verisign's interests are aligned with enforcement
of a patent like this one.

verisign should be asked to place a defense-only status on this patent.
i think they will do so.

-- 
Paul Vixie

---

From: Warren Kumari <[email-masked]>
Date: Sat, 25 Oct 2014 17:10:00 -0400

On Sat, Oct 25, 2014 at 2:27 PM, Paul Vixie <[email-masked]> wrote:

>
>
>   Paul Hoffman <[email-masked]>

Just an explicit "I personally do not know of any qname minimization
patent(s) that Google has".

I had heard some rumors of a Google patent regarding prepending nonces to
add entropy, but that's completely different.

W

> i do not believe that verisign's interests are aligned with enforcement of
> a patent like this one.
>
> verisign should be asked to place a defense-only status on this patent. i
> think they will do so.
>
> --
> Paul Vixie
>

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Paul Vixie <[email-masked]>
Date: Sat, 25 Oct 2014 15:12:25 -0700

> Warren Kumari <mailto:[email-masked]>
> Saturday, October 25, 2014 2:10 PM
>
>
> On Sat, Oct 25, 2014 at 2:27 PM, Paul Vixie <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>
>
>     thanks. however, i was told google also has one on Q-M. that's the
>     one i thought this thread referred to.
>
>
>
> I had heard some rumors of a Google patent regarding prepending nonces
> to add entropy, but that's completely different.
now that i read both (http://www.google.com/patents/US8484377) i see
that warren is correct.

i'll stand by my other statement-- verisign should be asked to put their
Q-M work (http://www.google.com/patents/EP2611116A1) into defensive-only
use.

-- 
Paul Vixie