Subject: [DNSOP] call for adoption: draft-vandergaast-dnsop-edns-client-subnet

From: Suzanne Woolf <[email-masked]>
Date: Tue, 28 Oct 2014 11:50:37 -0400

Dear DNSOP WG,

This draft documents the specification, use, and cautions regarding the "client-subnet" EDNS option. Please consider adoption of this draft as a WG work item.

As some of you will remember, this is a successor to a draft that was considered in DNSEXT some time ago and eventually expired without formal action. Since then, the option codepoint has been granted under the appropriate registry policy (expert review) and the option is in significant operational use. 

The topic has come up more than once on the WG mailing list, with some vigorous discussion, so a couple of the original authors and a couple of new people have revived the draft in the interests of documenting the option, including specific behavior and cautions in its use.

The draft is available here: http://datatracker.ietf.org/doc/draft-vandergaast-dnsop-edns-client-subnet/

Please review to see if you think this document is suitable for adoption by DNSOP and comment to the list. 

Please state your view, your reasons, and (if you're in favor of adoption) whether you are willing to contribute text, review, etc.

This call for adoption ends Tuesday 11-Nov.-2014, end of the day wherever you happen to be. This is the same day as our WG meeting at IETF 91.

Thanks,
Suzanne Woolf
DNSOP co-chair

---

From: Warren Kumari <[email-masked]>
Date: Tue, 28 Oct 2014 12:00:47 -0400

> The draft is available here: http://datatracker.ietf.org/doc/draft-vandergaast-dnsop-edns-client-subnet/

We actually have some updates that unfortunately didn't *quite* make
it in before the cutoff[0].

The updated version / version in the edit buffer is at:
https://github.com/wkumari/draft-vandergaast-edns-client-subnet
The changes are minor, so review the
http://datatracker.ietf.org/doc/draft-vandergaast-dnsop-edns-client-subnet/
version, but if you mention typos / etc we might say "Thanks! Already
fixed in edit buffer :-)"

W

[0]: Yes, making it in before the cut-off or not making it in before
the cut-off is a binary, but, well....

> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 28 Oct 2014 09:02:52 -0700

<no hat>

I support the adoption of this document in the WG even if it gets significantly changed during the WG discussion. I will review it as it progresses.

--Paul Hoffman

---

From: Paul Ebersman <[email-masked]>
Date: Tue, 28 Oct 2014 11:20:51 -0600

suzworldwide> The draft is available here: http://datatracker.ietf.org/doc/draft-vandergaast-dnsop-edns-client-subnet/

suzworldwide> Please review to see if you think this document is
suzworldwide> suitable for adoption by DNSOP and comment to the list.

I support this draft as a working group item and am willing to review
the draft.

---

From: David C Lawrence <[email-masked]>
Date: Tue, 28 Oct 2014 14:00:36 -0400

> the cut-off is a binary, but, well....

Please feel free to hurl suitably non-lethal objects at me.  It was
all my fault.

> fixed in edit buffer :-)"

I just synced some more changes, primarily of the typo / grammatical
consistency variety, and am done for now.

---

From: Paul Wouters <[email-masked]>
Date: Tue, 28 Oct 2014 14:28:22 -0400 (EDT)

> This draft documents the specification, use, and cautions regarding the "client-subnet" EDNS option. Please consider adoption of this draft as a WG work item.

I have a recollection we already did this call? Because I said I
reluctantly agreed to adopt the document before. Anyway, yes
I support adopting the work.

Paul

---

From: Allison Mankin <[email-masked]>
Date: Tue, 28 Oct 2014 15:33:44 -0700

I support adoption because operators are using this spec.  I plan to review
and also to encourage a few others who have reviews to contribute.

On 28 October 2014 08:50, Suzanne Woolf <[email-masked]> wrote:

> Dear DNSOP WG,
>
> This draft documents the specification, use, and cautions regarding the
> "client-subnet" EDNS option. Please consider adoption of this draft as a WG
> work item.
>
> As some of you will remember, this is a successor to a draft that was
> considered in DNSEXT some time ago and eventually expired without formal
> action. Since then, the option codepoint has been granted under the
> appropriate registry policy (expert review) and the option is in
> significant operational use.
>
> The topic has come up more than once on the WG mailing list, with some
> vigorous discussion, so a couple of the original authors and a couple of
> new people have revived the draft in the interests of documenting the
> option, including specific behavior and cautions in its use.
>
> The draft is available here:
> Please state your view, your reasons, and (if you're in favor of adoption)
> whether you are willing to contribute text, review, etc.
>
> This call for adoption ends Tuesday 11-Nov.-2014, end of the day wherever
> you happen to be. This is the same day as our WG meeting at IETF 91.
>
>
> Thanks,
> Suzanne Woolf
> DNSOP co-chair