Subject: [DNSOP] Comment on draft-ietf-dnsop-as112-dname-06.txt

From: Dave Thaler <[email-masked]>
Date: Wed, 26 Nov 2014 15:37:41 +0000

[note: I am not on the dnsop mailing list, so keep me on any replies]

One issue I have is with the first paragraph of the Introduction:

> Many sites connected to the Internet make use of IPv4 addresses that 
> are not globally unique.  Examples are the addresses designated in 
> [RFC1918] for private use within individual sites.

This makes it sound like the only use cases are for IPv4 addresses, which is not correct.  The DNS is also used at times for multicast addresses, including locally scoped ones, and such "private use" multicast addresses occur both in IPv4 and IPv6.

I have no data on whether anyone is _currently_ using AS112 for such, but
the point is that potential applicability is not limited to IPv4 as implied.

-Dave

---

From: Joe Abley <[email-masked]>
Date: Wed, 26 Nov 2014 11:18:50 -0500

Hi Dave,

> the point is that potential applicability is not limited to IPv4 as implied.

That text was cut-and-pasted from 6304, I think, which concerns itself just with the original AS112 service that only considered IPv4 reverse domains. I agree it could be usefully changed.

How about we just drop "IPv4" and make it "... make use of addresses that"

Joe

---

From: Dave Thaler <[email-masked]>
Date: Wed, 26 Nov 2014 16:23:01 +0000

Joe Abley writes:
> > This makes it sound like the only use cases are for IPv4 addresses, which is
> not correct.  The DNS is also used at times for multicast addresses, including
> locally scoped ones, and such "private use" multicast addresses occur both in
> IPv4 and IPv6.
> >
> > I have no data on whether anyone is _currently_ using AS112 for such,
> > but the point is that potential applicability is not limited to IPv4 as implied.
> 
> That text was cut-and-pasted from 6304, I think, which concerns itself just
> with the original AS112 service that only considered IPv4 reverse domains. I
> agree it could be usefully changed.
> 

Yes, that would address my concern.

Thanks Joe,
-Dave