Subject: [DNSOP] Workshop on DNS Future Root Service Architecture (2014 WDFRSA), Hong Kong, December 8-9, 2014

From: Paul Vixie <[email-masked]>
Date: Fri, 14 Nov 2014 01:14:06 -0800

Registration is now open for the 2014 Workshop on DNS Future Root
Service Architecture (2014 WDFRSA)

> Location: Hong Kong, HK
> Venue: The Mira Hotel (Kowloon district)
> Date: December 8-9, 2014
> Hosted by: ISOC-HK
> Sponsors: ZDNS/BII and CNNIC
> Co-chairs: Warren Kumari and Paul Vixie

This two day workshop will focus on the DNS root service architecture issues raised by two current Internet Drafts:

1.
http://www.ietf.org/internet-drafts/draft-wkumari-dnsop-root-loopback-01.txt
   Decreasing Access Time to Root Servers by Running One on Loopback
   W. Kumari, Ed.; P. Hoffman

2. http://tools.ietf.org/html/draft-lee-dnsop-scalingroot-00
   How to scale the DNS root system?
   Xiaodong Lee; Paul Vixie; Zhiwei Yan

At the time of this writing the DNS serves more than two billion people and more than five billion connected devices, with more to come due to expected growth in mobile, in Things, and in new connected users. The DNS root service architecture still resembles the way it was when there were just a few hundred hosts thirty years ago, although it is now more widely distributed.

Reachability of the DNS root zone content by a diverse collective of
recursive DNS servers is a vital go/no-go condition for all Internet
traffic. Extended outages which isolate a network from DNS root zone
content are effectively complete outages for that network, making access
to the DNS root zone information a vital enabler for human discourse and
commerce.

We wish to make root zone content as reachable and as resilient as it can be made without risking complexity collapse. Two extant proposals involve changes to RDNS configuration, and possibly also changes to routing, to addressing, and to root zone metadata. These proposals do not conflict with each other, but the operational results of deploying each would be quite different.

After the workshop, the various proponents will have new information to include in their proposals, and there will be a greater understanding of the various points of agreement and disagreement about how the community can move forwards.

--- Agenda:

Monday:

0900-0910: Welcome from ISOC-HK (local host)
0910-0915: Welcome from ZDNS/BII (sponsor)
0915-0920: Welcome from CNNIC (sponsor)
0920-0930: Logistics and late agenda changes (co-chairs)
0930-0945: Current problem statement (co-chairs)
0945-1030: Decreasing Access Time to Root Servers by Running One on Loopback (W. Kumari, P. Hoffman)
	(present current draft, field questions and objections, propose text or logic revisions)
1030-1100: Break (coffee)
1100-1145: How to scale the DNS root system? (X. Li, P. Vixie)
	(present current draft, field questions and objections, propose text or logic revisions) 
1145-1230: Open discussion of the two drafts, with expected refinements to the problem statement
1230-1400: Lunch (hosted)
1400-1430: Testbed for IPv6-only DNS development (Dr. Linjian Song, BII Lab)
1430-1500: Evolution of DNS root zone operation and management (Dr. Declan Ma, ZDNS Lab)
1500-1530: AS112 as an example of unowned anycast at scale (B. Manning, P.Vixie, J. Abley, W. Maton)
1530-1700: Open (proposals welcome, workshop participants to decide in the moment)
1700-1900: (unscheduled private time)
1900-2200: Dinner (hosted)

Tuesday:

0900-0930: Summary of day 1, closed issues, opened issues (co-chairs)
0930-1030: Summary of changes to text of Internet Drafts accepted during workshop
1030-1100: Break (coffee)
1100-1230: Open (proposals welcome, workshop participants to decide in the moment)
1230-1400: Lunch (hosted)

--- Workshop Logistics:

Travel support including round trip coach air fare, taxi fare, meals,
and a room at the venue hotel (The Mira Hotel, Kowloon district, Hong
Kong) will be offered to participating root name server operators,
authors of each of the two Internet Drafts to be discussed, and IETF
DNSOP Working Group co-chairs. The workshop will also be open to any
interested party, and every effort will be made to both stream and store
all presentations (via YouTube). There is no cost for attending the
workshop. Pre-registration is required.

Information on how to register and on the proposed agenda will be sent
shortly to this same distribution. For travel planning purposes, the
meeting will run all day on December 8, with a social event that
evening, and for half a day on December 9, finishing immediately after
lunchtime. Participants are invited to submit proposals for several open
slots, with final selection to be made during the workshop itself.

To register for this workshop, please e-mail to the co-chairs:
    Warren Kumari <[email-masked]>, Paul Vixie <[email-masked]>
...indicating your primary affiliation (root server operator, DNSOP WG
co-chair, draft co-author, interested party), and your needs (if any)
regarding travel support to attend the workshop. Note that to qualify
for travel support you must room at the venue hotel, using our
reservation code. If you wish to propose a topic for one of the open
agenda slots, you may do so at any time, up to and including the moment
of the workshop itself.

We have a room block at venue hotel. To reserve a room in this block,
visit the URL shown below:

https://bookings.ihotelier.com/The-Mira-Hong-Kong/bookings.jsp?hotelID=85171&groupID=1333820

-- 
Warren Kumari
Paul Vixie

---

From: Mehmet Akcin <[email-masked]>
Date: Thu, 13 Nov 2014 23:18:50 -1000

what is the url for workshop registration?

mehmet

> On Nov 13, 2014, at 11:14 PM, Paul Vixie <[email-masked]> wrote:
> 
> Registration is now open for the 2014 Workshop on DNS Future Root Service Architecture (2014 WDFRSA)
> 
> > Location: Hong Kong, HK
> 1. http://www.ietf.org/internet-drafts/draft-wkumari-dnsop-root-loopback-01.txt
> Reachability of the DNS root zone content by a diverse collective of recursive DNS servers is a vital go/no-go condition for all Internet traffic. Extended outages which isolate a network from DNS root zone content are effectively complete outages for that network, making access to the DNS root zone information a vital enabler for human discourse and commerce.
> Travel support including round trip coach air fare, taxi fare, meals, and a room at the venue hotel (The Mira Hotel, Kowloon district, Hong Kong) will be offered to participating root name server operators, authors of each of the two Internet Drafts to be discussed, and IETF DNSOP Working Group co-chairs. The workshop will also be open to any interested party, and every effort will be made to both stream and store all presentations (via YouTube). There is no cost for attending the workshop. Pre-registration is required.
> 
> Information on how to register and on the proposed agenda will be sent shortly to this same distribution. For travel planning purposes, the meeting will run all day on December 8, with a social event that evening, and for half a day on December 9, finishing immediately after lunchtime. Participants are invited to submit proposals for several open slots, with final selection to be made during the workshop itself.
> 
> ...indicating your primary affiliation (root server operator, DNSOP WG co-chair, draft co-author, interested party), and your needs (if any) regarding travel support to attend the workshop. Note that to qualify for travel support you must room at the venue hotel, using our reservation code. If you wish to propose a topic for one of the open agenda slots, you may do so at any time, up to and including the moment of the workshop itself.
> 
> We have a room block at venue hotel. To reserve a room in this block, visit the URL shown below:
> 
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: Paul Vixie <[email-masked]>
Date: Fri, 14 Nov 2014 01:30:52 -0800

> Mehmet Akcin <mailto:[email-masked]>
> Friday, November 14, 2014 1:18 AM

no url was given except for the hotel. to register for the conference
itself, you have to send e-mail. hereis:
>
> On Nov 13, 2014, at 11:14 PM, Paul Vixie <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>> ...
>>
>> ...indicating your primary affiliation (root server operator, DNSOP
>> WG co-chair, draft co-author, interested party), and your needs (if
>> any) regarding travel support to attend the workshop. Note that to
>> qualify for travel support you must room at the venue hotel, using
>> our reservation code. If you wish to propose a topic for one of the
>> open agenda slots, you may do so at any time, up to and including the
>> moment of the workshop itself.
>>

forgive us for the low-tech approach.

-- 
Paul Vixie

---

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 19 Nov 2014 20:04:30 +0000

Unfortunately, I won’t be able to attend this workshop.

I understand the need and desire for many geographic area and networks to run a local anycast node associated with one of the existing root letters. I have heard that in some cases the root operator is willing to enable a local anycast node but that the requesting geographic area or network lacks the financial resources to purchase servers to do so.

If anyone is in this situation, please feel free to contact me off-list as I may be able to assist.

Thanks
Jason