Subject: [DNSOP] Spartacus and new record types

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 11 Nov 2014 10:46:57 -1000

Does anyone know how Spartacus
(draft-dickson-dnsop-spartacus-{lang,system}, on the agenda for today)
handles new record types that may be invented tomorrow? I find nothing
in the drafts, which describe the JSON structure for today's record
types, but not for future types.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 12 Nov 2014 11:27:11 -1000

Can we change the name, please?

Spartacus Club was the name of the pedophile rapist organization at
the center of the on ongoing UK criminal enquiry involving 8 MPs and
three police forces. There is also an international dimension.

There is a significant probability it is going to become a PR
liability. Like having a protocol called BINLADEN or EBOLA.

Of lesser import is that this is now a trigger word for me having
reviewed some of the evidence for a report on the activities.

On Tue, Nov 11, 2014 at 10:46 AM, Stephane Bortzmeyer <[email-masked]> wrote:
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: Mehmet Akcin <[email-masked]>
Date: Wed, 12 Nov 2014 11:33:58 -1000

Second this. Also please do a brief wikipedia search before picking the next name?.

Mehmet 

> On Nov 12, 2014, at 11:27 AM, Phillip Hallam-Baker <[email-masked]> wrote:
>

---

From: Jay Daley <[email-masked]>
Date: Thu, 13 Nov 2014 10:40:15 +1300

There are basically two approaches to handling new record types in any 'DNS language' definition:

1.  Have a good extension mechanism built in; or
2.  Issue an updated language specification each time a new record is agreed.

Personally I think 2 is a big step backwards and 1 is much easier if the language is built on an underlying technology that supports it.

One of the reasons we chose XML Schema for draft-daley-dnsxml is that XML-Schema has polymorphism built into it.  Using the little known 'substitutionGroup' feature the spec has a built-in extension mechanism allows a new record type to have it's XML representation defined in a new document and work basically as though it were defined in the base specification (it sits in a different namespace).

Jay

-- 
Jay Daley
Chief Executive
.nz Registry Services (New Zealand Domain Name Registry Limited)
desk: +64 4 931 6977
mobile: +64 21 678840
linkedin: www.linkedin.com/in/jaydaley