Subject: [DNSOP] Fwd: New Version Notification for draft-wkumari-dnsop-root-loopback-02.txt

From: Paul Hoffman <[email-masked]>
Date: Wed, 26 Nov 2014 12:42:08 -0800

Greetings. Warren and I updated the draft a bit to reflect input from the WG, and to add another configuration example (for Windows Server).

--Paul Hoffman

> Begin forwarded message:
> 
> From: [email-masked]
> To: "Warren Kumari" <[email-masked]>, "Paul E. Hoffman" <[email-masked]>, Warren Kumari <[email-masked]>, Paul Hoffman <[email-masked]>
> Subject: New Version Notification for draft-wkumari-dnsop-root-loopback-02.txt
> Date: November 26, 2014 at 12:39:34 PM PST
> 
> 
> A new version of I-D, draft-wkumari-dnsop-root-loopback-02.txt
> has been successfully submitted by Paul Hoffman and posted to the
> IETF repository.
> 
> Name:		draft-wkumari-dnsop-root-loopback
> Revision:	02
> Title:		Decreasing Access Time to Root Servers by Running One on Loopback
> Document date:	2014-11-26
> Group:		Individual Submission
> Pages:		9
> URL:            http://www.ietf.org/internet-drafts/draft-wkumari-dnsop-root-loopback-02.txt
> Status:         https://datatracker.ietf.org/doc/draft-wkumari-dnsop-root-loopback/
> Htmlized:       http://tools.ietf.org/html/draft-wkumari-dnsop-root-loopback-02
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-wkumari-dnsop-root-loopback-02

---

From: Joe Abley <[email-masked]>
Date: Wed, 26 Nov 2014 17:29:07 -0500

> Greetings. Warren and I updated the draft a bit to reflect input from the WG, and to add another configuration example (for Windows Server).

I think the general problem space of how we distribute authoritative data to caches is well worth thought and investigation. The model "if you want good end-user performance, you need to anycast your authority servers all over the planet or pay someone to do it for you" is a poor one, no matter how much we enjoy it at Dyn.

This document is thinking in that direction, but it is restricting itself to what is arguably the best-served DNS zone in the world, with the most spare capacity in its infrastructure, and which is least in need of improvement. Generally, I am against adding complexity without benefit.

I continue to be concerned that slaving the root zone on (or near!) validators smells like a configure-and-forget project for some sysadmin who has since left the company, and the people left are only one firewall rule change away from weird troubleshooting nightmare. I agree that carefully documenting how this should be done is better than leaving those people with no documentation at all when they need it at 3am.

I think the document is well-written and clear, but that it needs the risks (non-zero) and benefits (near-zero) to be clearly discussed, and to avoid any unwarranted suggestion that doing this is sensible in the general case.

So...

On 14 Nov 2014, at 15:40, Wes Hardaker <[email-masked]> wrote:

> Warren Kumari <[email-masked]> writes:
> 
>> We are requesting a call for adoption of
>> draft-wkumari-dnsop-root-loopback.
> 
> Support adopting, but we will need to talk about careful wording of when
> to use it and when not to.

... +1 to Wes' conditional support above.

I will review, contribute text when not swamped by other things, etc.

Joe

---

From: "Jiankang Yao" <[email-masked]>
Date: Thu, 27 Nov 2014 14:41:11 +0800

From: Joe Abley
Date: 2014-11-27 06:29
To: Paul Hoffman
CC: dnsop
Subject: Re: [DNSOP] New Version Notification for draft-wkumari-dnsop-root-loopback-02.txt

>
>I think the document is well-written and clear, but that it needs the risks (non-zero) and benefits (near->zero) to be clearly discussed, and to avoid any unwarranted suggestion that doing this is sensible in the general case.
>

Agree.

adding one section about the pros and cons will be better.

Jiankang Yao