Subject: [DNSOP] I-D Action: draft-ietf-dnsop-child-syncronization-07.txt

From: [email-masked]
Date: Tue, 06 Jan 2015 20:58:33 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Domain Name System Operations Working Group of the IETF.

        Title           : Child To Parent Synchronization in DNS
        Author          : Wes Hardaker
	Filename        : draft-ietf-dnsop-child-syncronization-07.txt
	Pages           : 15
	Date            : 2015-01-06

Abstract:
   This document specifies how a child zone in the DNS can publish a
   record to indicate to a parental agent that the parental agent may
   copy and process certain records from the child zone.  The existence
   of the record and any change in its value can be monitored by a
   parental agent and acted on depending on local policy.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dnsop-child-syncronization/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-dnsop-child-syncronization-07

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-dnsop-child-syncronization-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Wes Hardaker <[email-masked]>
Date: Tue, 06 Jan 2015 22:05:33 -0800

manning bill <[email-masked]> writes:

> just for the record, the prior art was not referenced in this draft, even though
> Warren was notified when he was working on its predecessor. it would be nice
> to actually acknowledge prior art.

It just passed iesg review, and the posted changes this time were
wording agreements between myself and the IESG (the WG was cced for the
important changes).

> http://archive.icann.org/en/meetings/saopaulo/presentation-cadr-07dec06.pdf

I'll try to get an acknowledgment in the AUTH48 period if that works for
you.  It looks like the last (major) bullet on your slide 10 indicates
that a parent can trust the child information because of dnssec, which
is what we're making use of certainly.  Your slides seem to hint at a
much more active "update request" though, which is not the way the CSYNC
record works.
-- 
Wes Hardaker
Parsons

---

From: manning bill <[email-masked]>
Date: Tue, 6 Jan 2015 21:18:33 -0800

/bill
PO Box 12317
Marina del Rey, CA 90295
310.322.8102

On 6January2015Tuesday, at 20:58, [email-masked] wrote:

> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: manning bill <[email-masked]>
Date: Tue, 6 Jan 2015 22:21:45 -0800

the cadr software triggered updates on either a change in value of a referenced retype, OR, when sent a 
signal in an oob fashion  (e.g.   look for an update now)

in either case, the child was triggering synchronization - which is also what your draft does.

/bill
PO Box 12317
Marina del Rey, CA 90295
310.322.8102